
Wlf 315 Wildlife Ecology Lab I 

Fall 2011 

 

GIS Exercise: Analyses of Home Range and Space Use Patterns 
 

Introduction: 

In this exercise, you will use the Geospatial Modeling Environment 

(http://www.spatialecology.com/gme)  and ArcMap10 

(http://www.esri.com/software/arcgis/arcgis10/index.html) to estimate animal home ranges. 

First, you will create a GIS project and import the location data so that you can visualize the 

radio-telemetry data.  Then, you will start by calculating the utilization distributions and 95% 

isopleths boundaries for the fixed kernel home range in the Geospatial Modeling Environment 

program.  Then, you will calculate the 95% MCP home range.  Finally, you will use ArcGIS 

software to visualize the home ranges and estimate home range sizes.   

 

 

 

Getting Started in ArcGIS and Importing Telemetry Data: 
 

 

1. Create a folder with your name under the class directory (M:\wlf315\yourname).  You will use 

this folder for all of your input and output data. Copy all of the data files in the Wlf315 folder 

(there should be 6 or so) to your own folder.   

 

2. Create an ArcGIS project with the locations of radio-collared pygmy rabbits collected during 

the breeding season.  The locations were collected at 2 study sites that are about 7 km apart in the 

Lemhi Valley of eastcentral Idaho. 

 

- Open a new project in ArcMap:  Start – ArcGIS – ArcMap 

- Next, add the telemetry data to the project following directions below. 

- Save your project frequently:  File – Save (to your folder). 

 

 

 

 

 

 

 

3.  Import the data on rabbit radio-locations from a shape file into ArcMap.  Data in this file 

include: Animal ID, Sex, X (the East-West coordinate), and Y (the North-South coordinate).   

 

  

 

 

 

 

 

 

 

 

 

NOTE: All data for this project were collected and are displayed in the UTM (Universal Transverse 

Mercator) map projection system, zone 12, datum NAD27, units meters.  

  

- Add the file to ArcMap:  From the File menu, choose Add Data, then Add Data. 

- Click on the folder+ symbol (4
th

 from the right) along the top of the Add Data box and 

navigate to your folder to add breeding_locs.shp. 

- To set the map units, under the View tab, choose Data Frame Properties.  Set the units for 

both the Map and Display to meters.  Click Apply, and then OK. 

- Remember to Save your project frequently. 

 

http://www.spatialecology.com/gme
http://www.esri.com/software/arcgis/arcgis10/index.html


 

4.  Once you have successfully added the radio location data as a layer, use the Symbology to 

give each individual animal‟s location its own color and to rename the layer.   

 

- Right-click on breeding_locs.shp.  Select Properties, and then select Symbology tab.  

Under Categories, choose Unique Values.  Under Value Field, choose ID.  Click Add All 

Values, then click Apply and then OK.   

- Name the Layer:  Go back to Properties and choose the General tab and type Locations 

to rename the layer in the ArcMap project (NOTE! The shape file on the hard drive is 

still named breeding_locs.shp, the Layer Name is simply a label).  

- Look at the data – what do you see?  Zoom in and out to get a feel for the distribution of 

locations.   

 

Save and close your ArcMap project.  Having GME and ArcMap both open can cause 

problems, so be sure to close one before opening the other.  Always SAVE your ArcMap 

Project before closing! 

 

 

Home Range Computations in GME and visualization in ArcMap 
 

You will calculate home ranges (95% minimum convex polygon and 95% fixed-kernel home 

ranges) for 1 animal for practice.  This is done in GME and then the results are brought into 

ArcMap to display results. 

 

1. Start GME.  From the Windows menu, select Programs>Spatial Ecology>Geospatial 

Modeling Environment. 

 

2. Set your working directory to match your folder.   

 

setwd(all="M:\Wlf315\yourfoldername "); 

 

3. Use the kde command to calculate a probability distribution for animal male 174.  

The input dataset for this command is the telemetry point data in breeding_locs.shp.  

Name your output files m174s.img.  Although the kde command allows us to specify 

a bandwidth manually, we also can specify one of several statistical approaches to 

selecting an optimized bandwidth.  Let‟s start by using the smoothed cross-validation 

bandwidth estimator by setting the bandwidth parameter to “SCV” in the kde 

command.  Specify an output cellsize of 10.  To select the locations from a single 

animal, you will need to specify a where statement.  

kde(in="breeding_locs.shp", out="kdem174s.img", bandwidth="SCV", cellsize=10, 

where="Anim=174"); 

4. Next, calculate the 95% isopleths (contour that captures 95% of the KDE), which we 

will consider to be our estimate of the home range boundary.  Use the isopleth 

command to construct the boundary for your probability density function.  The input 

will be the KDE raster you just created in the previous step. The quantiles parameter 

determines which isopleths to calculate, in this case we only want the 95% isopleth, 

so we will set quantiles=0.95.  By default the output of the isopleths command is 

lines. We also want to create polygons, so you should specify both the out and poly 

parameters.  Name your output files isolinem174s.shp and isopolym174s.shp.   



isopleth(in="kdem174s.img", out="isolinem174s.shp", quantiles=0.95, 

poly="isopolym174s.shp"); 

 

5. Use the addarea command to add the area and perimeter estimates to your isopoly 

shapefile.   

 

addarea(in="isopolym174s.shp", area="AREA"); 

 

6. Close GME and open your ArcMap project. 

7. In ArcGIS add the shape files you created in GME.   

- Open your ArcMap project 

- From the File menu, choose Add Data, then Add Data.  Click on the folder+ 

symbol (4
th

 from the right) along the top of the Add Data box and navigate to the 

files that you want to add. 

- Add the kde file first.  What you will see is the probability density function.   

- Then add your isopoly file.  Now you see the outline of the fixed-kernel home 

range. 

- To see the area of the home range, right click on the layer name in the Table of 

Contents.  Note that if the kernel home range has more than one polygon, the area 

for each polygon will be reported on a separate line.  To convert area into 

hectares, recall that there are 10,000 square meters in one hectare.   

 

8. Save your ArcMap project, and close ArcMap.  Reopen GME and set your working 

directory as above. 

 

9. Calculate MCP polygon using the genmcp command.  Name your output file 

mcp.shp.   

 

genmcp(in="breeding_locs.shp", out="mcpm174.shp", where="Anim=174"); 

 

10. Use the addarea command to add area and perimeter fields to mcpm174.shp.   

 

addarea(in="mcpm174.shp ", area="AREA"); 

 

11. Close GME and reopen your ArcMap project.  Add mcpm174.shp to ArcGIS as you 

did above.   

 

12. Return to the second step and calculate new kernel density rasters and isopleths using 

the least-squares cross-validation bandwidth estimator (bandwidth=“LSCV”).  Make 

sure you give the new datasets a different name to those you created previously. 

 

13. Bring these into your ArcMap project (being sure to close GME first).  What are the 

main differences between your KDE estimates (based on LSCV versus SCV)?  Do 

you think one performs better than another in this case?  How do these compare with 

the MCP estimate?  How might you choose which to use in your own research?  

 

Now – you know how to calculate home ranges using 2 home range estimators (fixed kernel and 

minimum convex polygon).  And, you should have an appreciation for how the smoothing factor 

can alter the estimate of the size of the fixed-kernel home range.  NOW YOU CAN SEE WHY 

IT IS SO IMPORTANT TO ALWAYS REPORT YOUR EXACT METHODS WHEN 

REPORTING A HOME RANGE ESTIMATE!! 



Lab Assignment: 
 

Develop a hypothesis and prediction: 

1. State one hypothesis (educated guess about why something is the way it is) that explains 

some aspect of the spatial pattern in the rabbits, and then provide a short explanation of 

the reasoning behind the hypothesis.  You might consider asking questions about 

differences between sexes, or study areas, or seasons with respect to: 

 Size of home ranges (differences between sexes, study areas, or seasons) 

 Overlap between home ranges (differences between sexes, study areas, or  

 seasons) 

 Sizes of home ranges using different types of home range estimators  

(MCP vs. fixed kernel, or LSCV vs. SCV smoothing parameters for the 

fixed kernel) 

 

It does not matter if the hypothesis is “true” – it should be logical.  Then provide a prediction, 

which is what you will actually measure with your data. 

Example:   

                Hypothesis:  Home range sizes are larger for animals when resources are 

  spaced farther apart.   

    Explanation:  When resources are spaced out, animals must travel further between  

  resource patches which results in larger home ranges.   

     Prediction:    Home ranges for pygmy rabbits will be larger at the Cedar Gulch site 

     than the Rocky Canyon site because the sagebrush plants are farther 

     apart, and rabbits use the sagebrush for food and cover from predators. 

     

 Run your ideas past one of the instructors before launching off on the exercise. 

 

2. Make a table to display the sizes of the home ranges or number of overlapping home 

ranges (whatever information pertains to your hypothesis).   

3. Make a map that display the home ranges that you used for your hypothesis.  See 

instructions below for making maps from your GIS data. 

4. Use your analyses to provide a qualitative test of your hypothesis.  Briefly type a 

discussion about whether or not your hypothesis was supported by the analyses.  You 

should refer to your maps and/or tables in answering this question. 

 

 

Making Map Layouts: 
Make a map of one of the study areas that shows the home ranges that you chose as part of your 

hypothesis.  If your hypothesis is about both study areas, then choose one to display. 

  

- Zoom to the extent of one of the study areas (Cedar Gulch or Rocky Canyon) 

- Click on Layout View in the View menu. 

- If you prefer a Landscape view over Portrait – make the changes under Page and print 

setup in the File menu. 

- Add a title, legend, scale bar, and north arrow using the Insert menu.   

- You can choose different styles – just be sure that all of the parts are included. 

- When you are happy with the layout save it as a .jpg file; select Export Map in the File 

menu; select .jpg for the file type and name the output map. You can email the map to 

yourself or save it on a memory stick (thumb-drive).  

 



 

Turn in for your Assignment: 

 

- Hypothesis, Explanation, Prediction 

- Table(s) with the home ranges you estimated 

- Map(s) with the home ranges you estimated 

- Brief discussion (in paragraph format) that evaluates your hypothesis in light of the 

data – was your hypothesis supported or not?  Use your data (refer to tables and 

figures) to support your conclusion.   

 

Due by the start of your lab next week (2:30 on Dec 12/13) – in either Bill’s or Janet’s 

mailbox.  Please have Linda, the administrative assistant for Fish & Wildlife, sign & date 

your paper before putting it in the mailbox. 

 



Introduction to Home Range Estimation in GME 
(by Dr. Kerry Nicholson, 2011) 

 
1.  Introduction to GME 

 

The promise of GIS has always been that it would allow us to obtain better answers to our 

questions. But this is only possible if we have tools that allows us to perform rigorous 

quantitative analyses designed for spatial data.  Keeping up with the latest in available software 

can be a chore, however, it is extremely important for you to investigate and determine the most 

appropriate software available to conduct the analysis.  Often we would like it to be GIS 

compatible.     

 

The Geospatial Modelling Environment (GME) is a platform designed to help to facilitate 

rigorous spatial analysis and modelling.  It is an evolved tool from Hawthstools that only works 

up till ArcGIS 9.2.  Animal movements is an extension that is supported in ArcView.  Most, if 

not all, of the Animal movements commands are available in R or GME with added versatility. 

 

GME provides you with a suite of analysis and modelling tools, ranging from small 'building 

blocks' that you can use to construct a sophisticated work-flow, to completely self-contained 

analysis programs. It also uses the extraordinarily powerful open source software R as the 

statistical engine to drive some of the analysis tools. One of the many strengths of R is that it is 

open source, completely transparent and well documented: important characteristics for any 

scientific analytical software. 

 

GME incorporates most of the functionality of its predecessor, HawthsTools, but with some 

important improvements. It has a greater range of analysis and modelling tools, supports batch 

processing, offers new graphing functionality, automatically records work-flows for future 

reference, supports geodatabases, and can be called programmatically.  These exercises are 

meant to familiarize yourself with GME and the working environment.  It is NOT meant teach 

you R, though the scripting is “similar” it is not exactly the same and GME is not as flexible as 

R. 

 

For clarity, in this document we refer to data files (GIS layers or otherwise) using italics, to 

GME commands and options within those commands using bold text, and to specific attributes 

referenced within data files using “quotations”.  

 

Getting Started 

 

Installation:  

GME has dependencies on three other software packages:. 

ArcGIS 10 (ArcView or ArcEditor or ArcInfo license) 

R 2.12.1 or higher: free from http://www.r-project.org  

StatConn 3.1-2B7: free from http://rcom.univie.ac.at/ 

 

You should also have already downloaded and installed these packages along with GME.  

For full installation details see http://www.spatialecology.com/gme.    

 

Start GME: 

Windows "Start" button > Programs > SpatialEcology > Geospatial Modelling 

Environment 

http://www.r-project.org/
http://www.spatialecology.com/gme


 

Finding commands: 

GME specific commands are listed on: 

http://www.spatialecology.com/gme/gmecommands.htm 

and are available within the GME manual: 

Windows "Start" button  Programs  SpatialEcology  GME Manual and 

Help Documentation (keyword index at back, table of contents at front, PDF 

search box, PDF table of contents) 

Note that these sources contain only a subset of the full list of available commands.  

Commands also are accessible through the pull-down menu under Commands within 

the GME command processor. 

 

General tips for working in GME: 

 

 Type your commands outside of GME (using Notepad or other text editor like Tinn-

R) and then copy and paste your commands into GME.  You cannot page up or use 

the up arrow to recover previous commands entered into GME.  However,  the 

command is repeated in the review window.  You can copy material out of the review 

window by right-clicking and choosing copy.  To effectively trace your workstream 

you should edit your commands and save results outside of the GME.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 At the beginning of your analysis, specify your working directory using the setwd 

command.  This saves you from needing to specify paths to all data files.  

Importantly, plan to use a single directory for all your input and output files (this is 

done using the all option for setwd).   

 Save and document your commands within the text editor of your choice.  As with R, 

GME recognizes the pound sign (#) as the precursor for comments that will be 

ignored if entered into the command processor (see figures above).   

 Some notes on Syntax: 
 

1. Text parameter values must be specified using double quotes (e.g. “x”), but 

this does not apply to the Boolean TRUE and FALSE arguments. 

2. Multiple commands entered simultaneously must be separated by a semi-

colon.   

3. Vectors must be enclosed within c(…) 
 

  

Command 

window 

Review 

window 



e.g., fakecommand(radius=20.4, field=”PolyID”, bandwidth=c(1000,1200,-200), 

update=TRUE) 
 

 Given that you will access GIS data within the GME, it is unwise to have ArcGIS 

open with the data you are using while running GME. To avoid data corruption 

issues, ArcGIS will not update its image of the visible data (even if you have just 

modified the data within GME) until you shut down and reopen the GIS window.  So 

it is wise to develop a habit of closing ArcGIS when working within GME.   

 If you run a command twice, specifying the same name for the output file, the output 

file is not replaced but appended to.  So if you create a set of 10 polygons in 

outfile.shp and run the command a second time outfile.shp will contain 20 of 

polygons (duplicates).  So either delete the original file or change the name for the 

repeat run.    

 Almost all commands follow the basic syntax of function name (input, output, other, 

optional); where there is a comma separating each input and a ; at the end of each 

line.  Other rules of thumb or things to remember: Capitalization DOES matter.  

Similar to R there is a difference between AnID and anid.  Spacing within “ “ is 

recognized, however spacing between the inputs is OK.  For example  

o in = “C:\data\test”, out =  “C:\data” is the same as  

o in=“C:\data\test”,out=“C:\data” 

 

Automation tips: 

 Use the "where" parameter to process subsets of data 

 Use "for" loops in conjunction with the paste() function to repeat commands 

 

2.  Kernel density estimation in GME 

 

Kernel density estimation (KDE) is an n-dimensional data smoothing technique that estimates a 

continuous probability density distribution. This exercise interfaces GME and R using the „ks‟ 

library in R to automatically produce optimized bandwidth estimates using smoothed cross-

validation.  GME has several options to calculate the bandwidth.  The help documents in the „ks‟ 

library in R discusses what each of the options are and the algebra used to calculate it.  Note that 

there can be large differences among the different bandwidth estimators, so it is recommended 

that you try several of them in order to determine which is most biologically relevant to your 

data and question.  Processing times may be long with large numbers of points (thousands). Note 

also that some algorithms (e.g. LSCV) are sensitive to points with identical coordinates. An 

example may be a den location and just keep using that same exact coordinates to reference the 

den.  Here, in order to keep the “importance” of that location, you might consider adding a small 

amount of random noise to those coordinates if this is an issue with your dataset. The bandwidths 

are calculated using the default settings for these estimators in the ks library in R.  

It takes some experience to learn what suitable cell size values are. A cell size that is too large 

will result in a 'blocky' output raster that is a poor statistical approximation to a continuous 

surface. A cell size that is too small will result in a very large output raster (many cells) that 

takes a long time to calculate. The GME help documentation has a short discussion on how to 

help determine cell size.   

 


