AutoCAD Civil 3D 2009

Tutorials
# Contents

<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>Welcome to the AutoCAD Civil 3D Tutorials</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Getting More Information</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Setting Up the Workspace</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>Saving Your Tutorial Drawings</td>
<td>3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Getting Started Tutorials</th>
<th>5</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tutorial: Understanding the AutoCAD Civil 3D User Interface</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Exercise 1: Understanding the Toolspace</td>
<td>6</td>
</tr>
<tr>
<td></td>
<td>Exercise 2: Using the Panorama Window</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>Exercise 3: Using Workspaces</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>Tutorial: Using Basic Functionality</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Tutorial: Viewing AutoCAD Civil 3D Objects</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>Exercise 1: Setting Up the Drawing Window</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>Exercise 2: Changing the Display of an Object</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Exercise 3: Viewing a Drawing in Model</td>
<td>19</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>Points Tutorials</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Tutorial: Creating Point Data</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>Exercise 1: Creating Description Keys</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>Exercise 2: Creating Point Groups</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>Exercise 3: Importing Points from a Database</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td>Tutorial: Displaying and Editing Points</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td>Exercise 1: Displaying an Externally Referenced Drawing</td>
<td>29</td>
</tr>
</tbody>
</table>
Exercise 2: Changing the Style of a Point Group ........................................... 30
Exercise 3: Changing Point Group Display Order ......................................... 31
Exercise 4: Removing an Externally Referenced Drawing ................................. 33
Exercise 5: Editing Points ........................................................................... 33
Tutorial: Adding User-Defined Properties to Points ...................................... 35
Exercise 1: Creating User-Defined Properties .............................................. 35
Exercise 2: Creating a Label Style That Displays a User-Defined Property ....... 37
Exercise 3: Assigning User-Defined Properties to Points ............................. 39
Exercise 4: Importing Points with User-Defined Properties ......................... 40
Exercise 5: Querying User-Defined Property Information ............................ 42

Chapter 4  Surfaces Tutorials ................................................................. 45
Tutorial: Creating and Adding Data to a Surface ........................................... 45
Exercise 1: Creating a New TIN Surface ..................................................... 48
Exercise 2: Adding Point Data to a Surface ................................................. 49
Exercise 3: Adding Breaklines to a Surface ............................................... 51
Exercise 4: Adding an Outer Boundary to a Surface .................................... 53
Tutorial: Working with Large Surfaces ....................................................... 54
Exercise 1: Limiting Imported Surface Data ............................................... 55
Exercise 2: Simplifying a Surface ................................................................ 60
Tutorial: Changing the Surface Style and Display ........................................ 62
Exercise 1: Editing the Surface Style .......................................................... 63
Exercise 2: Using a Different Style for a Surface ....................................... 64
Exercise 3: Labeling a Surface ................................................................... 65
Tutorial: Editing Surface Data .................................................................... 67
Exercise 1: Swapping TIN Edges ................................................................. 69
Exercise 2: Deleting TIN Lines .................................................................... 72
Exercise 3: Adding a Hide Boundary .......................................................... 74
Exercise 4: Smoothing a Surface ............................................................... 76
Tutorial: Creating a Watershed and Water Drop Analysis ............................. 77
Exercise 1: Configuring a Style for Watershed Display ............................... 78
Exercise 2: Generating a Watershed Analysis .......................................... 79
Exercise 3: Creating a Watershed Legend ................................................. 80
Exercise 4: Extracting Objects from a Surface ......................................... 81
Exercise 5: Analyzing Surface Water Runoff ............................................. 82
Tutorial: Generating Surface Volume Information ....................................... 86
Exercise 1: Creating the Base and Comparison Surfaces .............................. 87
Exercise 2: Creating a TIN Volume Surface .............................................. 89
Exercise 3: Creating a Composite Volume Calculation ............................... 91
Tutorial: Visualizing Surface Data .............................................................. 92
Exercise 1: Moving Multi-View Blocks to a Surface ..................................... 92
Exercise 2: Rendering a Surface ............................................................... 94
Tutorial: Obtaining an Aerial Image and Draping It on a Surface .................... 96
Exercise 1: Publishing Surface Data to Google Earth ................................. 98
Exercise 2: Importing a Google Earth Image .............................................. 101
### Chapter 5  **Survey Tutorials**

- Tutorial: Survey Setup .............................................. 109
  - Exercise 1: Setting Up the Database and Drawing .......... 109
  - Exercise 2: Setting the Equipment and Figure Prefix Databases .................................................. 110
  - Exercise 3: Adjusting and Verifying Settings ............ 112
  - Exercise 4: Setting Survey Styles ............................. 113
- Tutorial: Importing and Viewing Survey Data ................ 114
  - Exercise 1: Importing from a Field Book File ........... 115
  - Exercise 2: Viewing Survey Data ............................. 117
  - Exercise 3: Editing a Figure .................................. 119
  - Exercise 4: Removing an Erroneous Figure ............... 120
- Tutorial: Analyzing and Reducing Survey Data ................ 121
  - Exercise 1: Querying Survey Data ........................... 122
  - Exercise 2: Performing Traverse Analysis ............... 123
  - Exercise 3: Performing Least Squares Analysis .......... 125
  - Exercise 4: Translating a Survey Database ............... 127
- Tutorial: Manually Creating Survey Data ....................... 129
  - Exercise 1: Creating Survey Data Using the Toolspace Survey Tab .............................................. 129
  - Exercise 2: Creating Survey Data Using the Traverse Editor .................................................. 133
  - Exercise 3: Creating Survey Data Using the Survey Command Window .......................................... 137
  - Exercise 4: Calculating an Azimuth in The Astronomic Direction Calculator ................................. 139
  - Exercise 5: Creating Figures from Parcels .................. 142
- Tutorial: Outputting Survey Information ....................... 143
  - Exercise 1: Viewing Inverse and Mapcheck Information on a Survey Figure .................................. 143
  - Exercise 2: Performing a Mapcheck Analysis with Parcel Labels .................................................. 144
  - Exercise 3: Performing a Mapcheck Analysis by Manually Entering Data ....................................... 147
  - Exercise 4: Working with Mapcheck Data ................... 151
  - Exercise 5: Creating Surface Breaklines from Figures .... 152

### Chapter 6  **Project Management Tutorials**

- Tutorial: Using Data Shortcuts .................................. 155
  - Exercise 1: Setting Up a Data Shortcut Folder .......... 156
  - Exercise 2: Creating Data Shortcuts ......................... 157
  - Exercise 3: Referencing Data Shortcuts .................... 159
- Tutorial: Vault Setup ............................................. 161
  - Exercise 1: Logging In to Autodesk Vault .................. 162
Exercise 2: Creating User Accounts and Groups ........................................... 163
Exercise 3: Creating a Project ................................................................. 166

Tutorial: Creating, Referencing, and Modifying Project Object Data ............ 167
Exercise 1: Adding a Drawing to the Project ........................................... 167
Exercise 2: Creating a Reference to a Project Object ............................... 169
Exercise 3: Checking Out and Modifying a Project Object ......................... 170
Exercise 4: Checking In a Project Object .................................................. 172
Exercise 5: Updating a Project Object ...................................................... 172

Tutorial: Creating and Modifying Project Point Data .................................. 173
Exercise 1: Adding Points to a Project ..................................................... 174
Exercise 2: Checking Out and Modifying Project Points ........................... 175
Exercise 3: Checking In Project Points ..................................................... 176

Tutorial: Exporting and Importing Vault Projects ...................................... 177
Exercise 1: Exporting a Vault Project ....................................................... 177
Exercise 2: Importing a Data Shortcut Project into Vault ......................... 178

Chapter 7 Alignments Tutorials ................................................................. 179
Tutorial: Creating Alignments ................................................................. 179
Exercise 1: Creating an Alignment with Spirals and Curves ...................... 180
Exercise 2: Adding Free Curves and Spirals to an Alignment .................... 183
Exercise 3: Adding Floating Curves to an Alignment ................................ 185

Tutorial: Editing Alignments ................................................................. 189
Exercise 1: Editing the Layout Parameter Values of an Alignment ............... 190
Exercise 2: Grip Editing an Alignment ..................................................... 191

Tutorial: Designing an Alignment that Refers to Local Standards ............... 193
Exercise 1: Drawing an Alignment that Refers to Design Criteria ............... 194
Exercise 2: Viewing and Correcting Alignment Design Criteria Violations ...... 199
Exercise 3: Working with Design Checks ............................................... 202
Exercise 4: Modifying a Design Criteria File .......................................... 205

Chapter 8 Profiles Tutorials ................................................................. 209
Tutorial: Using Surface Profiles .............................................................. 209
Exercise 1: Creating and Displaying Surface Profiles ............................... 210
Exercise 2: Changing the Profile Style ................................................. 212
Exercise 3: Reviewing Surface Profile Characteristics ............................. 214

Tutorial: Using Layout Profiles .............................................................. 215
Exercise 1: Creating a Layout Profile ..................................................... 216
Exercise 2: Editing a Layout Profile ....................................................... 218
Exercise 3: Copying a Profile and Offsetting it Vertically .......................... 221

Tutorial: Designing a Profile that Refers to Local Standards ..................... 223
Exercise 2: Adjusting Grading Triangulation with a Feature Line ........................................... 294
Exercise 3: Working with Crossing Feature Lines ............................................................... 295

Chapter 11 Corridors Tutorials ......................................................................................... 301
Tutorial: Creating a Simple Corridor Model ................................................................. 301
Exercise 1: Creating a Simple Assembly ........................................................................ 302
Exercise 2: Creating a Simple Corridor .......................................................................... 304
Tutorial: Creating a Corridor Model With a Transition Lane ........................................ 306
Exercise 1: Creating an Assembly with a Transition Lane ............................................. 307
Exercise 2: Creating a Corridor with a Transition Lane ............................................... 310
Tutorial: Creating a Divided Highway ............................................................................. 314
Exercise 1: Viewing the Superelevation Properties of an Alignment .................................. 315
Exercise 2: Creating a Divided Highway Assembly ....................................................... 315
Exercise 3: Creating a Divided Highway Corridor ......................................................... 319
Tutorial: Viewing and Editing Corridor Sections .......................................................... 320
Exercise 1: Viewing Corridor Sections .......................................................................... 321
Exercise 2: Editing Corridor Sections ............................................................................ 324
Tutorial: Viewing and Rendering a Corridor .................................................................. 327
Exercise 1: Creating Corridor Surfaces ......................................................................... 327
Exercise 2: Creating Corridor Surface Boundaries ....................................................... 330
Exercise 3: Visualizing a Corridor ................................................................................ 333

Chapter 12 Advanced Corridor Design Tutorials ......................................................... 339
Tutorial: Intersection Design .......................................................................................... 339
Exercise 1: Matching Corridor Elevations in Profile ..................................................... 340
Exercise 2: Adding the Side Road to the Corridor .......................................................... 345
Exercise 3: Removing Overlapping Geometry at the Intersection .................................. 346
Exercise 4: Designing Intersection Curb Return Alignments and Profiles .................... 349
Exercise 5: Designing Intersection Curb Return Assemblies ......................................... 352
Exercise 6: Adding the Curb Returns to the Intersection ............................................... 356
Exercise 7: Evaluating the Intersection Corridor Surface for Drainage Issues .............. 363
Exercise 8: Adding a Boundary to the Intersection Corridor Surface .......................... 367
Tutorial: Roundabout Design ......................................................................................... 371
Exercise 1: Removing Overlapping Geometry at the Roundabout ................................ 372
Exercise 2: Designing Roundabout Alignments and Profiles ........................................ 375
Exercise 3: Designing the Roundabout Assembly .......................................................... 378
Exercise 4: Adding the Roundabout to the Corridor ...................................................... 380
Welcome to the AutoCAD Civil 3D Tutorials

The following tutorial sets are included with AutoCAD® Civil 3D®:

■ **Getting Started Tutorials** (page 5). Learn about the application workspace and some important design tools and tasks.

■ **Points Tutorials** (page 23). Learn how to work with coordinate geometry (COGO) points, which are the basis for modeling land surfaces.

■ **Surfaces Tutorials** (page 45). Learn the basics about creating and working with land surfaces.

■ **Survey Tutorials** (page 109). Learn the basics about importing, creating, managing, and analyzing survey data.

■ **Project Management Tutorials** (page 155). Learn how to use the AutoCAD Civil 3D project management features, including data shortcuts and Autodesk Vault.

■ **Alignments Tutorials** (page 179). Learn about alignments, which are the basis for modeling roads.

■ **Profiles Tutorials** (page 209). Learn the basics about viewing and designing the elevation profile of land surfaces along an alignment.

■ **Parcels Tutorials** (page 245). Learn the basics about creating and editing parcels as well as working with the display of parcels.

■ **Grading Tutorials** (page 267). Learn how to design the finished grade for land surfaces such as housing subdivisions and retail sites.

■ **Corridors Tutorials** (page 301). Learn how to create simple and complex corridor designs.

■ **Advanced Corridor Design Tutorials** (page 339). Learn how to use the advanced corridor design tools to incorporate complex features into your roadway design.
Sections Tutorials (page 405). Learn how to create cross sections of your corridor design, calculate cut and fill earthwork quantities, and create mass-haul diagrams.

Pipe Network Tutorials (page 427). Learn how to create a pipe network using the specialized layout tools.

Part Builder Tutorials (page 449). Learn how to design and model parts that are used in pipe networks.

Labels and Tables Tutorials (page 537). Learn how to annotate AutoCAD Civil 3D objects using labels and tables.

Plan Production Tutorials (page 605). Learn how to prepare your design drawings for plotting or publishing.

Each tutorial set contains exercises that are designed to explore the various features of AutoCAD Civil 3D.

To learn about AutoCAD Civil 3D and how it handles data, first complete the Getting Started tutorials. Then, you will have the basic skills you need to explore the tutorials about AutoCAD Civil 3D features, such as points, surfaces, project management, alignments, parcels, grading, corridors, pipe networks, and plan production.

The tutorial exercises are organized in a logical sequence, based on how you typically work with the different types of features. However, you may complete the exercises in any order you choose. After you begin an exercise, you should complete the steps in the order presented. The first steps provide you with the information you need for the later steps in that exercise.

NOTE All drawings used in these tutorials are available in the tutorial drawings folder (page 615) and all source data files are available in the tutorial folder (page 615). If you want to save your changes to the tutorial drawings as you work, save them to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original tutorial drawings.

Getting More Information

The step-by-step procedures in these tutorials provide instructions for using AutoCAD Civil 3D to complete tasks using the drawings provided.

The tutorials do not explore all of the features and commands of AutoCAD Civil 3D, nor do the tutorials identify all of the options associated with each
feature and command. To obtain more detailed information about AutoCAD Civil 3D features and commands, refer to the following documentation:

- *AutoCAD Civil 3D 2009 Help*
- *AutoCAD Civil 3D 2009 Getting Started Guide*

## Setting Up the Workspace

Before you start the tutorials, you must set the appropriate workspace.

Workspaces are sets of menus and toolbars that are grouped and organized so that you can work in a custom, task-oriented drawing environment. When you choose a workspace, only the menus, toolbars, and secondary windows specified in that workspace are shown in the interface. To access other commands not shown in the menus, enter their command names on the command line.

The tutorials use the Civil 3D Complete workspace. If you use a different workspace, some of the menus and toolbars that are described may not be visible. To avoid confusion, it is recommended that you switch to the Civil 3D Complete workspace before you begin the tutorials.

For more information, see the AutoCAD Civil 3D Help topic *Civil 3D Workspaces*.

**To set up the workspace**

1. On the command line, enter `WORKSPACE`.
2. At the Workspace Option prompt, enter `C`.
3. When prompted to enter the name of the workspace, enter `Civil 3D Complete`.

## Saving Your Tutorial Drawings

If you want to save your changes to the tutorial drawings as you work, you must create a folder in which to save drawing and data files before beginning the tutorial exercises.

Before you begin the tutorials:

1. Open Windows Explorer.
2 Navigate to the \My Documents\Autodesk folder.

3 Click File menu ➤ New ➤ Folder.

4 Change the name of the new folder to My Civil 3D Tutorial Data.
These tutorials will get you started with the application workspace and some important design tools and tasks.

In AutoCAD Civil 3D, design data is organized as object collections in the Toolspace window. In Toolspace, the Prospector tab displays the hierarchy of design objects, such as points, surfaces, and alignments. The Settings tab displays a hierarchy of object styles, including styles for labels and tables.

The Panorama window displays data in a horizontally oriented grid, which makes it easier to see many columns at once. Each type of data displayed in Panorama uses a separate tab, known as a vista, that is specific to that data type.

Workspaces are sets of menus and toolbars that are grouped and organized so that you can work in a custom, task-oriented drawing environment. When you use a workspace, only the menus, toolbars, and secondary windows specified in that workspace are shown in the interface.

There are many ways to view AutoCAD Civil 3D objects, including Visual Styles, Named Views, and the Object Viewer.

NOTE All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic The Civil 3D User Interface.

Tutorial: Understanding the AutoCAD Civil 3D User Interface

In this tutorial, you will examine some of the major components of the AutoCAD Civil 3D user interface.
Exercise 1: Understanding the Toolspace

In this exercise, you will learn how to use the AutoCAD Civil 3D Toolspace, which provides an object-oriented view of your engineering data.

For more information, see the AutoCAD Civil 3D Help topic The Toolspace Window.

To explore the Civil 3D Toolspace

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing called Intro-1.dwg.

2. In Toolspace, click the Prospector tab. Toolspace can be docked, but it can also float.

   **NOTE** If the Toolspace is not visible, enter ShowTS on the command line.

3. Click next to the name of the drawing. This shows you the top-level objects in the drawing. If you want to see lower-level objects and further expand the object tree, click any of the signs.

   Each object is known as a *collection*, and represents a group of objects. The Prospector tab gives you a neatly organized view of all objects in a drawing.

4. Click next to the Sites collection. The drawing contains only one site, Site 1.

5. Expand the Site 1 collection. Notice that the Site 1 collection includes four object collections: Alignments, Feature Lines, Grading Groups, and Parcels. A site provides a logical grouping of objects that form part of the...
same design project, or are otherwise related. An object can belong to only one site.

Notice that there is an Alignments collection above the top-level Sites collection. This collection allows alignments to exist outside of a site. When an alignment is contained in a site, it subdivides any parcels it crosses over and creates new parcels if it forms closed areas from itself or other alignments in the site. When an alignment is in the top-level Alignments collection, it does not interact with itself or any other objects.

6 Expand the Parcels collection to see the names of individual parcels in Site 1. Notice that the drawing includes different styles of parcels, such as Single-Family and Standard.

7 Click a parcel name. The parcel is displayed in a preview region of the Prospector tab.

**NOTE** If the preview does not work, you can activate it. First, ensure that the item preview button at the top of the Prospector tab is pressed in. Then, right-click the Parcels collection and click Show Preview.

8 Right-click one of the Single-Family parcels. Click Properties. The properties of the parcel are displayed in a dialog box. Note the detailed survey data shown on the Analysis tab. Review these properties as you wish, but do not change anything.

9 Click the Information tab. Change the Object Style from Single-Family to Open Space. Click OK. Notice that the appearance of the parcel changes in the drawing, and in the item view preview. The name of the parcel changes in the Parcels collection on the Prospector tab. Use pan and zoom controls if necessary. For more information, see Panning and Zooming (page 12).

If a range of useful styles is available in a drawing template, it is easy to control object appearance by simply selecting an appropriate style.

**Further exploration:** In Toolspace, on the Prospector tab, in the expanded objects tree, right-click various objects at different levels. Note the different menus that appear. On the menus for individual objects, such as surfaces, alignments, and point groups, click Properties as you did for parcels. Do not change any data as you explore.

10 Along the edge of the Prospector tab, click the Settings tab. The Settings tab contains a tree structure of object styles and settings for the drawing. It is similar in structure to the Prospector tab, with collections at several levels.
11 Expand the Settings tree by clicking next to the drawing name, Parcel, and Parcel Styles. This collection displays the set of available styles, including the Standard style. Every object has a Standard style, which provides good display and behavior when you do not want to select a more specific style.

12 Right-click the Standard parcel style and click Edit. A four-tabbed dialog box is displayed, showing you the attributes of this style. Explore the contents of the tabs to see the various attributes that can be changed when you create a style.

13 Click Cancel to close the Parcel Styles dialog box.

**Further exploration:** Expand the Settings tree and look at several style objects and commands. Right-click various objects to see the available menu selections, but do not change anything.

To continue this tutorial, go to Exercise 2: Using the Panorama Window (page 8).

## Exercise 2: Using the Panorama Window

In this exercise, you will learn how you can use and customize the Panorama window.

For more information, see the AutoCAD Civil 3D Help topic *The Panorama Window*.

This tutorial continues from Exercise 1: Understanding the Toolspace (page 6).

### To display object data in the Panorama window

**NOTE** This tutorial uses *Intro-1.dwg* from the previous tutorial.

1 In Toolspace, on the Prospector tab, expand the Point Groups collection.

2 Right-click _All Points and click Edit Points. A table called Point Editor is displayed inside your drawing window in a separate window called the Panorama. In the next few steps, you will add another table to this window.

3 Ensure that you can see one of the road alignments in your drawing. The alignments are lines with labels in the center of the roadways. If necessary,
use Pan and Zoom controls. To move the Panorama window, click the middle part of the vertical control bar where you see the Panorama title. Drag the window to a new location.

**TIP** Hold down the Ctrl key to prevent the Panorama window from docking when you move it.

4 Click Alignments menu ➤ Edit Alignment Geometry. You are prompted to select an alignment.

5 Click an alignment in the drawing.

6 In the Alignment Layout Tools toolbar, click . Another table, called Alignment Entities, is added to the Panorama window.

Notice that the table names appear on tabs. The main control bar is labeled Panorama. Each table in Panorama is called a *vista*. These tables are useful for editing object attributes. Other vistas are available for features such as Surfaces and Profiles. You can edit data in cells that appears as black text. You cannot edit data in cells that are shaded (unavailable). In the next few steps, you will learn to use some of the Panorama controls.

7 Click the two vista tabs in turn to switch from one table to the other. Bring the Alignment Entities table to the front.

8 Scroll to the right until you see the Chord Length column. You will move this column to a position next to the Length column, which is about five columns to the left.

9 Click the Chord Length column heading, drag the column to the left, and drop it to the right of the Length column. Notice that each column heading is highlighted as you pass through it.

10 Right-click the Radius column heading. Click Customize Columns.

The Customize Columns dialog box allows you to modify the appearance of the columns in the current vista. You can hide unnecessary columns by clearing the appropriate check boxes in the Visibility column, or change the width of columns using the Width column. Clicking the New button allows you to save a custom vista configuration for later use.

11 Click Cancel to close the Customize Columns dialog box.
To change the appearance of the Panorama window

1. On the Panorama control bar, click \( \text{Auto-Hide Mode} \) to temporarily close the window.

2. Without clicking, move your pointer over the Panorama control bar. The window opens while the pointer is on the bar. It closes when you move the pointer off the vista. This is \textit{Auto-Hide Mode}, indicated by \( \text{Auto-Hide Mode} \). It is useful when you want to periodically consult a table while working in the drawing window.

3. Click \( \text{Auto-Hide Mode} \) to turn off Auto-Hide Mode.

4. On the Panorama control bar, click \( \text{Transparency} \). Click Transparency.

5. In the Transparency dialog box, move the General slider to a position in the middle of the range. Click OK.

6. Drag the Panorama window. When you move the cursor away from the window, notice that you can see some drawing details through the table.

7. In Panorama, click the Point Editor tab. Click \( \text{Close the vista} \) to close the vista. If other vistas are currently open, they remain open in the Panorama window.

To continue this tutorial, go to Exercise 3: Using Workspaces (page 10).

Exercise 3: Using Workspaces

In this exercise, you will change the menus and toolbars that are visible in the AutoCAD Civil 3D user interface.

Workspaces are sets of menus and toolbars that are grouped and organized so that you can work in a custom, task-oriented drawing environment. When you use a workspace, only the menus, toolbars, and secondary windows specified in that workspace are shown in the interface. To access other commands not shown in the menus, enter their command names on the command line.

For more information, see the AutoCAD Civil 3D Help topic \textit{Civil 3D Workspaces}.

This exercise continues from Exercise 2: Using the Panorama Window (page 8).
To change the workspace

NOTE This tutorial uses Intro-1.dwg from the previous tutorial.

1 On the AutoCAD status bar, click Workspace Switching. A list of the currently available workspaces is displayed. Click Visualization And Rendering.

The Visualization and Rendering workspace contains features that are commonly used for visualization and rendering tasks. Features that are not typically necessary for these tasks are hidden.

To access other commands not shown in the menus, enter their command names on the command line.

You also can change the workspace using the command line.

2 On the command line, enter Workspace. Enter ?.

The AutoCAD Text Window is displayed, and lists the names of the currently available workspaces.

3 Close the AutoCAD Text Window.

4 On the command line, enter Workspace. Press Enter to accept the default SetCurrent option.

5 Enter Civil 3D Complete.

The full set of original AutoCAD Civil 3D menus and toolbars is displayed.

6 On the status bar, click Workspace Switching. Click Save Current As.

The Save Workspace dialog box is displayed, where you can save your current workspace configuration as a new workspace. For example, if you move, hide, or display a toolbar or a tool palette group, you can preserve the display settings for future use by saving the current settings to a workspace.

7 In the Save Workspace dialog box, click Cancel.

8 On the status bar, click Workspace Switching. Click Workspace Settings.

The Workspace Settings dialog box is displayed, where you can change the display and menu order, and save the settings of a workspace. Examine the controls in the dialog box.
In the Menu Display And Order area, you can control which workspaces you want to appear in the Workspaces list, as well as the order in which they appear in the list.

The workspace shown in the My Workspace list is the default workspace.

In the When Switching Workspaces area, you can specify whether you want to save the changes you make to a workspace when you switch to another workspace.

9 Click Cancel to close the Workspace Settings dialog box.

10 On the status bar, click Workspace Switching. Click Customize. The Customize User Interface dialog box is displayed. You can use this dialog box to customize the menus, toolbars, tooltips, shortcut keys, and other user interface elements to tailor your drawing environment to suit your needs. For more information, see the AutoCAD Customization Guide, which is available in the AutoCAD Civil 3D Help.

11 In the Customize User Interface dialog box, click Cancel.

To continue to the next tutorial, go to Using Basic Functionality (page 12).

**Tutorial: Using Basic Functionality**

In this tutorial, you will learn how to navigate around AutoCAD Civil 3D and how to use some common features of the interface.

**Panning and Zooming**

You can use the zoom and pan commands to change the viewing scale of the drawing or move to a different area of the open drawing. Use either of the following two methods to pan and zoom:

**Right-Click (Shortcut) Menus**

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing called Intro-1.dwg.

2 Right-click the XGND surface name in the Prospector tree. Click Zoom To.
3 In the drawing, right-click and click Zoom. Click and drag upwards to zoom in closer to the surface.

4 To stop zooming and use the normal pointer, right-click and click Exit.

5 With no objects selected in the drawing, right-click in the drawing and click Pan.

6 Click and drag in any direction to move around the drawing.

7 To stop panning and use the normal pointer, right-click and click Exit.

**Standard Toolbar**

1 On the Civil 3D Standard toolbar, click

2 Click and drag upwards to zoom in closer to the surface.

3 To stop zooming and use the normal pointer, right-click and click Exit.

4 On the Civil 3D Standard toolbar, click

5 Click and drag in any direction to move around the drawing.

6 To stop panning and use the normal pointer, right-click and click Exit.

The standard toolbar includes additional zoom controls. All pan and zoom controls are also accessible on the View menu. For more information, open AutoCAD Help ➤ Command Reference ➤ Commands. See the entries for Pan in P Commands and Zoom in Z commands.

**Selecting and Deselecting**

There are several ways to select objects in AutoCAD Civil 3D:

- To select an object, click it in the drawing window.
- To select an individual object that is part of a group of objects, press and hold Ctrl while clicking the object.
- To select several objects by enclosing them within a rectangular area, drag your cursor from left to right. A rectangle with a solid line appears. Only objects that are enclosed in the rectangular area are selected.
To select several objects by crossing over them with a rectangular area, drag your cursor from right to left. A rectangle with a dashed line appears. Any objects that the dashed line crosses over are selected.

If you select the wrong object, press Esc to deselect it.

Experiment with the selection methods using the objects in drawing Intro-1.dwg.

**Object Snapping**

This standard AutoCAD feature is useful for precision drafting, when you want the line you are drawing to snap to entity edges or specific points. In these tutorials, you may prefer to use a freehand mode for drawing and editing objects, such as horizontal alignments and layout profiles.

Object snaps, also known as OSNAPs, can be used in either of two ways:

- **Individual, or single-point OSNAPs**—To snap to a specific type of point, hold the Shift key down and right-click. Select an object snap from the shortcut menu. The object snap stays in effect only for the next point that you click.

- **Multiple, or running OSNAPs**—You can toggle Object Snap on and off by clicking on the status bar at the bottom of the main application window, or by pressing F3 or Ctrl+F. Object Snap is off when the button is in a raised position.

For more information about using Object Snap, do the following:

1. Press F1 to open AutoCAD Civil 3D Help.
2. In the left pane, click Search.
3. In the Type In The Word(s) To Search For field, enter Osnap.
4. In the Select A Section To Search list, select All Documentation.
5. Click Search. Select from the topics that are displayed.

In most cases, it is recommended that you also turn off other cursor controls on the status bar, such as Snap, Grid, and Ortho. The Model button, however, should remain on.
Object Selection Preview

By default, the AutoCAD object selection feature gives you a preview whenever you place your cursor on an object you can select. This option creates a flickering effect as you pass your cursor over the features of large objects, such as contours on a surface. In some cases, you may prefer to see the selected effect for objects only after you have selected them. To change the selection preview settings:

1. On the command line, enter Options.
2. In the Options dialog box, on the Selection tab, clear When A Command Is Active and When No Command Is Active.
3. Click OK.

For more information about customizing object selection, see AutoCAD Help.

Dynamic Input

Dynamic input is an AutoCAD feature that displays prompts from the command line beside the cursor. Dynamic input provides a place for you to enter values when a command is active. For these tutorials, you may want to toggle off the dynamic input feature. To turn dynamic input off, click on the status bar at the bottom of the main application window, or press F12.

For more information about dynamic input, see AutoCAD Help.

To continue to the next tutorial, go to Viewing AutoCAD Civil 3D Objects (page 15).

Tutorial: Viewing AutoCAD Civil 3D Objects

This tutorial demonstrates several ways to display objects in plan and model views.

There are a variety of ways to view AutoCAD Civil 3D objects. In this tutorial, you will learn how to use some of the most common methods, including viewports, named views, display representations, 3D views, and visual styles.

For more information, see the AutoCAD Help topic Use 3D Viewing Tools.
Exercise 1: Setting Up the Drawing Window

In this exercise, you will configure the drawing window, using named views and viewports.

For more information, see the AutoCAD Help topics Save and Restore Views and Display Multiple Views in Model Space.

To divide the drawing area into separate viewports

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Intro-2.dwg.
   This drawing contains an existing ground surface, several alignments, and several profile views that contain existing ground and layout profiles.

2. Click View menu ➤ Viewports ➤ 2 Viewports. Press Enter to display the viewports vertically.
   Two viewports are displayed. Each viewport is a separate window in which you can pan and zoom to different views of the drawing. You can create custom viewport configurations and save them for later use.

3. Click in each of the viewports. Notice that as you click in a viewport, the border darkens to indicate which viewport is currently active. Click the viewport on the right side to make it active.

4. On the command line, enter ZE.
   The surface and profile views are displayed in the right viewport.

To apply a saved drawing view

1. Click the viewport on the left side to make it active.

2. Click View menu ➤ Named Views.

3. In the View Manager dialog box, under Views, expand the Model Views category.
   Three views have been created in this drawing. Each named view consists of a specific magnification, position, orientation, and layer status. Named views are saved with a drawing and can be used any time. When your drawing is displaying a specific view to which you want to return, you can save it as a named view by clicking the New button in the View Manager dialog box.
4 Click the Surface Extents view. Notice that a preview of the view appears in the lower right corner of the dialog box. Click Set Current. Click OK. The extents of the EG surface appears in the left viewport.

To continue this tutorial, go to Exercise 2: Changing the Display of an Object (page 17).

**Exercise 2: Changing the Display of an Object**

In this tutorial, you will change the appearance of a surface by changing its style. You will examine the style settings that affect how an object is represented in plan, profile, and model views.

For more information, see the AutoCAD Civil 3D Help topic *Styles*.

This exercise continues from Exercise 1: Setting Up the Drawing Window (page 16).

To modify the display of a surface

**NOTE** This tutorial uses *Intro-2.dwg* from the previous tutorial.

1 In Toolspace, on the Prospector tab, expand the tree under the drawing name. Expand the Surfaces collection to see the surface name XGND.

2 Right-click the surface, XGND, and click Surface Properties.

3 In the Surface Properties dialog box, on the Information tab, under Surface Style, select a different style, such as Border & Elevations.
4 Click Apply. The appearance of the surface now reflects the settings of the style you selected.

5 To show a different view of the surface, repeat Steps 2 through 4, selecting a different style.

6 After you have explored other styles, set the original style, Visualization. Click Apply. Leave the Surface Properties dialog box open.

**To examine the object style settings**

1 In the Surface Properties dialog box, on the Information tab, in the Default Styles area, notice the Render Material list. This list indicates the material that is applied to the surface object. When the surface is rendered in model view, the surface will be displayed using this material.

2 Click Cancel.

3 In the right viewport, zoom in to one of the profile grids. Select the blue, layout profile line. Right-click. Click Profile Properties.

4 In the Profile Properties dialog box, on the Information tab, in the Object Style area, click .

5 In the Profile Style dialog box, click the Display tab. In the View Direction list, make sure that Profile is selected. The table identifies how the profile components are displayed in a profile view. The basic appearance of the individual object components is controlled on this tab. Components that have ☑ in the Visibility column are visible when the profile is displayed in a profile view. The Layer, Color, Linetype, LT Scale, and Lineweight of the components are controlled on this table. In the drawing window, notice that the layout profile line is blue, as identified in the Color column.

Other AutoCAD Civil 3D object styles use the same basic structure to control display components. Most other objects, such as alignments, have a Plan view direction in place of the Profile view direction. The Plan view direction identifies how the object components are displayed in plan view.

6 In the View Direction list, select Model.
In the table, notice that the Layer and Color settings are different from the Profile view direction. When the layout profile line is viewed in model, it uses the display settings listed in this table.

**NOTE** In the View Direction list, notice that a Section selection is available. This View Direction specifies how the surface will be displayed when it is viewed as part of a corridor section. You will learn about viewing and editing corridor sections in the Viewing and Editing Corridor Sections tutorial (page 320).

7 Click Cancel to close the Profile Style and Profile Properties dialog boxes.
8 Press Esc to deselect the layout profile.

To continue this tutorial, go to Exercise 3: Viewing a Drawing in Model (page 19).

**Exercise 3: Viewing a Drawing in Model**

In this exercise, you will learn some ways to view drawing objects in three-dimensional views.

For more information, see the AutoCAD Help topic *Use 3D Viewing Tools*.

This exercise continues from Exercise 2: Changing the Display of an Object (page 17).

**To examine object display in plan and model views**

**NOTE** This tutorial uses Intro-2.dwg from the previous tutorial.

1 Click the left viewport to make it active.
2 Click View menu ➤ 3D Views ➤ SE Isometric. A Southeast isometric view of the surface is displayed in the left viewport, and the right viewport stays in plan view.
3 Zoom in to the isometric view of the surface. Notice the green and blue lines. The green lines are the layout profiles that you examined in profile view. They are green because the Model view direction in its style indicated that they will display as green. The blue lines under the surface are the horizontal alignments from which the profiles were created.
Click View menu ➤ Visual Styles ➤ 3D Wireframe.

AutoCAD visual styles give a fast, basic visualization of an object that is useful for on-screen presentation in AutoCAD Civil 3D. The 3D Wireframe visual style displays the surface in model view without applying a fill material to the object.

Notice that a cube is displayed in the upper right-hand corner. This is the AutoCAD ViewCube, which provides visual feedback of the current orientation of a model. You can use the ViewCube to adjust the viewpoint of the model when a visual style has been applied.
5 Click a corner of the ViewCube, and drag it to a new position. Experiment with dragging the ViewCube to various positions. When you are finished, click to return the model and ViewCube to their original positions.

6 Click View menu ➤ Visual Styles ➤ Conceptual.
The Conceptual visual style shades the object and smooths the edges between polygon faces. The shading in this style uses the Gooch face style, a transition between cool and warm colors rather than dark to light. The effect is not realistic, but it can make the details of the model easy to see.

7 Click View menu ➤ Visual Styles ➤ Realistic.
The Realistic visual style shades the surface and smooths the edges between polygon faces. The render material that is specified in the surface style is displayed.
These tutorials will get you started working with coordinate geometry (COGO) points, which are the basis for modeling land surfaces. These tutorials demonstrate how to import survey points into a drawing from a database, and how to classify a large set of points into more manageable groups.

Before you import a large set of points, it is a good idea to structure your drawing environment so that as the points are created, they are sorted into meaningful groups, with appropriate styles and other attributes.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Understanding Points.

**Tutorial: Creating Point Data**

This tutorial demonstrates several useful setup tasks for organizing a large set of points.

In this tutorial, you will learn about managing a set of points related to stormwater manholes and detention ponds. You will create description keys and point groups to sort the points as they are imported into a drawing. Then, you will import the points from an existing file.

*Description keys* can help you automate many point-handling tasks at the time that points are created or imported. A description key uses the raw description code of a point to determine how to process the point. For example, you can configure a description key to apply different styles or place points on different drawing layers.
You can classify a set of points into several point groups, based on the type of point, elevation, date of creation, source, or other criteria. Then you can run various queries or operations for point display against a point group, rather than the whole set.

Points can be imported from a text file or a Microsoft Access database. Data created in Autodesk Land Desktop can be migrated to AutoCAD Civil 3D by importing points directly from a project database.

You can create a large point set and organize it later. However, it is usually more efficient to classify points into several groups as they are being created.

For more information, see the AutoCAD Civil 3D Help topic Creating Points.

Exercise 1: Creating Description Keys

In this exercise, you will create description keys to sort the points as they are imported into a drawing.

For more information, see the AutoCAD Civil 3D Help topic Description Keys.

To create description keys

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Points-1.dwg.
2. In Toolspace, on the Settings tab, expand the Point collection.
3. Right-click Description Key Sets. Click New.
4. In the Description Key Set dialog box, Name field, enter Stormwater Keys.
5. In the Description field, enter Stormwater manhole and pond points.
6. Click OK. The new description key set is created.
7. In Toolspace, on the Settings tab, expand the Description Key Sets collection. Right-click Stormwater Keys. Click Edit Keys. The DescKey Editor is displayed in a Panorama window.
   In the DescKey Editor, you will next enter the raw description codes, and specify how AutoCAD Civil 3D handles new points that have these codes. All entries in the Code column of the DescKey Editor are case sensitive.
8. In DescKey Editor, in the Code column, click the default entry. Change it to POND*. The asterisk is a wild-card character. The asterisk causes any imported point with a description code that begins with POND, followed
by any other characters, to be handled according to the settings in this table row.

9 In both the Point Style and Point Label Style columns, clear the check box to deactivate these settings. Clearing these settings allows you to control these settings by using point group properties.

**NOTE** The Format column contains the entry $*, which specifies that a point’s raw description is copied without changes and used for the full description in the point label. This is an acceptable setting for the POND points.

10 In the Layer column, select the check box. Click the cell to open the Layer Selection dialog box.

11 In the Layer Selection dialog box, select V-NODE-STRM. Click OK. This setting means that the POND points reference the V-NODE-STRM layer for their display attributes. In the next few steps, you create another description key.

12 In the Code column, right-click the POND* entry. Click New.

13 In the new description key, click the default Code entry and change it to MHST*.

14 Set the same styles and layer as you did for POND* by repeating Steps 9 through 11.

15 In the Format column, enter STORM MH. This setting ensures that points with a raw description of MHST* (stormwater manholes) are labeled in the drawing as STORM MH.

16 Click ✅ to save the description keys and close the editor.

To continue this tutorial, go to Exercise 2: Creating Point Groups (page 25).

**Exercise 2: Creating Point Groups**

In this exercise, you will create point groups to sort the points as they are imported into a drawing.

For more information, see the AutoCAD Civil 3D Help topic *Point Groups*.
This exercise continues from Exercise 1: Creating Description Keys (page 24).
To create point groups

NOTE This exercise uses Points-1.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Prospector tab, right-click the Point Groups collection. Click New.

2. In the Point Group Properties dialog box, on the Information tab, in the Name field, enter Detention Pond. Optionally, enter a short description in the Description field.

3. On the Raw Desc Matching tab, select POND*. Click Apply. This option specifies that all points with the POND* raw description are added to the Detention Pond point group.

   Notice how the description key setting is recorded on both the Include and Query Builder tabs. If you know SQL, you can see how you could add more criteria to the Query Builder tab to select a more specific set of points for the point group.

4. Click OK to close the Point Group Properties dialog box.

5. Create another point group by repeating Steps 1 through 4, but use the following values:
   - Name: Storm Manholes
   - Raw Desc Matching: MHST*

   Your drawing should now contain the same description keys and point groups shown in sample drawing Points-1a.dwg.

6. In Toolspace, on the Prospector tab, expand the Point Groups collection.

7. Right-click the _All Points collection. Click Properties.

8. In the Point Group Properties dialog box, on the Information tab, change the Point Label Style to Standard.

9. Click OK to close the Point Group Properties dialog box.

To continue this tutorial, go to Exercise 3: Importing Points from a Database (page 27).
Exercise 3: Importing Points from a Database

In this exercise, you will import points from a database to a drawing that uses description keys to sort points into groups.

For more information, see the AutoCAD Civil 3D Help topic Importing and Exporting Points.

This exercise continues from Exercise 2: Creating Point Groups (page 25).

To import points from a database

NOTE This exercise uses Points-1.dwg with the modifications you made in the previous exercise, or you can open Points-1a.dwg from the tutorial drawings folder (page 615).

1. In Toolspace, on the Prospector tab, right-click Points. Click Create.

2. In the Create Points dialog box, click . Expand the Default Layer parameter, then change the value to V-NODE.

3. In the Create Points dialog box, click Import Points.

4. In the Format list, select External Project Point Database.

5. Click . Browse to the tutorial folder (page 615). Select points.mdb. Click Open.

6. In the Import Points dialog box, clear the Advanced Options.

7. Click OK. The points are imported.

8. In Toolspace, on the Prospector tab, right-click the _All Points point group. Click Zoom To.

   The points are displayed both in the drawing and in tabular form in the Toolspace list view. In the drawing window, if you move the cursor over a point, a tooltip displays basic data about the point. Notice that the two stormwater point groups appear to be empty. This is because they have not been updated with their new content. In the next few steps, you will see how AutoCAD Civil 3D provides several ways to check the point data before adding it to your drawing.

9. Right-click the Point Groups collection. Click Properties.
The Point Groups dialog box is displayed. Point groups are listed here according to their display order, with the highest priority group at the top. Arrows at the side of the dialog box allow you to change the display order. The icon † indicates that an update is pending for a point group.

10 To show the contents of the update for each point group, click . Review the list of points that the application is prepared to add to the Storm Manholes and Detention Pond point groups.

11 In the Point Group Changes dialog box, click Close.

12 To update the point groups, click . Click OK. Alternatively, you can right-click the Point Groups collection and click Update.

The point groups update. Now, you can display their points in the list view and zoom to them in the drawing.

13 Right-click a point group. Click Edit Points. The points are displayed in the Point Editor table. Review and change their attributes.

**NOTE** For information about changing the contents and display of the Panorama window, see the Using the Panorama Window tutorial (page 8).

To continue to the next tutorial, go to Displaying and Editing Points (page 28).

**Tutorial: Displaying and Editing Points**

This tutorial demonstrates how to use point groups, layers, external references, and styles to display points. It also explains the various ways to edit points using standard AutoCAD tools.

You can use point groups to organize points and to control their appearance in a drawing. While points are independent objects that do not have to be categorized into specific point groups, every point in a drawing is always part of the _All Points point group. The point group display order determines which point group’s properties take precedence. For example, if a point belongs to a point group that is higher in the display order than the _All Points point group, the higher group’s properties override the properties set in the _All Points point group.
The *point layer* controls the display attributes of the point. To see this, open the Point Group Properties dialog box, click the Point List tab, and look at the Point Layer column. This column also appears in the Prospector list view when the point group is selected. The point layer can be assigned by using a description key. If a point layer is not assigned during creation, points are placed on the default point layer specified in the drawing settings.

An external reference drawing (*xref*) is a useful way to see points in relation to other surface features without adding these features to your drawing. You can reference another drawing and make it appear as an underlay in your current drawing. Then, you can detach the external drawing when you no longer need it.

Changing the point or label style of a point group can help you distinguish these points more easily from other points in the drawing.

Each point is an object that can be individually selected and manipulated. Point objects have commands, property attributes, and grip behavior that are similar to other AutoCAD entities.

For more information, see the AutoCAD Civil 3D Help topic *Controlling the Appearance of Points in a Drawing*.

---

**Exercise 1: Displaying an Externally Referenced Drawing**

In this exercise, you will use a standard AutoCAD operation to display another drawing of the region around your set of points.

For more information, see the AutoCAD Help topic *Attach Drawing References (Xrefs)*.

This exercise continues from the *Creating Point Data* (page 23) tutorial.

**To display an externally referenced drawing**

1. Click Insert menu ➤ DWG Reference.
2. In the Select Reference File dialog box, navigate to the tutorial drawings folder (page 615) and open *Existing Basemap.dwg*. Select it and click Open.

---

NOTE This exercise uses *Points-1a.dwg* with the modifications you made in the previous tutorial, or you can open *Points-2.dwg* from the tutorial drawings folder (page 615).
3  In the External Reference dialog box, in the Reference Type area, click Overlay.

4  Clear the check boxes for Insertion Point and Scale.

5  Click OK.

The basemap appears on the screen, allowing you to see the points of interest in relation to the road design and other contextual features. This external reference remains separate from your drawing. There is no risk of unexpected changes to your drawing. In a later exercise, you will learn how to detach the external reference.

To continue this tutorial, go to Exercise 2: Changing the Style of a Point Group (page 30).

**Exercise 2: Changing the Style of a Point Group**

In this exercise, you will change the style of a point group. Point styles can help you distinguish the points more easily from other points in the drawing.

For more information, see the AutoCAD Civil 3D Help topic Changing the Properties of a Point Group.

This exercise continues from Exercise 1: Displaying an Externally Referenced Drawing (page 29).

**To change the style of a point group**

**NOTE** This exercise uses Points-2.dwg and Existing Basemap.dwg with the modifications you made in the previous exercise.

1  Zoom in to the upper left area of the screen where you can clearly see the labels for several POND points and one or more STORM MH points. Notice that both types of points use the same marker style (X).

2  In Toolspace, on the Prospector tab, right-click the point group _All Points. Click Properties.

3  In the Point Group Properties dialog box, on the Information tab, change the Point Label Style to <none>.

4  Click Apply, and then OK, to save the change and close the Point Group Properties dialog box. Labels for all points that do not have a label style set in another point group are hidden. The point markers are still visible.
because markers are controlled by the point style, which you did not change.

5 In Toolspace, on the Prospector tab, right-click the point group Storm Manholes. Click Properties.

6 In the Point Group Properties dialog box, on the Information tab, change the Point Style to Storm Sewer Manhole.

7 Click Apply, and then OK, to save the change and close the Point Group Properties dialog box. The stormwater manhole points are now marked with the symbol defined in the Storm Sewer Manhole point style.

To continue this tutorial, go to Exercise 3: Changing Point Group Display Order (page 31).

Exercise 3: Changing Point Group Display Order

In this exercise, you will use the point group display order to change the appearance of points.

For more information, see the AutoCAD Civil 3D Help topic Changing the Point Group Display Order.

To change the point group display order

NOTE This exercise uses Points-2.dwg and Existing Basemap.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Prospector tab, right-click the Point Groups collection. Click Properties.

2 In the Point Groups dialog box, notice the display order of the point groups.

The point group display order determines how points that belong to more than one point group are displayed in a drawing. When a drawing is opened or regenerated, AutoCAD Civil 3D searches down the point group display order to determine how the point will appear. For example, if a point belongs to all three groups, AutoCAD Civil 3D will first look in the Storm Manholes point to determine if point label style has been assigned to that point group. If it has not, AutoCAD Civil 3D will look in the Detention Pond point group, and then the _All Points group until the point label style setting is found.
3 Click Cancel to close the Point Groups dialog box.

4 In Toolspace, on the Prospector tab, right-click the _All Points point group. Click Properties.

5 In the Point Group Properties dialog box, on the Information tab, make sure that Point Style is set to Standard and Point Label Style is set to <none>. Click Apply, and then OK.

6 In Toolspace, on the Prospector tab, right-click the Point Groups collection. Click Properties.

7 In the Point Groups dialog box, select the Storm Manholes point group. Click twice to move Storm Manholes point group to the bottom of the display order.

8 Click OK. Notice that the point style for the STORM MH points has changed to an X, and the label has disappeared. This happened because when the Storm Manholes point group was placed below the _All Points point group, the _All Points point group's point style and point label style settings took precedence over those of the Storm Manholes point group.

9 In Toolspace, on the Prospector tab, right-click the _All Points point group. Click Properties.

10 In the Point Group Properties dialog box, on the Information tab, make sure that Point Style is set to Standard and Point Label Style is set to <none>. Click Apply.

11 On the Overrides tab, select the Point Label Style box. Click Apply, and then click OK.
   This option ensures that the Point Label Style setting of the point group overrides the Point Label Style setting of the individual points included in the point group.

12 In Toolspace, on the Prospector tab, right-click the Point Groups collection. Click Properties.

13 In the Point Groups dialog box, select the _All Points point group. Click to move the _All Points point group to the top of the display order.

14 Click OK. Notice that all point labels in the drawing are hidden. This happened because the _All Points point group’s point label style set to
and you placed the _All Points point group at the top of the display order.

To continue this tutorial, go to Exercise 4: Removing an Externally Referenced Drawing (page 33).

Exercise 4: Removing an Externally Referenced Drawing

In this exercise, you will remove the externally referenced drawing that you added previously.

For more information, see the AutoCAD Help topic Detach Referenced Drawings.

This exercise continues from Exercise 3: Changing Point Group Display Order (page 31).

To remove an externally referenced drawing

**NOTE** This exercise uses Points-2.dwg and Existing Basemap.dwg with the modifications you made in the previous exercise.

1. Click any entity in Existing Basemap.dwg to select the whole drawing.
2. Right-click, and click Xref Manager.
3. In the External References dialog box, right-click the reference name Existing Basemap. Click Detach.
   The reference drawing disappears from view.
4. Close the External References dialog box.

To continue this tutorial, go to Exercise 5: Editing Points (page 33).

Exercise 5: Editing Points

In this exercise, you will use standard AutoCAD commands to move and rotate point objects to improve their position in the drawing.

For more information, see the AutoCAD Civil 3D Help topic Editing Points.
To edit points

**NOTE** This exercise uses *Points-3.dwg*, which is similar to the drawing you used in the other exercises in the Displaying and Editing Points (page 28) tutorial.

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing *Points-3.dwg*.

2. Locate point 992 near the right side of the drawing.
   Notice that the label for point 992 is obscured by the hatching. In the next few steps, you will change the point marker style. You will rotate the point marker so that it is parallel with the nearby road, and then move the label to a more readable location.

3. Select point 992. Right-click. Click Properties. The AutoCAD Properties palette displays the properties of individual points. The properties are listed in two major categories: Basic, which are the standard AutoCAD object properties, and Civil 3D, which lists the properties that are specific to AutoCAD Civil 3D points.

4. In the Civil 3D category, under Display, select Catch Basin in the Point Style property.

5. In the drawing window, click the grip. The grip turns red.
   This is the point rotation grip, which rotates the point marker around the center point.

   **TIP** To rotate a group of points, use the AutoCAD ROTATE command.

6. Rotate the point clockwise until the point marker is parallel to the edge of the road, then click to position the point.
   The point marker now matches the angle of the road, but the label is still obscured by the hatching. You will correct this in the following steps.

7. Examine the grip that is offset from the center of the point. This is the drag label grip. Click the grip above the drag label grip.
   This toggles the display of the drag label grip. Three grips are available. These grips can be used to drag each line in the point label independently.

8. Click the grip to return the drag label grip to its original state.

9. Click the drag label grip.
10 Drag the label down and to the left, until it is in an unobstructed area. Click to place the label in its new orientation.

To continue to the next tutorial, go to Adding User-Defined Properties to Points (page 35).

Tutorial: Adding User-Defined Properties to Points

This tutorial demonstrates how to add custom properties to points.

A user-defined property can be any useful attribute, such as latitude and longitude, date of acquisition, or source. To create user-defined properties, you first create a property classification, which is a container for one or more related properties.

You assign classifications and their associated properties to the points in your drawing using point groups. After you have added the user-defined properties to a point group, you can add values for each property either by editing the properties of individual points or by importing values from an external point file.

For more information, see the AutoCAD Civil 3D Help topic User-Defined Property Classifications.

Exercise 1: Creating User-Defined Properties

In this exercise, you will learn how to create a user-defined property classification and add items to it.

For more information, see the AutoCAD Civil 3D Help topic New User-Defined Property Dialog Box.

To create user-defined classifications and properties

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Points-4.dwg. The drawing is similar to the ones you used earlier in the Points tutorials, except only the points for storm manholes and the detention pond are visible.
2 In Toolspace, on the Settings tab, expand the Point collection. Right-click User-Defined Property Classifications. Click New.

3 In the User-Defined Property Classification dialog box, enter Manhole UDP.

4 Click OK.
The new classification is created and added to the list of user-defined property classifications.

5 On the Settings tab, expand User-Defined Property Classifications.
Right-click Manhole UDP. Click New.

6 In the New User-Defined Property dialog box, for Name, enter MH_Pipe In Invert.

7 In the Property Field Type list, select Elevation.

8 Use the default values for all other properties. Click OK.
The property is added to the list of Manhole UDP properties.

9 Repeat steps 6 to 8 to add additional properties to the Manhole UDP classification, using the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>Property Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>MH_Material</td>
<td>String</td>
</tr>
<tr>
<td>MH_Diameter</td>
<td>Dimension</td>
</tr>
<tr>
<td>MH_Pipe In Diameter</td>
<td>Dimension</td>
</tr>
<tr>
<td>MH_Pipe In Material</td>
<td>String</td>
</tr>
<tr>
<td>MH_Pipe Out Invert</td>
<td>Elevation</td>
</tr>
</tbody>
</table>

NOTE The next exercise uses Points-4a.dwg, which contains all of the properties and classifications. To save time, you can skip steps 9 through 11 and proceed to Exercise 2: Creating a Label Style That Displays a User-Defined Property (page 37).
Create an additional user-defined property classification named Trees.

Repeat steps 6 to 8 to add properties to the Trees classification using the following values:

<table>
<thead>
<tr>
<th>Name</th>
<th>Property Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tree_Common Name</td>
<td>String</td>
</tr>
<tr>
<td>Tree_Genus</td>
<td>String</td>
</tr>
<tr>
<td>Tree_Species</td>
<td>String</td>
</tr>
<tr>
<td>Tree_Diameter</td>
<td>Dimension</td>
</tr>
<tr>
<td>Tree_Height</td>
<td>Distance</td>
</tr>
</tbody>
</table>

To continue this tutorial, go to Exercise 2: Creating a Label Style That Displays a User-Defined Property (page 37).

**Exercise 2: Creating a Label Style That Displays a User-Defined Property**

In this exercise, you will create a label style that displays user-defined property information for a point.

For more information, see the AutoCAD Civil 3D Help topic *Creating and Editing Label Styles*. 
This exercise continues from Exercise 1: Creating User-Defined Properties (page 35).

To add a label style that displays user-defined property information

NOTE This exercise uses Points-4.dwg with the modifications you made in the previous exercise, or you can open Points-4a.dwg from the tutorial drawings folder (page 615).

1. In Toolspace, on the Settings tab, expand the Point collection. Expand the Label Styles collection.
2. Under Label Styles, right-click Standard. Click Copy.
3. In the Label Style Composer, on the Information tab, for Name, enter Manhole UDP.
4. On the Layout tab, in the Preview list on the upper right side of the tab, select Point Label Style.
   Now, any edits you make to the point label style will be displayed in the preview pane.
5. Click to create a text component for the label.
6. Under General, for Name, enter Invert In.
7. For Anchor Component, select Point Description.
8. For Anchor Point, select Bottom Left.
9. Under Text, for Attachment, select Top Left.
10. Under Text, for Contents, click the default value. Click .
11. In the Text Component Editor – Label Text dialog box, on the Properties tab, in the Properties list, select MH_Pipe In Invert.
12. For Precision, select 0.01.
13. Click .
14. In the text editing window, delete the text “Label Text” from the label. Enter Invert In: before the property field, which is enclosed in angle brackets(<>). The text in the editor should look like this:
15 Click OK.

16 In the preview pane, your label should look like this:

[Image]

17 Click OK.

To continue this tutorial, go to Exercise 3: Assigning User-Defined Properties to Points (page 39).

Exercise 3: Assigning User-Defined Properties to Points

In this exercise, you will use point groups to associate user-defined properties with points in your drawing.

For more information, see the AutoCAD Civil 3D Help topic Assigning User-Defined Properties to Point Groups.

This exercise continues from Exercise 2: Creating a Label Style That Displays a User-Defined Property (page 37).

To assign user-defined properties to points

**NOTE** This exercise uses Points-4a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Prospector tab, click Point Groups.
2. In the item view, click the Storm Manholes entry. In the Classification column, select Manhole UDP.

3. In the Prospector tree view, expand Point Groups. Click Storm Manholes.

4. In the item view, right-click in a column heading. Click all the column values that have a check mark next to them, except Point Number, Point Label Style, MH_Pipe In Invert, and MH_Pipe In Material. Clearing the check boxes turns off the display of columns you do not need to see for this exercise.

5. Click the row for point 307.

6. Click the Point Label Style cell to display the Select Label Style dialog box.

7. In the Select Label Style dialog box, select Manhole UDP as the label style. Click OK.

8. For point 307, click the MH_Pipe In Invert cell. Enter 93.05.

9. Right-click the row for point 307. Click Zoom To.
   The value is displayed with the other point information in the drawing window.

10. Click the row for point 667.

11. Click the Point Label Style cell to display the Select Label Style dialog box.

12. In the Select Label Style dialog box, select Manhole UDP as the label style. Click OK.

13. For point 667, click the MH_Pipe In Invert cell. Enter 93.00.

14. Right-click the entry for point 667. Click Zoom To.

To continue this tutorial, go to Exercise 4: Importing Points with User-Defined Properties (page 40).

Exercise 4: Importing Points with User-Defined Properties

In this exercise, you will create a custom point file format, and then import point information that includes user-defined properties from an external file.
For more information, see the AutoCAD Civil 3D Help topic *Importing and Exporting User-Defined Property Classifications*.

This exercise continues from Exercise 3: Assigning User-Defined Properties to Points (page 39).

**To create a point file format for importing user-defined properties**

**NOTE** This exercise uses *Points-4a.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, expand the Point collection. Right-click Point File Formats. Click New.
2. In the Point File Formats – Select Format Type dialog box, select User Point File. Click OK.
3. In the Point File Format dialog box, for Format Name, enter Manhole Data.
4. For Comment Tag, enter #.
5. In the Format Options section, select Delimited By, and enter ,(a comma) as the delimiter.
6. In the table of column names, click the first column heading (labeled <unused>).
7. In the Point File Formats – Select Column Name dialog box, in the Column Name list, select Point Number. Click OK.
8. Repeat steps 6 and 7 to name additional columns using the following values:
   - Column 2: MH_Material
   - Column 3: MH_Diameter
   - Column 4: MH_Pipe In Invert
   - Column 5: MH_Pipe In Diameter
   - Column 6: MH_Pipe Out Invert
   - Column 7: MH_Pipe Out Diameter
   - Column 8: MH_Pipe Out Material
   - Column 9: MH_Pipe Out Material
To import user-defined property data using a text file

1 In Toolspace, on the Prospector tab, ensure that the Point Groups collection is expanded, and select the Storm Manholes group. In the item view, note that this group contains only nine points, and some of the data columns are blank.

2 In Toolspace, on the Prospector tab, right-click Points. Click Create.

3 In the Create Points dialog box, click Import Points.

4 In the Import Points dialog box, in the Format list, select Manhole Data.

5 Click . Browse to the tutorial folder (page 615). Select manhole_data.txt. Click Open.

6 Click OK.

7 In the Duplicate Point Number dialog box, in the Resolution list, select Merge. Click OK. The point data is imported.

   NOTE If the Duplicate Point Number dialog box is displayed, for Resolution, select Merge, and then click OK.

8 On the Prospector tab, click the Storm Manholes point group.
   The point data from the file import is displayed in the item view, including specific values for manhole data.

9 Close the Create Points dialog box.

To continue this tutorial, go to Exercise 5: Querying User-Defined Property Information (page 42).

Exercise 5: Querying User-Defined Property Information

In this exercise, you will create a point group. The list of points included in the group is determined by a query that contains user-defined properties.
For more information, see the AutoCAD Civil 3D Help topic Creating a Point Group Using the Query Builder.

This exercise continues from Exercise 4: Importing Points with User-Defined Properties (page 40).

To create a query that contains user-defined properties

NOTE This exercise uses Points-4a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Prospector tab, right-click Point Groups. Click New.

2 In the Point Group Properties dialog box, on the Information tab, for Name, enter Storm Manholes - Invert In.

3 On the Query Builder tab, select Modify Query.

4 Right-click the Query Builder table. Click Insert Row.

5 Click the row you created. Click Name in the Property column. In the Property list, select MH_Pipe In Invert.

6 Click the Operator value. In the Operator list, select < (less than).

7 Click the Value value. Enter 93.

8 Click OK.

9 On the Prospector tab, click Storm Manholes - Invert In.

A list of points that match your query is displayed in the item view. Points number 307 and 667 are excluded, because in a previous exercise you set their values for MH_Pipe In Invert to 93.05 and 93.00.
These tutorials will get you started working with land surfaces. A surface is a central object for AutoCAD Civil 3D, and can be referenced by alignments, parcels, and other objects throughout the design process.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Surfaces*

**Tutorial: Creating and Adding Data to a Surface**

This tutorial demonstrates how to create an empty TIN surface. You will then add data to the surface, including a set of survey points (in a point group), boundaries, and breaklines.

When you first create a surface, its name is displayed in the Surfaces collection in Toolspace on the Prospector tab. From this location, you can perform other operations, such as adding data and editing the surface. When first created, the surface is empty; therefore, it is not visible in the drawing.

After data has been added to a surface, it becomes visible in the drawing in accordance with the display settings specified in the referenced surface style.

**TIN Surfaces**

A TIN surface is composed of the triangles that form a triangulated irregular network. A TIN line is one of the lines that makes up the surface triangulation.
To create TIN lines, AutoCAD Civil 3D connects the surface points that are closest together. The TIN lines form triangles. The elevation of any point in the surface is defined by interpolating the elevations of the vertices of the triangles that the point lies in.

Point Groups

Point groups are a flexible and convenient way to group and identify points that share common characteristics or are used to perform a task, such as creating a surface.

You can create point groups that contain specific points, for example, all existing ground points, making it easier to manage the surface points.

Boundaries

Boundaries are closed polylines that affect the visibility of the triangles either inside or outside the polylines. An outer boundary defines the extents of the surface. All triangles inside the boundary are visible, and all triangles that are outside the boundary are invisible.

Areas hidden by boundaries are not included in calculations, such as total area and volume.

Surface boundaries are defined by selecting existing polygons in the drawing. The surface definition displays the numerical ID and a list of vertices for each boundary.
Breaklines

Breaklines define linear surface features, such as retaining walls, curbs, tops of ridges, and streams. Breaklines force surface triangulation to run along the breakline; triangles do not cross a breakline.

Breaklines are critical to creating an accurate surface model. Breaklines are important because it is the interpolation of the data, not just the data itself, that determines the shape of the model.

You can use 3D lines or 3D polylines as breaklines. The XYZ coordinates of each vertex on the polyline that you select are converted into TIN vertices. For 3D lines, each line that you select is defined as a two-point breakline.

For more information, see the AutoCAD Civil 3D Help topics Creating Surfaces and Adding and Editing Surface Data.

Exercise 1: Creating a New TIN Surface

In this exercise, you will create an empty TIN surface.

When you first create a surface, its name is displayed in the Surface collection on the Prospector tab. From this location, you can perform other operations such as adding data and editing the surface.

For more information, see the AutoCAD Civil 3D Help topic Creating a TIN Surface.

To create a TIN surface

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-1A.dwg.

2. Click Surfaces menu ➤ Create Surface.
   In the Create Surface dialog box, from the Type list, select TIN Surface.

3. Click to select the layer for the surface.

4. In the Object Layer dialog box, click . Select C-TOPO-XGND from the list of layers.
   This is the layer on which the surface will be created.
5 Click OK to close the Layer Selection dialog box. Click OK again to close
the Object Layer dialog box.

6 For the surface properties, use the following:
   ■ Name: XGND
   ■ Description: Existing ground surface
   ■ Style: Border & Contours
   ■ Render Material: ByLayer

7 Click OK to create the surface.

8 In Toolspace, on the Prospector tab, expand the Surfaces collection.
The new surface name is displayed in the Surfaces collection, but this
surface does not contain any data.

9 Right-click surface XGND. Click Surface Properties.

10 In the Surface Properties dialog box, click the Definition tab. Under
   Definition Options, expand the Build option. Select the Allow Crossing
   Breaklines option. In the Value column, select Yes. Click OK.
   This setting will be used later, in the exercise Exercise 3: Adding Breaklines
to a Surface (page 51).

11 In the Surface Properties - Rebuild Surfaces dialog box, click Rebuild The
   Surface.

To continue this tutorial, go to Exercise 2: Adding Point Data to a Surface
(page 49).

Exercise 2: Adding Point Data to a Surface

In this exercise, you will add a set of survey points to the surface from an
external file.

Adding a set of points to a surface by reference makes sense if you do not need
to analyze or edit the point data. The drawing file size is unaffected, and
application performance is optimized. However, if you must work with the
points, you should import them into the drawing. This process is described
in the Points tutorial lesson Exercise 3: Importing Points from a Database
(page 27).

For more information, see the AutoCAD Civil 3D Help topic Point Files.
This exercise continues from Exercise 1: Creating a New TIN Surface (page 48).

To add point data to a surface

**NOTE** This exercise uses Surface-1A.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Prospector tab, expand the XGND surface under the Surfaces collection.

2. Expand the Definition collection under the XGND surface. Right-click Point Files. Click Add.
   The Add Point File dialog box is displayed.

3. In the Format list, select PENZD (space delimited).

4. Click at the end of the Source File(s) field.

5. In the Select Source File dialog box, ensure that the Files of Type field is set to Text/Template/Extract File (*.txt).

   A reference to the point file is added to the XGND surface definition. The presence of point data in the surface definition is indicated by the marker next to the Point Files item on the Prospector tab.

   **NOTE** If the surface is not displayed in the drawing, right-click the XGND surface name on the Prospector tab and click Zoom To.

7. In Toolspace on the Prospector tab, right-click surface XGND. Click Surface Properties.

8. In the Surface Properties dialog box, click the Definition tab.
   At the bottom of the dialog box, the Operation Type list displays the surface operations and their applicable parameters in the order in which they were performed. The Import Point File item is the operation you performed in steps 1 to 6.

To continue this tutorial, go to Exercise 3: Adding Breaklines to a Surface (page 51).
Exercise 3: Adding Breaklines to a Surface

In this exercise, you will insert 3D polylines from an external DWG file. You will use the AutoCAD command QSelect to select the polylines, and create standard breaklines from the selected polylines.

For more information, see the AutoCAD Civil 3D Help topic Breaklines.

This exercise uses the QSelect command to create a selection set that includes all objects matching the filtering criteria you specify. QSelect can apply either to the entire drawing or to an existing selection set. The selection set created by QSelect either replaces or is appended to the current selection set.

This exercise continues from Exercise 2: Adding Point Data to a Surface (page 49).

To add breaklines to a surface

NOTE This exercise uses Surface-1A.dwg with the modifications you made in the previous exercise, or you can open Surface-1B.dwg from the tutorial drawings folder (page 615).

1 Click Insert menu ➤ Block.
2 In the Insert dialog box, click Browse. Navigate to the tutorial drawings folder (page 615). Select Breaklines.dwg. Click Open.
3 In the Insert dialog box, use the following settings:
   - Insertion point: Set X, Y, and Z to 0.00; clear Specify On Screen.
   - Explode: Selected.
   - Scale: Clear Specify On Screen; select Uniform Scale; set X to 1.00.
   - Rotation: clear Specify On Screen; set Angle to 0.
4 Click OK.
   The 3D polylines are inserted into the drawing. In their original drawing, these polylines existed on layer C-TOPO-BRKL, and this layer has been added to the current drawing.
5 On the command line, enter QSelect.
6 In the Quick Select dialog box, use the following settings:
   - Apply To: Entire Drawing
Click OK. The 3D polylines are selected in the drawing.

8 In Toolspace, on the Prospector tab, under the Surfaces collection, expand the XGND surface.

9 Under the XGND surface, expand the Definition collection.
   Right-click Breaklines. Click Add. The Add Breaklines dialog box is displayed.

10 For the breakline properties, use the following:
   - Description: XGND-Breaklines
   - Type: Standard
   - Mid-Ordinate Distance: 1.0000

11 Click OK. The previously selected 3D polylines are added to the surface definition as breaklines. The surface displayed in the drawing updates.

**NOTE** If there are any issues with the data, such as added breaklines crossing existing points, AutoCAD Civil 3D displays a corresponding message in the Event Viewer. For this exercise, you can ignore the message, but if you want to investigate the issue further, see Further exploration.

12 Optionally, to hide the original 3D polylines, turn their layer off. In the Layer list, next to the C-TOPO-BRKL layer, click .

**Further exploration:** You can investigate data contention issues reported in the Event Viewer, such as breaklines crossing existing points. If you closed Event Viewer, you can reopen it by clicking General menu ➤ Utilities ➤ Event Viewer.
To investigate crossing breakline data issues

1. When the Event Viewer is displayed, scroll to the right until you see the More Information column.

2. In the More Information column, click Zoom To.
   The drawing is zoomed in to and centered on the point that the breakline is crossing. If layer C-TOPO-BRKL is not frozen, you see the 3D polyline. To see the points and actual TIN triangles created along the breaklines, you can change the surface style to display the points and triangles, as follows. In Prospector, right-click surface XGND and click Surface Properties. In the Surface Properties dialog box, select the style Border & Triangles & Points, then click OK.

   Before proceeding to the next exercise, change the style back to Standard and zoom out so you can see the entire surface.

To continue this tutorial, go to Exercise 4: Adding an Outer Boundary to a Surface (page 53).

Exercise 4: Adding an Outer Boundary to a Surface

In this exercise, you will insert a polyline from an external DWG file and create an outer surface boundary from the polyline.

For more information, see the AutoCAD Civil 3D Help topic Boundaries.

This exercise continues from Exercise 3: Adding Breaklines to a Surface (page 51).

To add an outer boundary to a surface

NOTE This exercise uses Surface-1B.dwg with the modifications you made in the previous exercise.

1. Zoom out so that you can see the entire surface in your drawing window.

2. Click Insert menu ➤ Block.

3. In the Insert dialog box, click Browse. Navigate to the tutorial drawings folder (page 615). Select Outer Boundary.dwg. Click Open.

4. In the Insert dialog box, use the following settings:
   - Insertion Point: Set X, Y, and Z to 0.0000; clear Specify On-Screen.
■ Explode: Selected.
■ Scale: Clear Specify On-Screen; select Uniform Scale; set X to 1.0000.
■ Rotation: Clear Specify On-Screen; set Angle to 0.

5 Click OK.
The polyline is inserted into the drawing.

6 In Toolspace, on the Prospector tree, under the Surfaces collection, expand the XGND surface.

7 Under the XGND surface, expand the Definition collection.
   Right-click Boundaries and click Add.
The Add Boundaries dialog box is displayed.

8 For the boundary properties, use the following settings:
   ■ Name: XGND-Outer
   ■ Type: Outer
   ■ Non-Destructive Breakline: Cleared
   ■ Mid-Ordinate Distance: 1.0000

9 Click OK to accept the values and close the Add Boundaries dialog box.

10 In the drawing, select the green polyline that was inserted from the Outer Boundary.dwg file.
The boundary is added to the surface definition, and the surface display in the drawing is clipped to the area defined by the new outer boundary.

11 Optionally, to hide the original polyline, turn its layer off. In the Layers list, for the C-TOPO-BNDY layer, click the icon.

To continue to the next tutorial, go to Working with Large Surfaces (page 54).

**Tutorial: Working with Large Surfaces**

This tutorial demonstrates several features that can help you manage large surfaces efficiently in AutoCAD Civil 3D.
Because surfaces can contain large amounts of data, it is important to use only as much data is necessary for the current task. For example, when building a surface from LIDAR data, the corresponding point file can contain millions of points. If all of those points are included in the surface definition, it can take a considerable amount of time to rebuild the surface. If you restrict the points that the surface uses to a given area, the surface rebuilds faster and the drawing size is smaller.

The exercises in this tutorial demonstrate how to insert a relatively dense LIDAR point file into a surface, but restrict the amount of data that is actually used.

For more information, see the AutoCAD Civil 3D Help topic *Adding and Editing Surface Data*.

**Exercise 1: Limiting Imported Surface Data**

In this exercise, you will use a data clip boundary to restrict the quantity of points that is referenced by a surface.

Points that are in the point file, but outside the specified data clip boundary, will be ignored when the surface is built and during any subsequent surface editing operations.

For more information, see the AutoCAD Civil 3D Help topic *Boundaries*.

**To add a data clip boundary to a surface**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing *Surface-2.dwg*.

2. In Toolspace, on the Prospector tab, expand the Surfaces collection. Expand the EG surface.

   The EG surface is currently empty. In the following steps, you will use the red polyline in the drawing to create a *Data Clip* boundary, which will restrict imported surface data to the extents of the boundary. Then, you will import a relatively dense LIDAR point file and examine the results.

3. Expand the EG surface ➤ Definition collection. Right-click Boundaries. Click Add.
4 In the Add Boundaries dialog box, use the following settings, and then click OK.
   ■ Name: Site
   ■ Type: Data Clip
   ■ Mid-Ordinate Distance: 1.000'

5 In the drawing window, click the red polyline.
The polyline is added to the EG surface definition as a boundary. The presence of a boundary in the surface definition is indicated by the ● marker next to the Boundaries item on the Prospector tab. When the Boundaries collection is selected, the boundaries that have been added to the surface appear in the Prospector list view.

In the following steps, you will add a relatively dense LIDAR point file to the surface definition. The point file will be added only within the extents of the data clip boundary that you just added.

To import surface data from a point file

1 Expand the EG surface ➤ Definition collection. Right-click Point Files. Click Add.

2 In the Add Point File dialog box, in the Format list, select ENZ (Comma Delimited).

3 Click ‼ at the end of the Source File(s) field.

4 In the Select Source File dialog box, ensure that the Files Of Type field is set to (*.csv).

5 Navigate to the tutorial folder (page 615). Select LIDAR_ENZ (comma delimited).csv. Click Open.

6 In the Add Point File dialog box, clear both the Do Elevation Adjustment If Possible and Do Coordinate Transformation If Possible check boxes. Click OK.

   The point data is added to the drawing.
   A reference to the point file is added to the EG surface definition. The presence of point data in the surface definition is indicated by the ● marker next to the Point Files item on the Prospector tab.

7 Zoom in to the lower right corner of the surface.
Notice that only points that are inside the data clip boundary have been imported, and that a green border was created from the imported data. The border is outside the red data clip boundary in some areas, and inside the data clip boundary in other areas. This happened because points in the point file that are outside the data clip boundary were excluded during the import operation. The green border is formed by the points at the outermost extents of the points that were imported.

Surface with points imported within a data clip boundary (left) and detail of the surface (right)

8 On the command line, enter ZE to zoom to the extents of the drawing.

To restrict the surface data to a smaller area

1 In the Layers list, next to the C-TOPO-BNDY-CORR layer, click 🌡. This layer contains an orange polyline that you will use to create a second data clip boundary.

2 Expand the EG surface ➤ Definition collection. Right-click Boundaries. Click Add.
3 In the Add Boundaries dialog box, use the following settings, and then click OK.
   ■ Name: Corridor
   ■ Type: Data Clip
   ■ Mid-Ordinate Distance: 1.000’

4 In the drawing window, click the orange polyline.
   The polyline is added to the EG surface definition as a boundary, but the point data did not change. Data clip boundaries only affect surface editing operations that are performed after the data clip boundary has been added. Because the points were added to the surface before the Corridor boundary, the boundary currently does not affect the point data.
   In the following steps, you will rearrange the surface definition operations so that the points will be restricted to the extents of the new Corridor data clip boundary.

5 In Toolspace, on the Prospector tab, right-click the EG surface. Click Surface Properties.

6 In the Surface Properties dialog box, on the Definition tab, in the Operation Type column, examine the order of the operations.
   The operations you performed in this exercise are listed in the order in which they were performed. The Site data clip boundary was added first, and it affects the operations that follow it. The Corridor data clip boundary was added last, so it currently does not affect any other operations.

7 Select the last Add Boundary operation in the list. Click to move the Add Boundary operation to the top of the list.

8 Select the other Add Boundary operation. Click to move the Add Boundary operation to the bottom of the list. Click Apply.

9 In the Surface Properties - Rebuild Surface dialog box, click Rebuild Surface.
   When the surface rebuilds, the points outside the orange Corridor data clip boundary are excluded from the surface.
Further exploration: Rearrange the surface definition operations and observe the results. Before you continue to the next exercise, make sure that the Operation Type table is in the following order:

- Add Boundary: Corridor
- Import Point File
- Add Boundary: Site

To continue this tutorial, go to Exercise 2: Simplifying a Surface (page 60).
Exercise 2: Simplifying a Surface

In this exercise, you will reduce the number of points that is used to define a surface.

A surface can be simplified by removing either TIN edges or points. When the simplify surface command is complete, new points and TIN edges are calculated based on specified parameters. The original surface points are still contained in the referenced point file, but are not used in the surface triangulation.

In this exercise, you will use the Point Removal method of simplifying a surface. This method randomly selects points from the surface, and removes them based on the point density at different areas of the surface. More points are removed from areas in which the concentration of points is very dense than from areas that contain fewer points.

NOTE You cannot specify which points to remove. Points that are used to define surface borders and breaklines are not removed with the Simplify Surface command.

For more information, see the AutoCAD Civil 3D Help topic Simplifying Surfaces.

This exercise continues from Exercise 1: Limiting Imported Surface Data (page 55).

To simplify a surface

NOTE This exercise uses Surface-2.dwg with the modifications you made in the previous exercise.

1 In the Layers list, next to the C-TOPO-CONT-MAJR-ORIG and C-TOPO-CONT-MINR-ORIG layers, click .
   These layers contains polylines that represent the original major and minor contours. These polylines will enable you to observe the results of the Simplify Surface command.

2 Click Surfaces menu ➤ Edit Surface ➤ Simplify Surface.

3 In the Simplify Surface wizard, on the Simplify Methods page, select the Point Removal option. Click Next.

4 On the Region Options page, select the Select Objects option. For Mid-Ordinate Distance, enter 1.000’. Click Pick In Drawing.

5 In the drawing window, click the orange corridor boundary.
In the Simplify Surface wizard, notice the value for Total Points Selected In Region. This is the current number of points in the selected region.

6. In the Simplify Surface wizard, click Next.

7. On the Reduction Options page, set the following options:
   - Percentage Of Points To Remove: Selected, 50%
   - Maximum Change In Elevation: Cleared

8. Click Apply.
   At the bottom of the wizard, notice the Total Points Removed value. This value is the number of points that the simplify surface command removed within the selected boundary.

   **NOTE** You can click Apply again to repeat the Simplify Surface command and keep the wizard open. If you click Finish, the Simplify Surface command is repeated and the wizard is closed.

9. Click Cancel.

10. Zoom in to the surface.
    Notice that the points are not as dense as they were at the beginning of the exercise, and the new, gray surface contours are very similar to the original contours. The Simplify Surface command reduced the amount of data that the surface uses without sacrificing much surface accuracy.
To continue to the next tutorial, go to Changing the Surface Style and Display (page 62).

**Tutorial: Changing the Surface Style and Display**

This tutorial demonstrates how to change and constrain the surface styles and display.
Using styles is an efficient way to control surface display. Rather than answering prompts for numerous variables every time you create a surface, you can reference a predefined style that sets all the variables as required.

Surface styles are managed the way all object styles are managed in AutoCAD Civil 3D, by using the Toolspace Settings tree. All objects have a standard object style grouping on the Settings tree, called an object style collection. You can create, edit, copy, and delete the styles for an object.

Surface styles define how the surface components are displayed in the drawing. If you want to change the appearance of a component, either apply a different style or edit the style.

The surface styles contain the following component parameters and component display settings for the creation of surface data objects:

- **Borders** — Interior and exterior border and datum display
- **Contours** — Minor, major, depression, and user-defined contour lines display
- **Grid** — Primary and secondary grid display
- **Points** — All surface points for the TIN or Grid surfaces
- **Triangles** — TIN face information
- **Watersheds** — Watershed analysis display
- **Analysis** — Directions, elevations, slopes, and slope arrows

For more information, see the AutoCAD Civil 3D Help topic *Surface Styles and Display*.

## Exercise 1: Editing the Surface Style

In this exercise, you will hide the display of the points on the surface and turn on the display of depression contours.

Depression contours form closed loops around areas of descending elevation. These are areas where lakes or ponds can form if the rainfall and soil conditions are right.

For more information, see the AutoCAD Civil 3D Help topic *Surface Styles and Display*.
To edit the surface style

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-3.dwg.

2. In Toolspace, on the Settings tab, expand the Surface collection.

3. Expand the Surface Styles collection to display the list of existing surface styles in the drawing.

4. The style (Standard) that is being referenced by a surface in the drawing is designated with an orange marker. Right-click the Standard surface style. Click Edit.

5. In the Surface Style dialog box, click the Display tab.

6. In the Component Display table, turn off the visibility of Points in the surface. To do this, click in the Visible column. Click Apply.

7. Click the Contours tab.

8. Expand the Contour Depressions property group. Ensure that Display Depression Contours is set to True, and that Tick Mark Length is set to 5.

9. Click OK.

10. Depression contours are now visible in the drawing, with tick marks along their length.

To continue this tutorial, go to Exercise 2: Using a Different Style for a Surface (page 64).

**Exercise 2: Using a Different Style for a Surface**

In this exercise, you will change the surface style, which the surface is referencing, to display different views of the surface.

For more information, see the AutoCAD Civil 3D Help topic Surface Styles and Display.

This exercise continues from Exercise 1: Editing the Surface Style (page 63).
To use a different style

**NOTE** This exercise uses *Surface-3.dwg* with the modifications you made in the previous exercise.

1 In Toolspace, on the Prospector tab, expand the Surfaces collection. Right-click the XGND surface. Click Surface Properties.

2 In the Surface Properties dialog box, on the Information tab, in the Surface Style list, select Border & Triangles & Points.
   This style is set to display the borders and the TIN faces with 3x vertical exaggeration. These display settings make it easier to see the vertical relief of the surface.

3 Click OK.
   The surface representation updates to display the TIN triangles and border.

4 Click View menu ➤ Orbit ➤ Free Orbit.

5 Using the 3D Orbit tool, rotate the surface in the drawing to display the exaggerated elevations. These elevations are most evident along the bottom of the surface where a prominent ridge appears.

6 To return to the regular plan view of the surface, click View menu ➤ 3D Views ➤ Plan View ➤ Current UCS.

7 Follow steps 1 to 3 to return the surface style to Standard.

To continue this tutorial, go to Exercise 3: Labeling a Surface (page 65).

**Exercise 3: Labeling a Surface**

In this exercise, you will add labels across surface contours. You will place individual labels manually and a series of labels automatically, using AutoCAD polylines as a guide.

For more information, see the AutoCAD Civil 3D Help topic *Adding Surface Labels*.

This exercise continues from Exercise 2: Using a Different Style for a Surface (page 64).
To label surface contours

NOTE This exercise uses Surface-3.dwg with the modifications you made in the previous exercise.

1. Click View menu ➤ Named Views.
2. In the View Manager dialog box, under Model Views, select Surface Labels. Click Set Current. Click OK.
3. On the command line, enter PLine.
4. When prompted for a start point, click in the green circle in the upper left corner of the view.
5. Click in the middle circle, then the lower right circle. Press Enter to end the PLine command.
6. Click Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels.
7. In the Add Labels dialog box, set the Label Type to Contour - Multiple. Leave the other settings at their defaults. Click Add.
8. On the command line, enter O to specify that you will select an object to use as a guide.
9. On the command line, enter Y to delete the polyline after the labels have been created.
10. In the drawing window, select the polyline. Press Enter to end the selection command.
    The labels are created along the path you specified with the polyline. This method of surface labeling is useful when you want to lay out the path of surface contour labels before you create the labels. If you wanted to create the path and labels simultaneously without first drawing a polyline, you would click Surfaces menu ➤ Add Surface Labels ➤ Contour - Multiple, then draw the path.
    Next, you will add individual spot elevation labels.
11. In the drawing window, click the line on which the surface labels were drawn. Grips appear on the line.
12. Select the grip in the circle at the upper left. It turns red, indicating that it is active.
13. Drag the grip to a new location and click. Notice that the labels update automatically to reflect their new position.
14 In the Add Labels dialog box, set the Label Type to Spot Elevation and the Spot Elevation Label Style to Standard.

15 Click Add. When prompted, click a point along the ridge to place a label.

16 In the Add Labels dialog box, set the Spot Elevation Label Style to Foot Meter.

17 Click Add. When prompted, click a point along the ridge to place a label.

Using the Add Labels dialog box, you can change label properties as needed while you create surface labels.

To continue to the next tutorial, go to Editing Surface Data (page 67).

**Tutorial: Editing Surface Data**

This tutorial demonstrates some common surface editing tasks, including edge swapping, TIN line deletion, and surface smoothing. You will also hide part of the surface using a hide boundary.

For more information, see the AutoCAD Civil 3D Help topic *Surface Editing Operations*.

**Edge Swapping**

Edge swapping is used to change the direction of two triangle faces in the surface, to create a more accurate surface model. For example, edges can be swapped to match the triangle edges to ridges or swales.
Deleting TIN Lines

Deleting TIN lines may be required, for example, if the surface has TIN triangles on the perimeter that are long and narrow. In this case, the triangles might not be accurate for the surface, and should be deleted.

Surface TIN or Grid lines can also be deleted within a pond, for example, to create a void area. By removing these lines, you can prevent contours from being drawn through the void areas.

When an edge is removed, either an interior border that follows the adjacent lines is created, or the exterior border is modified to follow the new lines.

Hide Boundaries

Hide boundaries mask areas of the surface so triangulation, and therefore contours, are not visible in the area. Use hide boundaries to create holes in a surface, for example, to mark a building footprint.

**NOTE** When you use a hide boundary, the surface is not deleted. The full surface remains intact. If there are surface TIN lines that you want to permanently remove from the surface, use the Delete Line command.
Surface Smoothing

Surface smoothing is an operation that adds points at system-determined elevations using Natural Neighbor Interpolation (NNI) or Kriging methods. The result is smoothed contours, with no overlap.

You perform smoothing as an edit operation on a surface. You can specify smoothing properties and then turn them on or off. When the smoothing is turned off, the surface reverts back to its original state. However, the smoothing operation remains in the surface operation list, and it can be turned on again.

NNI is a method used to estimate the elevation (Z) of an arbitrary point (P) from a set of points with known elevations.

This method uses information in the triangulation of the known points to compute a weighted average of the elevations of the natural neighbors of a point.

To use NNI, specify only the output locations of the interpolated points. The elevations of the interpolated points are always based on the weighted average of the elevations of the existing neighboring points. NNI interpolates only within the surface.

Exercise 1: Swapping TIN Edges

In this exercise, you will swap several TIN edges in a surface.

For more information, see the AutoCAD Civil 3D Help topic Swapping Edges.
To swap TIN edges

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-4A.dwg.

   In this drawing, the surface is displayed as TIN lines overlaid on an externally referenced landbase image.

2. Zoom in to the lower edge of the surface.

3. In Toolspace, on the Prospector tab, expand the surface Definition collection. Right-click Edits.

4. Click Swap Edge.

   On the command line, you are prompted to select an edge (line) to swap.

5. Click a TIN edge to swap it.
The edge is swapped if the following criteria are met:

- Two visible triangles are separated by the edge.
- The quadrilateral formed by the two triangles (which are separated by the edge) is convex.

6 Optionally, continue to click other TIN edges to swap them.

7 Press Enter to complete the operation.

The edits are added as Swap Edge operations to the Edits list view on the Prospector tab.

**NOTE** The Description column in the list view provides the coordinates of the pick point along the edge that was swapped.
Exercise 2: Deleting TIN Lines

In this exercise, you will delete TIN lines from a surface. The TIN lines fall within a pond. By removing these lines, you can prevent contours from being drawn through the pond area.

For more information, see the AutoCAD Civil 3D Help topic Deleting TIN or Grid Lines.

This exercise continues from Exercise 1: Swapping TIN Edges (page 69).

To delete TIN lines

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-4B.dwg.
   In this drawing, the surface is displayed as TIN lines overlaid on an externally referenced landbase image.

2. Zoom in to the rounded pond area in the upper left of the surface.
3 In Toolspace, on the Prospector tab, expand the surface **Definition** collection, and right-click the **Edits** item.

4 Click Delete Line.
   On the command line, you are prompted to select an edge (line) to remove.

5 Click an edge that crosses the surface of the pond. Press Enter.
   The edge is removed and an interior border is created, following the adjacent TIN lines.

6 Repeat the Delete Line command and remove all TIN lines that cross the pond surface.

The edits are added as Delete Line operations to the Edits list view in Prospector.

**NOTE** The Description column in the list view provides the coordinates of the vertices for the edge that was deleted.

To continue this tutorial, go to Exercise 3: Adding a Hide Boundary (page 74).
Exercise 3: Adding a Hide Boundary

In this exercise, you will create a hide boundary on the surface, which will mask unwanted triangulation.

A boundary can be created from any polygon or polyline, but in this exercise you will use an existing breakline.

For more information, see the AutoCAD Civil 3D Help topic Boundaries.

This exercise continues from Exercise 2: Deleting TIN Lines (page 72).

To add a hide boundary

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-4C.dwg.

   **NOTE** This drawing is similar to Surface-3A.dwg with the addition of the C-TOPO-BRKL layer, which displays breaklines.

2. In Toolspace, on the Prospector tab, under the Surfaces collection, expand the XGND surface.


4. In the Add Boundaries dialog box, enter or select the following:
   - Name: XGND-Pond Hide
   - Type: Hide
   - Non-Destructive Breakline: Selected
   - Mid-Ordinate Distance: 1.0000

5. Click OK.

6. In the drawing, select the polyline object that matches the perimeter of the pond.
The hide boundary is added to the surface definition. The surface displayed in the drawing is modified to display the pond as a ‘hole’ in the surface.
To continue this tutorial, go to Exercise 4: Smoothing a Surface (page 76).

**Exercise 4: Smoothing a Surface**

In this exercise, you will smooth a surface using the Natural Neighbor Interpolation (NNI) method.

For more information, see the AutoCAD Civil 3D Help topic *Smoothing Surfaces*.

This exercise continues from Exercise 3: Adding a Hide Boundary (page 74).

**To smooth a surface using NNI**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing `Surface-4D.dwg`.

2. In Toolspace, on the Prospector tab, expand the XGND surface 🌱 Definition collection and right-click 🆙 Edits.

3. Click Smooth Surface.
4 In the Smooth Surface dialog box, for the Select Method property, select Natural Neighbor Interpolation.

5 In the Point Interpolation/Extrapolation Output parameter group, for Output Locations, select Grid Based.
The Grid Based output location interpolates surface points on a grid defined within specified polygon areas selected in the drawing. After the areas are defined, you can specify the grid X and Y spacing and orientation properties.

6 For the Select Output Region parameter, click the Value column. Click .

7 On the command line, enter Surface for the output region. This option will smooth the whole surface, rather than just the area within a specified rectangle or polygon.
The Smooth Surface dialog box is displayed.

8 For the Grid X-Spacing, enter 10.

9 For the Grid Y-Spacing, enter 10.

10 In the drawing window, notice where some of the contour lines are especially angular. Click OK to smooth the surface.
The display of the surface is smoothed; contours are less angular. A Smooth Surface item is added to the Edits list view on the Prospector tab.

**NOTE** The Description column in the list view displays the type of surface smoothing that was used (Natural Neighbor Smoothing). You can delete the Smooth Surface edit from the list, but this does not reverse the smoothing operation until you update the surface. Use Edit menu ➤ Undo to reverse the smoothing operation.

To continue to the next tutorial, go to Creating a Watershed and Water Drop Analysis (page 77).

**Tutorial: Creating a Watershed and Water Drop Analysis**

This tutorial demonstrates how to create two kinds of surface analysis: watershed and water drop.
You use watershed analysis, which is one of several types of analysis that you can perform on a surface, to visualize and analyze the surface watersheds. You use water drop analysis, which is a separate utility, to trace the path that water would take across a surface. This tutorial includes the following general steps:

- Configuring the watershed display and legend settings.
- Configuring and creating a watershed analysis.
- Inserting the watershed legend table.
- Extracting objects from a surface.
- Configuring and creating a water drop analysis.
- Creating a catchment area.

AutoCAD Civil 3D uses the surface TIN lines to calculate the areas that water would flow along the surface. From these areas, the drain targets and watersheds are determined.

Other types of surface analysis include slope, aspect, elevations, and contours.

For more information, see the AutoCAD Civil 3D Help topics Watersheds and Analyzing Surfaces.

### Exercise 1: Configuring a Style for Watershed Display

In this exercise, you will configure a style for watershed display.

For more information, see the AutoCAD Civil 3D Help topic Surface Styles and Display.

**To configure a style for watershed display**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-5A.dwg.
2. In Toolspace, on the Settings tab, expand the Surface collection.
3. Expand the Surface Styles collection to display the list of existing surface styles in the drawing.
4. Right-click the Standard surface style. Click Copy.
5 In the Surface Style dialog box, on the Information tab, for Name, enter Watersheds.

6 On the Watersheds tab, in the Watershed Properties table, expand the Depression Watershed property group. Change Use Hatching to True.
   Click Hatch Pattern and click ™.

7 In the Hatch Properties dialog box, click AR-SAND in the Pattern list and enter 15 in the Scale field.

8 Click OK to close the Hatch Properties dialog box.

9 Click the Display tab. In the Component Display table, click next to Watersheds to turn on display of these watershed components.

10 Click OK to close the Surface Style dialog box.

To continue this tutorial, go to Exercise 2: Generating a Watershed Analysis (page 79).

**Exercise 2: Generating a Watershed Analysis**

In this exercise, you will generate and display the watershed analysis.

For more information, see the AutoCAD Civil 3D Help topic *Analyzing Surfaces*.

This exercise continues from Exercise 1: Configuring a Style for Watershed Display (page 78).

**To generate a watershed analysis**

**NOTE** This exercise uses *Surface-5A.dwg* with the modifications you made in the previous exercise.

1 In Toolspace, on the Prospector tab, expand the Surfaces collection. Right-click the XGND surface. Click Surface Properties.

2 In the Surface Properties dialog box, on the Information tab, for Surface Style, select Watersheds.

3 On the Analysis tab, from the Analysis Type list, select Watersheds.

4 Ensure that Standard is selected in the Legend list.
5 Click to generate the watershed analysis. The details of the surface watersheds are displayed in the Details table.

6 Click to open the Watershed Display dialog box. Click the next to Boundary Point and Boundary Segment to turn off the display of these watershed types.

7 Click OK to close the Watershed Display dialog box. Click OK to close the Surface Properties dialog box.

8 The watersheds are displayed on the surface in the drawing.

9 In Toolspace, on the Prospector tab, expand the Surfaces ➤ XGND collection. Click the Watersheds collection. The Prospector list view displays a tabular list of the surface watersheds with their IDs, description, type, and the ID of the watershed that they drain into.

10 Optionally, pan or zoom to an individual watershed. Right-click the watershed item in the list view and click Pan To or Zoom To.

To continue this tutorial, go to Exercise 3: Creating a Watershed Legend (page 80).

**Exercise 3: Creating a Watershed Legend**

In this exercise, you will add a watershed legend table to the drawing.

For more information, see the AutoCAD Civil 3D Help topic Adding Surface Legend Tables.

This exercise continues from Exercise 2: Generating a Watershed Analysis (page 79).

**To add a watershed legend**

NOTE This exercise uses Surface-5A.dwg with the modifications you made in the previous exercise, or you can open Surface-5B.dwg from the tutorial drawings folder (page 615).

1 In Toolspace, on the Settings tab, expand the Surface ➤ Table Styles collection and then expand the Watershed collection.
2 Right-click the Standard style. Click Edit. The Table Style dialog box displays the properties of the Standard watershed table style.

3 On the Data Properties tab of the Table Style dialog box, clear the Sort Data check box.

4 Click OK to close the Table Style dialog box.

5 Click Surfaces menu ➤ Add Legend Table.

6 At the prompt to specify the table type, enter Watersheds.

7 You are prompted to specify whether you want the table to automatically update if the analysis information changes. Enter Dynamic to enable automatic updating.

   If a change is made to the surface and the watershed analysis is regenerated, the legend is automatically updated.

8 Click a location in the drawing where you want to place the upper-left corner of the table.

   The legend table is displayed in the drawing at the selected location.

To continue this tutorial, go to Exercise 4: Extracting Objects from a Surface (page 81).

**Exercise 4: Extracting Objects from a Surface**

In this exercise, you will use the watershed data to create nondestructive AutoCAD objects from the surface.

For more information, see the AutoCAD Civil 3D Help topic *Extracting Surface Data*.

This exercise continues from Exercise 3: Creating a Watershed Legend (page 80).

To extract objects from a surface

---

**NOTE** This exercise uses *Surface-5B.dwg* with the modifications you made in the previous exercise.

---

1 Click Surfaces menu ➤ Utilities ➤ Extract Objects From Surface.
2 The Extract Objects From Surface dialog box lists all of the surface properties that are visible in the currently selected surface style. Clear all boxes in the Properties column except for Watersheds.

3 Click OK.
   AutoCAD objects are created from each of the watersheds in the drawing.

4 In the drawing window, click inside several of the watershed areas. A blue grip appears inside each area, indicating that you have selected an AutoCAD object.

5 On the command line, enter List. The AutoCAD text window displays parameters for the first object you selected.

6 Press Enter to view the parameters for each subsequent object you selected. You can use any of the standard AutoCAD commands to modify or query the new objects.

To continue this tutorial, go to Exercise 5: Analyzing Surface Water Runoff (page 82).

**Exercise 5: Analyzing Surface Water Runoff**

In this exercise, you will create lines that illustrate the path that flowing water would take across a surface. Then, you will create a polygon that defines the catchment region and its area on the surface.

The water drop utility creates either a 2D or 3D polyline object that runs downhill on a surface from any point you select. You can specify whether the point you select is indicated with a marker. After the lines are created, you can edit or modify them as needed.

You can use the information you get from the water drop analysis to calculate catchment areas, based on specified low points of the surface. The catchment regions can be created on the surface as either 2D or 3D polygons, which can be exported to a hydrology application for detailed analysis.

For more information, see the AutoCAD Civil 3D Help topics Drawing Water Drop Paths and Displaying and Calculating Catchment Areas.

This exercise uses a drawing file similar to the one used in Exercise 3: Creating a Watershed Legend (page 80). The surface style is changed to make it easier to see the basic surface features, and it contains a simple point style for you to use as a start point marker.
This exercise continues from Exercise 4: Extracting Objects from a Surface (page 81).

**To perform a water drop analysis**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-5C.dwg.

2. Click Surfaces menu ➤ Utilities ➤ Water Drop.

3. In the Water Drop dialog box, specify the following settings. Click OK.
   - Path Layer: C-TOPO-WDRP
   - Path Object Type: 2D Polyline
   - Place Marker At Start Point: Yes
   - Start Point Marker Style: WD Start

4. In the drawing window, click several locations near those displayed in the following illustration.
   A 2D polyline is drawn, representing the flow of water from the spot you selected. The start point of the path is indicated by a + marker.
   If a water path splits, additional lines are drawn to follow each path.
5 Press Enter to end the waterdrop command.
Notice that most waterdrop paths in this area drain to the culverts that are indicated by the red arrows. Next, you will use the water drop paths you just created to define a catchment area that influences the culverts.

To create a catchment area

1 Click Surfaces menu ➤ Utilities ➤ Catchment Area.
2 In the Water Drop dialog box, specify the following settings. Click OK.
   ■ Catchment Layer: C-TOPO-CATCH
   ■ Catchment Object Type: 2D Polyline
   ■ Catchment Marker: Yes
   ■ Catchment Marker Style: Catchment Area
3 In the drawing window, click the marker for each waterdrop path. Blue polygons that define each catchment region are created. The area value of each catchment region is displayed on the command line. In the drawing, each catchment point is indicated by a marker.

**NOTE** If you receive a message indicating that the specified location results in a catchment area with no area, it means that there is no flat area or high spot on the specified point.

4 Press Enter to end the catchment area command.

5 In the drawing window, select the polygons that define catchment areas. Right-click. Select Isolate Objects ➤ Isolate Selected Objects. The polygons are displayed in the drawing window, but all other objects are hidden.

6 Select the polygons again.

7 On the command line, enter LineWorkShrinkWrap.
A black polygon that contains the combined area of the catchment areas is displayed. The LineWorkShrinkWrap command creates a single outside boundary of a selection of touching polygons. The original polygons are not deleted.

In the drawing window, right-click. Click Isolate Objects ➤ End Object Isolation. The remaining drawing objects are displayed in the drawing window.

**TIP** You can transfer individual or shrinkwrapped catchment area polygons to a hydrology application for further analysis.

To continue to the next tutorial, go to *Generating Surface Volume Information* (page 86).

**Tutorial: Generating Surface Volume Information**

This tutorial demonstrates how to create base and comparison surfaces, create a composite volume surface from those surfaces, and then perform composite volume calculations.
A *volume surface* is similar to other surface objects, in that you can display cut and fill contours, cut and fill points, add labels to it, and add it to a project. The cut, fill, and net volumes are properties that can be viewed by selecting Surface Properties.

The *composite volume* method uses the points from two surfaces, as well as any location where the triangle edges between the two surfaces cross. The cut, fill, and net volumes are calculated based on the elevation differences between the two surfaces.

![Diagram of volume surface]

For more information, see the AutoCAD Civil 3D Help topic *Calculating Surface Volumes*.

**Exercise 1: Creating the Base and Comparison Surfaces**

In this exercise, you will create base and comparison surfaces, from which to derive volume calculations.

For more information, see the AutoCAD Civil 3D Help topic *Creating Surfaces*.

**To create the surfaces**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing `Surface-6.dwg`. The surface (Existing Ground without Berm) in this file is similar to the one in `Surface-5A.dwg` except that there is no berm at the south end of
the surface. This surface will be the base surface for the volume calculations.

2 Click Surfaces menu ➤ Create Surface.
   In the Create Surface dialog box, in the Type list, select TIN Surface.

3 For the surface properties, use the following:
   ■ Name: Berm
   ■ Description: Berm surface
   ■ Style: Standard
   ■ Render Material Style: ByLayer

4 Click OK to create the surface.

5 In Toolspace, on the Prospector tab, expand the drawing Surface-6 and the Surfaces collection.
   The Berm surface is listed in the Surfaces collection, but it does not contain any data. This will be the comparison surface for the volume calculations.

6 Click Insert menu ➤ Block.

7 In the Insert dialog box, click Browse. Navigate to the tutorial drawings folder (page 615). Select the drawing Berm Breaklines.dwg and click Open.

8 In the Insert dialog box, use the following settings:
   ■ Insertion Point: Set X, Y, and Z to 0.0000; clear Specify On Screen.
   ■ Explode: Selected.
   ■ Scale: Cleared Specify On Screen; set X to 1.0000; select Uniform Scale.
   ■ Rotation: Cleared Specify On Screen; set Angle to 0.

9 Click OK.
   The polylines are inserted into the drawing.

10 On the command line, enter QSelect.

11 In the Quick Select dialog box, use the following settings:
   ■ Apply To: Entire Drawing
   ■ Object Type: 3D Polyline
12 Click OK. The 3D polylines are selected in the drawing.

13 In Toolspase, on the Prospector tab, under the Surfaces collection, expand the Berm surface.

14 Under the Berm surface, expand the Definition collection. Right-click Breaklines and click Add.

15 In the Add Breaklines dialog box, enter the following breakline properties:
   - Description: Berm-Breaklines
   - Type: Standard
   - Mid-Ordinate Distance: 1.0000

16 Click OK.
   The previously selected 3D polylines are added to the surface definition as breaklines. The surface displayed in the drawing updates.

To continue this tutorial, go to Exercise 2: Creating a TIN Volume Surface (page 89).

**Exercise 2: Creating a TIN Volume Surface**

In this exercise, you will create a TIN volume surface. A TIN volume surface is a persistent, differential surface object created from a composite of points based on base and comparison surfaces.

For more information, see the AutoCAD Civil 3D Help topic *Creating a TIN Volume Surface*.

This exercise continues from Exercise 1: Creating the Base and Comparison Surfaces (page 87).
To create a TIN volume surface

NOTE This exercise uses Surface-6.dwg with the modifications you made in the previous exercise.

1 Click Surfaces menu ➤ Create Surface.
   In the Create Surface dialog box, in the Type list, select TIN Volume Surface.

2 For the surface Information properties, use the following:
   ■ Name: Berm Volume
   ■ Description: Berm volume difference surface
   ■ Style: Standard
   ■ Render Material: ByLayer

3 Under the Volume Surfaces property group, click <Base surface>. Click .

4 In the Select Base Surface dialog box, select Existing Ground Without Berm. Click OK.

5 Under the Volume Surface property group, click <Comparison surface>.
   Click .

6 In the Select Comparison Surface dialog box, select Berm, and click OK. Click OK in the Create Surface dialog box.

7 In Toolspace, on the Prospector tab, expand the Surface-6 drawing object and the Surfaces collection.

   The Berm Volume surface is listed in the collection, with an icon to indicate that it is a TIN volume surface.

8 To view the volume statistics for the surface, on the Prospector tab, right-click the Berm Volume surface. Click Surface Properties.

9 In the Surface Properties dialog box, click the Statistics tab. Expand the Volume statistics to see the cut, fill, and net volumes.

Further exploration: If you want to add the data from the Statistics tab to the drawing, right-click the statistics table and click Copy To Clipboard. Then close the Surface Properties dialog box, zoom in to a clear space in the drawing, right-click, and click Clipboard ➤ Paste. The entire contents
of the Statistics tab (General, TIN, and Volume) are pasted in. To edit the
text content and format, right-click and click MText Edit. Another useful
option is to paste the statistical data from the clipboard into a separate
spreadsheet.

10 If necessary, click OK to close the Surface Properties dialog box.

To continue this tutorial, go to Exercise 3: Creating a Composite Volume
Calculation (page 91).

**Exercise 3: Creating a Composite Volume Calculation**

In this exercise, you will use the Composite Volume utility to calculate volume
information between two surfaces.

For more information, see the AutoCAD Civil 3D Help topic Calculating
Composite Volumes.

This exercise continues from Exercise 2: Creating a TIN Volume Surface (page
89) and presents an alternative method for generating the surface volume
statistics.

**To create composite volume information**

**NOTE** This exercise uses Surface-6.dwg with the modifications you made in the
previous exercise.

1 Click Surfaces menu ➤ Utilities ➤ Volumes.

2 In the Composite Volumes vista, click Create New Volume Entry.

3 Click the <select surface> entry in the Base Surface column. Select the
Existing Ground Without Berm surface from the list.

4 Click the <select surface> entry in the Comparison Surface column and
select the Berm surface from the list.

After the surfaces are selected, the volumes are calculated and displayed
in the table. The Net Graph entry shows a graphical percentage
representation of the whole volume. A net fill condition is represented
by a green bar; a net cut condition by a red bar.
To continue to the next tutorial, go to Visualizing Surface Data (page 92).

**Tutorial: Visualizing Surface Data**

This tutorial demonstrates how to add multi-view blocks to a surface and render it using a sample of the visualization techniques included with AutoCAD Civil 3D.

AutoCAD Civil 3D uses the same rendering functionality as standard AutoCAD. At a basic level, you can use the Render command to render your model without applying any materials, adding any lights, or setting up a scene. In this tutorial, you will create a basic rendering by applying a render material to a surface. You will explore some of the basic render settings that are available.

For more information, see the AutoCAD help topic *Create Realistic Images and Graphics*.

**Exercise 1: Moving Multi-View Blocks to a Surface**

In this exercise, you will insert multi-view blocks into a drawing, and then place them at the appropriate elevation on a surface.

A multi-view block is an AutoCAD Civil 3D object that can have different representations in different view directions.

Predefined multi-view blocks supplied with AutoCAD Civil 3D are available in DesignCenter. These blocks represent various items, such as signs, building footprints, trees, and shrubs. In DesignCenter, predefined multi-view blocks are located in the C:\Documents and Settings\All Users\Application Data\Autodesk\C3D 2009\enu\Data\Symbols\Mvblocks folder.

For more information, see the AutoCAD Civil 3D Help topic *Multi-View Blocks*.

To move multi-view blocks to a surface

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-7.dwg.

2. Click View menu ➤ Named Views.

3. In the View Manager dialog box, select the Plan Detail view. Click Set Current. Click OK.
The drawing view shows a two-way road with a median separating the lanes.

4 Click Insert menu ➤ DesignCenter.

5 In DesignCenter, navigate to the C:\Documents and Settings\All Users\Application Data\Autodesk\C3D 2009\enu\Data\Symbols\Mvblocks folder. Select the Mvblocks folder in the left pane.
   In the right pane, examine the blocks that are available.

   **NOTE** Before continuing with this exercise, either dock the DesignCenter palette or click [ ] to autohide it.

6 In the right pane, select R4-7a Keep Right.dwg. Right-click. Click Insert As Block.

7 In the Insert dialog box, select the Specify On Screen check boxes for Insertion Point, Scale, and Rotation. Clear the Explode check box. Click OK.

8 When prompted to specify an insertion point in the drawing window, click the symbol at the bottom of the median.

9 Press Enter to accept the default scale factor of 1.

10 When prompted to specify the rotation angle, zoom in to the insertion point and rotate the block until the sign is parallel with the symbol. Click to set the angle of rotation.
11 Repeat steps 6 and 7 to insert the Light Pole 01.dwg block. When prompted to specify an insertion point in the drawing window, click the symbol near the middle of the median. Press Enter to accept the default scale factor and rotation angle.

12 Click View menu ➤ Named Views.

13 In the View Manager dialog box, select the 3D Detail view. Click Set Current. Click OK.

In the 3D view, notice that the street light block appears at the lower portion of the drawing and is not at the appropriate surface elevation. In the following steps, you will move both blocks onto the surface.

14 Click Surfaces menu ➤ Utilities ➤ Move Blocks To Surface.

15 In the Move Blocks To Surface dialog box, in the Select Block Reference Names field, select Light Pole 1 and R4-7a Keep Right.

16 Click OK. Each selected block moves from its current elevation to the surface elevation at the block’s insertion point.

To continue this tutorial, go to Exercise 2: Rendering a Surface (page 94).

**Exercise 2: Rendering a Surface**

In this exercise, you will use some of the visualization features in AutoCAD Civil 3D to render a surface.

Like other AutoCAD Civil 3D objects, you must apply a render material to the surface using the Surface Properties dialog box.

For more information, see the AutoCAD Civil 3D Help topic *Render Material Styles*.

This exercise continues from Exercise 1: Moving Multi-View Blocks to a Surface (page 92).
To render a surface

NOTE This exercise uses Surface-7.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Prospector tab, expand the Surfaces collection.
2. Right-click the XGND surface. Click Surface Properties.
   This render material displays contrast in the surface elevations.
4. Set the Surface Style to Standard.
5. Click OK to close the Surface Properties dialog box.

Now that you have applied a render material, you will experiment with two different ways of rendering. Two methods are shown in steps 6 and 7 using the Visual Styles feature. Visual styles give a fast, basic visualization of the surface that is useful for on-screen presentation in AutoCAD Civil 3D.

6. Click View menu ➤ Visual Styles ➤ Realistic.
   This visual style shades the surface and smooths the edges between polygon faces. The render material that you applied to the surface is displayed.
7. Click View menu ➤ Visual Styles ➤ Conceptual.
   This visual style shades the surface and smooths the edges between polygon faces. The shading in this style uses the Gooch face style, a transition between cool and warm colors rather than dark to light. The effect is less realistic, but it can make the details of the model easier to see.
8. Click View menu ➤ Render ➤ Advanced Settings.
   Examine the many render settings that are available, including variations in image quality and output size. If you wanted to save the rendered image to a file, you would click ➤ and use the Output File Name control to specify a file name and destination.
9. Click .
The surface and blocks are rendered in the Render window. The effects of rendering are more apparent in a drawing that has different render materials applied to several surfaces and objects.

To continue to the next tutorial, go to Obtaining an Aerial Image and Draping It on a Surface (page 96).

**Tutorial: Obtaining an Aerial Image and Draping It on a Surface**

This tutorial demonstrates how to drape an image on an AutoCAD Civil 3D surface object.

You can drape an existing image on a surface. However, this tutorial demonstrates how to obtain a useful image by using the Google Earth™ mapping service import/export features in AutoCAD Civil 3D.
The Drape Image command combines the following operations into a few simple steps:

- A new render material is created from the source image, with mapping based on the scale, position, and rotation of the source image.
- The new render material is applied to the selected surface object. Like other render materials, the effect of the draped image is visible only when viewing the image in 3D.

**NOTE** AutoCAD Civil 3D makes it easy to retrieve low-resolution, public image and terrain data from Google Earth. While the data you can retrieve from Google Earth may not be suitable for detailed design, it can be useful for project planning and presentation.

For more information, see the AutoCAD Civil 3D Help topics *Draping Images on Surfaces* and *Google Earth Import and Export*. 
Exercise 1: Publishing Surface Data to Google Earth

In this exercise, you will publish the surface data of a drawing to Google Earth. Then, Google Earth will use the coordinate system specified in the drawing settings to retrieve an image of the area around the surface. The coordinate system specified in the drawing settings will be used to transform data as it is imported to or exported from Google Earth.

**NOTE** For best results, make sure that you have Google Earth version 4.0 or later.

For more information, see the AutoCAD Civil 3D Help topic *Publishing Civil Data to Google Earth*.

To publish surface data to Google Earth

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-8.dwg.

2. Start Google Earth.

3. In the AutoCAD Civil 3D window, click File menu ➤ Publish To Google Earth.

4. In the Publish AutoCAD DWG To Google Earth wizard, on the Describe page, you can enter information that will be used to create a new, temporary entry in the Temporary Places folder, in the Places pane in Google Earth. Enter the following information:
   - Name: Aerial Mapping_NH83F
     - This field is automatically populated by the drawing name.
   - Description: Aerial mapping of a project in New Boston, NH
   - Hyperlink: blank

5. Click Next.

6. On the Items page, select the Selected Model Space Entities option. This makes the button available, which you use to pick the specific objects in the drawing that you want to publish to Google Earth.
7 Click \( \text{Click} \). When you are prompted to select an object, pan and zoom to the upper left corner of the surface. Click the red line that defines the extents of the surface. If you pan or zoom to click the border, reset the zoom by entering ‘Z, and then P on the command line. Press Enter to accept the selection.

8 In the Publish AutoCAD DWG To Google Earth wizard, on the Items page, notice that one entity (the surface extents boundary) has been selected. Ensure that Publish Entity Information is selected. Click Next.

9 On the Geo-Reference page, notice that the Drawing Coordinate System Transform option is selected. NAD83 New Hampshire State Planes, US Foot is listed as the zone. This information is taken directly from the world coordinate system setting specified in the drawing settings. Notice that if you select the User-Defined Transform option, you can manually select coordinates. Ensure that the Drawing Coordinate System Transform option is selected. Click Next.

10 On the Nudge page, you can fine-tune the image location, using DWG linear units. Select the Drape Entities On Ground option. Click Next.

11 On the File page, you can specify a file location for the KMZ data file that Google Earth creates. Click \( \text{Click} \). Navigate to the My Civil 3D Tutorial Data folder (page 615). Click Save.
12 Click Publish. When the Publishing Status indicates that the model has been 100% published, click View.

Google Earth takes focus, panning and zooming to the specified coordinates and displaying the polygon that defines the extents of the surface. Notice that the name and description that you entered in the Publish AutoCAD DWG To Google Earth wizard has been used to create a new entry in the Temporary Places folder in the Google Earth Places pane. When you exit Google Earth, you are prompted to specify whether to save the new location to the My Places folder.

13 In the Google Earth window, in the Places pane, under Temporary Places, clear the Aerial Mapping_NH83F check box.

Clearing this check box turns off the polygon that defines the extents of the surface. The polygon was exported from AutoCAD Civil 3D so that
you can confirm the image location. Clearing the Aerial Mapping_NH83F check box turns the polygon off, which prevents it from being imported back into AutoCAD Civil 3D.

**NOTE** If Google Earth zooms past the polygon, expand the Temporary Places ➤ Aerial Mapping_NH83F ➤ Model ➤ Polyline collection. Double-click Polyline to zoom to the extents of the polyline.

To continue this tutorial, go to Exercise 2: Importing a Google Earth Image (page 101).

**Exercise 2: Importing a Google Earth Image**

In this exercise, you will import an aerial image from Google Earth into AutoCAD Civil 3D.

To provide a useful source image, Google Earth must display the image from directly above. If the image is tilted, it will still be captured by AutoCAD Civil 3D. However, it will not be a useful representation of the surface when it is converted to a render material.

When the Google Earth image is imported into AutoCAD Civil 3D, it appears in the drawing as a gray scale image object. The image is scaled by both the linear units in the drawing and the extents of the latitude/longitude of the image. The image aspect ratio matches that of the image displayed in the Google Earth window. AutoCAD Civil 3D automatically generates a name for the image, using the first three letters of the drawing file name and a unique ID number. The image is saved the image in the same directory as the drawing file.

When the image is draped on the surface, a new render material is created from the image, and the render material is applied to the surface. If the image is larger than the surface, the image is clipped to the extents of the surface object. If multiple, smaller images are needed to cover a surface, you must combine them into a single image.
TIP  If you do not want to get your surface image from Google Earth, you can use Autodesk Raster Design to prepare images from other sources. Using Raster Design, you can
  ■ combine multiple images into a single image.
  ■ convert images to a format (such as BMP, DIB, GIF, JPG, PCX, PNG, RLE, TGA, or TIF) that is suitable for use as a render material.
  ■ orient and scale an image appropriately for a drawing.

For more information, see the AutoCAD Civil 3D Help topic Importing a Google Earth Image to AutoCAD Civil 3D.

This exercise continues from Exercise 1: Publishing Surface Data to Google Earth (page 98).

To import a Google Earth image

NOTE  This exercise uses Surface-8.dwg with the modifications you made in the previous exercise.

1  In Google Earth, ensure that the image is viewed from directly above.
   If the Google Earth navigation controls are not visible, hover the cursor over the compass at the upper right-hand corner of the screen:
To reset the tilt so that the image is viewed from directly above, double-click . Alternatively, you can press the R key to reset the tilt.

To reorient the view so that North is oriented toward the top of the screen, click . Alternatively, you can press the N key to reset the North orientation.

To pan back to the view that was originally published, double-click the appropriate link under Temporary Places.

2 In AutoCAD Civil 3D, click File menu ➤ Import ➤ Import Google Earth Image.

3 When prompted to select a coordinate system for image location, press Enter to accept the default Coordinate System selection.

The gray scale Google Earth image appears in the drawing window in the appropriate location under the surface object. The image was placed on the current layer, which is named Image in the current drawing.
To continue this tutorial, go to Exercise 3: Draping an Image on a Surface (page 104).

**Exercise 3: Draping an Image on a Surface**

In this exercise, you will drape an image onto a surface, creating a render material from the image.

First, you will review a surface style to learn about some common settings that provide an acceptable view of the draped image on the surface. When you drape an image on a surface, the image is applied to the surface as a render material. However, it is not evident that you have applied a render material when you view the surface in plan view. The surface style must be set up to view the surface in model.

For more information, see the AutoCAD Civil 3D Help topic *Draping Images On Surfaces*.
This exercise continues from Exercise 2: Importing a Google Earth Image (page 101).

**To drape an image on a surface**

**NOTE** This exercise uses *Surface-8.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Prospector tab, under the drawing name, expand the Surfaces collection. Right-click Aerial Mapping. Click Edit Surface Style.
   In the Surface Style dialog box, on the Display tab, examine the current surface style, S’ Contours. Notice that the style displays the surface border and major and minor contours when the surface is viewed in plan view.

2. From the View Direction list, select Model.
   Notice that the surface style is set to display only triangles when the surface is viewed in model view.

3. Click the Triangles tab.
   Notice that the Triangle Display Mode is set to Exaggerate Elevation and the Exaggerate Triangles By Scale Factor is set to 3.000.
   These settings specify that when the surface is displayed in model view, the triangle elevations are exaggerated by a factor of three. The exaggeration makes the variations of the surface more obvious than if the surface was not exaggerated.

4. Click Cancel to close the Surface Style dialog box.

5. Click Surfaces menu ➤ Utilities ➤ Drape Image.

6. In the Drape Image dialog box, select the following information from the Image and Surface lists. All the images and surfaces available in the current drawing appear in the lists. Alternatively, you can click ![pick tool] to pick the image or surface directly in the drawing window.
   - Image: SurXXX
   - Surface: Aerial Mapping

**NOTE** The image name is automatically generated when it is imported into AutoCAD Civil 3D. Your image name and render material name may differ from the names that are shown in this tutorial.
The Render Material Name field is populated with an automatically generated name (Aerial Mapping_SurXXX_RenderMaterial). You can change this name as desired, but accept the default for this exercise.

7 Click OK.

The image is draped on the surface, but it is not evident in plan view. Next, you will hide the image, and then view the surface in model view.

8 In the drawing window, select the image. Right-click. Click Isolate Objects ➤ Hide Objects.

**NOTE** To make the image reappear, right-click in the drawing area and click Isolate Objects ➤ End Object Isolation.

9 Click View menu ➤ 3D Views ➤ SE Isometric.

This selection specifies an appropriate angle at which to view the surface in 3D.

10 On the command line, enter Zoom. When prompted, enter O to select an object.

11 When prompted to select an object, in the drawing window, click the surface. Press Enter to accept the selection.
Click View menu ➤ Visual Styles ➤ Realistic.

The gray scale Google Earth image appears draped over the surface. Notice that because the image was larger than the surface, the image has been clipped to the extents of the surface.
13 On the command line, enter Materials.

14 On the Materials palette, notice that a new render material has been created and is using the imported image as a diffuse map. The render material name and image name correspond to the names that were specified in Step 6.
Survey Tutorials

These tutorials will get you started working with the AutoCAD Civil 3D survey features.

AutoCAD Civil 3D contains a complete set of tools that surveyors can use to download and process survey information, perform adjustments on network and traverse data, and import survey points into an AutoCAD Civil 3D drawing.

The survey features also provide additional options for detailing points with figures and line work. Other options provide the capability of calculating directions based on astronomic observations.

For more information, see the AutoCAD Civil 3D Help topic Understanding Survey.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

**Tutorial: Survey Setup**

This tutorial demonstrates how to access the survey functionality and define and manage the survey settings in AutoCAD Civil 3D.

For more information, see the AutoCAD Civil 3D Help topic Survey Databases.

**Exercise 1: Setting Up the Database and Drawing**

In this exercise, you will open the Survey tab in Toolspace, create a local survey database, and open a drawing to display the survey data.

For more information, see the AutoCAD Civil 3D Help topic Survey Database.
To set up the survey database and drawing

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-1.dwg.

2. To open the Toolspace Survey tab, click Survey menu ➤ Open Survey Toolspace.

3. In Toolspace, on the Survey tab, right-click Survey Databases. Click New Local Survey Database.

4. In the New Local Survey Database dialog box, enter Survey 1 for the database name. Click OK.

   The newly created database is added to the Survey Databases collection on the Survey tab with empty collections items, including Networks, Figures, and Survey Points. These collections are populated when you add or create survey data.

To continue this tutorial, go to Exercise 2: Setting the Equipment and Figure Prefix Databases (page 110).

Exercise 2: Setting the Equipment and Figure Prefix Databases

In this exercise, you will create new survey equipment and figure prefix databases and definitions.

*Equipment definitions* specify the values associated with a specific surveying instrument, such as the standard deviations associated with the measuring capabilities of the instrument.

*Figure prefixes* specify the layer that a figure is drawn on, how a figure is stylized, and whether figures are created as breaklines and lot lines. When figures are created, they are matched based on their names and the prefix names. All figures that match a specific prefix are assigned the properties of the prefix.

For more information, see the AutoCAD Civil 3D Help topics *Survey Equipment Database* and *Survey Figure Prefix Database*.

This exercise continues from Exercise 1: Setting Up the Database and Drawing (page 109).
To create new equipment and figure prefix definitions

NOTE This exercise uses Survey-1.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Survey tab, right-click the Equipment Databases collection. Click New.

2 In the New Equipment Database dialog box, enter Survey 1 for the new equipment database and click OK. The database is created with the default equipment definition named Sample, which is displayed in the Equipment Databases collection.

3 To create an equipment definition, right-click the Survey 1 equipment database. Click New.

4 In the New Equipment dialog box, under the Miscellaneous property, for Name, enter Survey 1.

5 Review the Standard Deviations settings. These settings determine the accuracy of the survey observations based on the equipment that measured them.

6 Click OK to close the New Equipment dialog box.

7 In Toolspace, on the Survey tab, expand the Survey 1 equipment database. Right-click the Survey 1 equipment definition. Click Make Current. In Toolspace, the current equipment database name and definition name are displayed in bold text.

8 In Toolspace, on the Survey tab, right-click the Figure Prefix Databases collection. Click New.

9 In the New Figure Prefix Database dialog box, enter Survey 1 for the new figure prefix database and click OK.

10 To create a figure prefix definition, on the Survey tab, expand the Figure Prefix Databases collection. Right-click the figure prefix database Survey 1. Click New.

11 In the New Figure Prefix dialog box, click the Value column for the Name property and enter LOT for the figure prefix definition name.

12 Verify that the check box next to the Lot Line property is selected.

13 Click the Value column for the Site property and enter Survey 1.
14 All figures that match the LOT prefix name will have their Lot Line setting set to Yes. When the figure is inserted into the drawing, AutoCAD Civil 3D will create lot lines in the drawing in the Survey 1 site.

Click OK to close the New Figure Prefix dialog box.

15 In Toolspace, on the Survey tab, right-click the Survey 1 figure prefix database. Click Make Current.

To continue this tutorial, go to Exercise 3: Adjusting and Verifying Settings (page 112).

**Exercise 3: Adjusting and Verifying Settings**

In this exercise, you will view and adjust several types of survey settings.

Survey user settings are specific to a Windows user login account and affect only the survey features, and not the database or drawing data.

Survey database settings are specific to the survey features of an AutoCAD Civil 3D survey database.

For more information, see the AutoCAD Civil 3D Help topic *Survey Settings*.

This exercise continues from Exercise 2: Setting the Equipment and Figure Prefix Databases (page 110).

**To verify and adjust survey settings**

**NOTE** This exercise uses Survey-1.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Survey tab, click ![Survey User Settings dialog box](image)

2 In the Survey User Settings dialog box, under the Miscellaneous property group, verify that the check box next to Use External Editor is selected so that it is set to Yes.

3 For the Network Preview, Setup Preview, and Figure Preview property groups, select all the check boxes. Selecting the check boxes enables the previewing of all survey components in the Toolspace Survey tab.

4 Click OK to save the settings and close the Survey User Settings dialog box.
5 In Toolspace, on the Survey tab, in the Survey Databases collection, right-click the Survey 1 database. Click Edit Survey Database Settings to display the Survey Database Settings dialog box.

6 Under the Precision property group, verify that Angle, Distance, Elevation, and Coordinate are set to 4, 3, 3, and 4 respectively. Latitude and Longitude should be set to 8.
These precision settings are independent of the Drawing Settings precision settings and affect all aspects of the user interface that displays the survey data.

7 For the Least Squares Analysis Defaults property group, ensure that the following are set:
■ Network Adjustment Type: 3-Dimensional
■ Confidence Level: 99% confidence
■ Perform Blunder Detection: Yes

8 In the Error Tolerance property group, examine the properties that are available.
These values specify the acceptable error values for the survey measurement. The values in this collection correspond to the units of measure that are specified in the Units collection. For more information, see the AutoCAD Civil 3D Help topic Setting Error Tolerance.

9 Click OK to save the settings and close the Survey Database Settings dialog box.

To continue this tutorial, go to **Exercise 4: Setting Survey Styles** (page 113).

**Exercise 4: Setting Survey Styles**

In this exercise, you will review the survey network styles and create a figure style.

The survey styles control the way that survey features are displayed in the drawing.

For more information, see the AutoCAD Civil 3D Help topic Survey Styles and Display.

This exercise continues from **Exercise 3: Adjusting and Verifying Settings** (page 112).
To review and adjust the survey drawing settings and styles

**NOTE** This exercise uses *Survey-1.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, expand the Survey collection under the drawing Survey-1.

2. Expand the Network Styles collection to display the list of existing network styles in the drawing.

3. Right-click the Standard network style. Click Edit.

4. In the Network Style dialog box, click the Components tab. Notice that you can set different marker styles for known control points, unknown control points, and sideshot points.

5. Click OK to close the Network Style dialog box.

6. To create a figure style, right-click the Figure Styles collection. Click New.

7. In the Figure Style dialog box, on the Information tab, enter Building for the figure style name.

8. Click the Display tab.

9. In the Component Display table, change the color for the Figure Lines. To do this, click the Color column. In the Select Color dialog box, in the Color field, enter 11. Click OK.

10. Click OK to close the Figure Style dialog box.

To continue to the next tutorial, go to Importing and Viewing Survey Data (page 114).

**Tutorial: Importing and Viewing Survey Data**

This tutorial demonstrates how to import survey data to the AutoCAD Civil 3D survey database, and how to insert and browse to the survey data in your drawing.

**NOTE** Before performing the steps in this tutorial, you must have already set up the survey database. For more information, see the Survey Setup (page 109) tutorial.
You will input survey data from a field book file, which is a text file that contains survey observation measurements that you can import into a drawing and database. You would typically download data from a data collector and create a field book file to import.

You will also use the Survey tab in Toolspace to view and manage survey data, such as points, setups, directions, and figures.

**NOTE** The optional Survey Data Collection Link can be used to transfer and convert raw data to an FBK file. You can install the Survey Data Collection Link from the installation AutoCAD Civil 3D wizard, on the Programs to Install page.

For more information, see the AutoCAD Civil 3D Help topic Survey Data Input and Editing.

**Exercise 1: Importing from a Field Book File**

In this exercise, you will import survey data from an existing field book file, which is a text file that contains observed point data.

**NOTE** Before performing the steps in this exercise, you must have already created the survey database Survey 1. For more information, see the Setting Up the Database and Drawing (page 109) exercise.

For more information, see the AutoCAD Civil 3D Help topic Field Book File.

**To import a field book file**

**NOTE** This exercise uses Survey-1.dwg with the modifications you made in the previous tutorial, or you can open Survey-2.dwg from the tutorial drawings folder (page 615).

1. In Toolspace, on the Survey tab, expand the Survey Databases collection, expand Survey 1, right-click the Networks collection and click New.

   **NOTE** If the survey database does not expand, right-click the database name and click Open Survey Database.

2. In the New Network dialog box, enter Survey Network 1 and click OK.

3. On the Survey tab, right-click the newly created network Survey Network 1 and click Import Field Book.
4 In the Field Book Filename dialog box, browse to the tutorial folder (page 615) and select the field book file Survey-1.fbk. Click Open.

5 In the Import Field Book dialog box, verify that the following are set:
   ■ Current Equipment Database: Survey 1
   ■ Current Equipment: Survey 1
   ■ Current Figure Prefix Database: Survey 1
   ■ Display Tolerance Errors In Event Viewer: Selected
     This option specifies that if errors that are greater than a specified tolerance are detected, they will be displayed in the Event Viewer. Tolerance settings may be specified in the Survey Database Settings dialog box. If errors are displayed, you can quickly locate the erroneous data using the Zoom To and Browse To links in the Event Viewer. For more information, see the AutoCAD Civil 3D Help topics Setting Error Tolerance and Reporting Tolerance Errors.

6 Accept the defaults for all other settings and click OK.
   The survey data from the field book is imported into the survey database and displayed in the drawing.

To continue this tutorial, go to Exercise 2: Viewing Survey Data (page 117).
Exercise 2: Viewing Survey Data

In this exercise, you will use the Toolspace Survey tab and panorama vistas to view some of the data that you imported from the field book file.

You will also browse to the newly created network and figure objects in the AutoCAD Civil 3D Prospector tab and drawing.

For more information, see the AutoCAD Civil 3D Help topic *The Toolspace Survey Tab*.

This exercise continues from Exercise 1: Importing from a Field Book File (page 115).

To view and browse the survey data

**NOTE** This exercise uses *Survey-2.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Survey tab, expand the network Survey Network 1 to display the collections of survey data, including control points, directions, and setups.

2. To view the control points, click the Control Points collection. The control points are displayed in the Toolspace list view.

   **NOTE** By default, if the Toolspace is docked, the list view is the lower part of the Toolspace.

3. To view the setups, click the Setups collection and expand it. The setups are displayed in the Toolspace list view.

4. To view observations for a setup, right-click the setup and click Edit Observations.
   The Observations Editor vista is displayed with all the observations for the selected setup.

   **NOTE** The observations for the setup are highlighted in the drawing.

5. Click ✅ to close the Observations Editor.

6. To view the figures, click the Figures collection and expand it. The figures are also displayed in the Toolspace list view.
NOTE If a 🔄 is displayed beside the Figures collection, click the collection to refresh it and then click ➕ to view all the figures.

Notice that there is a duplicate BLDG2 figure preceded by a 🔄. You will resolve this issue in a subsequent exercise.

7 In Toolspace, click the Prospector tab and expand the Survey collection to display the collections of survey networks and figures. These collections are for the survey network and figure drawing objects as opposed to the survey database data that is displayed on the Survey tab.

8 To view a figure in the drawing, expand the Figures collection, right-click the figure name, for example BLDG1, and click Zoom To. The drawing zooms to the selected figure.

9 In the drawing, select the figure that you zoomed to and right-click. Click Browse To Survey Data. The Toolspace switches to the Survey tab with the figure selected. The survey data for the figure is displayed in the list view.

10 In the drawing window, hover your cursor over one of the survey network components extending from BLDG1. Notice that the properties for the network object are displayed in the tooltip.
11 Right-click the network object and select Browse To Survey Network. In Toolspace, on the Survey tab, the survey network is selected. The survey data for the survey network is displayed in the list view.

12 Ctrl+click one of the survey network components shown in the previous image. Right-click. Click Browse To Survey Data.
   The related setup is highlighted in Toolspace on the Survey tab.

13 In Toolspace on the Survey tab, right-click the selected station. Click Edit Observations.
   The Observations Editor vista is displayed in the Panorama window. You can use this vista to view and edit the survey observations for the selected setup.

14 Click ✅ to dismiss the Observations Editor vista.

To continue this tutorial, go to Exercise 3: Editing a Figure (page 119).

### Exercise 3: Editing a Figure

In this exercise, you will edit a figure to change its display in the drawing.

For more information, see the AutoCAD Civil 3D Help topic *Editing Figures*.

This exercise continues from Exercise 2: Viewing Survey Data (page 117).

#### To edit a figure

**NOTE** This exercise uses *Survey-2.dwg* with the modifications you made in the previous exercise.

1 In Toolspace, on the Survey tab, expand the database Survey 1 to display the Figures collection.

   **NOTE** If a ❌ is displayed beside the Figures collection, click the collection to refresh it and then click ✱ to view all the figures.

2 Right-click the figure BLDG1 and click Edit.

3 In the Figures Editor vista, click the field for the Style and select Building.
The entire row is displayed as bold. The bold row indicates that a change has been made to the figure data but it has not been saved to the survey database.

4  Click to save the change to the survey database.

5  Click to close the Figures Editor vista.

6  On the Toolspace Survey tab, right-click the BLDG1 figure and click Remove From Drawing.
    The figure is deleted from the drawing.

7  Right-click BLDG1 again and click Insert Into Drawing.
    The BLDG1 figure is displayed with the new style.

To continue this tutorial, go to Exercise 4: Removing an Erroneous Figure (page 120).

**Exercise 4: Removing an Erroneous Figure**

In this exercise, you will remove an erroneous figure, which may be partial or incomplete.

For more information, see the AutoCAD Civil 3D Help topic *Deleting Figures*. This exercise continues from Exercise 3: Editing a Figure (page 119).

**To view and remove an erroneous figure**

NOTE  This exercise uses Survey-2.dwg with the modifications you made in the previous exercise.

1  In Toolspace, on the Survey tab, expand the Survey 1 database and then expand the Figures collection.

2  Click the first figure named BLDG2 (it is preceded by a ).
   You can see that the figure is incomplete or erroneous from the following:
   ■  The name is a duplicate.
   ■  The figure name is preceded by a .

120 | Chapter 5  Survey Tutorials
The length of the figure is 0.

3 To delete the figure, on the Toolspace Survey tab, right-click the figure and click Delete.

4 In the confirmation dialog box, click Yes.
   The figure is removed from both the Figures collection and the active drawing.

To continue to the next tutorial, go to Analyzing and Reducing Survey Data (page 121).

**Tutorial: Analyzing and Reducing Survey Data**

This tutorial demonstrates how to analyze and reduce survey data.

In the following exercises, you will use the Survey Command Window to query survey data. Then, you will look at two ways to reduce the survey data.

You can reduce survey data by:

- Adjusting a traverse loop using the standard compass rule method or other adjustment methods.
- Using the network least squares adjustment method.

Each method produces slightly different results. The standard compass rule adjustment method adjusts the traverse loop and sideshots. The least squares method adjusts each of the observations so that the sum of the residuals is at a minimum.

**NOTE** Before performing the steps in this tutorial, you must have already created the survey database Survey 1 and imported the field book file Survey-1.fbk. For more information, see the Survey Setup (page 109) and Importing and Viewing Survey Data (page 114) tutorials.

For more information, see the AutoCAD Civil 3D Help topic Survey Analysis and Output.
Exercise 1: Querying Survey Data

In this exercise, you will use the Survey Command Window to perform a query on the survey data.

You will use the Inverse Points command to determine the direction and distance between two points.

For more information, see the AutoCAD Civil 3D Help topic Survey Command Window.

This exercise continues from the Importing and Viewing Survey Data (page 114) tutorial.

To use the Survey Command Window to query survey data

NOTE This exercise uses Survey-2.dwg with the modifications you made in the previous tutorial, or you can open Survey-2a.dwg from the tutorial drawings folder (page 615).

1 In Toolspace, on the Survey tab, expand the Survey Databases collection.
2 If the database Survey 1 is not open (that is, it is not displayed with a next to it), right-click and click Open Survey Database.

NOTE By default, to save on resource usage, when you start AutoCAD Civil 3D, all survey databases are displayed in a closed state.

3 Right-click Survey 1 and click Edit Survey Database Settings.
4 In the Survey Database Settings dialog box, expand the Survey Command Window property group and ensure that the following are set:
   ■ Point Course Echo: Yes
   ■ Figure Course Echo: Yes
   ■ Point Coordinate Echo: Yes
   ■ Figure Coordinate Echo: Yes
   ■ Command Echo: Yes

   These settings determine what information will be displayed in the Survey Command Window.

5 Click OK to close the Survey Database Settings dialog box.
6 On the Survey tab, expand the Networks collection, right-click Survey Network 1, and click Survey Command Window.

7 In the Survey Command Window, click View menu ➤ Zoom To Point.

8 In the Enter Point dialog box, enter 1. Click OK.
   The drawing zooms to point 1.

9 Click Point Information menu ➤ Inverse Points.

10 In the Point Information - Inverse Points dialog box, enter:
   ■ Start Point: 1
   ■ Ahead Point: 2

11 Click OK.
   The following information, which describes the location of each point and the direction and distance between the points, is displayed in the command output area:

   !
   ! POINT 1 NORTH: 5000.0000 EAST: 5000.0000 EL: 263.6500
   !
   ! Distance: 300.000 Course: N 72-56-33 E
   !
   ! POINT 2 NORTH: 5087.9995 EAST: 5286.8036 EL: 259.9600

12 Close the Survey Command Window.

To continue this tutorial, go to Exercise 2: Performing Traverse Analysis (page 123).

**Exercise 2: Performing Traverse Analysis**

In this exercise, you will reduce some of the survey data using the traverse analysis Compass Rule adjustment method.

The Compass Rule is a method of corrections. It assumes that the closing errors are as much due to errors in observed angles as by the errors in measured distances. The closing errors in latitude and departure are distributed according to the ratio of the length of the line to the total length of the traverse.
This exercise continues from Exercise 1: Querying Survey Data (page 122).

To perform traverse analysis using the Compass Rule method

NOTE This exercise uses Survey-2a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Survey tab, click the database Survey 1. Expand the Networks collection, and then the network Survey Network 1. Right-click the Traverses collection. Click New.

2 In the New Traverse dialog box, enter Traverse 1 in the Name field. Click OK.

3 On the Survey tab, right-click Traverse 1, and click Properties.

4 In the Traverse Properties dialog box, enter the following values:
   ■ Initial Station: 1
   ■ Initial Backsight: 1000
   ■ Stations: 2,3,4,5,6
   ■ Final Foresight: 6000

5 Click OK.

6 On the Survey tab, right-click Traverse 1, and click Traverse Analysis.

7 In the Traverse Analysis dialog box, ensure that the following values are set:
   ■ Horizontal Adjustment Method: Compass Rule
   ■ Vertical Adjustment Method: Length Weighted Distribution
     Use the default values for the other properties.

8 Click OK.

The analysis runs, the network adjusts, and the following files are displayed in the ASCII text editor:

■ Traverse 1 Raw Closure.trv: Displays the horizontal closure and angular error.

■ Traverse 1 Vertical Adjustment.trv: Displays a report of raw and adjusted elevations from the vertical adjustment methods.
■ Traverse 1 Balanced Angles.trv: Displays the adjusted station coordinates derived from balancing the angular error and horizontal closure with no angular error.

■ Traverse 1.lso: Displays the adjusted station coordinates based on the Horizontal Adjustment Type setting (Compass Rule).

9 Close all the text files.

After a traverse analysis is done, and the survey database updates, the following adjustments to the data that references the traverse take place:

■ Observed station points are updated and added to the Control Points collection.

■ All sides shots from adjusted setups within the traverse are updated.

■ All figures that reference points within the traverse are updated.

■ Any of the above data that is displayed in the current drawing is also updated.

10 You will perform a network analysis in the next exercise, so you must undo the adjustments to the survey data that resulted from the traverse analysis. Right-click the Control Points collection and click Reset Adjusted Coordinates.

The control points created from the adjustments are deleted from the survey database.

To continue this tutorial, go to Exercise 3: Performing Least Squares Analysis (page 125).

**Exercise 3: Performing Least Squares Analysis**

In this exercise, you will reduce the survey information using the least squares adjustment method.

The least squares method calculates the most probable value for each observation. The values are calculated by adjusting each of the observations simultaneously so that the sum of the squares of the residuals (the difference between measured and adjusted observations) is at a minimum.

For more information, see the AutoCAD Civil 3D Help topic *Least Squares Analysis*. 

This exercise continues from Exercise 2: Performing Traverse Analysis (page 123).

To reduce survey data using least squares

NOTE This exercise uses Survey-2a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Settings tab, expand the Survey collection under the drawing.

2 Expand the Network Styles collection to display the list of existing network styles in the drawing.

3 Right-click the Standard network style. Click Edit.

4 In the Network Style dialog box, click the Components tab.

5 In the Error Ellipse group, set the Error Ellipse Scale Factor to 10000.

6 Click OK to close the Network Style dialog box.

7 In Toolspace, on the Survey tab, expand the database Survey 1. Expand the Networks collection, and right-click the network Survey Network 1. Click Least Squares Analysis ➤ Perform Analysis.

8 In the Least Squares Analysis dialog box, verify that the following values are set for the Input properties:
   ■ Create Input File: Selected
   ■ Input File Name: Survey Network 1
   ■ Network Adjustment Type: 3-Dimensional

9 Use the default values for the other settings. Click OK. If prompted, click Yes to overwrite the existing Network File.

The analysis runs, the network and drawing updates, and the following files are displayed in the ASCII text editor:
   ■ <survey network>.lsi: Displays the initial station coordinates and elevations. The angle and distance information for each station, as well as the standard errors for angles and distances are also displayed.
   ■ <survey network>.lso: Displays the results of the calculations as well as the adjusted coordinate information.
10 When you have finished reviewing the least squares calculation data, close the text files.

11 To view an error ellipse, on the Survey tab, expand Survey Network 1, then expand its Control Points collection. Right-click 2, and click Zoom To.
   The drawing zooms to the point and ellipse.

To continue this tutorial, go to Exercise 4: Translating a Survey Database (page 127).

Exercise 4: Translating a Survey Database

In this exercise, you will translate the contents of a survey database from assumed coordinates to that of known coordinates.

This command is useful when you must move all the data in the survey database from an assumed location to a known location.

For more information, see the AutoCAD Civil 3D Help topic Translating a Survey Database.

This exercise continues from Exercise 3: Performing Least Squares Analysis (page 125).

To translate the contents of a survey database

NOTE This exercise uses Survey-2a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Survey tab, expand the Survey Databases ➤ Survey 1 ➤ Networks ➤ Survey Network 1 collections.

2 Click the Setups collection.
   In the list view, examine the elevation values of the following setups:
   ■ Station Point 1, Backsight Point 1000: Elevation = 263.650
   ■ Station Point 2, Backsight Point 1: Elevation = 259.960
   ■ Station Point 3, Backsight Point 2: Elevation = 257.438

   For this exercise, you will assume that the elevation value for Station Point 1, Backsight Point 1000, which is at Easting 5000 and Northing 5000, is 2.25 greater than the actual elevation.
3 In Toolspace, on the Survey tab, expand the Survey Databases collection. Select the Survey 1 database. Right-click. Click Translate Survey Database.

4 In the Translate Survey Database wizard, on the Base Point page, for Easting, enter 5000. For Northing, enter 5000. On this page, you specify the base point from which the survey network will be moved.

5 Click Next. On the Rotation Angle page, you specify the base point from which the survey network will be moved. For this exercise, you will not change the rotation of the survey network.

6 On the Rotation Angle page, for Rotation Angle, enter 0.

7 Click Next. On the Destination Point page, you specify the point to which the survey network will be moved. Notice that you can specify a new Easting, Northing, or Elevation Change value. In this exercise, you will change only the elevation.

8 On the Destination Point page, for Elevation Change, enter -2.25.

9 Click Next. On the Summary page, you can examine the results of the translation before it is applied to the survey network. If you want to modify the translation, you can use the Back button to return to previous pages on the wizard.

10 Click Finish.

11 In Toolspace, on the Survey tab, click the Setups collection. In the list view, examine the elevation values of the setups that you examined in Step 2. Notice that the values have been decreased by 2.25.

- Station Point 1, Backsight Point 1000: Elevation = 261.400
- Station Point 2, Backsight Point 1: Elevation = 257.710
- Station Point 3, Backsight Point 2: Elevation = 255.188

To continue to the next tutorial, go to Manually Creating Survey Data (page 129).
Tutorial: Manually Creating Survey Data

This tutorial demonstrates how to manually create and add survey data.

In the following exercises, you will use three different methods to create survey data:

- The Toolspace Survey tab collections and commands
- The Traverse Editor
- The Survey Command Window commands

For more information, see the AutoCAD Civil 3D Help topic Survey Data Input and Editing.

Exercise 1: Creating Survey Data Using the Toolspace Survey Tab

In this exercise, you will use the Toolspace Survey tab to create survey data. The Survey tab provides centralized access to survey data, settings, and various panorama vista editors, which can be used to create, edit, and manage survey data.

For more information, see the AutoCAD Civil 3D Help topic The Toolspace Survey Tab.

To create survey data using the Toolspace Survey tab

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-3.dwg.
2. In Toolspace, on the Survey tab, right-click Survey Databases and click New Local Survey Database.
3. In the New Local Survey Database dialog box, for the name, enter Survey 2.
4. In Toolspace, on the Survey tab, right-click the database Survey 2 and click Edit Survey Database Settings.
5 Expand the Measurement Type Defaults property group and ensure that the following are set:
   ■ Angle Type: Angle
   ■ Distance Type: Horizontal
   ■ Vertical Type: None
   ■ Target Type: None

6 Click OK to close the Survey Database Settings dialog box.

7 In Toolspace, on the Survey tab, under Survey 2 database, right-click the Networks collection and click New.

8 In the Network dialog box, for the name, enter Survey Network 2 and click OK.

9 On the Survey tab, expand Survey Network 2, right-click the Control Points collection and click New.

10 In the New Control Point dialog box, enter the following:
    ■ Point Number: 1
    ■ Easting: 1000.0000
    ■ Northing: 1000.0000
    ■ Description: STA 1

11 Click OK to create the control point.

12 On the Survey tab, under Survey Network 2, right-click the Directions collection and click New.

13 In the New Direction dialog box, enter the following:
    ■ From Point: 1
    ■ To Point: 4
    ■ Direction: 45.0000
    ■ Direction Type: Azimuth

14 Click OK to create the direction.

15 On the Survey tab, under Survey Network 2, right-click the Setups collection and click New.
In the New Setup dialog box, enter the following:

- Station Point: 1
- Backsight Point: 4

Press Tab to move to the next field. A dialog box is displayed indicating that point 4 is not defined. Click No and then click OK to create the setup.

On the Survey tab, under Survey Network 2, expand the Setups collection, right-click the setup Station: 1, Backsight: 4, and click Edit Observations.

In the Observations Editor, right-click in the grid and click New.

For the new observation, enter the following:

- Point Number: 2
- Angle: 90.0000
- Distance: 100.00
- Description: STA 2

Click to save the new observation.

On the Survey tab, under Survey Network 2, right-click the Setups collection and click New.

In the New Setup dialog box, enter the following:

- Station Point: 2
- Backsight Point: 1

Click OK to create the setup.

On the Survey tab, under Survey Network 2, expand the Setups collection, right-click the setup Station: 2, Backsight: 1, and click Edit Observations.

In the Observations Editor, right click in the grid and click New.

For the new observation, enter the following:

- Point Number: 3
- Angle: 90.0000
- Distance: 100.00
28  Click to save the new observation.

29  Follow steps 22 through 28 to create another setup with an observation.
    Information for the new setup:
    ■ Station Point: 3
    ■ Backsight Point: 2

    Information for the new observation:
    ■ Point Number: 4
    ■ Angle: 90.0000
    ■ Distance: 100.00
    ■ Description: STA 4

30  Follow steps 22 through 28 to create another setup with an observation.
    Information for the new setup:
    ■ Station Point: 4
    ■ Backsight Point: 3

    Information for the new observation:
    ■ Point Number: 1
    ■ Angle: 90.0000
    ■ Distance: 100.00

31  On the Survey tab, right-click Survey Network 2 and click Insert Into Drawing.
    The new survey data is displayed in the drawing.
To continue this tutorial, go to Exercise 2: Creating Survey Data Using the Traverse Editor (page 133).

**Exercise 2: Creating Survey Data Using the Traverse Editor**

In this exercise, you will use the Traverse Editor to create survey data.

The Traverse Editor is used to edit the observations of an existing named traverse or to enter traverse observations for a new traverse.

For more information, see the AutoCAD Civil 3D Help topic *Traverses*.

This exercise continues from Exercise 1: Creating Survey Data Using the Toolspace Survey Tab (page 129).

**To create survey data using the Traverse Editor**

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing *Survey-4.dwg*.

2. In Toolspace, on the Survey tab, right-click Survey Databases and click New Local Survey Database.
3 In the New Local Survey Database dialog box, for the name, enter Survey 3 and click OK.

4 In Toolspace, on the Survey tab, right-click the database Survey 3 and click Edit Survey Database Settings.

5 Expand the Measurement Type Defaults property group and ensure that the following are set:
   - Angle Type: Angle
   - Distance Type: Horizontal
   - Vertical Type: None
   - Target Type: None

6 Click OK to close the Survey Database Settings dialog box.

7 In Toolspace, under Survey 3 database, right click the Networks collection and click New.

8 In the Network dialog box, for the name, enter Survey Network 3.

9 On the Survey tab, expand Survey Network 3, right-click the Traverses collection and click New.

10 In the New Traverse dialog box, for the name, enter Traverse 3. Click OK.

11 On the Survey tab, expand the Traverses collection. Right-click Traverse 3 and click Edit.

12 In the Specify Initial Setup dialog box, enter the following values:
   - Initial Station: 1
   - Initial Backsight: 4

13 Click OK.

14 A message is displayed indicating that initial station point 1 is not defined. Click Yes to define it.

15 In the New Control Point dialog box, enter the following values:
   - Point Number: 1
   - Easting: 1000
   - Northing: 1000
   - Description: STA 1
16 Click OK.

17 A message is displayed indicating that backsight point 4 is not defined. Click Yes to define it.

18 A message is displayed indicating that a backsight direction must be created. Click Yes to create it.

19 In the New Direction dialog box, enter the following values:
   ■ Direction: 45
   ■ Direction Type: Azimuth

20 Click OK.
   The Traverse Editor is displayed.

21 In the right side of the editor, for Station 1, Backsight 4, enter the following information:
   ■ (point number): 2
   ■ Angle: 90
   ■ Distance: 100
   ■ Description: STA 2

22 For Station 2, Backsight 1, enter the following information:
   ■ (point number): 3
   ■ Angle: 90
   ■ Distance: 100
   ■ Description: STA 3

23 For Station 3, Backsight 2, enter the following information:
   ■ (point number): 4
   ■ Angle: 90
   ■ Distance: 100
   ■ Description: STA 4
24 For Station 4, Backsight 3, enter the following information:

- (point number): 1
- Angle: 90
- Distance: 100

25 Click to save the traverse information.

26 On the Survey tab, right-click Survey Network 3 and click Insert Into Drawing.
   The new survey data is displayed in the drawing.

To continue this tutorial, go to Exercise 3: Creating Survey Data Using the Survey Command Window (page 137).
Exercise 3: Creating Survey Data Using the Survey Command Window

In this exercise, you will create survey data using the Survey Command Window.

The Survey Command Window is used to enter survey commands directly using Command line input or interactively using the menus.

For more information, see the AutoCAD Civil 3D Help topic Survey Command Window.

This exercise continues from Exercise 2: Creating Survey Data Using the Traverse Editor (page 133).

To create survey data using the survey command window

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-5.dwg.

2. In Toolspace, on the Survey tab, right-click Survey Databases and click New Local Survey Database.

3. In the New Local Survey Database dialog box, for the name, enter Survey 4 and click OK.

4. In Toolspace, on the Survey tab, right-click the database Survey 4 and click Edit Survey Database Settings.

5. Expand the Survey Command Window property group and ensure that the following are set:

   - Ditto Feature: Yes
   - Auto Point Numbering: No
   - Start Point Numbering From: 1
   - Point Course Echo: Yes
   - Figure Course Echo: Yes
   - Point Coordinate Echo: Yes
   - Figure Coordinate Echo: Yes
   - Command Echo: Yes
   - Use Batch File: Yes
Use Output File: Yes

6 Click OK to close the Survey Database Settings dialog box.

7 In Toolspace, under Survey 4 database, right-click the Networks collection and click New.

8 In the Network dialog box, for the name, enter Survey Network 4.

9 In Toolspace, on the Survey tab, right-click Survey Network 4 and click Survey Command Window.

10 In the Survey Command Window, enter the following commands into the Command line. These are the survey language commands that will create four setups.

```
NE 1 1000.00 1000.00 "STA 1"
AZ 1 4 45.0000
STN 1
BS 4
AD 2 90.0000 100.00 "STA 2"
STN 2
BS 1
AD 3 90.0000 100.00 "STA 3"
STN 3
BS 2
AD 4 90.0000 100.00 "STA 4"
STN 4
BS 3
AD 1 90.0000 100.00
```

For more information about survey commands, see the AutoCAD Civil 3D Help topic Survey Command Language Commands.

11 As you enter the commands, the top section of the Survey Command Window displays the resulting output and the bottom section echoes the input.

12 Close the Survey Command Window.

13 On the Survey tab, right-click Survey Network 4 and click Insert Into Drawing.

The new survey data is displayed in the drawing.
To continue this tutorial, go to Exercise 4: Calculating an Azimuth in The Astronomic Direction Calculator (page 139).

**Exercise 4: Calculating an Azimuth in The Astronomic Direction Calculator**

In this exercise, you will use the Astronomic Direction Calculator to calculate an azimuth from solar observations by the hour angle method.

To calculate the azimuth, you can use either a single foresight or a multiple foresight. For this exercise, you will use a multiple foresight because it is the more commonly used solar observation method.

For more information, see the AutoCAD Civil 3D Help topic *Astronomic Direction Calculations*.

This exercise continues from Exercise 3: Creating Survey Data Using the Survey Command Window (page 137).
To calculate an azimuth using the Astronomic Direction Calculator

NOTE This exercise uses Survey-5.dwg with the modifications you made in the previous exercise.

1. Click Survey menu ➤ Astronomic Direction Calculator to open the Astronomic Direction Calculator dialog box.

2. For Calculation Type, click Sun Shot Calculation.

3. In the Observation Station Data fields, enter the following:
   - Station Point: 2
   - Backsight Point: 1
   - Station Latitude: 36.04
   - Station Longitude: -94.1008
   - UT1 Time: 13.34024

4. In the Ephemeris Data fields, enter the following:
   - GHA 00 Hours: 180.13402
   - GHA 24 Hours: 180.10431
   - Declination 00 Hours: 22.54505
   - Declination 24 Hours: 22.59437
   - Sun Semi-diameter: 0.15468

5. Click to create an observation set.

6. Specify the following values for Set 1 Direct:
   - Backsight Observation: 0.00
   - Sun Observation: 351.0835
   - Stop Time: 0.121590

7. Specify the following values for Set 1 Reverse:
   - Backsight Observation: 180.0005
   - Sun Observation: 171.3520
   - Stop Time: 0.154210
NOTE The observations will determine the true astronomic direction from the station point to the backsight point. Notice that after you enter the stop time for an observation, the observed and average direction are calculated automatically.

8 Click ![Icon](image) to create an observation set.

9 Specify the following values for Set 2 Direct:
   - Backsight Observation: 0.00
   - Sun Observation: 351.1300
   - Stop Time: 0.12491

10 Specify the following values for Set 2 Reverse:
   - Backsight Observation: 180.0005
   - Sun Observation: 171.3800
   - Stop Time: 0.16030

11 Click ![Icon](image) to create an observation set.

12 Specify the following values for Set 3 Direct:
   - Backsight Observation: 0.00
   - Sun Observation: 351.1450
   - Stop Time: 0.13112

13 Specify the following values for Set 3 Reverse:
   - Backsight Observation: 180.0005
   - Sun Observation: 171.4145
   - Stop Time: 0.16313

After you have entered the above data, notice that the Mean Direction value calculated by the Astronomic Direction Calculator is SOUTH87.96708EAST (if the drawing settings Direction Measurement Type is set to Bearings).

14 Close the Astronomic Direction Calculator.
Exercise 5: Creating Figures from Parcels

In this exercise, you will use AutoCAD Civil 3D parcel objects to add figures to a survey database.

In addition to parcel objects, you can also use feature lines, lot lines, and AutoCAD lines and polylines as a source to create figures.

For more information, see the AutoCAD Civil 3D Help topic Creating Figures.

This exercise continues from Exercise 4: Calculating an Azimuth in The Astronomic Direction Calculator (page 139).

To create survey figures from existing parcels

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-6.dwg. This drawing contains a small subdivision with several parcels.

2. In Toolspace, on the Survey tab, right-click Survey Databases and click New Local Survey Database.

3. In the New Local Survey Database dialog box, for the name, enter Survey 5.

4. In Toolspace, on the Survey tab, expand the database Survey 5, right-click the Figures collection, and click Create Figure From Object.

5. In the drawing, click the label for the parcel SINGLE-FAMILY: 101.

6. In the Create Figure From Objects dialog box, enter the following:
   - Name: LOT CORNER
   - Current Figure Prefix Database: Sample
   - Associate Survey Points To Vertices: Yes

7. Click OK. Press Esc to end the command. The figure is created and added to the Figures collection under the Survey 5 database.
To continue to the next tutorial, go to Outputting Survey Information (page 143).

**Tutorial: Outputting Survey Information**

This tutorial demonstrates how to view information reports for figures and how to use the figures as a source for surface data.

For more information, see the AutoCAD Civil 3D Help topics *Figure Inquiry Commands* and *Creating Breaklines from Figures*.

**Exercise 1: Viewing Inverse and Mapcheck Information on a Survey Figure**

In this exercise, you will display the figure mapcheck and inverse information.

The Mapcheck command checks the figure for length, course, perimeter, area, error of closure, and precision. It starts at the beginning of the figure and computes the figure vertex XY coordinates for each segment. These computations are based on the inverse direction and distance/curve data and the Linear and Angle precision (set in the Survey Database Settings).

For closed figures, error is introduced into the sequential computation of vertices of the mapcheck report, so a closure error, closure direction, and precision can be calculated. The area is also based on the computed vertex XY coordinates.

The Inverse command starts at the beginning of the figure and lists the direction and distance, or curve data computed from the XY coordinates of the endpoints of the figure segments. The area is calculated from the XY coordinates of each segment.

For more information, see the AutoCAD Civil 3D Help topic *Figure Inquiry Commands*.

This exercise continues from the Manually Creating Survey Data (page 129) tutorial.
To view inverse and mapcheck information for a figure

**NOTE** This exercise uses *Survey-6.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Survey tab, right-click the database Survey 1 and click Open Survey Database.
2. Under Survey 1, expand the Figures collections.
   **NOTE** If a """" symbol is displayed beside the Figures collection, click the collection to refresh it and then click """" to view all the figures.
3. Right-click the figure BLDG2 and click Display Inverse.
   The figure inverse information is displayed in the Figure Display vista.
   The """" icon indicates that a vertex is associated with a survey point.
4. When you have finished reviewing the inverse data, click """" to close the vista.
5. To display the mapcheck information for a property line, right-click the figure LOT1 and click Display Mapcheck.
   The figure mapcheck information is displayed in the Figure Display vista.
6. When you have finished reviewing the mapcheck data, click """" to close the vista.

To continue this tutorial, go to Exercise 2: Performing a Mapcheck Analysis with Parcel Labels (page 144).

**Exercise 2: Performing a Mapcheck Analysis with Parcel Labels**

In this exercise, you will use the data in parcel segment labels to perform a mapcheck analysis.
The Mapcheck command checks the figure for length, course, perimeter, area, error of closure, and precision. It starts at the beginning of the figure and computes the figure vertex XY coordinates for each segment. These computations are based on the actual labeled values, and not the inverse direction and distance/curve data and the Linear and Angle precision (set in the Survey Database Settings).

This method of performing a mapcheck analysis is useful as a final check of closure. The data for the mapcheck analysis is taken from parcel segment labels. The precision of the mapcheck analysis is based on the precision of the labels.

For more information, see the AutoCAD Civil 3D Help topic Performing a Mapcheck Analysis.

This exercise continues from Exercise 1: Viewing Inverse and Mapcheck Information on a Survey Figure (page 143).

To perform a mapcheck on parcel labels

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-7.dwg.
   This drawing contains a small subdivision with several parcels. All the parcel segments on the left side of the site are labeled. Notice that along the cul-de-sac, the line and curve labels have been converted to tags, and their data is displayed in a table on the left side of the site. You will perform a mapcheck analysis on parcel LOT 5.

2. Click General menu ➤ Mapcheck Analysis.

3. If a message is displayed, stating that the command line mode cannot be used while a command is active, click OK.

4. In the Mapcheck Analysis dialog box, make sure that the Use Command Line Interface option is toggled on.

5. Click Input View.
   The input view provides an interface in which you can add data to the mapcheck analysis.

6. Click New Mapcheck.

7. On the command line, for the name of the mapcheck, enter Parcel Labels.
8 When prompted to specify a point of beginning, click the intersection of the lot lines under label tag L1.

The icon indicates the point of beginning.

9 Select the L1 label tag above the point of beginning.
   A temporary arrow graphic is displayed at the point of beginning. Notice that the arrow is pointing away from LOT 5.

10 On the command line, enter R to reverse the direction of the arrow.

11 Select the C1 label tag. Notice that the temporary line and arrow are pointing in the wrong direction. Enter F to flip the arrow.

12 Select the C2 label tag.

13 Select the bearing over distance label to the left of the arrow. Enter R to reverse the direction.

14 Select the 100.00’ portion of the bearing over distance label below the arrow.
   A icon appears at the end of the current line, and the command line states that there is not enough data to define the segment. This happened because the current segment is a lot line that is shared by all the parcels on the left side of the site.

15 Select the bearing portion of the label. Enter R to reverse the direction.

16 Select the bearing over distance label to the right of the arrow.
   The arrow returns to the point of beginning.
17 Press Enter to end the command.

In the Mapcheck Analysis dialog box, notice that you can edit any of the sides you created during the mapcheck analysis.

18 Click Output View.

The Output View displays the results of the mapcheck analysis. You will learn how to work with the output data in Exercise 4: Working with Mapcheck Data (page 151).

To continue this tutorial, go to Exercise 3: Performing a Mapcheck Analysis by Manually Entering Data (page 147).

**Exercise 3: Performing a Mapcheck Analysis by Manually Entering Data**

In this exercise, you will manually enter survey data to perform a mapcheck analysis.

This method of performing a mapcheck analysis is useful when you must check survey data that does not exist as labels in the drawing. For example, you can use this method to enter survey data from a paper drawing.
For more information, see the AutoCAD Civil 3D Help topic *Manually Entering Mapcheck Data*.

This exercise continues from Exercise 2: Performing a Mapcheck Analysis with Parcel Labels (page 144).

**To perform a mapcheck by manually entering data**

**NOTE** This exercise uses *Survey-7.dwg* with the modifications you made in the previous exercise.

The parcel segments on the right side of the site are not labeled. Because the data is not available in parcel labels, you must enter the mapcheck information manually.

1. Click General menu ➤ Mapcheck Analysis.
2. If a message is displayed, stating that the command line mode cannot be used while a command is active, click OK.
3. In the Mapcheck Analysis dialog box, make sure that the *Use Command Line Interface* option is toggled off.
4. Click **Input View**. The input view provides an interface in which you can add data to the mapcheck analysis.
5. Click **New Mapcheck**.
6. In the Mapcheck Analysis dialog box, for the name of the mapcheck, enter Parcel Manual Input.
7. To specify the point of beginning, enter the following values:
   - Easting: 5576.199
   - Northing: 5291.0640
   
   The icon indicates the point of beginning.
8. Click **New Side**. Expand the Side 1 collection. Enter the following values:
NOTE Notice that the icon is displayed next to the side collection, and also next to the top-level mapcheck collection. This indicates that the mapcheck is incomplete, because it requires more data about the side.

- Side Type: Line
- Angle Type: Direction
- Angle: N00 00 10E
- Distance: 16.330

9 Click New Side. Expand the Side 2 collection. Enter the following values:
- Side Type: Curve
- Curve Direction: Clockwise
- Radius: 20.00
- Arc Length: 21.550

10 Click New Side. Expand the Side 3 collection. Enter the following values:
- Side Type: Curve
- Curve Direction: Counter-clockwise
- Radius: 75.00
- Arc Length: 80.800

11 Click New Side. Expand the Side 4 collection. Enter the following values:
- Side Type: Line
- Angle: N90 00 00E
- Distance: 99.990
12 Click New Side. Expand the Side 5 collection. Enter the following values:
■ Side Type: Line
■ Angle: S0 00 00E
■ Distance: 100

13 Click New Side. Expand the Side 6 collection. Enter the following values:
■ Side Type: Line
■ Angle: N89 59 54W
■ Distance: 149.990

The direction arrow meets the point of beginning.

14 Click Output View.

The Output View displays the results of the mapcheck analysis. You will learn how to work with the output data in Exercise 4: Working with Mapcheck Data (page 151).
To continue this tutorial, go to Exercise 4: Working with Mapcheck Data (page 151).

**Exercise 4: Working with Mapcheck Data**

In this exercise, you will learn about the tools that can leverage the data obtained from a mapcheck analysis.

For more information, see the AutoCAD Civil 3D Help topic *Mapcheck Analysis*.

This tutorial continues from Exercise 3: Performing a Mapcheck Analysis by Manually Entering Data (page 147).

**To change the default appearance of the mapcheck objects**

**NOTE** This exercise uses *Survey-7.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, expand the General ➤ Commands collection. Right-click MapCheck. Click Edit Command Settings.
2. On the Edit Command Settings dialog box, expand the Mapcheck collection. Examine the default settings that are available.
   The colors in this collection specify the appearance of the mapcheck objects. Notice that Mapcheck Color currently is set to green.
3. Click in the Mapcheck Color Value cell. Click ![Color Selector](icon)
4. In the Select Color dialog box, in the Color field, enter 10. Click OK.
5. In the Edit Command Settings dialog box, click OK.
   In the drawing window, notice that the mapcheck object around LOT 5 is red.

**To reuse the mapcheck data**

1. In the Mapcheck Analysis dialog box, click ![Output View](icon) Output View.
2. Select the Parcel Labels mapcheck.
3. Click ![Insert Mtext](icon) Insert Mtext.
4 Pan to a clear area of the drawing. Click to place the Mtext.

5 Click Copy To Clipboard.

6 On the command line, enter NOTEPAD. When you are prompted for a file to edit, press Enter.

7 In the Microsoft Notepad window, press Ctrl+V.
   The mapcheck data is displayed in Microsoft Notepad. You can save this file for later analysis in another application.

To create a polyline from the mapcheck data

1 Select the Parcel Manual Input mapcheck.

2 Click Create Polyline.
   A polyline is created on the perimeter of LOT 5. You can perform any standard AutoCAD functions on the polyline.

To continue this tutorial, go to Exercise 5: Creating Surface Breaklines from Figures (page 152).

Exercise 5: Creating Surface Breaklines from Figures

In this exercise, you will use figures to add breaklines to a surface.

The breaklines will define the edge of pavement (EP) features, such as retaining walls, curbs, tops of ridges, and streams. Breaklines force surface triangulation along the breakline and prevent triangulation across the breakline.

For more information, see the AutoCAD Civil 3D Help topic Creating Breaklines from Figures.

This exercise continues from Exercise 4: Working with Mapcheck Data (page 151).

To create surface breaklines from figures

1 Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Survey-8.dwg.
   This drawing contains the empty surface Figure Surface 1, to which you will add the figure data.
Exercise 5: Creating Surface Breaklines from Figures | 153
NOTE For more information about breaklines, see Exercise 3: Adding Breaklines to a Surface (page 51)

14 Click OK.

The surface boundaries and contours are displayed in the drawing.
These tutorials will get you started working with the AutoCAD Civil 3D project management tools. You can use the project management functionality to provide shared access to engineering data while preserving data integrity.

Two methods of project management are explained in these tutorials: data shortcuts and Vault.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Project Management*.

**Tutorial: Using Data Shortcuts**

This tutorial demonstrates how to create data shortcuts from objects in one drawing, and then import the data shortcuts into another drawing.

A data shortcut provides a complete reference copy of an object that you can import from one drawing into one or more other drawings. Data shortcuts provide a flexible, object-level project management tool for use outside of Autodesk Vault. Data shortcuts are managed in Toolspace on the Prospector tab, in a structure that is similar to Autodesk Vault. However, data shortcuts do not provide the controls, protection, and management that Autodesk Vault does.

In order for multiple users to use a data shortcut, it must be stored in a network location that is accessible to all users. You can use data shortcuts to reference surface, alignment, profile, pipe network, and view frame group objects. If a
referenced object is changed in the source drawing, changes are updated in any drawings that reference the object.

In this tutorial, you will set up a data shortcuts project, create data shortcuts in a source drawing, and then reference the data shortcuts in another drawing.

For more information, see the AutoCAD Civil 3D Help topic Using Data Shortcuts.

**Exercise 1: Setting Up a Data Shortcut Folder**

In this exercise, you will set up a folder in which to store objects that are referenced through data shortcuts.

The data shortcut folder contains all the source drawings and data shortcut objects in a project. In order for multiple users to use a data shortcut, it must be stored in a network location that is accessible to all users.

For more information, see the AutoCAD Civil 3D Help topic Using Data Shortcuts.

**To set up a data shortcut folder**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Project Management-1.dwg.

2. In Toolspace, on the Prospector tab, select the Master View.

3. In Toolspace, on the Prospector tab, right-click the Data Shortcuts collection. Click Set Working Folder.

   The working folder is the parent folder where you save project folders. For this exercise, you will specify a folder on your hard drive as your working folder.

4. In the Browse For Folder dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615). Click OK.

5. In Toolspace, on the Prospector tab, right-click the Data Shortcuts collection. Click New Data Shortcuts Folder.
6 In the New Data Shortcuts Folder dialog box, for Name, enter Tutorial Data Shortcuts Project.
Notice that the folder you specified in Step 4 is displayed in the Working Folder field.

7 Select the Use Project Template check box.
When you select this option, you can specify a template to use in structuring your project. This option enables you to structure similar projects in the same way.

8 In the Project Templates Folder area, notice that C:\Civil 3D Project Templates\ is displayed. Click .

9 In the Browse For Folder dialog box, navigate to the C:\Civil 3D Project Templates\_Sample Project folder.
This is a typical structure for an AutoCAD Civil 3D project. Folders are provided for many of the document types that are typical of a civil engineering project.

10 In the Browse For Folder dialog box, select the Civil 3D Project Templates folder. Click OK.

11 In the New Data Shortcut Folder dialog box, in the Project Template field, select _Sample Project. Click OK.

12 Using Windows Explorer, navigate to the My Civil 3D Tutorial Data folder (page 615). Examine the folder structure in the Tutorial Data Shortcuts Project folder.
The folder structure provides separate locations for data shortcuts, source drawings, and other data. You will save project objects in these folders in the next exercise.

To continue this tutorial, go to Exercise 2: Creating Data Shortcuts (page 157).

**Exercise 2: Creating Data Shortcuts**

In this exercise, you will create data shortcuts from the objects in a drawing. The data shortcuts will be available to reference into other drawings.

For more information, see the AutoCAD Civil 3D Help topic *Creating and Exporting Data Shortcuts*. 

Exercise 2: Creating Data Shortcuts | 157
This exercise continues from Exercise 1: Setting Up a Data Shortcut Folder (page 156).

To create data shortcuts

**NOTE** This exercise uses *Project Management-1.dwg* with the modifications you made in the previous exercise.

1. In Toolspace, on the Prospector tab, right-click the Data Shortcuts collection. Click Create Data Shortcuts.

   **NOTE** As a best practice, each object should reside in a separate drawing. To save time in this exercise, all the objects are in the current drawing.

2. In the Create Data Shortcuts dialog box, select the Surfaces and Alignments check boxes.

   This selects the XGND surfaces, and all of the alignments in the drawing. Notice that profiles that exist for the North-South Road and West-East Road alignments are selected automatically.

3. Click OK.

4. In Toolspace, on the Prospector tab, expand the Data Shortcuts collection. Expand the Surfaces and Alignments collections.

   Notice that the objects you selected in Step 2 have been created as references in these collections. In the next exercise, you will reference these objects in another drawing.

5. Click File menu ➤ Save As.

6. In the Save Drawing As dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615) \Tutorial Data Shortcuts Project\Source Drawings folder. Click Save.

   Source drawings that contain objects that are referenced in other drawings should be saved with the data shortcuts project.

7. Using Windows Explorer, navigate to the My Civil 3D Tutorial Data folder (page 615). In the Tutorial Data Shortcuts Project folder, examine the contents of the subfolders:

   - _Shortcuts\Alignments_: This folder contains an XML file for each alignment in the source drawing. The XML files identify the path to the drawing that contains the alignment, the name of the source drawing, and the name of the alignment.
- _Shortcuts\Profiles: This folder contains an XML file for each profile in the source drawing. The XML files identify the path to the drawing that contains the profile, the name of the source drawing, and the name of the profile.

- _Shortcuts\Surfaces: This folder contains an XML file for the XGND surface.

- Source Drawings: This folder contains the source drawing, which you saved in Step 6. The source drawings should always be saved with the data shortcut project. In a real project, you would save the drawings that contain each object in the subfolders.

8 In the AutoCAD Civil 3D window, close Project Management-1.dwg.

To continue this tutorial, go to Exercise 3: Referencing Data Shortcuts (page 159).

**Exercise 3: Referencing Data Shortcuts**

In this exercise, you will reference several shortcuts in a new drawing.

For more information, see the AutoCAD Civil 3D Help topic *Referencing a Data Shortcut*.

This exercise continues from Exercise 2: Creating Data Shortcuts (page 157).

**To reference data shortcuts**

**NOTE** Before you perform this exercise, you must have created data shortcuts as described in Exercise 2: Creating Data Shortcuts (page 157).

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Project Management-2.dwg.

2 In Toolspace, on the Prospector tab, in the Data Shortcuts ➤ Surfaces collection, right-click XGND. Click Create Reference.

In the Create Surface Reference dialog box, notice that you can specify a Name, Description, Style, and Render Material for the surface. The data shortcut reference object itself cannot be modified in the current drawing, but you can adjust the object properties. For this exercise, you will accept the existing property settings, except for the surface style.
3 In the Create Surface Reference dialog box, in the Style row, click the Value column. Click .

4 In the Select Surface Style dialog box, select Border & Contours. Click OK.

5 In the Create Surface Reference dialog box, click OK. The XGND surface is displayed in the drawing using the style that you specified.

6 In Toolspace, on the Prospector tab, expand the Project Management-2 ➤ Surfaces collection. Notice that the XGND surface is displayed in the Surfaces collection. The arrow next to the surface indicates that the surface was created from a data shortcut.

7 In Toolspace, on the Prospector tab, in the Data Shortcuts ➤ Alignments ➤ North-South Road ➤ Profiles collection, right-click North-South Road Layout. Click Create Reference.

8 In the Create Profile Reference dialog box, click OK.

9 In Toolspace, on the Prospector tab, expand the Project Management-2 ➤ Alignments collection. Notice that when you created the data shortcut to the North-South Road Layout profile, a data shortcut was created for the parent alignment. In the next few steps, you will learn how you can work with objects that are created from data shortcuts.

10 Click Profiles menu ➤ Create Profile From Surface. In the Create Profile From Surface dialog box, notice that the North-South Road, XGND surface, and North-South Road Layout profile are all available.

11 In the Create Profile From Surface dialog box, in the Alignment list, select North-South Road. In the Select Surfaces field, select XGND. Click Add. Click Draw In Profile View.

12 In the Create Profile View wizard, on the General page, for Profile View Style, select Major Grids.

13 On the Data Bands page, in the Set Band Properties table, in the Profile2 column, select XGND - Surface (1). Click Create Profile View.

14 In the drawing window, click to place the profile view grid.
The profile view is displayed in the drawing window. The profile view displays two profiles:

- The red North-South Road Layout profile, which was created from a data shortcut. The actual profile object resides in Project Management-1.dwg.

- The blue XGND - Surface (1) profile, which was created from the XGND surface and North-South Road alignments that you referenced into the current drawing. The XGND - Surface (1) profile object resides in the current drawing.

**Further exploration:** Create references to the other alignment data shortcuts that you created. Change the alignment geometry in the source drawing, and then examine the results in Project Management-1.dwg.

15 Click File menu ➤ Save As.
16 In the Save Drawing As dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615) \Tutorial Data Shortcuts Project \Production Drawings folder. Click Save.

Like source drawings, the final production drawings that contain references to other objects should be saved with the data shortcuts project.

**NOTE** This is the end of the data shortcuts tutorial. The next tutorials in this section demonstrate how to structure a project using Autodesk Vault.

To continue to the next tutorial, go to Database Setup (page 161).

---

**Tutorial: Vault Setup**

In this tutorial, you will act as a project administrator, creating a project in Autodesk Vault and some sample users.

You will log in as various users to see how the work of one user affects the work of another user. You will add files to the project, practice checking files in and out, and create object references.

The design of this tutorial assumes that you have installed the stand-alone version of Autodesk Data Management Server on your computer. This enables you to log in to the Vault database as the Administrator and create some sample users. However, if you are working with an Autodesk Vault database that is shared on a network and you are not permitted to log in as the Administrator, skip Exercise 2: Creating User Accounts and Groups (page 163).
and do the remaining exercises in this tutorial. You may need to modify some steps to suit your database setup.

If you are the Administrator of a shared database, you can use this tutorial as a basis for training users on correct procedures. To protect your existing data, and prepare a safe learning environment, the following steps are recommended:

1. Create a separate Tutorial database (vault).
2. Create a few user accounts and groups that can access only the Tutorial database. The steps in Exercise 2: Creating User Accounts and Groups (page 163) provide some useful guidelines.
3. Review the tasks in this tutorial to verify that users can do all the steps as written. If necessary, prepare additional instructions for your users, or prepare a revised version of the tutorial.

For best results, do the exercises in this tutorial in the order they are presented. Many of the exercises depend on having the database in a particular state created by completing the preceding exercise.

For more information, see the AutoCAD Civil 3D Help topic Managing Data Using Vault.

**Exercise 1: Logging In to Autodesk Vault**

In this exercise, you will log in to Autodesk Vault to prepare for other project tasks.

For more information, see the AutoCAD Civil 3D Help topic Logging In to a Vault Server.

**NOTE** If projects are not displayed in the Master View of the Prospector tab, as indicated in step 1 below, you may need to do the following: If you are running Windows 2000, ensure that you have installed the Microsoft Windows 2000 Updates (including MDAC 2.7 SP1) as well as Service Pack 4. If you are running Windows XP, ensure that you have installed Service Pack 2.

**To log in to the database**

1. In Toolspace, click the Prospector tab.

**NOTE** Ensure that you have a drawing open and that you select the Master View from the list at the top of the Prospector tab.
In the Prospector tree, you should see the Projects collection.

2 Right-click the Projects collection and click Log In To Vault.

3 If the Welcome dialog box appears, click Log In.

4 In the Log In dialog box, review the four data fields:
   ■ User Name: Administrator. Leave this entry as is.
   ■ Password: blank. Leave this field blank for this exercise.
   ■ Server: localhost (for stand-alone local database), or if you have a central Data Management Server on your network, use its name.
   ■ Database: Vault. Leave this entry as is, unless your system administrator advises you to use a different database.

5 Click OK.
The system logs you in to Autodesk Vault.

6 Right-click the Projects collection and click Properties.

7 In the Properties – Civil 3D Projects dialog box, note that the default location for the Working Folder:
   C:\Civil 3D Projects

8 Click OK to close the Properties - Civil 3D Projects dialog box.

To continue this tutorial, go to Exercise 2: Creating User Accounts and Groups (page 163).

**Exercise 2: Creating User Accounts and Groups**

In this exercise, you will create two user accounts and two user groups that can access files in the database.

For more information, see the AutoCAD Civil 3D Help topics *Creating Vault User Accounts* and *Creating Vault Groups*.
This procedure assumes that you are already logged in to the database as described in Exercise 1: Logging In to Autodesk Vault (page 162).

**NOTE** You cannot create a user group without assigning at least one user to the group. Therefore, you should create some user accounts before creating groups.

**To create user accounts**

1. To open Autodesk Vault Explorer, in Toolspace, on the Prospector tab, right-click the Projects collection, and click Autodesk Vault.

   **NOTE** You can also open Autodesk Vault Explorer from the Start menu ➤ Programs ➤ Autodesk ➤ Autodesk Data Management ➤ Autodesk Vault 2009.

2. In the Welcome dialog box, click Log In.

3. In the Log In dialog box, verify the Administrator’s login data, then click OK.

4. In Autodesk Vault, ensure that the correct database (vault) is selected. If you are using the default stand-alone server, there is only one database, and it is Vault. The current server, database (Vault), and user are displayed in the lower right corner of Autodesk Vault.

5. In Autodesk Vault, click Tools menu ➤ Administration.

6. In the Administration dialog box, on the Security tab, click Users.

7. In the User Management dialog box, click New User.

8. In the New User dialog box, enter the following information:
   - First Name: Pat
   - Last Name: Red
   - User Name: pred
   - Password: red123
   - Confirm Password: red123

9. Select Enable User. Click OK.

10. Repeat steps 7 through 9 to create another user profile as follows:
    - First Name: Kim
To create user groups

1. In the Administration dialog box, on the Security tab, click Groups.
2. In the Groups dialog box, click New Group.
3. In the Group dialog box, in the Group Name field, enter Engineers.
4. Click the Roles button, then select Vault Editor. Click OK.
5. Click the Vaults button, then select the database that your test users will work in. Select the default value, which is Vault. Click OK.
7. Click the Add button.
8. To add the member pred to the group, in the Add Members dialog box, in the Available Members table, click the row for pred. Click Add.
9. Click OK to close the Add Members dialog box.
10. Click OK to close the Group dialog box.
11. In the Group Management dialog box, click New Group again, and repeat Steps 3 through 10 to create a group named Technicians. This group has the role of Vault Consumer and access to the same Vault database. Add user kgreen to the Technicians group.
   
   You will not see the advantages of creating user groups in this tutorial, but the structure you have just created is recommended for project teams. Groups can have different roles in relation to a particular database, and you can change the roles of users by moving them into the appropriate group.

12. Click Close to close the Administration dialog box and then close Autodesk Vault.

To continue this tutorial, go to Exercise 3: Creating a Project (page 166).
Exercise 3: Creating a Project

This exercise demonstrates how to log in to the project management system and create a project.

A project is a collection in the Prospector tree that represents objects in a database (vault). Each project is essentially a folder that contains drawings, databases of points, and reference objects, such as surfaces, alignments, and pipe networks. A project folder can also contain other documents relevant to an engineering project.

A database user with the Vault Editor role can create projects.

For more information, see the AutoCAD Civil 3D Help topic Working with Vault Projects.

The following procedure assumes that you are already logged in to the database as described in Exercise 1: Logging In to Autodesk Vault (page 162).

To create a project

1. In Toolspace, on the Prospector tab, right-click the Projects collection, then click New.
2. In the New Project dialog box, for Name, enter Tutorial Vault Project. Optionally, add a short Description.
3. Select the Use Project Template check box.
   When you select this option, you can specify a template to use in structuring your project. This option enables you to structure similar projects in the same way.
4. In the Project Templates Folder area, click .
5. In the Browse For Folder dialog box, navigate to the C:\Civil 3D Project Templates\Sample Project folder.
   This is a typical structure for an AutoCAD Civil 3D project. Folders are provided for many of the document types that are typical of a civil engineering project.
6. In the Browse For Folder dialog box, select the Civil 3D Project Templates folder. Click OK.
7. In the New Project dialog box, in the Project Template field, select _Sample Project. Click OK.
Under the Projects collection, expand the Tutorial Vault Project collection. Examine the folders and nodes that were created from the template you specified in Step 7. For example, the Drawings collection contains folders in which you can save different types of project drawings. The object collections will contain data references to AutoCAD Civil 3D objects that reside in the project drawings.

To continue to the next tutorial, go to Creating, Referencing, and Modifying Project Object Data (page 167).

**Tutorial: Creating, Referencing, and Modifying Project Object Data**

In this tutorial, you will add a drawing to the project, create a project surface and then access the surface from another drawing. You will use the Surface-3.dwg tutorial drawing as the starting point.

This tutorial continues from the Database Setup (page 161) tutorial.

If you are logged in as Administrator, log out and log in as the first test user, pred (password: red123). To log out, right-click the Projects collection in Prospector, Master View, and click Log Out. Then right-click Projects and click Log In To Vault.

Each Civil 3D project object begins as an object within a drawing. When you add the drawing to the project, you specify which Civil 3D objects in the drawing you want to share with other members of the project team.

For more information, see the AutoCAD Civil 3D Help topic Working with Vault Project Objects.

**Exercise 1: Adding a Drawing to the Project**

In this exercise, you will add a drawing to a project. In the process, you will create a shared project surface.

You will create a drawing named Project-XGND.dwg that contains the surface to be shared.

For more information, see the AutoCAD Civil 3D Help topic Adding a Drawing to a Project.
To add the drawing to the project

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Surface-3.dwg.
   
   This drawing contains COGO points and an existing ground surface. Because you will share this data with other users, you must save the drawing with the project.

2. Click File menu ➤ Save As.

3. In the Save Drawing As dialog box, browse to the following location:
   
   C:\Civil 3D Projects\Tutorial Vault Project\Source Drawings\Surfaces

4. For File Name, enter Project-XGND.dwg. Click Save.

   **NOTE** You must be logged in to Autodesk Vault to perform the following steps. see Exercise 1: Logging In to Autodesk Vault (page 162) for instructions.

5. On the Prospector tab, ensure that Master View is selected, and expand the Open Drawings collection. Right-click Project-XGND.dwg and click Add To Project.

   The following warning message is displayed: “<file name and path> will be automatically saved if you add to a project. Do you want to continue?”

6. Click Yes in the warning dialog box.

7. In the first Add To Project dialog box, select Tutorial Vault Project and click Next.

8. In the Add To Project dialog box (Select a drawing location), select the Source Drawings ➤ Surfaces folder. Click Next.

9. In the Add To Project (Drawing file dependencies) dialog box, verify that Project-XGND.dwg is selected and click Next.

10. In the Add To Project dialog box (Share data), select XGND and click Finish.


   The icon displayed next to Project-XGND.dwg indicates that the drawing is available to be checked out.

168 | Chapter 6  Project Management Tutorials
Under the Tutorial Vault Project collection, expand the Surfaces object collection.

The icon next to XGND indicates that the project drawing that contains the surface is available to be checked out.

To continue this tutorial, go to Exercise 2: Creating a Reference to a Project Object (page 169).

---

**Exercise 2: Creating a Reference to a Project Object**

In this exercise, you will create a drawing and create a read-only copy of a project surface in the drawing.

For more information, see the AutoCAD Civil 3D Help topic *Creating References to Project Objects*.

This exercise continues from Exercise 1: Adding a Drawing to the Project (page 167).

To create a reference to a project object

1. Click File menu ➤ New.
2. In the Select Template dialog box, click _AutoCAD Civil 3D (Imperial) NCS Extended.dwt. Click Open.
3. Click File menu ➤ Save As.
4. In the Save Drawing As dialog box, browse to the following location: C:\Civil 3D Projects\Tutorial Vault Project\Production Drawings.
5. Save the file as Project-1.dwg.
7. In the Create Surface Reference dialog box, change the surface style from Contours 2’ And 10’ (Background) to Contours And Triangles. This style specifies how the surface XGND will be displayed in the drawing Project-1. This style setting is independent of the surface style used for the master copy of the surface in Project-XGND.dwg.
8. Click OK.
NOTE If the Events vista is displayed, indicating that the surface is created, close it.

The drawing Project-1 now contains a read-only copy of the project surface XGND. The master copy of the object remains untouched in the project database. The drawing Project-1 is not in the project database, but it is considered to be attached to the Tutorial Vault Project because it contains a reference to an object in that project. While this link remains, the drawing Project-1 can include references to other objects in the Tutorial project, but cannot contain references to objects in other projects.

9 Save and close the drawing.

To continue this tutorial, go to Exercise 3: Checking Out and Modifying a Project Object (page 170).

Exercise 3: Checking Out and Modifying a Project Object

You check out a project object by checking out the drawing that contains the object.

In this exercise, you will check out and modify the drawing that contains the surface object XGND.

For more information, see the AutoCAD Civil 3D Help topic Checking Out Project Object Source Drawings.

This exercise continues from Exercise 2: Creating a Reference to a Project Object (page 169).

To check out a project object

1 On the Prospector tab, expand the Projects ➤ Tutorial Vault Project ➤ Drawings collection.

2 Select the Source Drawings ➤ Surfaces folder to display the list view for the collection.

   In the list view, note that the Version for Project-XGND.dwg is 1.

   The icon next to Project-XGND.dwg indicates that the drawing is checked in.
Right-click *Project-XGND.dwg* and click Check Out.

In the Check Out Drawing dialog box, verify that *Project-XGND.dwg* is selected.

Click OK.

The drawing is checked out and opened. The icon next to *Project-XGND.dwg* in the Open Drawings collection indicates that the drawing is checked out to you. In the next few steps, you will modify the surface by adding a breakline.

With the surface clearly visible, click **(the Polyline tool)** and draw a polyline anywhere on the surface.

Expand Open Drawings ➤ Project-XGND ➤ Surfaces ➤ XGND ➤ Definition.

In the surface Definition, right-click the Breaklines collection. Click Add.

In the Add Breaklines dialog box, optionally give the breakline a name. Click OK. In the drawing window, click the polyline to convert it to a breakline.

Click File menu ➤ Save to save the changes to the surface.

Further exploration: If you want to see how the drawing icon appears to another database user, complete the following steps:

- On the Prospector tab, Master View, right-click the Projects collection and click Log Out.
- Right-click the Projects collection, click Log In, then log in as user kgreen.
- In the Tutorial Vault Project, note the ‘checked out’ icon next to *Project-XGND.dwg*.
- Hover the cursor over the ‘checked out’ icon to see a tooltip that indicates which user has checked out the drawing.
- Log out as kgreen, then log in as pred.

To continue this tutorial, go to Exercise 4: Checking In a Project Object (page 172).
Exercise 4: Checking In a Project Object

You check in a project object by checking in the checked-out drawing that contains it.

For more information, see the AutoCAD Civil 3D Help topic Checking a Drawing In to a Project.

In this exercise, you will check in the source drawing that contains the surface XGND, which you modified in the previous exercise.

This exercise continues from Exercise 3: Checking Out and Modifying a Project Object (page 170).

Before starting this exercise, ensure that you are logged in to the database as pred, or the same user who checked out the drawing Project-XGND.dwg.

To check in a project object

1. On the Prospector tab, expand the Open Drawings collection.
2. Right-click Project-XGND, and click Check In.
3. In the first Check In Drawing dialog box, verify that Project-XGND.dwg is selected.
4. Click Finish.
   The drawing is checked in and closed.
5. Expand the Projects ➤ Tutorial Vault Project ➤ Drawings ➤ Source Drawings collection. Select the Surfaces folder to display the list view.
   In the list view, note that the Version for file Project-XGND.dwg has changed from 1 to 2. Version 2 is the drawing containing the project surface with the most recent modifications.

To continue this tutorial, go to Exercise 5: Updating a Project Object (page 172).

Exercise 5: Updating a Project Object

When the drawing that contains a project object is checked in to the database, the changes are immediately available to other drawings that reference the object.
In this exercise you will open the drawing *Project-1.dwg* that references the surface XGND, which was modified in the previous exercise.

For more information, see the AutoCAD Civil 3D Help topic *Getting the Latest Version of Project Objects*.

This exercise continues from Exercise 4: Checking In a Project Object (page 172).

**To update a project object**

1. Click File menu ➤ Open, navigate to *C:\Civil 3D Projects\Tutorial Vault Project\Production Drawings*, and click the drawing *Project-1.dwg*. The drawing opens.

2. In Toolspace, on the Prospector tab, expand the Surfaces collection, right-click the surface XGND, and click Surface Properties.

3. In the Surface Properties dialog box, change the Surface Style to one that will make the breaklines visible, such as any of the Contours styles.

Notice that the breaklines are displayed on the surface, but you cannot move them. Also, because this surface is a reference object, the surface collection in Prospector does not show the breaklines or other elements of the surface definition that you cannot modify.

**Further exploration:** Keep the drawing *Project-1.dwg* open and check out *Project-XGND.dwg*. Add another breakline to the master copy of the surface, then right-click Project-1 and click Switch To to make this drawing active. See how the change to the surface is reflected in a reference object within a drawing that is already open.

To continue to the next tutorial, go to Creating and Modifying Project Point Data (page 173).

### Tutorial: Creating and Modifying Project Point Data

This tutorial demonstrates how to create, access, and modify project point data.

You will add points to a project database, check out and modify a project point, and check the point back in.
Exercise 1: Adding Points to a Project

In this exercise, you will add point data to the project.

To create project points, you first create a drawing that contains the points. When you are ready to share the points with others, you use the Add To Project command to add the points to the project point database. The project points can then be accessed by others.

After you create project points with the Add To Project command, a local copy of the points remains in the drawing. The icons displayed in the points list view indicate the state of a point with respect to the project.

For more information, see the AutoCAD Civil 3D Help topic Adding Points to a Project.

In this exercise, you will add points to the project from the drawing Project-XGND.dwg, which has already been added to the project.

This exercise continues from the Creating, Referencing, and Modifying Project Object Data (page 167) tutorial.

To add points to the project

1. In Toolspace, on the Prospector tab, expand Projects collection ➤ Tutorial Vault Project ➤ Drawings ➤ Source Drawings ➤ Surfaces folder. Right-click drawing Project-XGND.dwg, and click Open (Read-Only).

2. On the Prospector tab, in the Open Drawings collection, under Project-XGND, click Points to display the points list view.

3. In the points list view, select all the points by clicking the first row and then pressing Ctrl+A.

4. Right-click, and then click Add to Project.
   This operation may take a few moments.

   NOTE You can also add all points in a drawing to a project by expanding the Point Groups collections, right-clicking the _All Points point group, and clicking Add Points To Project.

5. In the Add To Project dialog box, select Tutorial Vault Project. Click OK.
In the points lists view, the open lock icon is now displayed next to each point. The icon indicates that it is a project point that is available to be checked out.

To continue this tutorial, go to Exercise 2: Checking Out and Modifying Project Points (page 175).

Exercise 2: Checking Out and Modifying Project Points

In this exercise, you will check out one project point and correct its elevation.

For more information, see the AutoCAD Civil 3D Help topic Checking Out Points.

This exercise continues from Exercise 1: Adding Points to a Project (page 174).

To check points out

1 Click File menu ➤ New.
2 In the Select Template dialog box, click _AutoCAD Civil 3D (Imperial) NCS Extended.dwt. Click Open.
3 Click File menu ➤ Save As.
4 In the Save Drawing As dialog box, browse to the following location: C:\Civil 3D Projects\Tutorial Vault Project\Production Drawings
5 Save the file as Project-Point.dwg.
6 On the Prospector tab, expand the Projects ➤ Tutorial Vault Project collection.
7 Click the Points collection to display the points list view.
8 Select point number 3.
9 Right-click and click Check Out.
10 In the Check Out dialog box, click OK.
   The point is checked out to the active drawing, Project-Point.dwg.
11 In the Open Drawings collection, expand the Project-Point drawing and click Points to display the list view.

The icon in the drawing list views indicates that the point is a checked-out project point.

12 To modify point 3 by adjusting its elevation, click in the list view under Point Elevation and enter 96.434.

13 Save the drawing.

To continue this tutorial, go to Exercise 3: Checking In Project Points (page 176).

Exercise 3: Checking In Project Points

In this exercise, you will check in a modified project point to update the master version of the point in the project point database.

Checking in the updated point creates a version and makes your changes available to others.

For more information, see the AutoCAD Civil 3D Help topic Checking In Points.

This exercise continues from Exercise 2: Checking Out and Modifying Project Points (page 175).

To check points in

1 In the Open Drawings collection, expand the Project-Point drawing and click the Points collection to display the points list view.

The icon displayed next to the modified point indicates that it is checked out to you.

2 In the list view, select point number 3.

3 Right-click and click Check In.

4 In the Check In dialog box, click OK.

The icon displayed next to the point in the list view shows you that the point has been checked in with your changes. If you expand the Projects ➤ Tutorial Vault Project collection and click Points, you can see in the list view that Point 3 is set to Version 2.
To continue to the next tutorial, go to **Exporting and Importing Vault Projects** (page 177).

**Tutorial: Exporting and Importing Vault Projects**

This tutorial demonstrates how to export a Vault project, and how to import a data shortcuts project into Vault.

You will export the Vault project that you created in the [Vault Setup](#) (page 166) tutorial. Then, you will import into Vault the data shortcut project that you created in the [Using Data Shortcuts](#) (page 155) tutorial.

For more information, see the AutoCAD Civil 3D Help topic *Working with Vault Projects*.

**Exercise 1: Exporting a Vault Project**

In this exercise, you will export a Vault project into a portable ZIP file.

Project export is useful for archiving a project, or packaging it for transmission to another vault.

For more information, see the AutoCAD Civil 3D Help topic *Exporting a Project*.

**To export a project**

1. In Toolspace, on the Prospector tab, Projects collection, right-click Tutorial Vault Project ➤ Export To ZIP file.

   **NOTE** The Event Viewer might indicate that project drawings must be closed before the project can be exported. Make sure that all project drawings are closed, and then repeat Step 1.

2. In the Browse For Folder dialog box, navigate to the *My Civil 3D Tutorial Data folder* (page 615). Click OK.

   While the operation continues, you see a progress bar, then a message about successful export with the complete path to the ZIP file.

3. In the message dialog that reports the successful export, note the complete path to the ZIP file, then click OK.
4 In Windows Explorer, navigate to the My Civil 3D Tutorial Data folder (page 615). Extract the ZIP file with WinZip or another file compression utility.

To continue this tutorial, go to Exercise 2: Importing a Data Shortcut Project into Vault (page 178).

Exercise 2: Importing a Data Shortcut Project into Vault

In this exercise, you will import a data shortcut project into Vault, creating a new Vault project in the process.

Project import is more than just the reverse of export. You can use this operation to import a data shortcut project into Vault, or to import several drawings that are not part of a formal project. In the import process, any data shortcut references are converted into Vault references.

NOTE Before you start this exercise, you must have created the data shortcuts project that is described in the Using Data Shortcuts tutorial (page 155).

For more information, see the AutoCAD Civil 3D Help topic Importing a Project.

This exercise continues from Exercise 1: Exporting a Vault Project (page 177).

To import a project

1 In Toolspace, on the Prospector tab, right-click Projects node ➤ Import From ➤ Folder.

   Notice that you can also import from a ZIP file. Typically, you would use this option to import a project that had been exported from Vault.

2 In the Browse For Folder dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615). Select Tutorial Data Shortcuts Project. Click OK.

   You see a progress bar and several command-line messages about the operation. When the project is imported, it appears in the Projects collection on the Prospector tab, and a copy is created in your working folder Tutorial Data Shortcuts Project is now a Vault project.
These tutorials will get you started working with horizontal alignments, which are the basis for modeling roads.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Alignments.

**Tutorial: Creating Alignments**

This tutorial demonstrates how to create and modify alignments.

You begin creating an alignment by marking the location of tangents and points of intersection for a road centerline alignment. During the creation process, curves between the tangents can be created automatically, or added later. To accommodate high-speed travel, spirals and superelevation can be added to the curves. You can enter numeric parameter values for lines, curves, and spirals in the Alignment Entities table.

If your alignment design must meet minimum standards, you can apply design criteria to an alignment either before or after it is created. This tutorial demonstrates basic alignment creation tasks. For information on applying design criteria to an alignment, see the Designing an Alignment Using Local Standards (page 193) tutorial.

For more information, see the AutoCAD Civil 3D Help topic Creating Alignments.
Exercise 1: Creating an Alignment with Spirals and Curves

In this exercise, you will use the Create Alignment By Layout command to create an alignment with spirals and curves.

For more information, see the AutoCAD Civil 3D Help topic Creating an Alignment Using the Alignment Layout Tools.

To create an alignment

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Align-1.dwg. The drawing contains a surface marked with several circles, labeled A through F.

   NOTE Ensure that Object Snap (OSNAP) is turned on. For more information, see Using Basic Functionality.

2 Click Alignments menu ➤ Create Alignment By Layout.

3 In the Create Alignment – Layout dialog box, accept the default values for Name and Starting Station. Leave the Description field blank for this exercise.

4 On the General tab, select the following settings:
   ■ Site: <None>
Alignment Style: Design Style
Alignment Layer: C-ROAD
Alignment Label Set: Standard

Setting the site to <None> prevents the alignment from interacting with other objects in the drawing. The <None> selection is helpful when you do not want parcels to be created when either intersecting alignments form closed regions or an alignment crosses an existing parcel.

5 Click the Design Criteria tab.
The Starting Design Speed value specifies the default design speed at the alignment starting station. Design speeds can be specified at other stations along the alignment. If no other design speeds are specified, the Starting Design Speed is applied to the entire alignment. You will accept the default Starting Design Speed value for this exercise.

The other options on this tab are used only if you want to ensure that the alignment design meets specified design criteria. You will not apply design criteria to the alignment in this exercise. You will learn how to use the design criteria feature in the Designing an Alignment that Refers to Local Standards (page 193) tutorial.

6 Click OK. The Alignment Layout Tools toolbar is displayed. It includes the controls required to create and edit alignments.

7 In the Alignment Layout Tools toolbar, click the drop-down list and select Curve and Spiral Settings. In the Curve and Spiral Settings dialog box, you can specify the type of curve to be automatically placed at every point of intersection (PI) between tangents.

8 In the Curve and Spiral Settings dialog box, for Type, select Clothoid.

9 Select the Spiral In, Curve, and Spiral Out check boxes. Enter the following values:
   ■ Spiral In Length: 50.0000’
   ■ Radius: 150.0000’
   ■ Spiral Out Length: 50.0000’

10 Click OK.
11 On the Alignment Layout Tools toolbar, click the drop-down list . Select Tangent-Tangent (With Curves).

12 Snap to the center of circle A to specify a start point for the alignment.

13 Stretch a line out, and specify additional PIs by snapping to the center of circles B, C, and D (in order). Then, right-click to end the horizontal alignment layout command.

14 Pan and zoom in the drawing to examine the style and content of the labels. Note especially the geometry point labels marking the start and end points of each line, spiral, and curve.

15 Zoom your display window out until you can clearly see circles B, C, and D.

In the next steps, you will delete the spiral and curve sub-entities that were automatically created. You will manually add new spiral and curve sub-entities in later tutorial exercises.

16 In the Alignment Layout Tools toolbar, click Delete Sub-Entity. You are prompted at the command line to select a sub-entity to delete.

17 Select the spiral-curve-spiral groups in circles B and C. Right-click to end the operation.
Exercise 2: Adding Free Curves and Spirals to an Alignment

In this exercise, you will add a free curve and a free spiral-curve-spiral to a simple alignment.

The drawing contains a simple alignment consisting of three tangents. In the next few steps, you will add free curves at circles B and C.

For more information, see the AutoCAD Civil 3D Help topics Adding Curves and Adding Curves with Spirals.

This exercise continues from Exercise 1: Creating an Alignment with Spirals and Curves (page 180).
To add free curves and spirals to the alignment

NOTE This exercise uses Align-1.dwg with the modifications you made in the previous exercise.

1. Set your drawing window so that you can see circles B and C on the surface.

2. If the Alignment Layout Tools toolbar is not open, select the alignment. Right-click and click Edit Alignment Geometry.

3. In the Alignment Layout Tools toolbar, click the drop-down list and select Free Curve Fillet (Between Two Entities, Radius).

4. As prompted on the command line, click the tangent that enters circle B from the left (the ‘first entity’).

5. Click the tangent that exits from circle B on the right (the ‘next entity’).

6. Press Enter to select the default value of a curve less than 180 degrees.

7. Enter a radius value of 200. The curve is drawn between the tangents as specified.

8. In the Alignment Layout Tools toolbar, click the arrow next to . Select Free Spiral-Curve-Spiral (Between Two Entities).

9. As prompted on the command line, click the tangent that enters circle C from the left (the ‘first entity’).

10. Click the tangent that exits circle C on the right (the ‘next entity’).

11. Press Enter to select the default value of a curve less than 180 degrees.

12. Enter a radius value of 200.

13. Enter a spiral in length of 50.

14. Enter a spiral out length of 50.

NOTE Notice that the default values that are shown on the command line are the values you entered in the Curve and Spiral Settings dialog box in Exercise 1: Creating an Alignment with Spirals and Curves (page 180).
Exit the layout command by right-clicking in the drawing area.

To continue this tutorial, go to Exercise 3: Adding Floating Curves to an Alignment (page 185).

Exercise 3: Adding Floating Curves to an Alignment

In this exercise, you will add two floating curve entities to a simple alignment. First, you will add a best fit floating curve that follows the most likely path through a series of points. Then, you will add a floating reverse curve with spirals.

The initial drawing shows a simple alignment consisting of three tangents with curves. In the next few steps, you will add two floating curves to the end of the alignment.

For more information, see the AutoCAD Civil 3D Help topic Adding Lines, Curves, and Spirals to an Alignment.

This exercise continues from Exercise 2: Adding Free Curves and Spirals to an Alignment (page 183).
To add a floating curve by best fit to the alignment

NOTE This exercise uses Align-1.dwg with the modifications you made in the previous exercise, or you can open Align-2.dwg from the tutorial drawings folder (page 615).

1 Set your drawing window so you can see circles D and E on the surface.

2 In the Layer Control list, in the C-POINTS row, click to turn on the C-POINTS layer.
   A group of points is displayed. You will use these points as a basis for creating a floating curve that follows the most likely path through the points.

   NOTE If the points do not appear, enter REGEN on the command line.

3 If the Alignment Layout Tools toolbar is not open, select the alignment. Right-click and click Edit Alignment Geometry.

4 In the Alignment Layout Tools toolbar, click the drop-down list. Select Floating Curve - Best Fit.

5 As prompted on the command line, click the tangent that ends in circle D (the 'entity to attach to').

6 In the Curve By Best Fit dialog box, make sure that From Civil 3D Points is selected. Click OK.

7 The command line prompts you to Select Point Objects or [Numbers/Groups]. Enter G.

8 In the Point Groups dialog box, select _All Points. Click OK. The points in the drawing window are selected.
   The Regression Data vista displays information about each of the points that are included in the regression analysis. The drawing window displays a dashed red line indicating the path of the best fit curve. An X marks the location of each regression data point.

   NOTE The point numbers in the Pt No. column are sequentially generated as regression data points are added or removed. They do not correspond to the actual AutoCAD Civil 3D point numbers.
Now you will modify some of the regression data to better suit your design.

9 In the Regression Data vista, select the Pass Through check box for Pt No. 16.

Selecting this check box specifies that if the curve does not deviate from the regression data, it will always pass through point 16.

10 Click to create the best fit floating curve.

The Regression Data vista closes, and the regression point markers disappear.

11 In the drawing window, select the alignment. Click the grip at the end of the floating curve, and drag it toward one of the other points. Click to place the grip in its new location.

12 In the Alignment Layout Tools toolbar, click Edit Best Fit Data For All Entities.

Notice that the original regression data is displayed in the Regression Data vista, and the original best fit curve is displayed in the drawing. The
icon in the Regression Data vista indicates that the alignment layout does not comply with the regression data. When you moved the grip in Step 11, you moved the pass-through point from the location you specified in Step 10.

13 Click to synchronize the entity to the original regression data. Click to close the Regression Data vista. The entity returns to its original location.

14 In the Layer Control list, in the C-POINTS row, click to turn off the C-POINTS layer.

To add a floating reverse curve with spirals to the alignment

1 On the Alignment Layout Tools toolbar, click the arrow next to . Select Floating Reverse Curve with Spirals (From Curve, Radius, Through Point).
2 As prompted on the command line, click the curve entity that ends in circle E (the ‘curve to attach to’).

3 Enter a spiral in length of 75.

4 Enter a radius of 200.

5 Enter a spiral out length of 75.

6 Specify a pass-through point in circle F. The reverse curve with spirals appears.

7 Exit the layout command by right-clicking in the drawing area.

To continue to the next tutorial, go to Editing Horizontal Alignments (page 189).

Tutorial: Editing Alignments

This tutorial demonstrates some common editing tasks for alignments.

Editing the layout parameter values of an alignment allows you to make fine adjustments to alignment sub-entities. Grip editing provides a convenient method of manually reshaping an alignment.

For more information, see the AutoCAD Civil 3D Help topic Editing Alignments.
Exercise 1: Editing the Layout Parameter Values of an Alignment

In this exercise, you will use the Alignment Entities vista and Alignment Layout Parameters dialog box to edit the layout parameter values of an alignment.

For more information, see the AutoCAD Civil 3D Help topic Editing Alignment Entity Layout Parameters.

This exercise continues from the Creating Alignments (page 179) tutorial.

NOTE Ensure that Dynamic Input (DYN) is turned on. For more information, see the Using Basic Functionality tutorial.

To edit alignment layout parameters

NOTE This exercise uses Align-2.dwg with the modifications you made in the previous exercise, or you can open Align-3.dwg from the tutorial drawings folder (page 615).

1 If the Alignment Layout Tools toolbar is not open, click Alignments menu ➤ Edit Alignment Geometry. Select the alignment in the drawing window when prompted.

2 On the Alignment Layout Tools toolbar, click Alignment Grid View.

Examine the Alignment Entities table in Panorama. In the first column, alignment segments are numbered in the order in which they are solved. Each row of the table shows useful design data about a specific entity. Each curve group has a two-part entity number and a separate table row for each spiral and curve. Values shown in black can be edited.

3 On the Alignment Layout Tools toolbar, click Sub-Entity Editor.

The Alignment Layout Parameters window is displayed, containing no data.

4 In the Alignment Entities table, click any row for segment no. 4, which is the free spiral-curve-spiral entity in circle C in your drawing window.
The design data for all three sub-entities is displayed in a two-column table in the Alignment Layout Parameters window, where data is easy to review and edit.

If your design requires precise values for minimum curve radius, length, or spiral A values, you can use the Alignment Layout Parameters window to enter the values.

5 In the Alignment Layout Parameters window, change the Length value for a spiral to a higher number, such as 100, and press Enter. Note how this immediately increases the spiral length in three locations: in both the Alignment Layout Parameters window and the Alignment Entities table, numeric values change; in the drawing window, geometry point labels move and their station values change, and the length of the spiral itself changes.

Further exploration: Experiment with changing the curve radius. In the Alignment Entities table, click a line or curve entity and note the data that you can edit in the Alignment Layout Parameters window.

6 Press Esc to clear the Alignment Layout Parameters dialog box.

7 In the drawing window, Ctrl+click the curve entity in circle B. The Alignment Entities vista displays only the attributes for the curve entity.

8 In the drawing window, Ctrl+click the spiral-curve-spiral entity in circle C.

Notice that the Alignment Entities vista now displays the attributes for each of the entities you selected, plus the tangent between them. To display the parameters of another entity in the Alignment Layout Parameters dialog box, click the appropriate row in the Alignment Entities vista.

9 Press Esc to display all alignment entities on the Alignment Entities vista.

To continue this tutorial, go to Exercise 2: Grip Editing an Alignment (page 191).

**Exercise 2: Grip Editing an Alignment**

In this exercise, you will use grips to move alignment curves.

For more information, see the AutoCAD Civil 3D Help topic *Editing Alignments Using Grips.*
This exercise continues from Exercise 1: Editing the Layout Parameter Values of an Alignment (page 190).

**NOTE** Ensure that Dynamic Input (DYN) is turned on, and OSNAP is turned off. For more information, see the Using Basic Functionality tutorial.

**To edit an alignment using grips**

**NOTE** This exercise uses Align-3.dwg with the modifications you made in the previous exercise.

1. Zoom to the area around circle B.
   First, you will experiment with editing the grips of a free curve.

2. Click the alignment. Grips appear at the curve ends, midpoint, and at the point of intersection (PI).

3. Click the midpoint grip at the midpoint of the curve. It turns red.

4. Click a new location for the curve to pass through.
   Notice that the curves and tangents remain tangent to each other, but both endpoints move along the tangents.

5. Click the radius grip directly above the pass-through point grip and experiment with moving it.
   Notice that this grip affects only the curve radius and constrained to the direction of the radius change.

6. Select either an endpoint grip or the PI grip, and experiment with reshaping the curve in different ways.
   Next, you will experiment with editing the grips of a floating curve and its preceding tangent.

7. Pan to the area around circles D and E.

8. Select the square grip in circle D. It turns red.

9. Click a new location for the grip.
   Notice that the pass-through point grip in circle F does not move.

10. Select the pass-through point grip in circle E. It turns red.

11. Click a new location for the grip.
Notice that the pass-through point grip in circle D does not move. The spiral-curve entity in circle D moves along the preceding tangent to accommodate the new pass-through point.

To see how grip editing affects curve specifications, in the next few steps you will add a segment label to the curve. This label shows curve length and radius. The values update each time you reshape the curve.

Notice that with this type of curve, if you edit the triangular PI grip, the curve radius does not change.

12 Click Alignments menu ➤ Add Alignment Labels ➤ Single Segment.
13 Click the curve in circle D. A label is placed on the curve.
14 Press Enter to end the label command.
15 Click the curve to activate the grips.
16 Edit the curve using the pass-through point grip.
   Notice that while the grip is active, you can use dynamic input to enter a specific pass-through point. You may also enter a specific value in the Alignment Layout Parameters window.
17 Press Esc to deselect the alignment. The label shows the new length of the curve.
18 Close this drawing.

To continue to the next tutorial, go to Designing an Alignment that Refers to Local Standards (page 193).

**Tutorial: Designing an Alignment that Refers to Local Standards**

This tutorial demonstrates how to validate that your alignment design meets criteria specified by a local agency.

To create an alignment using design criteria, you use the same basic workflow that you use to create an alignment without design criteria. During alignment creation, you can select a design criteria file, from which you can specify the superelevation attainment method and minimum radius and transition (spiral) length tables. Design criteria files that contain AASHTO design standards are included with AutoCAD Civil 3D. If your local design standards differ from
the AASHTO standards, you can create a custom design criteria file using the Design Criteria Editor dialog box.

Some alignment design criteria is not available in table form in the design criteria file. For these criteria, you can define design checks to validate design standards. To apply a design check to an alignment, you must add it to a design check set.

If the design parameters for a sub-entity violate a design check or the minimum values established in the design criteria file, a warning symbol appears on the sub-entity in the drawing window, and next to the violated value in the Alignment Entities vista and Alignment Layout Parameters dialog box. When you hover the cursor over a warning symbol, a tooltip displays the standard that has been violated. The display of the warning symbol is controlled by the alignment style.

**NOTE** You can also use the Design Criteria tab on the Alignment Properties dialog box to apply design criteria to an alignment after it has been created.

For more information, see [Criteria-Based Alignment Design](#).

---

**Exercise 1: Drawing an Alignment that Refers to Design Criteria**

In this exercise, you will use the criteria-based design tools to create an alignment that complies with specified standards.

This exercise is divided into two parts:

- First, you will specify design criteria for an alignment as you create it, and then draw a series of alignment entities that violate the design criteria. You will correct the violations in **Exercise 2: Viewing and Correcting Alignment Design Criteria Violations** (page 199).

- Second, you will create an alignment entity that meets the design criteria specified in the design criteria file. You will use the minimum default values that are displayed on the command line to ensure that the entity meets the specified design criteria.

For more information, see the AutoCAD Civil 3D Help topic *Creating an Alignment Using the Alignment Layout Tools*. 

---

194 | Chapter 7  Alignments Tutorials
To draw an alignment that refers to design criteria

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Align-4.dwg. The drawing contains a surface marked with several circles, labeled A through E.

   **NOTE** Ensure that Object Snap (OSNAP) is turned on. For more information, see Using Basic Functionality.

2 Click Alignments menu ➤ Create Alignment By Layout.

3 In the Create Alignment – Layout dialog box, accept the default values for Name and Starting Station. Leave the Description field blank for this exercise.

4 On the General tab, select the following settings:
   - Site: <None>
   - Alignment Style: Design Style
   - Alignment Layer: C-ROAD
   - Alignment Label Set: Major Minor and Geometry Points

5 On the Design Criteria tab, for Starting Design Speed, enter 50 km/h. This speed will be applied to the starting station of the alignment. You can add design speeds as needed to other stations. A design speed is applied to all subsequent stations until either the next station that has an assigned design speed or the alignment ending station.

6 Select the Use Criteria-Based Design check box.

   When this option is selected, the criteria-based design tools are available. There are two check boxes that are selected by default:
   - Use Design Criteria File—The design criteria file is an XML file that contains minimum design standards for alignment and profile objects. The design criteria file can be customized to support local design standards for design speed, superelevation, and minimum speed, radius, and length of individual entities. The Default Criteria table lists the properties that are included in the default design criteria file, the location of which is displayed in the field above the Default Criteria table.
   You will learn more about the design criteria file in Exercise 4: Modifying a Design Criteria File (page 205).
Use Design Check Set—Design checks are user-defined formulas that verify alignment and profile parameters that are not contained in the design criteria file. Design checks must be included in a design check set, which is applied to an alignment or profile.

7 In the Use Design Criteria File area, click .

8 In the Select Design Speed Table dialog box, select AutoCAD Civil 3D Metric Roadway Design Standards_2001.xml. Click Open. For this exercise, you will use AASHTO 2001 standards, which are included in one of the provided design criteria files. You will learn about creating a custom design criteria file in Exercise 4: Modifying a Design Criteria File (page 205).

9 In the Default Criteria table, in the Minimum Radius Table row, change the Value to AASHTO 2001 eMax 6%.

10 In the Use Design Check Set list, select 50kmh Roadway Length Checks. Click OK. This design check set contains a simple design check. You will create another design check and add it to this design check set in Exercise 3: Working with Design Checks (page 202).

To draw alignment entities that meet the specified design criteria

1 On the Alignment Layout Tools toolbar, click Tangent-Tangent (No Curves).

2 Snap to the center of Circle A to specify a start point for the alignment. Stretch a line out, and specify additional PIs by snapping to the center of Circles B, C, and D (in order). Then, right-click to end the horizontal alignment layout command.

3 On the Alignment Layout Tools toolbar, click Free Spiral-Curve-Spiral (Between Two Entities).

4 As prompted on the command line, click the tangent entity that enters Circle B from the left (the ‘first entity’).

5 Click the tangent that exits Circle B on the right (the ‘next entity’).
6 Press Enter to accept the default value of a curve solution angle that is less than 180 degrees.

7 For radius, enter 75.

   Notice that the Specify Radius prompt includes a default value. This value is the minimum acceptable curve radius at the current design speed. The minimum value is contained in the Minimum Radius Table in the design criteria file. You can enter a different value, as long as it is greater than the default minimum value that is displayed. For this exercise, we will use values that do not meet the design criteria, and then examine the results.

8 For spiral in length, enter 25.

9 For spiral out length, enter 25.

10 In the Alignment Layout Tools toolbar, click the drop-down list and click Free Curve Fillet (Between Two Entities, Radius).

11 As prompted on the command line, click the tangent that enters Circle C from the left (the ‘first entity’).

12 Click the tangent that exits from Circle C on the right (the ‘next entity’).

13 Press Enter to select the default value of a curve less than 180 degrees.

14 Press Enter to select the minimum radius of 90.000m.

15 Right-click to end the command.

   Notice that in the drawing window, symbols appear on the curve entities you created. The symbols indicate that the entities violate the specified design criteria. You will learn how to correct these violations in Exercise 2: Viewing and Correcting Alignment Design Criteria Violations (page 199).

   In Step 14, you accepted the minimum radius value specified in the design criteria file, yet a warning symbol is displayed on the curve. This happened because while the curve meets the design criteria specified in the design criteria file, it violates the design check that is in the design check set. You will learn how to correct design criteria and design check violations in the next exercise.
Next, you will add another curve entity and examine the results.

16 On the Alignment Layout Tools toolbar, click the drop-down list. Select More Floating Curves ➤ Floating Curve (Entity End, Radius, Length).

17 As prompted on the command line, click the tangent entity that ends in Circle D (the ‘entity to attach to’).

**TIP** The warning symbols do not automatically scale when you zoom in. Enter `REGEN` on the command line to resize the warning symbols.

18 On the command line, enter O to specify the counterclockwise direction.

19 Enter a radius value of 200.000m.

20 When prompted to specify a curve length, click in the center of Circle D, and then click in the center of Circle E.
   The curve is displayed in the drawing. The length value is the distance between the two points that you clicked.

21 Right-click to end the command.
   Notice that a warning symbol is not displayed on this curve. The radius value you entered in Step 19 exceeds the minimum value defined in the minimum radius table that you specified.
Exercise 2: Viewing and Correcting Alignment Design Criteria Violations

In this exercise, you will examine alignment design criteria violations, and then learn how to correct a criteria violation.

When a sub-entity violates either a criteria or design check, a warning symbol is displayed on the sub-entity in the drawing window, Alignment Entities vista, and Alignment Layout Parameters dialog box. When the cursor is hovered over a warning symbol in the drawing window, a tooltip displays information about the violation. If a design criteria has been violated, the tooltip displays the criteria that has been violated, as well as the minimum value required to meet the criteria. If a design check has been violated, the tooltip displays the name of the design check that has been violated.

For more information, see Viewing and Correcting Alignment Design Criteria Violations.

This exercise continues from Exercise 1: Drawing an Alignment that Refers to Design Criteria (page 194).

To check the alignment design for criteria violations

NOTE This exercise uses Align-4.dwg with the modifications you made in the previous exercise.

1 Set your drawing window so that you can see Circles B and C on the surface.

TIP The warning symbols do not automatically scale when you zoom in. Enter REGEN on the command line to resize the warning symbols.
2 Hover the cursor over the middle ⚠ symbol in Circle B.

The tooltips are a convenient way to review design criteria violations in the drawing window. Two violations are displayed in the tooltip:

- First, the curve does not meet the recommended minimum radius. The curve radius and minimum acceptable parameter values are both displayed.

- Second, the curve violates the design checks that has been applied to the alignment. Notice that the name of the design check is displayed, but not the current or recommended values. Values are not displayed because design checks are custom formulas that are created by the user.

NOTE If a sub-entity violates multiple criteria or design checks, only a single symbol is displayed on the sub-entity. To clear a symbol from a sub-entity, all of the violations must be cleared.

3 If the Alignment Layout Tools toolbar is not open, select the alignment. Right-click. Click Edit Alignment Geometry.

4 On the Alignment Layout Tools toolbar, click Alignment Grid View.

In the Alignment Entities vista, in rows 2.1 through 2.3, notice that a ⚠ warning symbol appears in the No. column, as well as in several other columns. Warning symbols appear next to each value that violates the design criteria that are specified in the design criteria file.
5 In row 2, hover the cursor over the warning symbol in the No. column. Notice that the tooltip displays the design criteria and design checks that have been violated.

6 Hover the cursor over the warning symbol in row 4. Notice that the name of the design check that has been violated is displayed in the tooltip. Also notice that warning symbols are not displayed in any other cells in this row. Design checks are custom mathematical formulas that return either a true or false value. They indicate whether the applicable entities violate the conditions in the design check, but do not specify how to correct the violation. You will learn more about design checks in Exercise 3: Working with Design Checks (page 202).

7 On the Alignment Layout Tools toolbar, click Sub-Entity Editor . The Alignment Layout Parameters window is displayed, containing no data.

8 In the Alignment Entities vista, click any row for segment No. 2, which is the spiral-curve-spiral entity in Circle B. The design data for all three sub-entities is displayed in a three-column table in the Alignment Layout Parameters window, where data is easy to review and edit.

Notice that in the Alignment Layout Parameters window, in the Design Criteria panel, a symbol is displayed next to each design criteria property that has been violated. In the Layout Parameters panel, the Value column displays the actual parameters of each sub-entity. The Constraints column displays the design criteria values that the sub-entities must meet. A symbol is displayed next to each parameter that violates the design criteria. As is true in the drawing window and Alignment Entities Vista, the design check that has been violated is displayed, but individual parameters that violate the check are not marked.

**To correct design criteria violations**

1 In the Alignment Layout Parameters window, on the Layout Parameters panel, change the Spiral In Length Value to 33.000m. Press Enter.
Notice that the warning symbol is cleared from the Spiral In Length row.

2 Change the Spiral Out Length Value to 33.000m. Press Enter.

3 Change the Curve Radius Value to 100.000m. Press Enter.

The ⚠️ warning symbol is cleared from the Curve Radius row, as well as from the Alignment Entities vista.

Notice that the warning symbol is still displayed on all the curve sub-entity. The curve still violates the design check. To clear the warning symbols, all sub-entities in the group must meet the values specified in both the design criteria file and the applicable design checks.

4 In the Alignment Entities vista, in row 2.2, examine the Length column. Notice that the Length value is less than the value of 40 that is specified by the design check. Notice that you cannot edit the Length value for this type of curve. However, you can increase the curve radius to increase the curve length.

5 In row 2.2, change the Radius value to 200.000m. Press Enter.

6 In the Alignment Entities vista, select row 4. In the Length column, change the value to 40.000m. Press Enter.

To continue this tutorial, go to Exercise 3: Working with Design Checks (page 202).

**Exercise 3: Working with Design Checks**

In this exercise, you will create an alignment design check, add the design check to a design check set, and then apply the design check set to an alignment.

To create a design check, you set up a mathematical formula, using existing alignment sub-entity properties. The complexity of design check formulas can vary greatly. In this exercise, you will create a relatively simple design check that validates whether the tangent length meets a minimum value at a given design speed.

**NOTE** The processes for creating design checks for alignments and profiles are very similar. The basic workflow that is demonstrated in this exercise can be used for both alignment and profile design checks.
For more information, see Alignment Design Checks.

This exercise continues from Exercise 2: Viewing and Correcting Alignment Design Criteria Violations (page 199).

To create an alignment design check

NOTE This exercise uses Align-4.dwg with the modifications you made in the previous exercise, or you can open Align-5.dwg from the tutorial drawings folder (page 615).

1 In Toolspace, on the Settings tab, expand the Alignment ➤ Design Checks collection.

Notice that five collections are available. The Design Check Sets collection contains combinations of design checks. A design check must be added to a design check set before it can be applied to an alignment.

The other four collections contain the design checks for each type of alignment entity. Each entity type has specific properties that can be checked. When you create a design check set, you specify the type of entity you want to check, and then the specific design check you want to apply to that entity. You can apply multiple design checks to each entity type.

NOTE The Tangent Intersection collection contains design checks for spiral and curve groups.

2 Right-click the Line collection. Click New.

3 In the New Design Check dialog box, for Name, enter L>=310m @ 50km/h.

BEST PRACTICE Because design check tooltips do not display specific values, a design check name should be specific and unique. Use the mathematical formula or other specific information to simplify the process of correcting a design check violation.

4 For Description, enter Tangent length must be >= 310m if design speed is >= 50km/h.

5 Click Insert Function. Click IF.

The IF function is displayed in the Design Check field.

6 Click Insert Property. Select Design Speed.
7 In the Design Check field, use the keypad to enter >=50, (including the comma) after the [Design Speed] property.

8 Click Insert Property. Select Length.

9 In the Design Check field, enter >=310,1) (including the closing parenthesis).
   The following formula should be displayed in the Design Check field:
   IF([Design Speed]>=50,Length>=310,1)

   **NOTE** In this formula, the ending numeral 1 specifies that the preceding formula is acceptable. If the entity parameters do not meet the values specified in the formula, a violation is issued.

10 Click OK.

11 In Toolspace, on the Settings tab, expand the Alignment ➤ Design Checks ➤ Line collection.
   The design check you created is displayed in the Line collection.

**To add a design check to a design check set**

1 In Toolspace, on the Settings tab, expand the Alignment ➤ Design Checks ➤ Design Check Sets collection. Click 50kmh Roadway Length Checks.
   This is the design check set that is applied to the alignment in the current drawing. Notice that the design checks that are in the selected design check set are displayed in the Toolspace list view.

2 Right-click the 50kmh Roadway Length Checks design check set. Click Edit.

   **TIP** To create a new, empty design check set, right-click the Design Check Sets collection and click New.

3 In the Alignment Design Check Set dialog box, click the Design Checks tab.
   The table on this tab lists the design checks that are currently in the design check set. The drop-down lists above the table allow you to add design checks to the set.

4 In the Type list, select Line.
5 In the Line Checks list, select L>=310m @ 50km/h, which is the design check that you created in the previous procedure. Click Add. Click OK.

6 If the Alignment Layout Tools toolbar is not open, select the alignment. Right-click. Click Edit Alignment Geometry.

7 On the Alignment Layout Tools toolbar, click Alignment Grid View. Click Sub-Entity Editor.

8 In the Alignment Entities vista, select row 5.

9 In the Alignment Layout Parameters dialog box, examine the Length value.

Further exploration: Increase the length of the line until it meets or exceeds 310 meters. This is a fixed line that was created using the Tangent-Tangent (No Curves) command, so you must move the endpoint grip inside Circle D to increase the length.

To continue to the next tutorial, go to Exercise 4: Modifying a Design Criteria File (page 205).

Exercise 4: Modifying a Design Criteria File

In this exercise, you will add a radius and speed table to the design criteria file.

If your local agency standards differ from the standards in the supplied design criteria file, you can use the Design Criteria Editor dialog box to customize the file to support your local standards.

In this exercise, you will add a minimum radius table to an existing design criteria file, and then save the file under a new name.

For more information, see Design Criteria Files.

This exercise continues from Exercise 3: Working with Design Checks (page 202).
To modify a design criteria file for alignments

1. Click Alignments menu ➤ Design Criteria Editor.

When the Design Criteria Editor dialog box opens, it displays the design criteria for the default design criteria file. The folders on the left side of the dialog box contain tables that specify the units of measure used in the design criteria file, and design criteria tables for alignments and profiles. You can use this dialog box to modify the criteria in the current file, open another file, or create a new file. In the following steps, you will add a criteria table to an existing file, and then save the changes as a new file.

2. On the left side of the dialog box, expand the Alignments ➤ Minimum Radius Tables collection.

The collection contains several minimum radius tables.

3. Right-click Minimum Radius Tables. Click New Minimum Radius Table.

An empty table appears at the end of the Minimum Radius Tables collection.

4. Replace the New Minimum Radius Table text with Local Standards eMax 7%. Press Enter.

5. Click Save As.

6. In the Enter A File Name To Save dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615). In the File Name field, enter Sample_Local_Criteria.xml. Click Save.

If a design criteria file must be shared by multiple users, it must be saved in a location to which all applicable users have access. If you send a drawing that uses a custom design criteria file to a user that does not have access to the shared location, then you also must send the design criteria file.

TIP When the Use Design Criteria File option is selected during alignment creation, the first design criteria found in the C:\Documents and Settings\All Users\Application Data\Autodesk\C3D 2009\enu\Data\Corridor Design Standards \[Units\] directory is applied to an alignment by default. To ensure that a custom design criteria file is selected by default, make sure that its name places it first in the directory.
In the Design Criteria File Editor dialog box, on the left-hand side, ensure that the Local Standards eMax 7% table is selected.

On the right-hand side of the dialog box, select the first row in the table. Click the Speed cell. Select 50 from the list.

Click the Radius cell. Enter 54. Press Enter.

Repeat steps 8 and 9 to add the following values to the table:

<table>
<thead>
<tr>
<th>Speed</th>
<th>Radius</th>
</tr>
</thead>
<tbody>
<tr>
<td>70</td>
<td>125</td>
</tr>
<tr>
<td>90</td>
<td>235</td>
</tr>
<tr>
<td>110</td>
<td>387</td>
</tr>
<tr>
<td>130</td>
<td>586</td>
</tr>
</tbody>
</table>

**TIP** To add a row between two existing rows, click ⌁. To remove a row, click .

In the Comments field, enter Minimum radii for 7% superelevation at various design speeds.

**Further exploration:** Expand the other collections on the left-hand side of the dialog box. Right-click the various folders and tables and examine the options that are available.

Click Save And Close. When you are notified that the file has unsaved changes, click Save Changes And Exit.

**Further exploration:** Use the Alignment Properties dialog box to apply the new Sample_Local_Criteria.xml design criteria file and Local Standards eMax 7% table to the alignment in Align-4b.dwg.
Profiles Tutorials

These tutorials will get you started viewing and designing the elevation profile of land surfaces along a horizontal alignment.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Understanding the Profile Object.

**Tutorial: Using Surface Profiles**

This tutorial demonstrates how to create surface profiles and display them in a profile view.

A surface profile is extracted from a surface, and is often called an existing ground profile. It is displayed on a graph called a profile view. Each profile view is associated with a single horizontal alignment, but it can display multiple surfaces and offset profiles from that alignment. An offset profile displays surface elevations at a specified distance horizontally offset from the alignment. When you create a profile along the centerline of a horizontal alignment, AutoCAD Civil 3D can create one or more offset profiles automatically.

Surface profiles can be either static or dynamic. A static profile shows the elevations at the time it was created, but does not react to later changes in the alignment or surface. A dynamic profile automatically changes if the elevation changes along the horizontal alignment, so it remains current.

For more information, see the AutoCAD Civil 3D Help topic Creating Profiles.
Exercise 1: Creating and Displaying Surface Profiles

In this exercise, you will create a surface profile from an existing surface.

After creating the profile and several offsets, you will create a profile view to display the profiles.

For more information, see the AutoCAD Civil 3D Help topic Creating Surface Profiles.

To create a surface profile

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-1.dwg. Note the two horizontal alignments. The red one with curves is named Ridge Road, representing a proposed road centerline. The other is named Power Line, representing a proposed power line offset about 25 feet from the road.

2. Click Profiles menu ➤ Create Profile From Surface.

3. In the Create Profile From Surface dialog box, in the Alignment field, select Ridge Road.

4. On the right side of the dialog box, click Add. A centerline profile is added to the Profile List.

5. Select Sample Offsets.

6. In the Sample Offsets field, enter 25,-25 (including comma) to specify profiles offset 25 feet on each side of the centerline. The left offset (-25) will mark the approximate location of the power line. If you wanted more offsets, you could enter a series of them here. Use positive numbers for right offsets and negative numbers for left offsets, with values separated by commas.

7. Click Add.

8. In the Profile List, in the Description column, enter Centerline for the first profile (the one with 0 offset). Enter Right Offset for the profile with a 25-foot offset, and Left Offset for the profile with a -25-foot offset.

9. In the Profile List, in the Update Mode column, for the left offset, change the value to Static.
This option specifies that the left offset reflects the surface elevations at the time of its creation. It will not update to reflect future changes in the surface.

10 Click . The Create Profile View wizard is displayed, where you can configure the display of the profile. The wizard contains the many controls for displaying profiles in a profile view. You can use either the Back and Next buttons at the bottom or the links along the left side to navigate through the pages. You can click Create Profile View at any time to accept the settings and create the profile view in the drawing.

11 Click Profile Display Options.

The table on the Profile Display Options page shows the existing profiles for Ridge Road. By default, they are all checked in the Draw column, indicating that they will appear in the profile view.

12 In the Specify Profile Draw Options table, in the Style column, double-click the cell for the Left Offset.

13 In the Pick Profile Style dialog box, change the style to Existing Ground. Click OK.

14 In the Specify Profile Draw Options table, in the Labels column, double-click the cell for the Left Offset.

15 In the Pick Profile Label Set dialog box, change the style to <None>. Click OK.

You will not create labels for the existing ground profiles. You will specify a label set when you create a layout profile in the Using Layout Profiles tutorial (page 215).

16 Repeat Steps 14 and 15 for the other two profiles.

17 In the Create Profile View wizard, click Create Profile View. You are prompted to select the profile view origin.

18 Use scroll bars on the window, as required, to move to a blank area at the lower right of the surface. Click at a suitable location for the lower left corner of the profile view grid. The profile view is drawn, with a grid, axes, title, and two data bands along the X axis, one above the grid and another below it.

Because of its style, the left offset line is blue in color. In the next exercise, you will create another profile view using the same profiles. Then, you will change the style of the left offset.
NOTE If you want to move a profile view within a drawing, click anywhere on the grid to select it. A blue grip appears near the lower left corner. Click the grip and drag the profile view to a new location.

To continue this tutorial, go to Exercise 2: Changing the Profile Style (page 212).

Exercise 2: Changing the Profile Style

In this exercise, you will change a profile style in two different ways.

First, you will change a profile style globally, which changes the profile’s appearance in all profile views. Then, you will learn how to override a profile style in a single profile view. Finally, you will hide the offset profiles.

For more information, see the AutoCAD Civil 3D Help topic Profile and Profile View Styles and Display.

This exercise continues from Exercise 1: Creating and Displaying Surface Profiles (page 210).

To change the profile style

NOTE This exercise uses Profile-1.dwg with the modifications you made in the previous exercise.

1 Click Profiles menu ➤ Create Profile View.
2 In the Create Profile View wizard, on the General page, click Ridge Road in the Select Alignment field.
   This action populates the Specify Profile Draw Options table on the Profile Display Options page, showing the available profiles for the alignment.
3 Click Profile Display Options.
4 In the Specify Profile Draw Options table, in the Style column, double-click the cell for the Left Offset profile.
5 In the Pick Profile Style dialog box, change the style to Standard. Click OK.
6 In the Name column, select the first row. Hold down the Shift key, and then select the last row.
7 In the Labels column, double-click one of the cells.
8 In the Pick Profile Label Set dialog box, change the style to <None>. Click OK.

9 In the Create Profile View wizard, click Create Profile View. You are prompted to pick a location for the profile view origin.

10 Pan to a location above the top of the first profile view, then click in the drawing. The new profile view, PV - (2), is drawn. The left offset profile is the same color as the other two profiles.

11 Pan to the lower profile view, PV - (1). Notice that its left offset line has also changed. The left offset profile changed because you changed the style of the profile, which affects every instance of the profile in every profile view in the drawing.

In the next few steps, you will see another way to modify profile style.

12 Select the PV - (1) profile view grid. Right-click and click Profile View Properties.

13 Click the Profiles tab. On this tab, you can change properties of a profile line after it has been drawn in a profile view.

14 On the Profiles tab, set your display to see the Style and Override Style columns.

15 In the Override Style column for the Left Offset, double-click the check box. In the Pick Profile Style dialog box, change the profile style to Existing Ground, then click OK. In the Profile View Properties dialog box, click Apply.

The Left Offset profile changes to blue (reflecting the Existing Ground style) in profile view PV - (1), but not in PV - (2). The left offset profiles are different because you overrode the profile style for the particular profile view, but did not change the profile style. You can use a style override to preserve the profile style within a profile view, protecting it from later style changes.

**Further exploration:** In the Profile View Properties dialog box, clear the Override Style check box for the left offset. Click the Style column for this offset, change it to Standard, then click Apply. This changes the style for the profile and affects both profile views in the drawing. If you want to use your drawing for the next exercise, before you close the Profile View Properties dialog box, reset the Override Style column for the left offset to Existing Ground for profile view PV - (1).
NOTE The left offset line is an approximate and static profile of the terrain along the power line. Optionally, if you wanted to see the actual profile, you could create a profile and profile view based on the Power Line alignment.

To continue this tutorial, go to Exercise 3: Reviewing Surface Profile Characteristics (page 214).

Exercise 3: Reviewing Surface Profile Characteristics

In this exercise, you will examine some of the information displayed in the profile and the profile view.

For more information, see the AutoCAD Civil 3D Help topic Editing Profile Curve and Tangent Attribute Values.

This exercise continues from Exercise 2: Changing the Profile Style (page 212).

To examine the profile view characteristics

NOTE This exercise uses *Profile-1.dwg* with the modifications you made in the previous exercise, or you can open *Profile-2.dwg* from the tutorial drawings folder (page 615).

1. Zoom in to the lower profile view PV - (1) so that you can clearly see the three profile lines.

2. Select the highest profile line (the right offset profile), being careful not to select the profile view grid. Right-click and click Edit Profile Geometry. The Profile Layout Tools toolbar is displayed. Notice that no editing grips are displayed along the profile, and most controls in the Profile Layout Tools toolbar are shaded and unavailable. This profile is dynamic. It is linked to the surface elevations, and no part of the line can be edited.

3. In the Profile Layout Tools toolbar, click . The Profile Entities vista is displayed in the Panorama window. This table displays useful grade data for the entire profile. Again, values are shaded and unavailable so you cannot edit them. Editing these values would break the integrity of the link between the profile and the surface.

4. Press Esc to deselect the right offset profile.
5 Click the blue (left offset) profile line. Notice that editing grips appear along this profile. If you zoom out, you can see that the same profile is also selected in the other profile view. If you grip edit the profile in one profile view, the same changes apply to the other copy of the profile.

Because this line is a static profile, and detached from the surface, you can edit it in various ways, including copying and moving it. You would not edit this line if you wanted to preserve it as a snapshot of the surface at a particular time.

Notice that the Profile Entities table now displays the design data for the left offset profile, with values you can edit. When you selected the left offset profile, it became the active profile for the editing tools.

6 Close the Profile Layout Tools toolbar.

The Profile Layout Tools toolbar and Profile Entities vista both close, and the left offset profile line is deselected in the drawing.

To continue to the next tutorial, go to Using Layout Profiles (page 215).

**Tutorial: Using Layout Profiles**

This tutorial demonstrates how to create and edit layout profiles, which are often called design profiles or finished grade profiles.

A layout profile represents a proposal for a road or other designed surface. This type of profile is always drawn on the grid of a profile view, which usually displays the surface profile along the same horizontal alignment.

A layout profile includes the following elements:

- Straight line tangents with specified grade or slope.
- Points of vertical intersection (PVI) where tangents meet.
- Vertical curves that are usually parabolic in shape. Vertical curves can also be circular or asymmetrical parabolic.

Vertical curves can be one of two basic types: crest curves or sag curves.

- A *crest* curve exists at a hilltop, or wherever the incoming tangent has a higher grade than the outgoing tangent. There are three types of crest curves: a positive to negative grade transition, positive to positive, and negative to negative. The point of vertical intersection (PVI) of a crest curve is above the curve.
A sag curve exists at the bottom of a valley, or wherever the incoming tangent has a lower grade than the outgoing tangent. There are three types of sag curves: a negative to positive grade transition, negative to negative, and positive to positive. The PVI of a sag curve is below the curve.

The vertical curves on a layout profile can be designed in relation to engineering speed tables for safe vehicular travel at a particular maximum speed. Other tables can be used to design vertical curves so that the distance illuminated by the headlights of a vehicle at night is always greater than the stopping distance at the maximum design speed.

For more information, see the AutoCAD Civil 3D Help topics Creating Layout Profiles and Vertical Curve Design.

Exercise 1: Creating a Layout Profile

In this exercise, you will create the layout profile. Typically, this profile is used to show the elevations along a proposed road surface or a finished grade.

The layout profile is similar to a horizontal alignment, in that it is constructed of straight tangents with optional curves placed where the tangents intersect. These tangents and curves on a layout profile are located in the vertical plane and the intersection points are called points of vertical intersection (PVI).

For more information, see the AutoCAD Civil 3D Help topic Creating Layout Profiles.

This exercise continues from the Using Surface Profiles (page 209) tutorial.

To create a profile by layout

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-2.dwg. Before you draw the layout profile, you will hide the offset profiles.
2. Click the grid to select the profile view. Right-click and click Profile View Properties.
3. In the Profile View Properties dialog box, on the Profiles tab, clear the Draw check boxes for the right offset and left offset profiles. The Profiles tab displays all existing profiles for a given horizontal alignment, both surface profiles and layout profiles. You can use the Draw check boxes to specify which profiles to display in the profile view.
Further exploration: You can permanently delete a profile by selecting it in the drawing (or in Toolspace) and pressing the Delete key. If you delete a profile, it is removed from all profile views, the list of profiles in the Profile View Properties dialog box, and Toolspace. To restore a deleted surface profile, click Profiles menu ➤ Create From Surface, and enter the required settings. The new profile is displayed in any applicable profile views, and can be edited in the Profile View Properties dialog box.

To continue with this exercise, ensure that the centerline profile is visible in profile view PV- (1).

4 Click OK. The offset profiles are hidden from the profile view.

5 **NOTE** Turn off Object Snap (OSNAP). For more information, see *Object Snapping*.

6 Click Profiles menu ➤ Create Profile By Layout.

7 Click one of the grid lines to select profile view PV - (1).

8 In the Create Profile – Draw New dialog box, change the Profile Style to Finished Ground.

9 In the Profile Label Set list, select Standard. Click .

10 In the Profile Label Set dialog box, click the Labels tab. For Type, select Horizontal Geometry Points. For Profile Horizontal Geometry Point, select Station & Type. Click Add.

11 In the Geometry Points dialog box, examine the geometry points that can be labeled. You can specify any combination of points that you want to label. Click OK.

**NOTE** For more details about geometry point labels, see the *Adding Labels in Groups* tutorial exercise (page 543).

12 In the Profile Label Set dialog box, click OK.

13 Click the Design Criteria tab.

The options on this tab are used only if you want to ensure that the profile design meets specified design criteria. You will not apply design criteria to the profile in this exercise. You will learn how to use the design criteria feature in the *Designing a Profile that Refers to Local Standards* tutorial (page 223).
14 Click OK to accept the settings.

15 In the Profile Layout Tools toolbar, click the arrow on the right side of and click Curve Settings.

16 On the Vertical Curve Settings dialog box, note that you can select one of three curve types and specify parameters for each type.

17 Set the following values:
   - Curve Type: Parabolic
   - Crest Curve Length: 100
   - Sag Curve Length: 100

18 Click OK.

19 In the Profile Layout Tools toolbar, ensure that Draw Tangents With Curves is selected.

   You are now ready to draw the layout profile by clicking in the drawing at the proposed locations of PVIs. At each PVI, the application inserts a curve. To be realistic, your line should follow the general profile of the surface centerline. However, it can cut across steep hills and valleys to outline a smoother road surface.

20 In the profile view, click the left side, near the centerline surface profile, to start the layout profile.

21 Extend the line to the right and click at another location near the centerline surface profile. Continue in this manner.

22 At the last point, right-click to end the profile. The layout profile is now drawn and labeled.

23 Zoom and pan along the layout profile to examine the labels.

To continue this tutorial, go to Exercise 2: Editing a Layout Profile (page 218).

**Exercise 2: Editing a Layout Profile**

In this exercise, you will modify the layout profile by using grips and entering specific attribute values.
For more information, see the AutoCAD Civil 3D Help topic Editing Layout Profiles.

This exercise continues from Exercise 1: Creating a Layout Profile (page 216).

To edit the profile design data

**NOTE** This exercise uses Profile-2.dwg with the modifications you made in the previous exercise.

1. Select the red layout profile. Right-click and click Edit Profile Geometry. The Profile Layout Tools toolbar is displayed.

2. On the Profile Layout Tools toolbar, click . This option specifies that you will edit the data for each profile PVI. If you had clicked , you would edit the data for each profile line and curve sub-entity.

3. On the Profile Layout Tools toolbar, click Profile Grid View . The Profile Entities vista is displayed in the Panorama window. The first row in the table provides data about the starting point of the layout profile. Subsequent rows provide data about the PVIs. The last row provides data about the end point.

4. Examine the Grade In and Grade Out columns with the aim of reducing one or more of the steeper grades in the profile. Notice that the Grade Out value for one PVI is the same as the Grade In value for the next PVI. The values are the same because they refer to the same tangent.

5. Decide on a maximum grade value that you want to implement in this profile. For example, use 5% or any value lower than at least one of the existing grades in the profile.

6. In the Grade In or Grade Out column, double-click a grade value that is higher than your chosen maximum, and then enter the chosen value (% symbol not required). Press Enter. The value changes in the associated Grade In/Out column. The line in the drawing adjusts to the new value.

**Further exploration:** Experiment with changing K values and Profile Curve Lengths. In each case, the Profile Curve Radius also changes.

This exercise demonstrates that if your design process provides you with guidelines for K values or vertical curve length, you can easily edit profile specifications in the Profile Entities table.
7 On the Profile Layout Tools toolbar, click Profile Layout Parameters.

8 In the Profile Entities vista, select row 2. The Profile Layout Parameters dialog box displays the parameters for the first PVI on the profile.

9 With the first PVI clearly visible, click the circular grip at the curve midpoint. The grip turns red, indicating that it can be moved.

10 Move the cursor to a new location closer to or farther from the PVI, then click. The curve moves to pass through the point you clicked. The length of the curve changes. Notice that the affected attributes update in the Profile Entities vista and Profile Layout Parameters window.

Further exploration: Click another grip and move it to a new location. Note how other grips react.

11 Click the triangular grip at the curve midpoint. The grip turns red, indicating that it can be moved.

12 Move the cursor to a new location closer to or farther from the PVI, then click. In the Profile Entities vista, notice which entity’s PVI Elevation updates.

13 Select the row of the entity that you changed. The entity’s attribute values are displayed in the Profile Layout Parameters window.

14 Click the red triangular grip and move it, but do not click a new location.
15 In the Profile Layout Parameters dialog box, double-click the Value cell for the PVI Elevation parameter. Enter a new value and press Enter. The profile line snaps to the elevation you specified.

16 Close the Profile Layout Tools toolbar.
The Panorama window (Profile Entities vista) and Profile Layout Parameters dialog box close.

To continue this tutorial, go to Exercise 3: Copying a Profile and Offsetting it Vertically (page 221).

Exercise 3: Copying a Profile and Offsetting it Vertically

In this exercise, you will copy part of a centerline layout profile. You will use the copy to create a starting line for a ditch profile that is a specified distance below the centerline.

For more information, see the AutoCAD Civil 3D Help topic Copying a Profile.

This exercise continues from Exercise 2: Editing a Layout Profile (page 218).

To copy a profile and offset it vertically

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-2a.dwg.

2 In profile view PV-1, select the red layout profile. Right-click and click Edit Profile Geometry.

3 In the Profile Layout Tools toolbar, click Copy Profile . In the next few steps, you will copy part of the layout profile.

4 In the Copy Profile Data dialog box, under PVI Range, click Station Range. To use more advanced features of the product, you will make the profile copy shorter than the original.
NOTE The station values recommended in steps 5 and 6 have been chosen because in the drawing Profile-2a.dwg, they include the two center tangents of FGProfile - (1). If you are using another drawing with a much different profile, you may have to enter different station values. To be included in the profile copy, a complete tangent must be within the copied range. If part of a tangent extends beyond the range, the whole tangent is excluded from the selection set.

5 In the Start field, enter a value of 300.

6 In the End field, enter a value of 1700.

7 Under Destination Profile Options, select Create New Profile. Click OK. The new profile is drawn on top of the old one.

8 In Toolspace, on the Prospector tab, expand the Profiles collection under the Ridge Road alignment. Your profile copy is displayed with the layout profile icon and the name Layout (2).

9 In the drawing, click the profile view. Right-click and click Profile View Properties.

10 On the Profiles tab, clear the Draw check box for the original layout profile, Layout (1). Clearing the check box removes the original profile from the profile view. Later, you can restore this profile to the profile view if you wish.

TIP Instead of removing Layout (1) from the profile view, you can try selecting Layout (2) to move it. However, the process described here is more reliable with overlapping profiles.

11 Click OK. The Profile View Properties dialog box closes and the profile view is redrawn, showing the copy of part of the layout profile.

12 Click the layout profile.
   The name of the selected profile is displayed in the Profile Layout Tools toolbar. In the next few steps, you will lower the profile copy by 5 feet to represent the elevation of the ditch.

13 On the Profile Layout Tools toolbar, click Raise/Lower PVIs .

14 In the Raise/Lower PVI Elevation dialog box, enter -5 in the Elevation Change field.
In the PVI Range area, select All. Click OK. In both profile views, the line moves to its new position.

This profile copy is a full-featured object that can be edited in the same way as the original layout profile.

Press Esc to deselect the profile.

In the drawing, click the profile view. Right-click and click Profile View Properties.

On the Profiles tab, select the Draw check box for the original layout profile, Layout (1), and clear the check box for the profile copy, Layout (2). Click OK. Clearing the check box removes the copy of the profile from the profile view. Notice that the copy is still displayed in the profile view PV-(2).

To continue to the next tutorial, go to Designing a Profile that Refers to Local Standards (page 223).

**Tutorial: Designing a Profile that Refers to Local Standards**

This tutorial demonstrates how to validate that your profile design meets criteria specified by a local agency.

To create a profile using design criteria, you use the same basic workflow that you use to create a profile without design criteria. During profile creation, you can select a design criteria file, from which you can specify the minimum K tables to which the profile must comply. If the parent alignment also uses design criteria, the design criteria file that is specified for the alignment is applied to the profile by default. You can specify a different design criteria file for the profile, if desired.

The design criteria file specifies minimum K values at given speeds for stopping, passing, and headlight sight distances. You can create custom design checks to validate profile design criteria other than minimum K values. To apply a design check to a profile, you must add it to a design check set.

**NOTE** For detailed exercises on creating design checks and modifying the design criteria file, see the Designing an Alignment that Refers to Local Standards tutorial (page 193).
Exercise 1: Specifying Profile Design Criteria

In this exercise, you will specify minimum standards for a layout profile.

To create a profile using design criteria

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-3.dwg.
2. Click Profiles menu ➤ Create Profile By Layout.
3. Click one of the grid lines to select the profile view.
4. In the Create Profile – Draw New dialog box, accept the default Name. On the General tab, select the following settings:
   ■ Profile Style: Design Profile
   ■ Profile Label Set: <none>
5. On the Design Criteria tab, select the Use Criteria-Based Design check box.
   The Use Design Criteria File, Default Criteria, and Use Design Check Set options are now available. The design criteria file that was selected by default is the same file that was applied to the parent alignment. You may choose to use a different design criteria file for the profile. For this exercise, you will accept the default.
6. In the Use Design Check Set area, click the arrow next to . Click Create New.
   In the next few steps, you will create a new design check set to validate that the sag and crest curves meet a minimum length value.
7. In the Profile Design Check Set dialog box, on the Information tab, for Name, enter Profile Curve Length.

9. In the Design Check table, in the Apply To column, select Crest Curves Only.

10. Repeat Steps 8 and 9 to add the L>=60 curve design check to the design check set. In the Apply To column, select Sag Curves Only.

11. Click OK.

12. In the Create Profile - Draw New dialog box, click OK.

   The Profile Layout Tools toolbar is displayed in the drawing window. You can start drawing the layout profile that refers to the criteria you specified.

To continue this tutorial, go to Exercise 2: Drawing a Profile that Refers to Design Criteria (page 225).

Exercise 2: Drawing a Profile that Refers to Design Criteria

In this exercise, you will draw a profile that refers to specified minimum standards.

You will use the standard profile layout tools to create a profile using the criteria-based design feature.

This exercise continues from Exercise 1: Specifying Profile Design Criteria (page 224).

For more information, see the AutoCAD Civil 3D Help topic Creating Layout Profiles.

To draw a profile that refers to design criteria

NOTE This exercise uses Profile-3.dwg with the modifications you made in the previous exercise.

1. On the Profile Layout Tools toolbar, ensure that Draw Tangents is selected.
In the profile view, snap to the center of each of the blue circles that are labeled A through E. After you click in Circle E, right-click to end the profile.

The layout profile consists of tangents connected at points of vertical intersection (PVIs). Next, you will add curves at each PVI.

**NOTE** For information about using object snaps, see the Using Basic Functionality tutorial (page 12).

On the Profile Layout Tools toolbar, click the arrow next to . Select Free Vertical Curve (Parameter).

On the profile view, click the tangent that enters Circle B on the left (the “first entity”). Click the tangent that exits Circle B on the right (the “next entity”).

On the command line, notice that you can select the parameter that you want to use to define the curve. The displayed value for the selected parameter is the minimum value that will meet the minimum K value that is required by the design criteria file. For this exercise, you will enter values that do not meet the design criteria, and then examine the results.

On the command line, enter R to specify a curve radius. Enter a radius of 500.

The curve is drawn between the tangents, and a warning symbol is displayed. You will learn how to diagnose and correct the violations in Exercise 3: Viewing and Correcting Profile Design Criteria Violations (page 227).

Repeat steps 4 and 5 to add an identical curve to the PVI in Circle C.

On the profile view, click the tangent that enters Circle D on the left (the “first entity”). Click the tangent that exits Circle D on the right (the “next entity”).

Press Enter to accept the minimum radius value that is displayed on the command line.

The curve is drawn at Circle D, but this time no warning symbol is displayed. You can use the command line to quickly apply minimum values to profile entities as you draw them.
9  Right-click to end the command.

To continue this tutorial, go to Exercise 3: Viewing and Correcting Profile Design Criteria Violations (page 227).

Exercise 3: Viewing and Correcting Profile Design Criteria Violations

In this exercise, you will check the profile design for criteria violations, and then learn how to correct violations.

When a profile sub-entity violates a criteria or design check, a warning symbol is displayed on the sub-entity in the drawing window, Profile Entities vista, and Profile Layout Parameters dialog box. When the cursor is hovered over a warning symbol, a tooltip displays information about the violation. If a design criteria has been violated, the tooltip displays the criteria that has been violated, as well as the minimum value that is required to meet the criteria. If a design check has been violated, the tooltip displays the name of the design check that has been violated.

For more information, see the AutoCAD Civil 3D Help topic Viewing and Correcting Profile Design Criteria Violations.

This exercise continues from Exercise 2: Drawing a Profile that Refers to Design Criteria (page 225).

To check the profile design for criteria violations

NOTE This exercise uses Profile-3.dwg with the modifications you made in the previous exercise.

1  Set your drawing window so that you can see Circles B and C on the profile view.

NOTE The warning symbols do not automatically scale when you zoom in. Enter REGEN on the command line to resize the warning symbols.

2  Hover the cursor over the symbol in Circle C.
The tooltips are a convenient way to review design criteria violations in the drawing window. Two violations are displayed in the tooltip:

- First, the curve does not meet the recommended minimum K value for headlight sight distance. The curve K value and minimum acceptable K value are both displayed.
- Second, the curve does not meet the formula specified in one of the design checks. Notice that the name of the design check is displayed, but not the current or recommended values. Values are not displayed because design checks are custom formulas that are created by the user.

**NOTE** If a sub-entity violates multiple criteria or design checks, only a single symbol is displayed on the sub-entity. To clear a symbol from a sub-entity, all the violations must be cleared.

3. If the Profile Layout Tools toolbar is not open, select the red layout profile. Right-click. Click Edit Profile Geometry.

4. On the Profile Layout Tools toolbar, click Entity Based. Click Profile Grid View.

In the Profile Entities vista, in rows 2 and 4, notice that a ⚠ warning symbol appears in the No. column, as well as several other columns. Warning symbols appear next to each value that violates the design criteria that are specified in the design criteria file.

5. In row 2, hover the cursor over the ⚠ warning symbol in the No. column.
Notice that the tooltip displays the design criteria and design checks that have been violated. Notice that while the two curves violate the minimum length specified by the design checks, a warning symbol does not appear in either Length cell. Design checks are custom, mathematical formulas that return either a true or false value. They do not provide feedback other than whether the applicable entities meet or violate the conditions in the design check.

6 On the Profile Layout Tools toolbar, click Profile Layout Parameters.

The Profile Layout Parameters window is displayed, containing no data.

7 In the Profile Entities vista, click row No. 4, which is the curve entity in Circle C.

The design data for the curve entity is displayed in a three-column table in the Profile Layout Parameters window, where data is easy to review and edit.

Notice that in the Profile Layout Parameters window, in the Design Criteria panel, a symbol is displayed next to the design criteria property that has been violated. In the Layout Parameters panel, the Value column displays the actual parameters of each sub-entity. The Constraints column displays the design criteria values that the sub-entities must meet. A symbol is displayed next to the K Value row because the value violates the design criteria. As is true in the drawing window and Profile Entities Vista, the design check that has been violated is displayed, but individual parameters that violate the check are not marked.

To correct design criteria violations

1 In the Profile Layout Parameters window, on the Layout Parameters panel, change the Length Value to 60.000m. Press Enter.

Notice that the warning symbol is cleared from the Design Checks panel, as well as from row 4 in the Profile Entities vista. The new curve length value meets the value specified by the design check. Increasing the curve length also affected the K value, which increased to meet the minimum value for Headlight Sight Distance.

2 In the Profile Entities vista, click row No. 2, which is the curve entity in Circle B.
In the Profile Layout Parameters window, on the Layout Parameters panel, change the Length Value to 30.000m. Press Enter.

The warning symbol is cleared from the Design Checks panel, but not from the K Value row or the Profile Entities vista. The curve still does not meet the minimum K value for passing sight distance, so the warning symbols are displayed. To clear a warning symbol, the entity must meet all values specified in both the design criteria file and the applicable design checks.

**TIP** There are two recommended methods for working around a Minimum K For Passing Sight Distance violation:

- Add a new design speed at the station at which the curve begins. You can do this in the Alignment Properties dialog box, on the Design Criteria tab.

- Designate the station range along curve as a No Passing Zone. This solution does not clear the warning symbol from the drawing, so you should annotate the symbol and No Passing Zone in the final plot.

To continue to the next tutorial, go to Displaying and Modifying Profile Views (page 230).

**Tutorial: Displaying and Modifying Profile Views**

This tutorial demonstrates how to change the appearance of profile views. You may change profile view style, add labels and data bands, split a profile view, and create multiple profile views to suit your production requirements.

The **profile view style** controls the format for titles, axis annotation, and other elements of a profile view.

Multiple profile views are useful for plotting short segments of a profile in separate profile view grids of a consistent length and vertical scale.

A profile can be **split** within either a single or multiple profile view. Splitting a profile allows a profile view to display a profile elevation range that is greater than the profile view’s specified height.
Multiple profile views are most useful when you are creating final construction documents from your design. For best results, design your profile in a single profile view, then use the plan production tools to create multiple profile views.

When you must annotate centerline and offset profiles extensively, you can create stacked profile views, in which each profile line is displayed in a separate profile view grid.

For more information, see the AutoCAD Civil 3D Help topic Working with Profile Views.

**Exercise 1: Editing the Profile View Style**

In this exercise, you will learn how to change the data displayed in a profile view.

You use the Profile View Style dialog box to define profile view styles that control the format for titles, axis annotation, and other elements of a profile view.

The Profile View Properties dialog box is the central location in which you can modify all components of the profile view, including profiles, labels, styles, and data bands.

You can also do some common editing tasks, such as deleting profiles or modifying profile labels, within the drawing window by right-clicking the appropriate object.

For more information, see the AutoCAD Civil 3D Help topic Editing Profile Views.

This exercise continues from the Using Layout Profiles (page 215) tutorial.

**To edit the profile view style**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-4.dwg.

2. Pan and zoom to see a part of the lower profile view, PV- (1), where the profiles are clearly separated.

3. Click the grid to select the profile view. Right-click and click Profile View Properties.

4. Click the Information tab.
5 In the Object Style field, change the profile view style to Major Grids. Click Apply. Notice that this style change affects the X-axis annotation as well as the grid.

6 Click Edit Current Selection.

7 In the Profile View Style dialog box, examine the contents of the various tabs to see the many settings that can be included in a style definition. For example, on the Title Annotation tab, you can change the format and location of the profile view title. On the Display tab, you can turn various parts of the profile view on and off.

8 Click Cancel, and then click OK to close the Profile View Properties dialog box.

9 Zoom out so you can see both profile views. When you applied the Major Grids style, which includes grid padding above and below the profile, PV- (1) enlarged to overlap PV- (2).

10 Click PV- (2) and move it up above the title block for PV- (1).
Now you will edit the Major Grids profile view style to add consistent grid padding, clip the profile view grid, and modify the appearance of the ticks along the axis.

11 Click the PV - (1) grid to select the profile view. Right-click and click Edit Profile View Style.

12 In the Profile View Style dialog box, on the Grid tab, under Grid Padding, change the padding of all four axes to 1.0000.

13 Click Apply. Notice that in the drawing, there is now one full major grid between the profiles and the profile view extents.

14 Under Grid Options, select Clip Vertical Grid and Clip Horizontal Grid. Under both selections, select Omit Grid In Padding Areas.
Notice that the graphics in the dialog box change to demonstrate the effect the setting has on the profile view.

15 Click Apply. Notice that in the drawing, the profile view grid has been removed from above the surface profile and the padding area you specified.
The grid is clipped to the surface profile because the Clip Grid setting in the profile view properties for PV - (1) is set to the centerline surface profile. Setting the profile view style to Clip To Highest Profile(s) would override the property setting and clip the grid to the layout profile.
16 Click OK to close the Profile View Style dialog box.

**NOTE** If the style changes have not been applied to the profile view, enter REGEN at the command line.

17 Pan and zoom to see the lower left corner of the profile view grid. Zoom in so you can clearly see the tick marks on the horizontal and vertical axes.

Notice that the starting station labels overlap. In the next few steps, you will correct the overlap and modify the justification of the ticks at the major stations.

18 Click the grid to select the profile view. Right-click and click Edit Profile View Style.

19 In the Profile View Style dialog box, on the Horizontal Axes tab, click Bottom. This control sets the focus of the controls on this tab to the bottom axis. If, after you have changed the bottom axis, you would like the changes to carry over to the top axis, select Top and repeat the changes.

**NOTE** The bottom axis controls the major and minor grid spacing.

20 Clear the Tick And Label Start Station check box. Click Apply. Notice that the tick and station \(-1+00\) label are removed.

21 On the Vertical Axes tab, make sure Left is selected as the axis to control.

**NOTE** The left axis controls the major and minor grid spacing.

22 In the Major Tick Details area, change the Tick Justification setting to Right and click OK. Notice that the tick marks along the vertical axis are moved to the right side.

**Further exploration:** Experiment with offsetting tick label text using the X Offset and Y Offset settings in the Major Tick Details area. Make the same changes you made in steps 17–22 to the top and right axes.

To continue this tutorial, go to Exercise 2: Working with Profile View Data Bands (page 234).
Exercise 2: Working with Profile View Data Bands

In this exercise, you will modify data bands along the bottom of the profile view.

Data bands can be placed either at the top or bottom of the profile view to annotate profile station and elevation data, vertical or horizontal geometry points, and so on. Data bands can be added to a profile view either as a set or individually.

For more information, see the AutoCAD Civil 3D Help topic Profile Labels and Label Styles.

This exercise continues from Exercise 1: Editing the Profile View Style (page 231).

To add profile view data bands

NOTE  This exercise uses Profile-4.dwg with the modifications you made in the previous tutorial, or you can open Profile-5.dwg from the tutorial drawings folder (page 615).

1  In the drawing window, pan and zoom profile view PV- (1) so you can clearly see the data band along the top of the grid. This band shows the locations of horizontal curves in the parent alignment. Blue vertical lines cross the profile view to mark the start and end of each curve.

2  Pan and zoom so you can see the data band at the bottom of the profile view grid for PV - (1).

3  Select the profile grid. Right-click and click Profile View Properties.

4  In the Profile View Properties dialog box, click the Bands tab.

5  In the Location field, select Bottom Of Profile View.
  In the List Of Bands area, the table lists the data bands in the same order as they appear in the drawing. The existing Profile Data band shows the elevation of the centerline profile at major stations, which are represented by grid lines in the profile view.

6  In the Band Type field, select Horizontal Geometry. Select Curvature in the Select Band Style list and click Add>>. The band is added to the bottom of the list.
7 Click Apply. The horizontal geometry band is added to the bottom of the profile view in the drawing.

The horizontal geometry band you just created is drawn in a different style from the one along the top of the grid. However, both styles show the location of horizontal curves and are labeled with basic engineering data about the curves. These bands are useful for evaluating the design profile from a drainage and safety point-of-view.

8 In the Band Type list, select Profile Data. In the Select Band Style list, select Horizontal Geometry Point Distance. Click Add.

9 In the Geometry Points To Label In Band dialog box, you can specify the individual horizontal and vertical geometry points to label using the current style. Click OK.

NOTE For more information on geometry point labeling, see the Adding Labels in Groups tutorial exercise (page 543).

10 Click Apply.

The new data band is displayed at the bottom of the stack of data bands. This data band labels the incremental distance between the horizontal geometry points of the parent alignment.

11 In the table of bands list, select the Profile Data band at the top of the list. Click twice, then click Apply. The Profile Data band moves to the bottom of the stack of data bands.

12 In the List Of Bands area, note the location of the two Profile Data bands. Scroll to the right and change both Profile1 settings to the new layout profile, Layout (1). Now, the Profile Data band shows elevations of both the existing ground and finished grade profile at each major station. The Horizontal Geometry Point Distance band displays the finished ground elevation at each horizontal geometry point.

13 Click the Horizontal Geometry band. Click to move this band to the bottom.

14 In the Band Type field, select Vertical Geometry. Set the band style to Geometry and click .

15 For the Vertical Geometry band, change the Profile1 setting to Layout - (1). Now, this band shows the length of each grade segment along the layout profile.
16 Click OK, then set your display to see the data bands below the profile view.
This arrangement of bands is convenient for analysis. It displays vertical geometry next to horizontal geometry. It also shows comparative elevation data for the surface profile and the layout profile.
Notice that in the bottom, Vertical Geometry band, the labels in the uphill tangents are obscured by the tangents. You will correct this in the following steps.

To modify a data band style
1 Select the profile grid. Right-click and click Profile View Properties.
2 In the Profile View Properties dialog box, click the Bands tab.
3 In the Location field, select Bottom Of Profile View.
4 Click next to Geometry in the Vertical Geometry Band Type.
5 In the Pick Band Style dialog box, click Edit Current Selection.
6 In the Vertical Geometry Band Style dialog box, on the Band Details tab, in the Labels and Ticks area, the At field indicates which type of band labeling has the focus of the editing tools. Make sure that Uphill Tangent is selected.
7 In the Labels and Ticks area, click Compose Label.
The Label Style Composer dialog box contains the controls for creating and editing label components. Notice the many controls that are available for band label format.
8 In the Text collection, change the Attachment value to Bottom Center.
9 Click OK to close the Label Style Composer, Vertical Geometry Band Style, and Pick Band Style dialog boxes.
10 In the Profile View Properties dialog box, click Apply. Notice that in the drawing, the position of the data band’s crest curve label has changed.
**Further Exploration:** Change the label position for the downhill tangents and sag and crest curves using steps 16 through 22.

To continue this tutorial, go to Exercise 3: Splitting a Profile View (page 237).
Exercise 3: Splitting a Profile View

In this exercise, you will split a profile view so that a layout profile's full elevation range fits in a shorter profile view.

For more information, see the AutoCAD Civil 3D Help topic Working with Profile Views.

This exercise continues from Exercise 2: Working with Profile View Data Bands (page 234).

To split a profile view

NOTE This exercise uses Profile-5.dwg with the modifications you made in the previous tutorial, or you can open Profile-6.dwg from the tutorial drawings folder (page 615).

1 Click Profiles menu ➤ Create Profile View.

2 In the Create Profile View wizard, on the General page, under Select Alignment, select Ridge Road.

3 Under Profile View Style, select Standard.

4 On the left side of the wizard, click Profile View Height.

5 On the Profile View Height page, under Profile View Height, select User Specified. The Minimum and Maximum boxes and the Split Profile View check boxes are now available.

6 In the Maximum field, enter 670.00'.

7 Select the Split Profile View check box. The split profile view controls are now available. These controls allow you to select separate profile view styles for the first, intermediate, and last segments of the split profile view. For this exercise, accept the default split profile view settings.

8 Click Next to display the Profile Display Options page.

9 On the Profile Display Options page, clear the Draw check boxes for all profiles except EG - Surface (1) and Layout (1). In the Layout (1) row, select the Split At option. This option specifies that the split occurs at the appropriate elevation of the layout profile and ensures that the entire layout profile will appear in the profile view.

10 Scroll to the right until the Labels column is visible. In the EG - Surface (1) row, click the Labels cell.
11 In the Pick Profile Label Set dialog box, select <None> from the list and click OK.

12 Click Create Profile View.

13 When prompted, pan and zoom to a clear area in the drawing window, then click to create the profile view.
A new profile view is created. Notice that because you specified a shorter maximum height in step 6, the profile view grid is shorter than the other two profile views in the drawing. In order to fit the profile in the shorter grid, the profile has been split into two segments. The full length and elevations of the red, layout profile are visible because you set the Split At setting to Layout (1) in step 9. Notice that there is a vertical axis in the middle of the profile view that displays the elevations for both split segments.

14 In Toolspace, on the Prospector tab, expand the Alignments, Ridge Road, and Profile Views collections. Notice that a single new profile view (PV - (3)) was created.

15 On the Prospector tab, right-click PV - (3) and select Properties.

16 In the Profile View Properties dialog box, on the Elevations tab, under Elevation Range, change the Height to 20.000'.

17 Click Apply. Notice that in the drawing window, the profile view has been split into four segments to accommodate the new height.
Now you will change the style of the first and last profile view segments.

18 In the Profile View Properties dialog box, in the Split Profile View Data table, in the No. 1 row, click in the Profile View Style column.

19 In the Pick Profile View Style dialog box, select Left & Bottom Axis from the list and click OK.

20 Repeat steps 18 and 19 to change the Profile View Style in row No. 4 to Full Grid.

21 Click OK. Three different profile view styles are displayed in the single profile view grid. While a split profile is displayed in a single profile view grid, it may have separate styles applied to each of its split segments.

To continue this tutorial, go to Exercise 4: Creating Multiple Profile Views (page 239).
Exercise 4: Creating Multiple Profile Views

In this exercise, you will produce a set of profile views to display short, successive segments of a profile.

Multiple profile views are most useful when you are creating final construction documents from your design. For best results, design your profile in a single profile view, then use the plan production tools to create multiple profile views for plotting or publishing. During the plan production process, you create sheets that display sections of alignments and profiles.

In this exercise, you will bypass the plan production tools to create multiple profile views in a currently open drawing. You will use the Create Multiple Profile Views wizard, which allows you to quickly specify the profile view properties before you create them. If you access this wizard during the plan production process, many of the properties are not available because they are already set in the **view frame group**.

For more information, see the AutoCAD Civil 3D Help topic *Working with Profile Views*.

For a tutorial that demonstrates the plan production tools, go to *Plan Production Tutorials* (page 605).

This exercise continues from *Exercise 3: Splitting a Profile View* (page 237).

To create multiple profile views

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the **tutorial drawings folder** (page 615). Open the drawing *Profile-7.dwg*. Notice that the drawing contains two roads, Maple Road and Oak Road, and a single profile view of Oak Road.

2. Click Profiles menu ➤ Create Multiple Profile Views.

3. In the Create Multiple Profile Views wizard, on the General page, under Select Alignment, select Oak Road.


5. Click Next to open the Station Range page. This page allows you to specify the station range for the profile, as well as the length of each profile view.

6. In the Length of Each View box, enter 500.00’.

7. Click Next to open the Profile View Height page. Under Profile View Height, select User Specified. Selecting this option makes the height box and the Split Profile View controls available.
8 In the User Specified field, enter 50.00’.

9 In the Profile View Datum By list, select Mean Elevation.
This option specifies that the profile lines will be positioned in the profile based on the mean of the highest and lowest elevation value of the profiles that are drawn in the grid. This option provides an equal amount of space above and below the profile lines. This option is useful when you have to annotate a profile that has fairly consistent elevation values.

10 Select the Split Profile View check box. This option makes the split profile view controls available, which allow you to select separate profile view styles for the first, intermediate, and last segments of any split profile views. For this exercise, accept the default split profile view settings.

11 Click Next to open the Profile Display Options page. Ensure that the Draw check box is selected for both profiles. In the Oak Road - Proposed row, select the Split At option. This option specifies that if the profiles contained in the profile view must be split to fit in the specified profile view height, the split will occur at the appropriate elevation of the layout profile. This option ensures that the entire layout profile appears in the profile view.

12 Click Next to open the Pipe Network Display page. You can use this page to select the pipe network or parts that you want to display in the profile view. For this exercise, you will not display any pipe network parts.

13 Click Next to open the Data Bands page. Under Select Band Set, select the EG-FG Elevations and Stations band set.

14 Click Next to open the Multiple Plot Options page. Set Maximum in a Row to 4. Accept the other default settings on this page.

15 Click Create Profile Views.

16 When prompted, pan and zoom to a clear area in the drawing window, then click to create the profile views.

17 In Toolspace, on the Prospector tab, expand the Alignments, Oak Road, and Profile Views collections. Notice that a separate profile view was created for each 500.00’ segment.

To continue this tutorial, go to Exercise 5: Creating Stacked Profile Views (page 241).
Exercise 5: Creating Stacked Profile Views

In this exercise, you will create a series of three profile views that contain a centerline and left and right offset profiles.

Stacked profile views are a collection of related profiles that are drawn in separate, vertically arranged profile views. When each profile is displayed on its own profile view grid, more space is available to annotate each profile.

For more information, see the AutoCAD Civil 3D Help topic Working with Profile Views.

This exercise continues from Exercise 4: Creating Multiple Profile Views (page 239).

To create stacked profile views

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Profile-8.dwg. The drawing contains an existing ground surface, several alignments, and a profile view. The profile view contains centerline and left and right offset profiles.
edge of pavement (EOP) profiles of the alignment that travels from North to South along the West side of the site. Because the profiles are crowded in the profile view, you will create a series of stacked profile view so that you can see the profiles clearly and have ample room for annotation.

2 ClickProfiles menu ➤ Create Profile View.

3 In the Create Profile View wizard, on the General page, under Select Alignment, select North-South Road.

4 Select the Show Offset Profiles By Vertically Stacking Profile Views option. The graphic at the bottom of the page changes color to indicate that the option is active.

**NOTE** The Profile View Style setting on this page is not used. You will assign separate styles for each profile view in the stack.

5 On the left side of the Create Profile View wizard, click Stacked Profile.

6 On the Stacked Profile page, select the following settings:
   ■ Number Of Stacked Views: 3
   ■ Gap Between Views: 0
   ■ Top View Style: Stacked - Top
   ■ Middle View Style: Stacked - Middle
   ■ Bottom View Style: Stacked - Bottom

**NOTE** The Gap Between Views value is measured in drawing units. A positive value adds space between the profile view grids. A negative value causes the profile view grids to overlap.

7 Click Next.

8 On the Profile Display Options page, in the Select Stacked View To Specify Options For list, ensure that Middle View is selected.

**NOTE** The number of views that is visible in this list depends on the value you specified for Number Of Stacked Views in Step 6.

9 In the Specify Profile Display Options table, select the Draw check box for both the EG Centerline and Centerline profiles.
In the Select Stacked View To Specify Options For list, select Top View.

In the Specify Profile Display Options table, select the Draw check box for the EG Left Offset and EOP Left profiles.

In the Select Stacked View To Specify Options For list, select Bottom View.

In the Specify Profile Display Options table, select the Draw check box for the EG Right Offset and EOP Right profiles.

Click Next.

On the Pipe Network Display page, in the Select Stacked View To Specify Options For list, select Bottom View. Most of the pipe network is on the right-hand side of the alignment. You will specify that the pipe network components will be displayed in the profile view that displays the right EOP profiles.

In the Select Pipe Network Parts To Draw In Profile View area, select the Select check box. In the Name column, expand the Network - (1) pipe network. Clear the check boxes for W-E Pipe - (1), W-E Pipe - (2), W-E Structure - (1), and W-E Structure - (2). These parts are a branch of the pipe network that follow the West-East alignment.

In the Select Stacked View To Specify Options For list, select Middle View. In the Select Pipe Networks To Draw In Profile View list, select the Select check box. Clear all check boxes except W-E Pipe - (1), W-E Pipe - (2), W-E Structure - (1), and W-E Structure - (2).

In the Select Stacked View To Specify Options For list, select Top View. In the Select Pipe Networks To Draw In Profile View list, select the Select check box. Clear all check boxes except W-E Pipe - (1), W-E Pipe - (2), W-E Structure - (1), and W-E Structure - (2).

Click Create Profile View.

In the drawing, pan to the clear area at the right of the surface. Click to place the profile views.

In Toolspace, on the Prospector tab, expand the Alignments ➤ Road: North-South ➤ Profile Views collection. Notice that three separate profile views were created.
These tutorials will get you started creating and editing parcels.

Parcel objects in AutoCAD Civil 3D are typically used to represent real estate parcels, such as lots in a subdivision.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Parcels*.

**Tutorial: Creating Parcels**

This tutorial demonstrates the main methods for creating parcels.

You can create parcels either from drawing objects, such as lines, arcs, or polylines, or by using the parcel layout tools. Parcels can also be created automatically by the interaction of alignments and other parcels within a site. To prevent alignments from creating or interacting with parcels, place the alignments in the top-level Alignments collection, which is outside of all sites.

Parcels are contained in a parcels collection, which in turn is contained by a site. Each site can include only one parcels collection, but a parcels collection can include any number of parcels.

For more information, see the AutoCAD Civil 3D Help topic *Creating Parcels*. 
**Exercise 1: Creating Parcels from AutoCAD Objects**

In this exercise, you will convert AutoCAD entities to land parcels with automatic labels that show useful topological data, such as land area.

For more information, see the AutoCAD Civil 3D Help topic *Creating Parcels from Objects*.

**To create parcels from existing AutoCAD objects**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Parcel-IA.dwg. This drawing contains AutoCAD lines and arcs from which you can define parcels.

2. Select the lines that form the road edges. You can select them by drawing a selection rectangle around the roadway.

3. Click Parcels menu ➤ Create Parcel From Objects.

4. In the Create Parcels – From Objects dialog box, select the following entries:
   - Site: Subdivision A
   - Parcel Style: Road (Local)
   - Area Label Style: Standard
NOTE Parcels must have area labels, but segment labels are optional. You can label parcel segments as you create them by selecting the Automatically Add Segments check box, or later. For more information about annotating parcels and other AutoCAD Civil 3D objects, see the Labels and Tables Tutorials (page 537).

Use the default values for the other fields.

5 Click OK. The road parcel is created and labeled.

6 On the Toolspace Prospector tab, expand Sites ➤ Subdivision A ➤ Parcels until you can see the individual parcel.

The parcel name includes its style type, Road (Local), and a unique number (100).

In the next few steps, you will create the property parcels.

7 Select all the lines that form the property edges. You can select them either by drawing a selection rectangle that surrounds all the properties, or by clicking individual lines.

8 Click Parcels menu ➤ Create Parcel From Objects.
9 In the Create Parcels – From Objects dialog box, select the following values:

- Site: Subdivision A
- Parcel Style: Single-Family
- Area Label Style: Standard

Use the default values for the other fields.

10 Click OK. The parcels are created and automatically labeled.

11 On the Toolspace Prospector tab, expand Sites ➤ Subdivision A ➤ Parcels until you can see the individual parcels.

**NOTE** If the Parcels node has a ⌴ next to it, right-click the icon. Click Refresh.

12 Right-click SINGLE-FAMILY: 103. Click Zoom To.

The drawing area zooms to the parcel.

To continue this tutorial, go to Exercise 2: Creating Individual Parcels by Layout (page 248).

### Exercise 2: Creating Individual Parcels by Layout

In this exercise, you will use two methods to subdivide an existing parcel.

For more information, see the AutoCAD Civil 3D Help topic *Creating Parcels by Layout*.

**NOTE** Turn off OSNAP and OTRACK for this exercise.

This exercise continues from Exercise 1: Creating Parcels from AutoCAD Objects (page 246).

**To create individual parcels by layout**

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing *Parcel-IB.dwg*.

2 Click Parcels menu ➤ Create Parcel By Layout.

3 On the Parcel Layout Tools toolbar, click .
4 Select the following settings for parcel creation:
   ■ Default Area: 5000 sq. ft.
   ■ Minimum Frontage: 20'
   ■ Automatic Mode: Off
   ■ Snap Increment: 1000 sq. ft.

Leave other settings at their default values.

5 Click to collapse the Parcel Layout Tools toolbar.

6 Click (Slide Angle – Create).

7 In the Create Parcels – Layout dialog box, click Single-Family from the Parcel Style list. Leave other settings at their default values. Click OK.

8 Click inside the parcel to be subdivided, Single-Family: 101.

9 Select a start point on the frontage, on the curve on the lower left side of the parcel.

10 Select an end point on the frontage, on the curve on the lower right side of the parcel.

11 Enter a frontage angle of 90 degrees. With this setting, the new lot line will be perpendicular to the frontage.

A lot line is drawn across Parcel 101.
12 Use the cursor to slide the lot line to the right and left. Notice that it snaps to area increments of 1000 square feet. The length of frontage is also displayed.

13 Place the lot line to enclose an area of 8000 square feet, then click. The new parcel is created and labeled.

14 Enter the frontage angle of 90 degrees, then create another parcel of 8000 square feet.

15 End the command by pressing Esc twice.

16 On the Parcel Layout Tools toolbar, click (Swing Line – Create).

17 Follow the command-line prompts to select a point within the parcel to be subdivided, the large parcel on the right. Pick start and end points along the road frontage, and then pick a swing point along the back line.

18 Slide the cursor along the back lot line. Click to choose a swing point for the new lot line.

19 Using the cursor, swing the new lot line to see the options for location, then choose a location and click. The new parcel is created and labeled.

To continue this tutorial, go to Exercise 3: Creating Multiple Parcels by Layout (page 250).

**Exercise 3: Creating Multiple Parcels by Layout**

In this exercise, you will use the slide angle method to create a series of parcels.
For more information, see the AutoCAD Civil 3D Help topic *Creating Parcels by Subdividing*.

This exercise continues from *Exercise 2: Creating Individual Parcels by Layout* (page 248).

**To create multiple parcels by layout**

**NOTE** This exercise uses *Parcel-1B.dwg* with the modifications you made in the previous exercise.

1. Click Parcels menu ➤ Create Parcel By Layout.

2. On the Parcel Layout Tools toolbar, click 📊.

3. Select the following settings for parcel creation:
   - Default Area: 7000 sq. ft.
   - Minimum Frontage: 40’
   - Automatic Mode: On
   - Snap Increment: 1000 sq. ft.

   Leave other settings at their default values.

4. On the Parcel Layout Tools toolbar, click 📊 (Slide Angle – Create).

5. In the Create Parcels – Layout dialog box, click Single-Family in the Parcel Style list. Leave other settings at their default values. Click OK.

6. Click inside the Single-Family: 109 parcel, which is the large parcel on the South side of the site.

7. Select a start point on the frontage, on the curve on the upper left side of the parcel.

8. Select an end point on the frontage, on the curve on the upper right side of the parcel.
9 Enter a frontage angle of 90 degrees. With this setting, the new lot line will be perpendicular to the frontage.

10 Press Enter to accept the default area of 7000 square feet.
A series of four new parcels is created and labeled. Notice that the last parcel encloses a larger area than 7000 square feet. This area is larger because the Remainder Distribution setting on the Parcel Layout Tools toolbar places the remaining area in the last parcel. Other options for this setting are to create a separate parcel with the remainder, or to distribute it across the other parcels in the series.

11 End the command by pressing Esc twice.

To continue this tutorial, go to Exercise 4: Working with Alignments and Parcels (page 252).

Exercise 4: Working with Alignments and Parcels

In this exercise, you will create an alignment outside of a site and move existing alignments out of sites. These practices eliminate unwanted parcels being created by alignments interacting with a site.

When an alignment is in a site, it creates new parcels if it forms closed areas by crossing over itself or other alignments or parcels on the same site.

For more information, see the AutoCAD Civil 3D Help topic Understanding Sites.
To work with alignments and parcels

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Parcel-1C.dwg. This drawing contains five roads off of a main West-East road. The two Northern side roads have centerline alignments, each of which created a parcel in the roadway and cul-de-sac center island. In the next few steps, you will convert the centerline of one of the Southern side roads to an alignment and prevent it from forming parcels.

2. In Toolspace, on the Prospector tab, expand Sites ➤ Site 1 ➤ Alignments. Notice that the four existing centerline alignments all reside in Site 1, while the top-level Alignments collection (above the Sites collection) is empty.

3. Click Alignments menu ➤ Create Alignment From Polyline.

4. When prompted, select the red centerline for the road in the lower middle of the drawing.

5. In the Create Alignment - Layout dialog box, accept the default name and select the following settings:
   - Site: <None>
   - Alignment Style: Standard
   - Alignment Label Set: Major & Minor - Parallel

6. Click OK to create the alignment. Expand the top-level Alignments collection in Prospector.
   Notice that the new alignment was placed in the Alignments collection, and did not form a parcel in the cul-de-sac center island. This happened because you selected <None> when you were prompted to select a site in step 5. In the next few steps, you will move one of the two existing cul-de-sac road alignments out of its existing site and into the top-level Alignments collection.

7. In Toolspace, on the Prospector tab, right-click Alignment - (4), which is the cul-de-sac alignment to the Northeast of the alignment you created in step 6. Click Move To Site.

8. In the Move To Site dialog box, make sure that the Destination Site is set to <None>, then click OK.

Exercise 4: Working with Alignments and Parcels | 253
Notice that in Toolspace on the Prospector tab, Alignment - (4) has moved to the top-level Alignments collection. In the drawing window, the parcel label and hatching has been removed from the cul-de-sac center island.

**Further Exploration**: Repeat steps 7 and 8 to move Alignment - (3) to the top-level Alignments collection.

9 Close Parcel-1C.dwg.

To continue to the next tutorial, go to Editing Parcel Data (page 254).

**Tutorial: Editing Parcel Data**

This tutorial demonstrates two ways of resizing a parcel by moving a lot line. The tools that you use to edit a parcel lot line depends on whether the lot line is attached.

An attached lot line is a parcel segment that was created with the slide angle, slide direction, and swing line precise sizing tools on the Parcel Layout Tools toolbar. You can use the slide angle, slide direction, and swing line precise editing tools to edit only attached lot lines. In this tutorial, you will learn how to use two precise editing tools:

- The *Slide Angle – Edit* tool slides a lot line at a specified angle through a selected parcel until a target area is enclosed.
The Swing Line – Edit tool swings a lot line from a specified point through a selected parcel until a target area is enclosed.

If a lot line is created either from other AutoCAD Civil 3D objects or the fixed line and curve tools on the Parcel Layout Tools toolbar, it is not attached. You can use grips and the feature line editing tools to change the geometry of these lot lines.

For more information, see the AutoCAD Civil 3D Help topic Editing Parcels.

Exercise 1: Slide Angle Editing of Parcel Size

In this exercise, you will use the slide angle tool to resize a parcel.

For more information, see the AutoCAD Civil 3D Help topic Creating Parcels by Subdividing.

To modify a parcel using the slide angle tool

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Parcel-2.dwg.

2. Click Parcels menu ➤ Create Parcel By Layout.

3. In the Parcel Layout Tools toolbar, click (Slide Angle – Edit) in the list.

   You are prompted to select the attached lot line to adjust.

   An attached lot line is one that was created with the slide angle, slide direction, and swing line precise sizing tools available on the Parcel Layout Tools toolbar. You can use the slide angle, slide direction, and swing line precise editing tools to edit only attached lot lines. You will learn how to edit lot lines created using other methods in Exercise 3: Editing Parcel Lot Lines with the Feature Line Editing Tools (page 257).

4. In the drawing area, click the lot line that runs between parcel 101 and parcel 102.

5. Press Enter to accept the default angle.

6. Select the parcel to adjust by moving the cursor over property 102. The parcel borders are highlighted. Click inside the parcel.

7. At the command line, enter 6000 as the desired area.
8 Specify the search region by clicking along the bottom of the parcel, where the sliding lot line is perpendicular to the road edge.

Parcel 102 is resized to an area of 6000 square feet.

9 Press Enter to end the command.

To continue this tutorial, go to Exercise 2: Swing Line Editing of Parcel Size (page 256).

Exercise 2: Swing Line Editing of Parcel Size

In this exercise, you will use the swing line tool to resize a parcel.

For more information, see the AutoCAD Civil 3D Help topic Creating Parcels by Subdividing.

This exercise continues from Exercise 1: Slide Angle Editing of Parcel Size (page 255).

To modify a parcel using the swing line tool

NOTE This exercise uses Parcel-2.dwg with the modifications you made in the previous exercise.

1 Click Parcels menu ➤ Create Parcel By Layout.

2 In the Parcel Layout Tools toolbar, click (Swing Line – Edit). You are prompted to select the attached lot line to adjust.
In the drawing area, click the lot line that runs between parcel 103 and parcel 104.

Select the parcel to adjust by moving the cursor over property 103 and clicking. Notice that the parcel borders are highlighted.

At the command line, enter 7000 as the desired area.

Move the cursor to swing the lot line, then specify the search region by clicking in the adjacent parcel (104).

Parcel 103 is resized to an area of 7000 square feet.

Press Enter to end the command.

Press Esc to exit the parcel editing tools.

To continue this tutorial, go to Exercise 3: Editing Parcel Lot Lines with the Feature Line Editing Tools (page 257).

**Exercise 3: Editing Parcel Lot Lines with the Feature Line Editing Tools**

In this exercise, you will use the feature line editing tools to modify parcel lot line geometry.

Exercise 3: Editing Parcel Lot Lines with the Feature Line Editing Tools | 257
You will use two different methods to change the geometry of the two large parcels at the end of the cul-de-sac.

First, you will learn about the grips that are available on lot lines. You will use lot line grips with the feature line tools to change the geometry of a parcel.

Second, you will join two separate lot lines, and then remove a point of intersection from the combined lot line.

For more information, see the AutoCAD Civil 3D Help topic Editing Parcels.

This exercise continues from Exercise 2: Swing Line Editing of Parcel Size (page 256).

To add points of intersection and grip edit parcel lot lines

NOTE This exercise uses Parcel-2.dwg with the modifications you made in the previous exercise.

1 In the drawing, select the lot line that separates parcel 102 and 103.
   Notice the blue grip on the lot line. This grip is available on attached lot lines, which are created with the slide angle, slide direction, and swing line precise sizing tools available on the Parcel Layout Tools toolbar. You can use this grip to slide the lot line along the lot line to which it is attached.

2 Press Esc to deselect the lot line.

3 Select the lot line that separates parcel 105 and 106.
   Notice the black grips on the ends of the lot line. These grips are available on lot lines that were created either from other AutoCAD Civil 3D objects or the fixed line and curve tools available on the Parcel Layout Tools toolbar. You can use these grips to change the endpoint location of a lot line.

4 Press Esc to deselect the lot line.

5 Click Parcels menu ➤ Edit Parcel. Notice that many of the same tools that are used to edit survey figures and feature lines are available in this menu. Click ➤ Insert PI.

6 Select the back lot line that is shared by parcels 106 and 107.
Triangles are displayed on the existing points of intersection. A green triangle that indicates the location of a new point of intersection is displayed under the selection cross hairs.

7 In the drawing window, snap to the intersection of the back lot line and the lot line that separates parcels 106 and 107. Click to insert a point of intersection.

8 Press Enter to accept the default elevation of 0.

9 Press Esc twice to end the command.

The back lot line now has a point of intersection at the point at which the parcels meet. With a PI in this location, you can edit the lot line on one of the parcels without affecting the other.

10 Select the back lot line of parcel 106. Click the grip at the top of the lot line. Drag the grip toward the lot line that separates parcels 105 and 106. Snap to the intersection of the three lot lines. Click to place the grip.
Notice that the area of parcel 106 has changed. However, there is now an unnecessary lot line remaining to the North of the parcel. You will delete the unnecessary portion of that lot line in the following steps.

11 Click Parcels menu ➤ Edit Parcel ➤ Trim.

12 Select the back lot line of parcel 106 as the cutting edge. Press Enter.

13 Select the lot line that extends past parcel 106 as the object to trim.
14 Press Enter to end the command.

To join parcel lot lines and remove points of intersection

1 Click Parcels menu ➤ Edit Parcel ➤ Break.
2 Select the back lot line that is shared by parcels 107 through 112.
3 On the command line, enter F to specify the first point to break.
4 In the drawing window, snap to the intersection of the back lot line and the lot line that separates parcels 107 and 108. Click the intersection.
5 Press Enter.
   Two lot lines are created, separated at the point you specified.

6 Click Parcels menu ➤ Edit Parcel ➤  . Join.

7 In the drawing, click the two lot lines that form the Southeast corner of parcel 107.

8 Press Enter.
   The two lot lines are now a single entity. Next, you will remove the point of intersection between the two lot lines.

9 Click Parcels menu ➤ Edit Parcel ➤  . Delete PI.

10 In the drawing, select the lot line that forms the South and East boundaries of the parcel.
    Triangles are displayed at each point of intersection (PI) of the lot line.

11 Click the green PI at the Southeast corner of parcel 108.
12  Press Enter twice to end the command.

To continue to the next tutorial, go to Displaying and Analyzing Parcels (page 263).

**Tutorial: Displaying and Analyzing Parcels**

This tutorial demonstrates using parcel styles and display order to control the appearance of parcels, and exporting reports to analyze parcel data.

The parcel *display order*, which is set in the Site Parcel Properties dialog box, controls the display of shared parcel segments. The different styles of parcels in a drawing are drawn in a specified order that you can control. Where two styles of parcels share a common segment, the displayed color of the segment is determined by the parcel style that is drawn last.

AutoCAD Civil 3D allows you to export inverse or map check reports for either a single parcel, a series of parcels, or all parcels in a site.

For more information, see the AutoCAD Civil 3D Help topics *Parcel Styles*, *Parcel Properties*, and *Exporting a Parcel Inverse or Mapcheck Report*. 
For a tutorial on using the AutoCAD Civil 3D survey tools to perform a mapcheck analysis, see the Outputting Survey Information (page 143).

**Exercise 1: Changing Parcel Style Display Order**

In this exercise, you will control the display of overlapping parcel lines. Parcel style display order in AutoCAD Civil 3D controls which lot lines are visible where different types overlap.

For more information, see the AutoCAD Civil 3D Help topic *Changing Parcel Display Order*.

**To change parcel style display order**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Parcel-3.dwg.

2. In Toolspace, on the Prospector tab, expand the Sites ➤ Site 1 collection. Right-click the Parcels collection. Click Properties. In the Parcel Style Display Order area, note that Single-Family parcels have the highest display order, which explains why their lines cover the Standard lines.

3. In the Parcel Style Display Order list, select Standard and click to move it to the top of the stack.

4. Click Apply. After the model regenerates, notice that the blue Standard lot lines have overwritten the pink ones for Single-Family lots.

5. Repeat Steps 3 and 4, but give the Property style the highest display order. This setting displays a light blue line around the extents of the site. **Further exploration:** Change the display order again, moving the Road (Local) parcels to the top of the display order, then moving them to a position between Standard and Single-Family. These settings change the display of the curved road edges.

6. In the Site Parcel Properties dialog box, click OK.

To continue this tutorial, go to Exercise 2: Exporting Parcel Data (page 265).
Exercise 2: Exporting Parcel Data

In this exercise, you will generate a mapcheck report for the parcels in the residential road at the top right of the drawing.

In AutoCAD Civil 3D you can export inverse or mapcheck reports for either a single parcel, a series of parcels, or all parcels in a site.

For more information, see the AutoCAD Civil 3D Help topic Exporting a Parcel Inverse or Mapcheck Report.

This exercise continues from Exercise 1: Changing Parcel Style Display Order (page 264).

To export parcel data

NOTE This exercise uses Parcel-3.dwg with the modifications you made in the previous exercise.

1. On the Toolspace Prospector tab, expand Sites ➤ Site 1 ➤ Parcels.
2. In the list view below the Prospector tree, click the heading of the Number column to sort the parcels by number.
3. Select parcel numbers 120 through 136. Parcel number 136, STANDARD: 131, represents the road on which the parcels are located. Ctrl+click parcel number 136 in the list view to deselect it and exclude it from the analysis.
4. In the list view, right-click and select Export Analysis.
5. In the Export Parcel Analysis dialog box, specify the following settings:
   - Destination File: Click and navigate to the My Civil 3D Tutorial Data folder (page 615). Name the file ExportAnalysis.txt.
   - Analysis Type: Mapcheck Analysis
6. Click OK.

The ExportAnalysis.txt file automatically opens in the text editor associated with AutoCAD Civil 3D and is saved in the location you specified in step 5.

NOTE If the file does not automatically open, open it from the My Civil 3D Tutorial Data folder (page 615).
Grading Tutorials

These tutorials will get you started with adjusting grading settings, creating gradings, and editing gradings to balance cut and fill volumes.

A grading object in AutoCAD Civil 3D, like an alignment or a surface, has its own properties and behaviors.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Grading Objects*.

**Tutorial: Setting up Grading Standards**

This tutorial demonstrates how to adjust grading settings, criteria, and styles.

Grading settings are used for managing the work environment and specifying the units for grade and slope values.

There are many common grading situations. For example, you may frequently need to create grading with a slope of 3:1 and a target of a relative elevation. By defining a grading criteria with these settings and saving it, you can easily apply these same criteria to other gradings.

Grading styles control the display of each grading component. You can create different styles to use for different types of gradings. For example, you can create styles to display different colors for cut and fill slopes.

For more information, see the AutoCAD Civil 3D Help topics *Using Grading Criteria* and *Using Grading Styles*. 
Exercise 1: Reviewing Grading Settings

In this exercise, you will learn how to use grading settings.

For more information, see the AutoCAD Civil 3D Help topic Changing Grading Settings.

To review grading settings

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615) and open the drawing Grading-1.dwg.

2. In Toolspace, on the Settings tab, right-click Grading ➤ Edit Feature Settings.

3. In the Edit Feature Settings dialog box, expand the General collection.

4. In the Save Command Changes To Settings property, verify that the value is set to Yes.
   This setting saves command settings for reuse. For example, if you create a grading and set the grade to 5%, then 5% is the default value the next time you create a grading.

5. Expand the collections for Grade, Slope, and Grade/Slope.
   Notice the options for unit format and precision. The integer value for precision specifies the number of digits to the right of the decimal place.

6. Click OK.

To continue this tutorial, go to Exercise 2: Creating Grading Criteria (page 268).

Exercise 2: Creating Grading Criteria

In this exercise, you will create a grading criteria set for a ditch grading, then create three criteria in the set.

Each grading criteria provides a standard formula for creating a graded slope. Individual criteria values can be locked so that they cannot be changed for individual gradings.

For more information, see the AutoCAD Civil 3D Help topic Using Grading Criteria.
This exercise continues from Exercise 1: Reviewing Grading Settings (page 268).

To create a criteria set and criteria

NOTE This exercise uses Grading-1.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, expand the Grading collection.
2. Expand the Grading Criteria Sets collection.
   The Grading Criteria Sets collection displays the existing grading sets for the drawing. You will create a new grading criteria set then create two new criteria within the new set.
4. In the Grading Criteria Set Properties dialog box, enter Ditch Criteria Set in the Name field, and optionally enter a description.
5. Click OK. The new criteria set is displayed in the Grading Criteria Sets collection.
7. In the Grading Criteria dialog box, click the Information tab.
8. In the Name field, enter Distance @ -6%.
   This criteria creates a grade to a distance of 10 feet at -6% grade.
9. Click the Criteria tab and set the following values:
   ▪ Target: Distance
   ▪ Distance: 10.000'
   ▪ Projection: Slope
   ▪ Format: Grade
   ▪ Grade: -6.000%
10. For the Grade parameter, click \( \hat{\text{g}} \) to change it to \( \hat{\text{g}} \). When you lock a grade value in a grading criteria, you are not prompted to specify its value each time you use the criteria.
11. Click OK.
12 Create another criteria by repeating steps 6 through 9. However, use the name Surface @ 4-1 Slope and set the following values for the criteria:

- **Target:** Surface
- **Projection:** Cut/Fill Slope
- **Search Order:** Cut First

Set the following values for both the Cut Slope Projection and Fill Slope Projection property groups:

- **Format:** Slope
- **Slope:** 4:1

This criteria creates a grade to an existing surface at a 4-to-1 slope. In the next few steps, you will create another grading criteria by copying an existing one.

13 Click OK to close the Grading Criteria dialog box.

14 In the Grading Criteria Sets collection, expand the Basic Set. Right-click the Relative Elevation @ Slope criteria. Click Copy.

15 In the Grading Criteria dialog box, change the name to Relative Elevation @ 3-1 Slope. Set the following values for the criteria:

- **Target:** Relative Elevation
- **Relative Elevation:** -3.0’
- **Projection:** Slope
- **Format:** Slope
- **Slope:** 3:1

This criteria creates a grade to a relative elevation of -3 feet at a 3-to-1 slope.

16 Click OK to close the Grading Criteria dialog box.

17 On the Toolspace Settings tab, click and drag the new criteria (Relative Elevation @ 3-1 Slope) from the Basic Set to the Ditch Criteria Set.

When you create a criteria by copying, the new criteria name must be unique within the drawing, regardless of criteria set.

To continue this tutorial, continue to Exercise 3: Creating Grading Styles (page 271).
Exercise 3: Creating Grading Styles

In this exercise, you will create a new grading style and slope pattern.

For more information, see the AutoCAD Civil 3D Help topic Using Grading Style.

This exercise continues from Exercise 2: Creating Grading Criteria (page 268).

To create a new grading style

NOTE This exercise uses Grading-1.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, right-click the Grading Styles collection. Click New.

2. In the Grading Style dialog box, click the Information tab. Enter Ditch into the name field. Optionally, enter a description for the style.

3. Click the Display tab and change the color of the Daylight Line to red by clicking its entry in the Color column.
The Select Color dialog box is displayed, where you can select a color. Select red, then click OK.

4. Click the Slope Patterns tab.

5. Select the Slope Pattern check box. Select the Basic style.

6. Click the style drop down list and click Copy Current Selection.

7. In the Slope Pattern Style dialog box, on the Information tab, change the name to Ditch Slope.

8. On the Layout tab, in the Component field, select Component 2.
The parameter table displays values for Component 2, which is the second slope pattern component from the left side. In this case, it is a long line with a tapered line symbol along the top of the slope.

9. In the Slope Line Symbol section, change the Symbol Type to None.

   Further exploration: For Component 1, in the Slope Line section, change Percent Of Length to a higher value. You can see the results in the Preview pane.

10. Click OK. The new Ditch Slope pattern is selected for the Ditch grading style.
To view summary information about the style, click the Summary tab.

Click OK.

In Toolspace, on the Settings tab, the Ditch grading style is added to the Grading Styles collection. The Ditch Slope pattern is added to the General ➤ Multipurpose Styles ➤ Slope Pattern Styles collection.

To continue to the next tutorial, go to Creating Gradings (page 272).

**Tutorial: Creating Gradings**

This tutorial demonstrates how to create a feature line and how to grade from the feature line.

You can create gradings from parcel lot lines or feature lines. A feature line is a linear object that the grading commands can recognize and use as a baseline. When designing a grading, you must often adjust the elevations along a feature line. You create a feature line by converting existing objects, such as lines or polylines.

In the next two exercises, you will perform the following tasks:

- Create three feature lines.
- Assign elevation values along the feature lines using several methods.
- Create a set of gradings from one of the feature lines.

For more information, see the AutoCAD Civil 3D Help topic *Creating Grading*.

**Exercise 1: Creating Feature Lines**

In this exercise, you will use two different methods to create feature lines.

Feature lines can be either drawn with straight and curved feature line segments, or created from existing alignments or AutoCAD lines, arcs, polylines, or 3D polylines.

A feature line can be used as a grading baseline, but not as a target.

For more information, see the AutoCAD Civil 3D Help topic *Creating Feature Lines*.
This exercise continues from the Setting Up Grading Standards (page 267) tutorial.

**To create feature lines from AutoCAD objects**

**NOTE** This exercise uses Grading-1.dwg with the modifications you made in the previous tutorial, or you can open Grading-2.dwg from the tutorial drawings folder (page 615).

1. Click the Line drawing tool on the AutoCAD Draw toolbar. In the drawing area, draw a line from circle A to B to C.
2. Click Grading menu ➤ Create Feature Lines From Objects.
3. Click both lines, then right-click and click Enter to end the selection.
   In the Create Feature Lines dialog box, notice that you can assign a name to the feature lines as they are created. Naming significant feature lines can make it easier to assign targets when creating a corridor. For this exercise, you will assign names after the feature lines have been created. Following this workflow enables you to create many feature lines at the same time, but name only the most significant feature lines.
4. In the Create Feature Lines dialog box, click OK.
   The lines are converted to feature lines and added to Site 1. You will assign elevation values to these feature lines later in this exercise. Next, you will draw a feature line and specify elevations along the line.

**To assign feature line names**

1. In the drawing window, select feature lines AB and BC. Right-click. Click Apply Feature Line Names.
2. In the Apply Feature Line Names dialog box, click .
3. In the Name Template dialog box, for Property Fields, select Next Counter. Click Insert. Click OK.
4. In the Apply Feature Line Names dialog box, place the cursor at the beginning of the Name field. Enter ABC.
   The Name field should contain ABC <[Next Counter]>.
   Click OK.
5 In Toolspace, on the Prospector tab, expand Sites ➤ Site 1. Select the Feature Lines collection. Notice that the two feature lines and their names are displayed in the Prospector list view. Next, you will draw a feature line and specify elevations along the line.

To specify elevations as you draw a feature line

1 Click Grading menu ➤ Draw Feature Line.
2 In the Create Feature Lines dialog box, apply the following settings:
   - Name Check Box: Selected
   - Name: CDEF <[Next Counter]>
   - Style Check Box: Selected
   - Style: Ditch
3 In the Create Feature Lines dialog box, click OK.
4 In the drawing window, snap to the end of the feature line inside circle C. When prompted, enter 688.00 as the elevation. You have entered a known value for the starting elevation. In the following steps, you will use the transition command to defer entering elevation values at intermediate points along the feature line.
5 Stretch the feature line and click inside circle D. When prompted for an elevation, enter T.
6 Stretch the feature line and click inside circle E. When prompted for an elevation, press Enter to accept Transition.
7 Stretch the feature line and click inside circle F. When prompted for a transition, enter SU to use the elevation of the surface at that point.
8 Note the surface elevation shown at the command line. Press Enter twice to accept the elevation and end the command.
9 In Toolspace, on the Prospector tab, expand Sites ➤ Site 1. Select the Feature Lines collection. Notice that the three feature lines you created are displayed in the list view. You can use this box to edit the feature lines’ name, style, and layer, and view other properties of all the feature lines.
To continue this tutorial, go to Exercise 2: Assigning Feature Line Elevations (page 275).

Exercise 2: Assigning Feature Line Elevations

In this exercise, you will assign elevations to the feature lines you created from AutoCAD lines in the previous exercise.

For more information, see the AutoCAD Civil 3D Help topic Editing Feature Lines.

This exercise continues from Exercise 1: Creating Feature Lines (page 272).

To edit feature line elevations

NOTE This exercise uses Grading-2.dwg with the modifications you made in the previous exercise.

1 Click Grading menu ➤ Edit Feature Line Elevations ➤ Elevation Editor.

2 Click the feature line that stretches from circles C, D, E, to F.

In the Grading Elevation Editor, you see the length of each segment and elevations at each vertex. Notice that as you specified in Exercise 1: Creating Feature Lines, the elevation of the first point is 688.000 and the elevation of the last point matches the elevation of the surface. The elevation values of the two intermediate points are automatically interpolated based on the beginning and end-point values. You can use this table to edit the elevation and grade values. Now you will assign elevation values to line AB.

3 Click , and then click the feature line between circles A and B. The Grading Elevation Editor now displays the elevations along the feature line between circles A and B.

4 Double-click the elevation value for the starting station (0+00.00), and change it to 630.00’. This value puts it a few feet below the surface. Change the elevation of the end point to 690.00’.

In the next few steps, you will insert an elevation point on the feature line.
To insert an elevation point on a feature line

1 In the Grading Elevation Editor, click (Insert Elevation Point).
   On feature line AB, you see a small circle and a tooltip that shows the
   station value and elevation of the point. You can use the cursor to move
   this point to a new location.

2 Move the point to a location near the middle of the feature line, then
   click.

3 In the Insert PVI dialog box, optionally move the elevation point to a
   specific station. Click OK.
   The point is added to the table in the Grading Elevation Editor, where
   you can edit the station, elevation, grade, and length (distance between
   points).

4 Click feature line AB.
   Editing grips are displayed for the endpoints and elevation point. You
   can click the elevation point and slide it along the feature line. You can
   also click one of the endpoints and move it to a new location. When you
   do any grip editing, values in the Grading Elevation Editor update.

5 Move the cursor over the surface near the elevation point to see the
   surface elevation displayed.

6 In the Grading Elevation Editor, set the elevation point to an elevation
   that is at or below the surrounding surface.
   In the next few steps, you will drape feature line BC across the existing
   ground surface. This command assigns an elevation to each vertex of the
   feature line.

To drape a feature line on a surface

1 If necessary, press Esc once or twice to deselect feature line AB.
2 Click Grading menu ➤ Edit Feature Line Elevations ➤ Elevations From Surface.

3 In the Set Elevations From Surface dialog box, click OK.

4 Click feature line BC, then right-click and click Enter to end the command.

5 Click feature line BC again. An elevation point has been added wherever the line crosses the edge of a triangle in the TIN surface.

6 Right click and click Elevation Editor.

   The Elevation Editor displays data for each elevation point along feature line BC, including its elevation, and the distance and grade to the next point. A feature line on the surface like this can be a useful starting point for a grading. You can use controls along the top of the Grading Elevation Editor to add and delete elevation points, and to adjust their elevations. You can select multiple points within the table for group operations, such as raising or lowering them the same amount, or “flattening” their elevations to the same value.

7 Click ✔ to close the Grading Elevation Editor.

To continue this tutorial, go to Exercise 3: Creating a Grading (page 277).

---

Exercise 3: Creating a Grading

In this exercise, you will create a set of gradings, called a grading group, that form a runoff on the side of an embankment.

For more information, see the AutoCAD Civil 3D Help topic Creating Grading from a Footprint.

This exercise continues from Exercise 2: Assigning Feature Line Elevations (page 275).

To create a grading

NOTE This exercise uses Grading-2.dwg with the modifications you made in the previous exercise, or you can open Grading-3.dwg from the tutorial drawings folder (page 615).

1 Click Grading menu ➤ Create Grading.
2 In the Grading Creation Tools toolbar, click Set The Grading Group.

3 In the Create Grading Group dialog box, enter Ditch Drainage in the Name field. Select Automatic Surface Creation. Select Volume Base Surface. Click OK.

4 In the Create Surface dialog box, click OK.

5 In the Grading Creation Tools toolbar, click Select a Criteria Set.

6 Select Ditch Criteria Set from the list. Click OK.

7 In the Select A Grading Criteria list, ensure that Distance @ -6% is selected.

8 Click to expand the Grading Creation Tools toolbar.

9 In the Style list, select Ditch.

10 Click Create Grading. Click feature line AB.

11 In response to the command-line prompt, click above the feature line to indicate where to apply the grading.

12 Press Enter (Yes) to apply the grading to the entire length of the feature line.

13 Press Enter to accept the default distance (10 feet).

14 The grading is created. Ditch Drainage is added to the grading groups collection in Site 1 on the Toolspace Prospector tab. This grading creates one side of a ditch, extending down from the baseline at a 6% grade for a distance of 10 feet.

15 Press Enter to end the command.

In the next few steps, you will create another grading from the target line of the first grading to the existing surface.

16 Set your display so that feature line AB fills most of the drawing window.

17 Click the Select a Grading Criteria list and click Surface @ 4-1 Slope.

18 Click Create Grading and click the red target line from the first grading that you created.
19 Enter Yes to apply the grading to the entire length of the line.
20 Press Enter to accept the cut slope (4:1).
21 Press Enter to accept the fill slope (4:1).
22 Right-click to end the command.

The grading is created. This grading creates a 4:1 slope up from the bottom of the ditch to the surface. Your results may differ from the illustration.

NOTE The Event Viewer might notify you that duplicate points have been ignored. A surface was created from the two gradings, which share a common feature, and therefore share point data. The daylight line of the first grading is the baseline of the second grading. When the surface is created, the data from the points was extracted for each grading. Because the point data is duplicate, the data of one of the two instances of each point is ignored.

To continue to the next tutorial, go to Editing Gradings (page 279).

**Tutorial: Editing Gradings**

This tutorial demonstrates common grading editing tasks, including elevation adjustment and grading criteria editing.

You use the Grading Elevation Editor to edit elevations along a baseline. A baseline is a feature line or lot line that has had a grading applied to it. You
can modify the elevations of a lot line unless it is being used as a target for a grading.

You can also insert a PVI (Point of Vertical Intersection) between the start and end stations of the baseline, creating an intermediate elevation point.

For more information, see the AutoCAD Civil 3D Help topic Editing Grading.

**Exercise 1: Editing the Grading Elevation**

In this exercise, you will edit the elevation of a grading baseline. The grading adjusts to reflect the elevation change.

For more information, see the AutoCAD Civil 3D Help topic Editing Grading Criteria.

**To edit the elevation**

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Grading-4.dwg.
   
   This drawing contains a rectangular building pad graded to the surrounding surface at a 3:1 slope. Where the slope pattern is green, it is a fill slope in which the grading slopes down from the pad to the surface. Where the slope pattern is red, it is a cut slope in which the grading slopes up from the pad.

2. Click Grading menu ➤ Edit Feature Line Elevations ➤ Elevation Editor.

3. In the drawing, select the baseline for the grading (rectangular line).

   **NOTE** The surface style for the building pad grading has borders turned off, making it easier to select the baseline. Otherwise, the surface border would be on top of the baseline.

   The Elevation Editor shows the following grading settings for each corner of the feature line in a clockwise direction. The starting point is the upper left corner.

   - Station — Distance from the start of the feature line.
   - Elevation — Elevation of the current point.
   - Length — Distance to the next point.
Grade Ahead — Grade toward the next point. Adjusting this setting holds the elevation of the current point and adjust the elevation of the next point for the new grade.

Grade Back — Grade from the previous point. Adjusting this setting affects the elevation of the current point, holding the elevation of the next point for the new grade.

Further exploration: Another way to review and edit the elevations of a feature line is to click Grading menu ➤ Edit Feature Line Elevations ➤ Edit Elevations. A triangular marker is displayed at the starting point of the feature line. Press Enter to move to the next point. You can edit data on the command line.

4 In the Grading Elevation Editor, Shift+click the second and third rows to select them.

5 Double-click the elevation value in one of the rows and change it to 730 feet.
Both of the selected rows’ elevation values change to 730 feet. Notice that the shape of the grading and the Grade Ahead and Grade Back values have changed to reflect the elevation change.

6 Select the first three rows in the table. Click Flatten Grade or Elevations.

7 In the Flatten dialog box, select Constant Grade. Click OK. The first two points are set to the same grade, 2.693%, and the shape of the grading changes in response to the elevation change. Flattening the grade holds the elevation values of the first and last selected points and modifies elevations of the points in between.

8 Click Show Grade Breaks Only. The second station’s row is hidden, because there was no difference in grade between it and the previous station.

9 In the first row, change the Grade Ahead value to -3.000%.

10 Click Show Grade Breaks Only. Notice that the second station’s grade has changed to reflect the change you made in step 9.

11 Click to close the Grading Elevation Editor.
To continue this tutorial, go to Exercise 2: Adjusting the Cut and Fill Volumes (page 282).

Exercise 2: Adjusting the Cut and Fill Volumes

In this exercise, you will adjust the elevation of a building pad to balance the cut and fill volumes.

For more information, see the AutoCAD Civil 3D Help topic Displaying and Adjusting Surface Volumes.

This exercise continues from Exercise 1: Editing the Grading Elevation (page 280).

To adjust grading volumes

NOTE This exercise uses Grading-4.dwg with the modifications you made in the previous exercise, or you can open Grading-5.dwg from the tutorial drawings folder (page 615).

1. Click Grading menu ➤ Grading Utilities ➤ Grading Volume Tools. On the Grading Volume Tools toolbar, notice that the Group is set to Building Pad, which is the only grading group in the drawing. The fields for Cut, Fill, and Net show that the grading as designed requires the net cutting and removal of a large volume of surface material.

2. Click Raise the Grading Group to raise the building pad elevation by one foot. Note the changes to cut and fill requirements.

Further exploration: You can also click Lower the Grading Group and you can change the elevation increment to a value other than 1.0.

3. Click Automatically Raise/Lower to Balance the Volumes.

4. In the Auto-Balance Volumes dialog box, leave the Required Volume set to 0, or change the value if you wish. Click OK.

The elevation of the building pad is adjusted to bring the Net amount as close as possible to the set value.

5. Click (Expand the Grading Volume Tool). The history of your elevation changes and their effects is displayed.
To continue this tutorial, go to Exercise 3: Editing the Grading Criteria (page 283).

**Exercise 3: Editing the Grading Criteria**

In this exercise, you will edit a grading criteria and an associated grading adjusts to reflect the criteria change.

You will edit grading criteria attribute values in two ways:

- In the Elevation Editor dialog box. Using this method updates the grading criteria for only the currently selected grading object.
- Directly in the Grading Criteria settings. Using this method will apply the attribute changes to future grading objects created with the criteria. If the attribute value is locked, attribute changes will also be applied to grading objects that currently use the criteria.

For more information, see the AutoCAD Civil 3D Help topic *Editing Grading Criteria*.

This exercise continues from Exercise 2: Adjusting the Cut and Fill Volumes (page 282).

This exercise uses the drawing *Grading-3A.dwg*, which contains two grading groups that use the same grading criteria.

**To edit the criteria**

1. Click File ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing *Grading-3A.dwg*.
2. Click Grading menu ➤ Edit Grading ➤ Grading Editor.
3. Click inside the grading that projects from feature line AB.
4. In the Grading Editor Panorama, change the distance value to 5.0000. Notice that grading AB updates to reflect the change. Now, you will make a similar change that will affect all grading groups using the Distance @ -6% grading criteria.
5. In Toolspace, on the Settings tab, expand Grading ➤ Grading Criteria Sets ➤ Ditch Criteria Set.
6. Right-click Distance @ -6%. Click Edit.
7 In the Grading Criteria dialog box, click the Criteria tab. Change the Distance parameter to 20 and click . This locks the attribute value, which will apply it to all grading objects that currently use the Distance @ -6% grading criteria. Leaving the value unlocked applies the value to only grading objects that are created in the future.

8 Click OK.

The AB and BC grading objects are both updated in the drawing to account for the new criteria value.

To continue to the next tutorial, go to Grading from a Complex Building Footprint (page 284).

**Tutorial: Grading from a Complex Building Footprint**

This tutorial demonstrates how to grade around a building footprint that has relatively complicated geometry and variations in elevation.

The drawing used in this tutorial contains a surface and a building pad that consists of two tiers connected by a small ramp. The elevation of the top portion of the building pad is 402 feet, and the bottom portion is 400 feet.

Projection grading, also known as slope grading, involves projecting a slope from a feature line to a specified target. Projection grading targets include an intersection with a surface, or a specified distance, elevation, or elevation difference. The ramp that connects the two tiers consists of arcs and inside corners, both of which complicate a grading plan. Simply applying projection grading, which was demonstrated in the Creating a Grading exercise (page 277), would result in a grading that overlaps itself.

In this tutorial, you will learn how to create a successful grading solution for similarly complicated scenarios. After you have completed this tutorial, proceed to the Using Feature Lines to Modify a Grading tutorial (page 292) to learn how to modify the grading solution, using the AutoCAD Civil 3D feature line editing tools.

For more information, see the AutoCAD Civil 3D Help topic *Creating Grading*. 
Exercise 1: Simplifying a Building Footprint

In this exercise, you will use the feature line stepped offset command to generate a simplified footprint from which to grade.

The drawing you will use in this tutorial displays a building pad in two vertically arranged viewports. In the right viewport, the building pad is shown in plan view. You will design the building pad in the right viewport. In the left viewport, the building pad is displayed in model view. You will use this viewport to see the status of the design as you work.

For more information, see the AutoCAD Civil 3D Help topic Editing Feature Lines.

To create a stepped offset feature line

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Grading-6.dwg.

2. On the command line, enter OffsetGapType. Enter 1 as the value. The OffsetGapType variable controls how potential gaps between segments are treated when closed polylines, such as the building pad feature line, are offset. Setting this variable to 1 fills the gaps with filleted arc segments; the radius of each arc segment is equal to the offset distance.

3. Click Grading menu ➤ Edit Feature Line Geometry ➤ Stepped Offset.

4. On the command line, enter 1.5 as the offset distance.
5 In the right viewport, click the blue feature line representing the building pad when prompted to select a feature line.

6 Click outside the building pad when prompted to specify the side to offset.

7 At the command line, enter G to specify a grade value. Enter -1 as the grade.

8 Press Enter to end the command.

The stepped offset feature line is displayed. Notice that in the left viewport, on the left side of the ramp, the curve of the stepped offset feature line is not well formed. Because it is an independent feature line, you can use the feature line editing tools to refine the solution.

To add fillets to the feature line

1 Click Grading menu ➤ Edit Feature Line Geometry ➤ Fillet.

2 Click the offset feature line when prompted to select an object.

3 On the command line, enter R to specify a radius for the fillet. Enter 15.000 as the radius value.

4 On each side of the ramp, click a sharp inside corner of the offset feature line.

When you move the cursor over the feature line, a green triangle highlights the corners that can be filleted and a preview fillet is displayed. See the following image for an example of a corner to click.
The fillet is applied to the feature line. In the left viewport, notice that the fillet uses the elevations from the existing feature line and smoothly interpolates the elevations along the length of the fillet.
To continue this tutorial, go to Exercise 2: Grading from a Building Footprint to a Surface (page 288).

**Exercise 2: Grading from a Building Footprint to a Surface**

In this exercise, you will grade from the simplified, offset footprint to the existing ground surface.

The stepped offset feature line has much simpler geometry than the original footprint. The simpler feature line geometry will result in a much simpler grading than one created directly from the original footprint.

For more information, see the AutoCAD Civil 3D Help topic *Creating Grading*. 

Press Enter twice to end the command.
This exercise continues from Exercise 1: Simplifying a Building Footprint (page 285).

**To grade from the footprint to the surface**

**NOTE** This exercise uses *Grading-6.dwg* with the modifications you made in the previous exercise.

1. Click Grading menu ➤ Create Grading.


3. In the Select Grading Group dialog box, under Site Name, ensure that Grading - Building Pad site is selected.

4. Under Group Name, click Create A Grading Group.

5. In the Create Grading Group dialog box, for Name, enter Slope Grading With Feature Lines. Click OK to close the Create Grading Group and Select Grading Group dialog boxes.

6. On the Grading Creation Tools toolbar, click Set The Target Surface.

7. In the Select Surface dialog box, ensure that EG surface is selected. Click OK.

8. On the Grading Creation Tools toolbar, click Select a Criteria Set.

9. In the Select A Criteria Set dialog box, ensure that Basic Set is selected. Click OK.

10. From the Select a Grading Criteria list, select Grade To Surface.

11. Click Create Grading.

12. When prompted to select a feature, click the blue feature line that is offset from the building pad.

13. When prompted to select the grading side, click outside the offset feature line.

14. Press Enter to apply the grading to the entire length of the feature line.
15 Press Enter to accept the default Slope Cut Format. Press Enter to accept the default 2.00:1 Cut Slope.

16 Press Enter to accept the default Slope Fill Format. Press Enter to accept the default 2.00:1 Fill Slope.

17 Press Enter to end the command.

   The stepped offset feature line is graded to the EG surface. Notice that while the cut and fill slopes are shown in red and green, there are still open areas inside the grading group. In the next exercise, you will fill these areas and apply appropriate grading styles.

   The stepped offset feature line is graded to the EG surface. Notice that while the cut and fill slopes are shown in red and green, there are still open areas inside the grading group. In the next exercise, you will fill these areas and apply appropriate grading styles.

To continue this tutorial, go to **Exercise 3: Filling Holes in a Grading** (page 290).

### Exercise 3: Filling Holes in a Grading

In this exercise, you will create infill gradings to fill in the open areas inside the grading group.

An *infill grading* has no criteria applied to it. Any area bounded by feature lines or lot lines that is not already a grading can be converted to an infill grading. Using infill gradings to fill in holes in a grading group ensures correct contour display and volume calculations.

For more information, see the AutoCAD Civil 3D Help topic *Filling a Void Area.*
This exercise continues from Exercise 2: Grading from a Building Footprint to a Surface (page 288).

To fill holes in the grading

NOTE This exercise uses Grading-6.dwg with the modifications you made in the previous exercise.

1. On the Grading Creation Tools toolbar, from the Select A Grading Criteria list, select Grade To Distance.

NOTE Although an infill has no criteria, you select its grading style from an existing criteria.

2. Click Expand The Toolbar.

3. From the Style list, select Shoulder.

   This setting specifies the grading style to apply to the infill.

4. Click Create Infill.

5. Click in the area between the building footprint and the offset feature line (near the right side of the ramp).

   A diamond is displayed in that area, indicating that an infill has been created. In the left viewport, notice that the infill grading fills the entire area between the two blue feature lines.

6. On the Grading Creation Tools toolbar, from the Style list, select Pad.

7. Click inside the building footprint to create an infill using the Pad grading style.

8. Press Enter to end the command.

   In the left viewport, the gray area is the infill grading that represents the shoulder. The gold area is the building pad infill grading. The green and red areas are the grade-to-surface slope grading.
To continue to the next tutorial, go to Using Feature Lines to Modify a Grading (page 292).

**Tutorial: Using Feature Lines to Modify a Grading**

This tutorial demonstrates how to use feature lines to control grading around inside corners.

*Feature line* grading involves creating a set of feature lines to define the graded region as surface breaklines, and then adjusting the elevation of key points to control the shape of the surface. This technique is ideal for wide, fairly flat areas, such as parking lots or building pads. It is also well suited to areas with rapidly changing elevations or slopes where walls would normally be required to grade successfully. You can manually add or remove feature lines and adjust their location in three dimensions to achieve precise slope design. Using this process, you can control water drainage or clean up difficult geometry in areas, such as the intersection of two or more slopes.

For more information, see the AutoCAD Civil 3D Help topic *Editing Feature Lines*.

**Exercise 1: Smoothing Feature Line Arcs**

In this exercise, you will adjust the tessellation of the arcs around the ramp, which will result in a more accurate representation of the ramp.
For more information, see the AutoCAD Civil 3D Help topic *Editing Feature Lines*.

**To modify feature line arc tessellation**

NOTE This exercise uses *Grading-6.dwg* with the modifications you made in the previous exercise, or you can open *Grading-7.dwg* from the tutorial drawings folder (page 615).

1. Click the right viewport to make it active.
2. Click View menu ➤ Visual Styles ➤ 3D Wireframe.
   The grading triangulation is displayed in the 3D Wireframe visual style. It is helpful to observe the triangles as you use the feature line to break the surface.
3. Click Grading menu ➤ Create Grading.
5. In the Grading Group Properties dialog box, on the Information tab, select the Automatic Surface Creation check box.
6. In the Create Surface dialog box, click OK.
   To adjust the arc tessellation, a surface must be created from the grading group. This surface is temporary. You will delete it after you have adjusted the arc tessellation.
7. In the Grading Group Properties dialog box, on the Information tab, change the Tessellation Spacing setting to 1.000’. Click Apply.
8. Clear the Automatic Surface Creation check box. When asked if you want to delete the Slope - Projection Grading surface, click Yes. Click OK.
   Now that you have updated the arc tessellation, you must update the grading infill areas to apply the new setting. The easiest way to update the infill areas is by using the AutoCAD Move command.
9. On the command line, enter MOVE.
10. Click the original, interior feature line (the blue building pad). Press Enter.
11. Press Enter again to select the default Displacement selection.

Exercise 1: Smoothing Feature Line Arcs | 293
Press Enter again to accept the default displacement of <0.0000, 0.0000, 0.0000>.

In the left viewport, notice that the triangulation of the arcs along the ramp has improved.

To continue this tutorial, go to Exercise 2: Adjusting Grading Triangulation with a Feature Line (page 294).

**Exercise 2: Adjusting Grading Triangulation with a Feature Line**

In this exercise, you will use a feature line to break a poorly triangulated grading surface.

The triangles in the area on the right side of the ramp are steeper than desired. These triangles can be corrected by creating a feature line to break the surface in this area.

For more information, see the AutoCAD Civil 3D Help topic *Editing Feature Lines*.

This exercise continues from Exercise 1: Smoothing Feature Line Arcs (page 292).

To use a feature line to adjust surface triangulation

**NOTE** This exercise uses *Grading-7.dwg* with the modifications you made in the previous exercise.

1. In the Layers list, next to the C-TOPO-FEAT-CROSS layer, click 🕵️.  
2. Zoom in to the area to the right of the ramp.
Notice the polyline between the three circles labeled A, B, and C. You can use the following steps on any polyline. However, this polyline is in a specific location so that you will get the results described in this tutorial.

3 Click Grading menu ➤ Create Feature Lines From Objects.

4 Click the polyline between Circles A, B, and C. Press Enter.

5 In the Create Feature Lines dialog box, under Site Name, make sure that Grading - Building Pad is selected.

6 Under Conversion Options, make sure that the Erase Existing Entities and Assign Elevations check boxes are selected. Click OK.

7 In the Assign Elevations dialog box, select From Surface. Make sure that the Insert Intermediate Grade Break Points check box is selected. Click OK.

**TIP** To reduce processing time when working with larger grading groups, clear the Insert Intermediate Grade Break Points check box. This option adds an elevation point at each point at which the feature line crosses a triangle.

The polyline is converted to a feature line and breaks the triangulation along the right side of the ramp. The new triangulation creates a more gradual slope in the infill area.

To continue this tutorial, go to Exercise 3: Working with Crossing Feature Lines (page 295).

**Exercise 3: Working with Crossing Feature Lines**

In this exercise, you will learn how feature lines interact when they cross each other at and between vertices.

For more information, see the AutoCAD Civil 3D Help topic *Editing Feature Lines*. 
This exercise continues from Exercise 2: Adjusting Grading Triangulation with a Feature Line (page 294).

To work with crossing feature lines

NOTE  This exercise uses Grading-7.dwg with the modifications you made in the previous exercise, or you can open Grading-8.dwg from the tutorial drawings folder (page 615).

1. In the right viewport, select feature line ABC. Right-click. Click Elevation Editor.

   The Grading Elevation Editor displays a list of the points of intersection (PIs, or horizontal geometry points) and elevation change points (vertical geometry points) along the feature line.

   Notice that the icon is displayed in the first row. This icon indicates that the building pad feature line also has a PI at this point. When two feature lines cross at a common vertex, both vertices must share the same elevation value. The elevation for both feature lines at this point is determined by whichever feature line was most recently edited. In the following illustration, the common vertex is in Circle A.

2. In the Grading Elevation Editor click Unselect All Rows. Click Flatten Grade Or Elevations.
3 In the Flatten dialog box, select Constant Grade. Click OK. Notice that in the Grading Elevation Editor, the Grade Ahead and Grade Back values are updated to a consistent value. When you flatten a feature line, the points between the start elevation and the end elevation are set to the same grade, effectively eliminating the grade breaks. You may flatten either the entire feature line, or a selection of points.

4 In the row, in the Elevation column, change the elevation value to 402.00'.

5 In the Grading Elevation Editor, click Select A Feature Line, Parcel Line, Or Survey Figure.

6 In the drawing window, click the building pad feature line. The elevation points of the building pad are now displayed in the Grading Elevation Editor.

7 Locate the row containing the icon. Notice that the value in the Elevation column is 402.000', which is the same value you entered for the other feature line in Step 4. Change the Elevation value to 405.000'. In the left viewport, notice that the value you entered for the shared vertex updated the elevation of both feature lines. As you see in the following image, the new common feature line elevation affected the infill gradings of both the ramp and gray infill area. When two feature lines share a vertex, the elevation of both feature lines at that vertex is determined by whichever of the feature lines was most recently edited.
8  In the Grading Elevation Editor, in the row, change the Elevation value to 400.00'.

9  In the right viewport, select feature line ABC. Using the grip inside Circle A, move the beginning point of the feature line toward the lower left of Circle A.

**NOTE** You may need to hover over the feature line, and then use Shift+spacebar to select the feature line.

10 Right-click the feature line. Select Elevation Editor.

In the Grading Elevation Editor, the icon indicates the point at which the feature line crosses the building pad. The white triangle indicates a *split point*, which is created when two feature lines cross at a location where neither one has a PI. Much like a shared vertex point, a split point acquires the elevation of the feature line that was most recently edited. If the other feature line has a different elevation, it gets a grade break at the crossing point.

Unlike a shared vertex, there is not an actual point at a split point, so you cannot directly edit the elevation. When you edit one of the feature lines, its grade runs straight through the intersection, forcing the other feature line to break at the split point. You can use the Insert PI command...
to create a permanent point at that location on one of the feature lines. After you convert a split point to a permanent point, you can edit the elevation of a split point directly, and have better control over that point.

11 Select the grip at the beginning point of the feature line. On the command line, enter END to apply an endpoint OSNAP. Snap the feature line to the building pad feature line.

Notice that an elevation change point with an elevation of 402.000' was added in the second row. The change point was added because you changed the elevation of the endpoint (the shared vertex) of this feature line to 402.000' in Step 4. When you changed the elevation of the shared vertex on the building pad feature line to 400.000' in Step 8, the grade break point was created. The grade break point ensures that the elevation of this feature line would match the elevation of the building pad.

12 In the Grading Elevation Editor, click Flatten Grade Or Elevations.

13 In the Flatten dialog box, select Constant Grade. Click OK.
The grade flattens, and the elevations updates to accommodate the new grade.
Corridors Tutorials

These tutorials will get you started working with the corridor modeling tools, which are used to design and generate complex roadway corridor models.

NOTE If you have not installed AutoCAD Civil 3D to the default location, you may receive messages in the Event Viewer indicating that subassembly macro paths are not found. To avoid these messages, it is recommended that you follow the exercises in the order presented.

NOTE All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Understanding Corridor Modeling.

Tutorial: Creating a Simple Corridor Model

This tutorial demonstrates how to build a simple assembly and corridor, and then view and modify the corridor model.

A corridor model builds on and uses various AutoCAD Civil 3D objects and data, including subassemblies, assemblies, alignments, surfaces, and profiles.

Corridor objects are created along one or more baselines (alignments) by placing a 2D section (assembly) at incremental locations and by creating matching slopes that reach a surface model at each incremental location.

For more information, see the AutoCAD Civil 3D Help topic Creating Corridors.
Exercise 1: Creating a Simple Assembly

In this exercise, you will use some of the subassemblies that are shipped with AutoCAD Civil 3D to create an assembly for a simple crowned roadway with travel lanes, curbs, gutters, sidewalks, and slopes to an existing surface.

For more information, see the AutoCAD Civil 3D Help topic Creating Assemblies.

To create a simple assembly

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open Corridor-1a.dwg.
   This drawing contains an existing ground surface, a centerline alignment, offset alignments to the left and right of the centerline, and ground and layout profiles for the alignments.

2. If the Tool Palette containing the subassemblies is not visible, enter Toolpalettes on the command line.

3. Click Corridors menu ➤ Create Assembly.

4. In the Create Assembly dialog box, accept the default settings. Click OK.

5. When the ‘Specify assembly baseline location’ prompt is displayed on the command line, click a point in the drawing to build the assembly. The viewport zooms to the assembly baseline, which looks like this:

6. In the Tool Palette, click the Imperial - Basic tab.

   NOTE If the Civil 3D - Imperial tool palette is not visible, right-click the Tool Palettes control bar and select Civil 3D - Imperial.

7. Click BasicLane.
8 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Width: 14.0000
   ■ Depth: 1.0000

9 In the drawing, click the marker point on the assembly baseline. A lane is drawn, extending 14 feet to the right, with a slope of -2% and a depth of 1 foot.

10 In the Tool Palette, click BasicCurbAndGutter.

11 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Gutter Width: 1.2500

12 In the drawing, click the marker point at the top-right edge of the travel lane to draw the curb and gutter.

   **NOTE** For easier subassembly placement, zoom in close enough to clearly see the marker to select. You can zoom transparently while adding a subassembly.

13 In the Tool Palette, click BasicSidewalk.

14 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Buffer Width 1: 2.0000
   ■ Buffer Width 2: 3.0000

15 In the drawing, click the marker point at the top back of curb to add the sidewalk and its buffer zones.

16 In the Tool Palette, click BasicSideSlopeCutDitch.
17 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Cut Slope value to 3.000:1

18 In the drawing, click the marker point at the outside edge of the outer sidewalk buffer zone to add the cut-and-fill slope.

19 Press Esc to exit subassembly placement mode.

20 In the drawing window, select the four subassemblies you added. Right click. Click Mirror.

21 Click the marker point on the assembly baseline. The subassemblies are displayed on the left side of the assembly marker. The Mirror command creates a mirror image of the selected subassemblies. All the subassembly parameters, except for the Side parameter, are retained.

NOTE The parameters of the mirrored subassemblies are not dynamically linked. If you change a parameter value for a subassembly on one side of the assembly baseline, the change will not be applied to the opposite side.

To continue this tutorial, go to Exercise 2: Creating a Simple Corridor (page 304).

**Exercise 2: Creating a Simple Corridor**

In this exercise, you will create a corridor using an assembly, an existing ground surface, a centerline alignment, offset alignments to the left and right of the centerline, and ground and layout profiles for the centerline and right offset alignments.
For more information, see the AutoCAD Civil 3D Help topic Creating Corridors. This exercise continues from Exercise 1: Creating a Simple Assembly (page 302).

To create a corridor model

NOTE This exercise uses Corridor-1a.dwg from the previous exercise, or you can open Corridor-1b.dwg from the tutorial drawings folder (page 615).

1 Click Corridors menu ➤ Create Corridor.
2 When the ‘Select baseline alignment’ prompt is displayed, press Enter. Click Centerline (1) in the Select An Alignment dialog box. Click OK.
3 When the ‘Select a profile’ prompt is displayed, press Enter. Click Layout (1) in the Select A Profile dialog box. Click OK.
4 When the ‘Select an assembly’ prompt is displayed, press Enter. Click Assembly (1) in the Select An Assembly dialog box. Click OK.

NOTE The code set styles that are defined in the assembly will be applied to the corridor. For more information, see the AutoCAD Civil 3D Help topic Using Codes and Code Set Styles.

5 In the Create Corridor dialog box, in the Corridor Name field, enter Urban Street.
6 Click Set All Targets.
In the Target Mapping dialog box, you can map logical names in subassemblies to actual objects in the drawing. For example, the BasicSideSlopeCutDitch subassembly requires that a surface be specified for calculating the daylight points.

7 In the table, click <Click Here To Set All> in the Object Name column. In the Pick A Surface dialog box, click surface EG. Click OK.
This sets the daylight points for both the BasicSideSlopeCutDitch subassemblies to the same surface.

8 Click OK to close the Target Mapping dialog box.
9 Click OK to close the Create Corridor dialog box.
The corridor model is built and looks like this:
To continue to the next tutorial, go to Creating a Corridor Model With a Transition Lane (page 306).

**Tutorial: Creating a Corridor Model With a Transition Lane**

This tutorial demonstrates how to create a corridor with a transition lane. The tutorial uses some of the subassemblies that are shipped with AutoCAD Civil 3D to create an assembly. Then, you create a roadway where the travel lane widths and slopes are controlled by offset alignments, profiles, polylines, and feature lines.

For more information, see the AutoCAD Civil 3D Help topic *Assemblies and Subassemblies*. 

---

306 | Chapter 11  Corridors Tutorials
Exercise 1: Creating an Assembly with a Transition Lane

In this exercise, you will create the assembly with the transitions.

Before you create the assembly, you will modify the subassembly name template to ensure that the subassembly names will identify the side of the assembly on which they are located. Performing this task will make it easy to assign targets in Exercise 2: Creating a Corridor with a Transition Lane (page 310).

For more information, see the AutoCAD Civil 3D Help topic Creating Assemblies.

To modify the subassembly name template

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open Corridor-2a.dwg.

2. In Toolspace, on the Settings tab, right-click the Subassembly collection. Click Edit Feature Settings.

3. In the Edit Feature Settings dialog box, expand the Subassembly Name Templates Property. In the Create From Macro row, click the Value cell. Click ⬤.

4. In the Name Template dialog box, in the Name field, highlight the <[Next Counter(CP)]> property.
   
   This default subassembly naming template causes subassemblies to use the subassembly name on the tool palette followed by a sequential number. For example, BasicSidewalk subassemblies placed on either side of the assembly would be named BasicSidewalk - (1) and BasicSidewalk - (2) using this convention.

5. In the Property Fields list, select Subassembly Side. Click Insert. The Name field should contain the following formula:
   
   <{Macro Short Name(CP)}> - (<{Subassembly Side}>)

   TIP To display the subassembly name in the local language, use the <{Subassembly Local Name}> property in place of the <{Macro Short Name(CP)}> property.

6. Click OK to close the Name Template dialog box.
7 Click OK to close the Edit Command Settings dialog box.

To create an assembly with a transition lane

1 If the Tool Palette containing the subassemblies is not visible, enter Toolpalettes on the command line.

2 Click Corridors menu ➤ Create Assembly.

3 In the Create Assembly dialog box, for Name, enter Transition. Accept the other default settings. Click OK.

4 When the ‘Specify assembly baseline location’ prompt is displayed on the command line, click a point in the drawing to build the assembly. The viewport zooms to the assembly baseline, which looks like this:

   ![Assembly Baseline Image]

5 In the Tool Palette, click the Imperial - Basic tab.

   **NOTE** If the Civil 3D - Imperial tool palette is not visible, right-click the Tool Palettes control bar and select Civil 3D - Imperial.

6 Click \[BasicLaneTransition.\]

7 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   - Side: Right
   - Default Width: 14.0000
   - Depth: 1.0000
   - Transition: Change Offset And Elevation

8 In the drawing, click the marker point on the assembly baseline. A lane is drawn, extending 14 feet to the right, with a slope of -2% and a depth of 1 foot.
9 In the Tool Palette, click BasicCurbAndGutter.

10 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Gutter Width: 1.2500

11 In the drawing, click the marker point at the top-right edge of the travel lane to draw the curb and gutter.

12 In the Tool Palette, click BasicSidewalk.

13 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Buffer Width 1: 2.0000
   ■ Buffer Width 2: 3.0000

14 In the drawing, click the marker point at the top back-side of the curb to add the sidewalk and its buffer zones.

15 In the Tool Palette, click BasicSideSlopeCutDitch.

16 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Right
   ■ Cut Slope: 3.000:1

17 In the drawing, click the marker point at the outside edge of the outer sidewalk buffer zone to add the cut-and-fill slope.

18 In the Tool Palette, click BasicLaneTransition.

19 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Left
   ■ Default Width: 12.0000
   ■ Depth: 1.0000
Transition: Hold Grade, Change Offset

20 In the drawing, click the marker point on the assembly baseline. A lane is drawn, extending 12 feet to the left, with a slope of -2% and a depth of 1 foot.

21 Press Esc to exit subassembly placement mode.

22 In the drawing window, on the right-hand side of the assembly, select the curb, sidewalk, and daylight subassemblies. Right click. Click Mirror.

23 Click the marker point at the top-left edge of the transition lane to draw a mirror of the curb, sidewalk, and daylight subassemblies.

The subassemblies are displayed on the left side of the assembly marker. The Mirror command creates a mirror image of the selected subassemblies. All the subassembly parameters, except for the Side parameter, are retained.

NOTE The parameters of the mirrored subassemblies are not dynamically linked. If you change a parameter value for a subassembly on one side of the assembly baseline, the change will not be applied to the opposite side.

The finished assembly looks like this:

To continue this tutorial, go to Exercise 2: Creating a Corridor with a Transition Lane (page 310).

Exercise 2: Creating a Corridor with a Transition Lane

In this exercise, you will create a corridor using the assembly created in the last exercise. You will target the width and elevation of the right lane edge to
a right alignment and profile, and the left lane edge to a polyline and a feature line.

For more information, see the AutoCAD Civil 3D Help topic Creating Corridors.

This exercise continues from Exercise 1: Creating an Assembly with a Transition Lane (page 307).

To create a corridor model with a transition lane

**NOTE** This exercise uses Corridor-2a.dwg from the previous exercise, or you can open Corridor-2b.dwg from the tutorial drawings folder (page 615).

1. Click Corridors menu ➤ Create Corridor.
2. When the ‘Select baseline alignment’ prompt is displayed, press Enter. Click Centerline (1) in the Select An Alignment dialog box. Click OK.
3. When the ‘Select a profile’ prompt is displayed, press Enter. Click Layout (1) in the Select A Profile dialog box. Click OK.
4. When the ‘Select an assembly’ prompt is displayed, press Enter. Click Transition in the Select An Assembly dialog box. Click OK.
   The Transition assembly includes the BasicLaneTransition subassembly, which uses the Transition parameter to specify that both the offset and elevation can change on the right side of the corridor. The offset can change on the left side of the corridor but the grade is held at -2%.
5. In Create Corridor dialog box, enter Corridor - Transition Lanes in the Corridor Name field.
6. Click Set All Targets.
7. In the Target Mapping dialog box, in the table, click <Click Here To Set All> in the Object Name column.
8. In the Pick A Surface dialog box, click surface EG. Click OK.
   This sets the daylight points for both the BasicSideSlopeCutDitch subassemblies to the same surface.
9. In the Transition Alignment row for BasicLaneTransition - (Right), click the Object Name field.
10. In the Set Width Or Offset Target dialog box, in the Select Object Type To Target list, select Alignments. In the Select Alignments box, select Right (1). Click Add. Click OK.
11 In the Transition Alignment row for BasicLaneTransition - (Left), click the Object Name field.

12 In the Set Width Or Offset Target dialog box, in the Select Object Type To Target list, select Feature Lines, Survey Figures And Polylines. Click Select From Drawing.

13 In the drawing window, on the left side of the alignment, select the blue polyline and magenta feature line. Press Enter.

The entities are added to the table at the bottom of the Set Width Or Offset Target dialog box.

14 In the Set Width Or Offset Target dialog box, click OK. Notice that because the subassembly names contain the assembly side, it is easy to determine which assembly must target which offset object. This naming convention is even more useful in road designs that contain many alignments and subassemblies.

15 In the Transition Profile row for BasicLaneTransition - (Right), click the Object Name field.
In the Set Slope Or Elevation Target dialog box, in the Select Object Type To Target list, select Profiles. In the Select An Alignment list, select Right (1). In the Select Profiles box, select Layout (1). Click Add. Click OK. The right-side edge-of-pavement elevation is set to the Layout (1) profile. The left-side edge-of-pavement elevation does not need to be set since its elevation is determined by the grade setting (see Step 4).

Click OK to close the Target Mapping dialog box.

Click OK to close the Create Corridor dialog box. The corridor model is built. The corridor looks like this:
NOTE Notice that at station 7+50, the lane uses the polyline as a target, and not the feature line. When more than one target object is found at a station, the object that is closest to the corridor baseline is used as the target.

To continue to the next tutorial, go to Creating a Divided Highway (page 314).

**Tutorial: Creating a Divided Highway**

This tutorial demonstrates how to create a divided highway corridor. The tutorial uses some of the subassemblies that are shipped with AutoCAD Civil 3D to create a more complex and realistic highway model.

This highway has a depressed median with a flat bottom ditch and inside paved shoulders, two travel lanes on each side of the median, and paved outside shoulders. The total median width between inside edges-of-traveled-ways is 44 feet. The highway may have at-grade intersections, so the superelevation rotation point is set to be located at the design profile grade above the centerline of the median ditch. This creates a single consistent cross slope across the entire roadway in superelevated areas.

For more information, see the AutoCAD Civil 3D Help topic *Creating Corridors.*
Exercise 1: Viewing the Superelevation Properties of an Alignment

In this exercise, you will view superelevation specifications that have already been defined for an alignment.

For more information, see the AutoCAD Civil 3D Help topic *Superelevation*.

**To view the superelevation properties of the alignment**

1. Click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open *Corridor-3a.dwg*.
2. In Toolspace, on the Prospector tab, under the drawing Corridor-3a, expand the Alignments collection. Right-click Centerline (1). Click Properties.
3. In the Alignment Properties dialog box, click the Superelevation tab. The superelevation properties have been defined for a 50 m.p.h. road using AASHTO tables for a 6% maximum superelevation rate. The outside shoulders have a normal crown slope of -5% and rotate upward to follow the lane slope on the high side of superelevation. The slopes of the inside shoulders are set to the algebraic opposite of the lanes on each side.

**NOTE** The superelevation specifications of an alignment can be automatically validated against specified design criteria. For more information, see the *Designing an Alignment that Refers to Local Standards* tutorial (page 193).

4. Click OK to close the Alignment Properties dialog box.

To continue this tutorial, go to Exercise 2: Creating a Divided Highway Assembly (page 315).

Exercise 2: Creating a Divided Highway Assembly

In this exercise, you will create a fairly complex assembly with a depressed median and separated lanes.

For more information, see the AutoCAD Civil 3D Help topic *Creating Assemblies*.

This exercise continues from Exercise 1: Viewing the Superelevation Properties of an Alignment (page 315).
To create a divided highway assembly

**NOTE** This exercise uses *Corridor-3a.dwg* with the modifications you made in the previous exercise.

1. If the Tool Palette containing the subassemblies is not visible, enter Toolpalettes on the command line.

2. Click Corridors menu ➤ Create Assembly.

3. In the Create Assembly dialog box, for Name, enter Divided Highway. Accept the other default settings. Click OK.

4. When the ‘Specify assembly baseline location’ prompt is displayed on the command line, click a point in the drawing to build the assembly. The viewport zooms to the assembly baseline, which looks like this:

5. In the Tool Palette, click the Imperial - Roadway tab.

**NOTE** If the Civil 3D - Imperial tool palette is not visible, right-click the Tool Palettes control bar and select Civil 3D - Imperial.

6. Right-click MedianDepressedShoulderExt. Click Help. Review the diagram to better understand the subassembly.

7. Click MedianDepressedShoulderExt.

8. In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   - Centerline Pivot: Pivot about centerline
   - Left Median Width: 22.0000
   - Right Median Width: 22.0000
9 In the drawing, click the marker point on the assembly baseline. A depressed median and inside shoulders are drawn.

10 In the drawing, pan to the left edge of the MedianDepressedShoulderExt subassembly. Zoom in so that each marker point can be seen distinctly.

11 In the Tool Palette, click LaneOutsideSuper. This subassembly inserts a travel lane that follows the outside lane superelevation slope for the superelevation properties of the alignment.

12 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Left
   ■ Width: 24.0000

13 In the drawing, click the marker that is at the top left edge of the median to insert the 24 foot lane to the left side:

14 In the drawing, pan to the left side of the LaneOutsideSuper subassembly.

15 In the Tool Palette, click ShoulderExtendSubbase.
16 In the Properties palette, in the ADVANCED Parameters section, set the following parameter values:
   ■ Side: Left
   ■ Use Superelevation Slope: Outside Shoulder Slope
   ■ Subbase - Use Superelevation: Outside Shoulder Slope
This sets these slopes to the outside shoulder superelevation slope. For more information, see the subassembly help.

17 In the drawing, click the marker point at the top outside edge-of-lane on finish grade to add the paved shoulder.

18 In the drawing, pan to the left side of the ShoulderExtendSubbase.

19 In the Tool Palette, click the Imperial - Daylight tab.

20 Right-click DaylightStandard. Click Help. Review the diagram and Behavior section to better understand the cut and fill daylighting behaviors.

21 In the Tool Palette, click DaylightStandard.

22 In the drawing, click the marker point at the outside edge of the ShoulderExtendSubbase subassembly to add the daylight slopes for cut and fill.

23 Press Esc to exit out of subassembly placement mode.

24 In the drawing, zoom out until you see the entire assembly. On the left-hand side of the assembly, select the daylight, shoulder, and lane subassemblies. Right click. Click Mirror.

25 Click the marker point at the top-right edge of the median subassembly to draw a mirror of the daylight, shoulder, and lane subassemblies.
The Mirror command creates a mirror image of the selected subassemblies. All the subassembly parameters, except for the Side parameter, are retained.

   **NOTE** The parameters of the mirrored subassemblies are not dynamically linked. If you change a parameter value for a subassembly on one side of the assembly baseline, the change will not be applied to the opposite side.

   The finished assembly looks like this:
Exercise 3: Creating a Divided Highway Corridor

In this exercise, you will create a divided highway corridor.

For more information, see the AutoCAD Civil 3D Help topic Creating Corridors.

This exercise continues from Exercise 2: Creating a Divided Highway Assembly (page 315).

To create a corridor model

NOTE This exercise uses Corridor-3a.dwg from the previous exercise, or you can open Corridor-3b.dwg from the tutorial drawings folder (page 615).

1. Click Corridors menu ➤ Create Corridor.
2. When the ‘Select baseline alignment’ prompt is displayed, press Enter. Click Centerline (1) in the Select An Alignment dialog box. Click OK.
3. When the ‘Select a profile’ prompt is displayed, press Enter. Click Layout (1) in the Select A Profile dialog box. Click OK.
4. When the ‘Select an assembly’ prompt is displayed, press Enter. Click Divided Highway in the Select An Assembly dialog box. Click OK.
5. In the Create Corridor dialog box, enter Divided Highway in the Corridor Name field.
6. Click Set All Targets.
7. In the Target Mapping dialog box, in the table, click <Click Here To Set All> in the Object Name column.
8. In the Pick A Surface dialog box, click surface EG. Click OK.
9. Click OK to close the Target Mapping dialog box.
10. Click OK to close the Create Corridor dialog box.
11. Zoom to the extents of the corridor model.
The corridor model looks like this:

To continue to the next tutorial, go to Viewing and Editing Corridor Sections (page 320).

Tutorial: Viewing and Editing Corridor Sections

This tutorial demonstrates how to edit the corridor in section.

You use the corridor section tools that are demonstrated in this exercise to edit the corridor model. To plot corridor sections, you must create section views. See the Sections Tutorials (page 405) for more information.
Exercise 1: Viewing Corridor Sections

In this exercise, you will view how a corridor assembly is applied at various stations along the baseline alignment.

The view/edit corridor section tools are useful for inspecting how the corridor assemblies interact with other objects in the corridor model.

For more information, see the AutoCAD Civil 3D Help topic Viewing and Editing Corridor Sections.

To view corridor sections

   The drawing contains an assembly, profile view, and corridor model. Each object is displayed in a separate viewport. The viewport that contains the assembly is active.

2. Click Corridors menu ➤ View/Edit Corridor Section.
3  Press Enter. In the Select A Corridor dialog box, click Corridor - (1). Click OK.

The View/Edit Corridor Section Tools toolbar opens and a cross-section of the corridor at the starting station is displayed. The elevations and offsets are displayed on the grid axes. The cross section view contains the assembly, as well as the other adjacent objects.

**TIP** You can also open the View/Edit Corridor Section Tools toolbar at a specific station. In plan view, select the corridor. With the cursor hovered over the desired station, right-click, and select View/Edit Corridor Section.

At the current station, the offset alignments are represented by vertical green lines, and the existing ground surface is represented by the horizontal red line. The vertical red line in the center of the grid represents the assembly baseline. Profile intersections with the baseline are indicated by markers.

4  Use the View/Edit Corridor Section Tools to view the corridor sections at each corridor station. Click Previous Station and Next Station, or select stations from the dropdown list.

Notice that as each station is displayed on the grid, its location in the plan and profile viewports is identified by a perpendicular line.

5  Zoom in to the lane on the right-hand side of the assembly. Click Next Station.
Notice that the view zooms back out to the grid extents. There are three zoom modes in the view/edit corridor section tools. These modes control the behavior of the grid when you navigate to another station:

- **Zoom To Extents**—View zooms out to the extents of the assembly, plus the view scale factor. This is the default zoom mode.

- **Zoom To An Offset And Elevation**—View remains zoomed in on the current offset and elevation. As you navigate to other sections, the current offset and elevation remains at the center of the viewport.

- **Zoom To A Subassembly**—View remains zoomed in on a selected subassembly. As you navigate to other sections, the selected subassembly remains at the center of the viewport.

**NOTE** The current zoom mode is displayed in the lower right corner of the View/Edit Corridor Section Tools toolbar.

6 In the Select A Station list, select 3+00.00.

7 Click **Zoom To A Subassembly**.

8 In the Pick Subassembly dialog box, select Daylight (Right). Click OK.
   The view zooms in to the Daylight (Right) subassembly at station 3+00.00. Notice the shape, elevation, and offset of the subassembly.

9 In the Select A Station list, select 9+00.00.
   The view zooms in to the Daylight (Right) subassembly at station 9+00.00. Notice that the shape, elevation, and offset of the subassembly is quite different from station 3+00.00. The subassembly remains at the center of the grid and at the same zoom factor as you navigate to other stations.

10 On the View/Edit Corridor Section Tools toolbar, click **Zoom To An Offset And Elevation**.

11 Click **Next Station** several times.
   Notice that the offset and elevation values that are displayed on the grid axes do not change. The shape of the Daylight (Right) subassembly changes to reflect how it ties in to the existing ground surface.
On the View/Edit Corridor Section Tools toolbar, click \(\text{Zoom To Extents}\).

Click \(\text{Next Station}\).
The view zooms back out to the extents of the assembly.

To continue this tutorial, go to Exercise 2: Editing Corridor Sections (page 324).

Exercise 2: Editing Corridor Sections

In this exercise, you will edit the parameters at several corridor sections.

You will edit a section in two ways. First, you will modify a subassembly parameter at a single station, which will override the subassembly settings for that station only. Second, you will modify a subassembly parameter, and then apply the modification to a range of stations.

For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Sections.

This exercise continues from Exercise 1: Viewing Corridor Sections (page 321).

To modify subassembly properties for a single station

**NOTE** This exercise uses Corridor-4a.dwg from the previous exercise.

1. On the View/Edit Corridor Section Tools toolbar, in the Select A Station list, select 7+75.00.

2. On the View/Edit Corridor Section Tools toolbar, click \(\text{Zoom To A Subassembly}\).

3. In the Pick Subassembly dialog box, select Lane (Right). Click OK.

4. On the View/Edit Corridor Section Tools toolbar, click \(\text{Expand The Toolbar}\).

5. In the Assembly - (1) tree, under Group - (1), expand Lane (Right).
   Notice that identical values are displayed in the Design Value and Value columns. The Design Value column displays the value that was specified
when the subassembly was added to the assembly. The Value column displays the actual value of the subassembly at the current station. In the following steps, you will override the Design Value at the current station, and then examine the results.

6 Change the Width Value to 36.0000’. Notice that the Override check box is automatically selected, which indicates that the Design Value has been overridden at this station.

7 Click Next Station several times. Notice that for the other stations, the Width Value is 24.000’. The lane subassembly that is displayed in the section view updates in width to reflect the width at the current station.

8 On the View/Edit Corridor Section Tools toolbar, in the Select A Station list, select 7+75.00.

9 In the Assembly - (1) tree, under Group - (1), under Lane (Right), in the Width row, clear the Override check box. The Value column displays the same value as the Design Value column.

To modify subassembly properties for a range of stations

1 On the View/Edit Corridor Section Tools toolbar, in the Select A Station list, select 4+50.00. Notice that the road is in a shallow cut on one side and deep cut on the other. The criteria set for the daylight subassembly caused it to use a 6:1 slope on the left side, and a 4:1 slope on the right side. Also notice the superelevation transition of the road. At station 4+50.00, the lanes are relatively flat.

2 On the View/Edit Corridor Section Tools toolbar, in the Select A Station list, select 7+75.00.
Notice the superelevation transition at this station. Using the Centerline Pivot option on the depressed median subassembly causes the lanes and shoulders to superelevate about a point above the centerline ditch. A straight edge laid against the lane surfaces would pass through the profile grade point.

3 In the Assembly - (1) tree, under Group - (1), expand Median. Notice that the Centerline Pivot? Design Value is set to Pivot About Centerline.


5 Click the arrow next to . Click Apply To A Station Range.

6 In the Apply To A Range Of Stations dialog box, notice that Start Station is 7+75.00, which is the current station. For End Station, enter 11+00.00. Click OK.

7 In Toolspace, on the Prospector tab, expand the Corridors collection. Right-click Corridor - (1). Click Rebuild to update the corridor model.

8 View the corridor section at station 7+75.00. Notice that the profile grade is held at the inside edges-of-traveled-ways and the lanes and shoulders pivot about this point.
Click Next Station to view the grade at subsequent stations. Notice that the change you made is visible through station 11+00.00. At station 11+25.00, the Centerline Pivot Value returns to Pivot About Centerline.

To continue to the next tutorial, go to Viewing and Rendering a Corridor (page 327).

**Tutorial: Viewing and Rendering a Corridor**

This tutorial demonstrates how to add surfaces to a corridor, create boundaries on the surfaces, and then visualize the corridor using the AutoCAD rendering tools.

For more information, see the AutoCAD Civil 3D Help topic *Managing and Editing Corridors*.

**Exercise 1: Creating Corridor Surfaces**

In this exercise, you will create Top, Datum, Pave, and Median surfaces from the corridor.

The *Top* surface tracks the finish grade of the roadway from the left daylight point to the right daylight point on both paved and unpaved portions. This surface is used for finish grade modeling.

The *Datum* surface tracks the finish grade on unpaved portions, and also the subbase on paved portions, going from the left daylight point to the right daylight point. This surface represents the grading elevations before pavement materials are applied. This surface is used for calculating cut and fill quantities.

The *Pave* surface defines the finished pavement on both travel lanes in the divided highway.

The *Median* surface defines the area between the travel lanes.

For more information, see the AutoCAD Civil 3D Help topic *Creating and Editing Corridor Surfaces*. 
To create corridor surfaces

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Corridor-5a.dwg.

2. In the drawing, click the corridor. Right-click. Click Corridor Properties.

3. In the Corridor Properties dialog box, click the Surfaces tab.

4. Click Create A Corridor Surface to create an entry in the surfaces table.

5. Change the surface name to Corridor - (1) Top.

6. Click the Surface Style cell for the Corridor - (1) Top surface.

7. In the Pick Corridor Surface Style dialog box, select Border & Contours. Click OK.

8. Click the Render Material cell for the Corridor - (1) Top surface.

9. In the Pick Render Material dialog box, select Sitework.Paving - Surfacing Asphalt. Click OK.

10. Select the Corridor - (1) Top surface by clicking the icon next to its name.

11. Change the Overhang Correction setting to Top Links, which specifies that the surface will be built using the links along the top of the assembly. This setting is especially critical when an assembly has overlapping subassembly links that, if connected, would result in errors in surface triangulation.

12. Set the Specify Code field to Top. Click Add Surface Item. This adds the corridor links with the Top code to this surface.

13. Repeat steps 4 through 12 to create a Datum surface, using these settings:
   - Name: Corridor - (1) Datum
   - Surface Style: Hide Surface
   - Render Material: Sitework.Planting.Soil
   - Overhang Correction: Bottom Links
   - Link Code: Datum
Repeat steps 4 through 12 to create a Pave surface, using these settings:
■ Name: Corridor - (1) Pave
■ Surface Style: Border & Contours
■ Render Material: Sitework.Paving - Surfacing Asphalt
■ Overhang Correction: Top Links
■ Link Code: Pave

Repeat steps 4 through 12 to create a Median surface, using these settings:
■ Name: Corridor - (1) Median
■ Surface Style: Border & Contours
■ Render Material: Sitework.Planting.Gravel.Mixed
■ Overhang Correction: Top Links
■ Link Code: Gravel

16 Click OK to create the surfaces and close the Corridor Properties dialog box.

17 In Toolspace, on the Prospector tab, expand the Surfaces collection. Notice that the corridor surfaces you created have been added to the Surfaces collection. You can work with a corridor surface the same way you do with any surface in the Surfaces collection, including changing its style, adding labels to it, and using it for surface analysis. The following features and behaviors are unique to corridor surfaces:
■ When you select a corridor surface, only the surface is selected. The corridor it is based on is not selected.
■ When you change the surface style of a corridor surface using its surface properties, the style is also changed in the Corridor Properties dialog box on the Surfaces tab.
■ When a corridor is rebuilt, corridor surfaces are updated to reflect any changes in the corridor, and then any edits are applied to the corridor model.
■ The corridor from which the surface was taken is listed in the surface properties definition.
Exercise 2: Creating Corridor Surface Boundaries

In this exercise, you will use two different methods to define surface boundaries for your corridor design.

Use corridor surface boundaries to prevent triangulation outside of the daylight lines of a corridor surface. You may also use boundaries to either prevent an area of a surface from being displayed or to render an area of the corridor surface using a render material.

Corridor surfaces support the following types of boundaries:

- Outside Boundary — Used to define the outer boundary of the corridor surface.
- Hide Boundary — Used as a mask to create void areas or punch holes in the corridor surface. For example, a corridor might use a link code Paved either side of the corridor with another surface (a median), separating them. When you create a corridor surface using Paved as the data, AutoCAD Civil 3D tries to connect the gap in between two link codes. To create voids, you define boundaries to represent the surface appropriately.
- Render Only — Used to represent different parts of corridor surface with different materials (when rendering), for example, asphalt and grass.

NOTE The Advanced Corridor Design tutorials demonstrate how to create corridor boundaries for intersections (page 367) and roundabouts (page 399).

For more information, see the AutoCAD Civil 3D Help topic Adding and Editing Corridor Boundaries.

This exercise continues from Exercise 1: Creating Corridor Surfaces (page 327).

To create a corridor surface boundary

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Corridor-Sb.dwg.
2. In the drawing, click the corridor. Right-click. Click Corridor Properties.
If you have difficulty selecting the corridor in the drawing window, go to Toolspase on the Prospector tab. Expand the Corridors collection. Right-click the corridor name and select Properties.

3 In the Corridor Properties dialog box, click the Boundaries tab. The four corridor surfaces are displayed in the boundary table.

4 Select the Corridor - (1) Top surface. Right-click and click Add Automatically ➤ Daylight. This creates a boundary from the daylight lines that are generated from the daylight point codes in the subassembly.

5 Select the Corridor - (1) Datum surface. Right-click and click Add Automatically ➤ Daylight.

6 For both boundaries, keep the Use Type set to Outside Boundary. The daylight line in the corridor model is created at the points where the design surface matches the existing ground on each side. By selecting Outside Boundary, the surface will be clipped outside the boundary formed by the left and right daylight lines.

7 Click OK. The new boundaries are added to the Corridor - (1) Top and Corridor - (1) Datum surfaces. The corridor model is regenerated and the surfaces are rebuilt.

These surface boundaries are defined by a pair of feature lines. If there are more than two of a given type of feature lines, then you must use the interactive method to use them to define a boundary.

For example, you were able to automatically create a surface boundary for the daylight region because there is a single pair of Daylight feature lines that define the daylight edges of the corridor assembly.

By contrast, the assembly has two lanes, each of which are defined by its own pair of EPS feature lines. In this case, you must define the boundary interactively.

Next, you will add three more boundaries to the other surfaces using the interactive definition method. The first boundary will define the outside edges of both lanes by using the lanes’ outer EPS feature lines. This will be an outside boundary to define the outside edges of the Corridor - (1) Pave surface.

The second boundary will define the inside edges of both lanes by using the lanes’ inner EPS feature lines. This will be a hide boundary and will act as a mask over the median area of the Corridor - (1) Pave surface.
The third boundary will define the outside edges of the median area using the lanes' inner EPS feature lines. This will be an outside boundary to define the outside edges of the Corridor - (1) Median surface.

8 Click View menu ➤ Named Views. In the View Manager dialog box, in the Model Views category, select the Corridor_Begin view. Click Set Current. Click OK.
The drawing is redrawn to a zoomed-in view of starting area of Corridor (1).

9 In the drawing, click the corridor. Right-click. Click Corridor Properties.

10 In the Corridor Properties dialog box, on the Boundaries tab, select the Corridor - (1) Pave surface. Right-click and click Add Interactively.

11 In the drawing, click the feature line along the left-inside edge of the paved shoulder within circle 3.

12 Since there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click EPS. Click OK.

13 Pan to the other end of the corridor. Notice that a red line appears along the first feature line you selected.

14 Click the feature line in circle 10.

15 Since there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click EPS. Click OK.

16 Pan to the beginning of the corridor, and click the feature line along right-inside edge of paved shoulder within circle 4.

17 On the command line, enter C to close the boundary.

18 The Corridor Properties dialog box is displayed. Expand the Corridor (1) – Pave surface collection item to see the boundary item. Change the corridor boundary name to Pave Outside and set its Use Type to Outside Boundary.

19 In the Corridor Properties dialog box, on the Boundaries tab, select the Corridor - (1) Pave surface. Right-click and click Add Interactively

20 Repeat steps 11 through 18 to define the inside boundary of the paved region:
   ■ Click in circle 1 and select EPS to define the left-outside edge of the paved shoulder.
Click in circle 8 and select EPS to define the left-outside edge of the paved shoulder.

Click in circle 2.

On the command line, enter C to close the boundary.

Change the name of the boundary to Pave Inside.

Change the Use Type to Hide Boundary.

21 In the Corridor Properties dialog box, on the Boundaries tab, select the Corridor - (1) Median surface. Right-click and click Add Interactively.

22 Repeat steps 11 through 18 to define the outside boundary of the median:

Click in circle 1 and select EPS to define the left-outside edge of the paved shoulder.

Click in circle 8 and select EPS to define the left-outside edge of the paved shoulder.

Click in circle 2.

On the command line, enter C to close the boundary.

Change the name of the boundary to Median.

Change the Use Type to Outside Boundary.

23 Click OK to create the boundaries and close the Corridor Properties dialog box.

To continue this tutorial, go to Exercise 3: Visualizing a Corridor (page 333).

Exercise 3: Visualizing a Corridor

In this exercise, you will visualize the corridor using the rendering and hatching features in AutoCAD Civil 3D.

Rendering a corridor requires that you assign an AutoCAD render material to each of the appropriate subassembly links. Rendering produces a realistic image of the corridor that is useful for on-screen presentations.

Applying hatching to a corridor requires that you apply a material are fill style to each of the appropriate subassembly links. Hatching produces a less realistic
image of the surface than rendering, but hatching prints easily through AutoCAD.

For more information, see the AutoCAD Civil 3D Help topic Rendering Corridor Models.

This exercise continues from Exercise 2: Creating Corridor Surface Boundaries (page 330).

To apply 3D render materials to a corridor

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Corridor-Sc.dwg.

2. In the drawing, click the corridor. Right-click. Click Corridor Properties.

   **TIP** If you have difficulty selecting the corridor in the drawing window, go to the Toolspace Prospector tab. Expand the Corridors collection. Right-click the corridor name and select Properties.

First, you will apply render materials to the corridor link codes.

3. In the Corridor Properties dialog box, click the Codes tab.

4. Under Code Set Style, make sure that All Codes is selected.

   In the Render Material column, examine the materials that are set for the links that are included in the subassemblies for the current corridor. These materials will be displayed on each link when you render the corridor model:

   - Daylight_Cut: Sitework.Planting.Grass.Short
   - Daylight_Fill: Sitework.Planting.Grass.Short
   - Ditch: Sitework.Planting.Grass.Thick
   - Gravel: Sitework.Planting.Gravel.Mixed
   - Median: Sitework.Planting.Grass.Short
   - Pave: Sitework.Paving - Surfacing.Asphalt
   - Slope_Link: Sitework.Planting.Grass.Short

5. Click OK to close the Corridor Properties dialog box.

6. Click View menu ➤ Named Views. In the View Manager dialog box, select the Corridor_3D View view. Click Set Current. Click OK.
The drawing is redrawn to a three-dimensional view of the corridor.

7 In Toolspace, on the Prospector tab, expand the Surfaces collection.

8 Right-click the Corridor - (1) Median surface. Click Surface Properties.

9 In the Surface Properties dialog box, on the Information tab, change the Surface Style to Hide Surface. Click OK.

   The Hide Surface style has all of its components turned off, which allows the surface’s render material to be effectively ignored. The rendering method used in this exercise applies render materials that are assigned to the subassembly link codes, and not the surface itself.

10 Follow Steps 8 and 9 to apply the Hide Surface style to the Corridor - (1) Pave and Corridor - (1) Top surfaces.

   **NOTE** The Corridor - (1) Datum surface already uses the Hide Surface style.

11 On the command line, enter RENDER to render the corridor in 3D using the render materials that are applied to the subassembly links.
Next, you will view 2D hatch patterns on the corridor by applying shape styles to the appropriate subassembly links.

To apply 2D hatching to a corridor model

1. Click View menu ➤ Named Views. In the View Manager dialog box, select the Corridor_All view. Click Set Current. Click OK. The drawing is redrawn to plan view.

2. In the drawing, click the corridor. Right-click. Click Corridor Properties.

3. In the Corridor Properties dialog box, click the Codes tab.

4. Under Code Set Style, select All Codes With Hatching. In the Material Area Fill Style column, notice that a fill has been applied to each of the subassembly links that you examined in the previous procedure. However, notice that Slope_Link does not have a Material
Area Fill Style associated with it. In the next few steps, you will apply a style by modifying the code set style.

5 Click Edit Current Selection.

**NOTE** You can also open the Code Set Style dialog box from Toolspace on the Settings tab. Expand General ➤ Multipurpose Styles ➤ Code Set Styles. Right-click the appropriate code set style and click Edit.

6 In the Code Set Style dialog box, in the Slope_Link row, set the Material Area Fill Style to Strip Hatch.

7 Click OK to close the Code Set Style and Corridor Properties dialog boxes. The material area fill styles are applied to the 2D corridor model. Zoom in on the beginning of the corridor to examine the hatch patterns.
These tutorials will get you started using the advanced design tools in AutoCAD Civil 3D to perform complex corridor design tasks, including intersection and roundabout design.

**IMPORTANT** Before you begin these tutorials, you must have a thorough understanding of the concepts that are explained in the basic Corridors Tutorials (page 301).

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Understanding Corridor Modeling.

**Tutorial: Intersection Design**

This tutorial demonstrates how to design a four-way intersection within a corridor.

Designing an intersection is one of the most challenging corridor design tasks. The intersecting roads (which may have different slopes) must intersect at a single point, new assemblies must be built to model the intersection, and the final corridor surface must be carefully checked for any drainage issues.

Because the intersection design process is so complex, it helps to break it down into several discrete tasks. This tutorial demonstrates each of the most common tasks involved in intersection design.
IMPORTANT Before you begin this tutorial, you must have a thorough understanding of the concepts that are explained in the basic Corridors Tutorials (page 301).

For more information, see the AutoCAD Civil 3D Help topic Creating Corridors.

**Exercise 1: Matching Corridor Elevations in Profile**

In this exercise, you will design intersecting road profiles so that they share a common elevation at the point of intersection.

The drawing used in this exercise contains a fully developed, West-to-East corridor along an alignment named Through Road. The intersecting alignment, named Side Road, contains a partially designed layout profile.
The drawing also includes both an Existing Ground surface and a corridor surface named Intersection. Key points of interest are marked with a circle and a letter. You will use these points, as well as the other alignments in the drawing, later in this tutorial.

The layout profile for the Side Road must be modified to match the elevation at the intersection with the Through Road. You will create surface spot labels to determine the surface elevation at key points on the Through Road portion of the corridor surface. Then, you will use that information to complete the layout profile.

For more information, see the AutoCAD Civil 3D Help topic Editing Layout Profiles.

**To obtain surface elevations along an alignment**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open Intersection-1.dwg.

2. Click Surfaces menu ➤ Add Surface Labels ➤ Add Surface Labels.

3. In the Add Labels dialog box, for Label Type, select Spot Elevation. For Spot Elevation Label Style, select Elevation At Alignment Station. Click Add.

   The Elevation At Alignment Station label style uses the Reference Text label style component to annotate two different types of objects. For more information about creating label styles that refer to other objects,
see the Creating a Label Style that Refers to Another Object tutorial exercise (page 595).

**NOTE** You must turn on Center OSNAP to complete the following steps.

4 Press Enter. In the Select A Surface dialog box, select Intersection. Click OK.

5 In the plan view, snap to the center of Circle I. Press Enter to select an alignment.

6 In the Select An Alignment dialog box, select Side Road. Click OK. Side Road is the alignment for which station values are displayed in the label.

7 In the plan view, snap to the center of Circles K and J.

8 In the Add Labels dialog box, click Close to close the dialog box and end the labeling command. The labels display the elevation values at the appropriate stations along the Side Road alignment. You will use those values to add PVIs to the layout profile in the next procedure.

**To modify the Side Road profile elevations to match the Through Road profile**

1 Click Profiles menu ➤ Edit Profile Geometry. In the Side Road PROFILE profile view, click the blue layout profile.

2 On the Profile Layout Tools toolbar, click Insert PVIs - Tabular.

3 In the Insert PVIs dialog box, enter the Station and Elevation values for each of the spot elevation labels you created. Enter the values in ascending order by station. Click OK. In the Side Road PROFILE view, notice that three new PVIs have been added.

4 Click the blue layout profile. Zoom in to the new PVIs you created in Step 3. The three PVIs represent the centerline and outer edges of the Through Road.
5 On the Profile Layout Tools toolbar, click the Profile Grid View.

6 In the Profile Entities vista, row 4 is the PVI at the intersection of the Through Road alignment. In row 3, change the PVI Station value to 0+194.11m. In row 5, change the PVI Station value to 0+223.11m. The new station values provide room to create 20-meter vertical curves, which provide a smooth transition into the intersection.
7 On the Profile Layout Tools toolbar, click the arrow next to **Fixed Vertical Curve (Three Points)** ➤ **More Free Vertical Curves** ➤ **Free Vertical Parabola (PVI Based)**. Click the PVI to the right side of the Through Road centerline PVI. Enter 20 for the curve length.

8 In the profile view, click the PVI to the left side of the Through Road centerline PVI. Enter 20 for the curve length.

9 Click the PVI in the upper left side of the profile. Enter 50 for the curve length.

10 Click the PVI in the lower right side of the profile. Enter 50 for the curve length.

11 Press Enter to end the Add Parabolic Curve command.

The Side Road profile now matches the elevation of the Through Road. Parabolic vertical curves form a smooth transition from the elevation of the proposed Side Road to the elevation of the intersection with the Through Road.

12 In the Layers list, next to the C-TOPO-TEXT layer, click .

Now that the profile has been designed, you do not need to see these labels.
To continue this tutorial, go to Exercise 2: Adding the Side Road to the Corridor (page 345).

**Exercise 2: Adding the Side Road to the Corridor**

In this exercise, you will add the side road to the existing corridor, specifying the appropriate profile and assembly.

For more information, see the AutoCAD Civil 3D Help topic *Editing Corridor Parameters*.

This exercise continues from Exercise 1: Matching Corridor Elevations in Profile (page 340).

**To add the side road to the corridor**

**NOTE** This exercise uses *Intersection-1.dwg* with the modifications you made in the previous exercise, or you can open *Intersection-2.dwg* from the tutorial drawings folder (page 615).

1. In the plan view, select the corridor. Right-click. Click Corridor Properties.
2. In the Corridor Properties dialog box, on the Parameters tab, click Add Baseline.
3. In the Pick Horizontal Alignment dialog box, select Side Road. Click OK.
4. In the Corridor Properties dialog box, on the Parameters tab, in the Baseline (2) row, change the Name to Side Road.
5. In the Side Road row, click the Profile column.
6. In the Select A Profile dialog box, select Side Road FGCL. Click OK.

**NOTE** Side Road FGCL is the profile you matched to the Through Road profile in Exercise 1: Matching Corridor Elevations in Profile (page 340).

7. In the Corridor Properties dialog box, on the Parameters tab, right-click the Side Road row. Click Add Region.
8. In the Select An Assembly dialog box, select Side Road Main. Click OK.
9. In the Corridor Properties dialog box, on the Parameters tab, in the Region (1) row, enter the following values:
   - Start Station: 0+100.00
End Station: 0+300.00

10 Click Set All Targets.

11 In the Target Mapping dialog box, in the Surfaces row, click <Click Here To Set All>.

12 In the Pick A Surface dialog box, select Existing Ground. Click OK.

13 In the Target Mapping dialog box, click OK.

14 In the Corridor Properties dialog box, click OK.

The Side Road is built using the selected assembly and is added to the corridor.

To continue this tutorial, go to Exercise 3: Removing Overlapping Geometry at the Intersection (page 346).

**Exercise 3: Removing Overlapping Geometry at the Intersection**

In this exercise, you will remove the overlapping geometry at the intersection by splitting the intersecting roads into several regions.

Corridor regions are used to associate assemblies with specific station ranges along the corridor.
For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Regions Using Grips.

This exercise continues from Exercise 2: Adding the Side Road to the Corridor (page 345).

To remove overlapping corridor geometry

NOTE This exercise uses Intersection-2.dwg with the modifications you made in the previous exercise, or you can open Intersection-3.dwg from the tutorial drawings folder (page 615).

1. In the plan view, select the corridor. Right-click. Click Corridor Properties.
   
   NOTE You must turn on Endpoint OSNAP to complete the following steps.

2. In the Corridor Properties dialog box, on the Parameters tab, under Side Road, right-click Region (1). Click Split Region.

3. When prompted to specify a station, snap to the end points inside Circles A, C, and H. Press Enter.

4. In the Corridor Properties dialog box, on the Parameters tab, in the Assembly column, assign the following assemblies:
   - Region (2): Side Road Right Only
   - Region (3): Null Assembly

5. In the Region (2) row, in the Target column, click .

6. In the Target Mapping dialog box, in the Object Name column, click <Click Here To Set All>.

7. In the Pick A Surface dialog box, select Existing Ground. Click OK.

8. In the Target Mapping dialog box, click OK.

9. In the Corridor Properties dialog box, click Apply.
   The corridor rebuilds, and some of the overlapping geometry has been removed. Notice that the region split above point H. You will correct the split location by adjusting the ending station value of the region that does not reference an assembly.
10 In the Corridor Properties dialog box, on the Parameters tab, in the Region (3) row, click the End Station cell. Reduce the End Station value by 0.01 meter. Click Apply. The corridor rebuilds to reflect the new end station value.

11 Repeat Steps 2 through 10 to split the Through Road into multiple regions using the following guidelines:
- Circles: Snap to the center of Circle E and G when prompted to specify stations.
Assembly: Assign the Through Road At Intersection assembly for Region (2).

End Station: In Region (2), reduce the End Station value by 0.01 meter.

NOTE If you would like to examine the construction of the assemblies used in this drawing, go to the Assemblies Named View.

To continue this tutorial, go to Exercise 4: Designing Intersection Curb Return Alignments and Profiles (page 349).

Exercise 4: Designing Intersection Curb Return Alignments and Profiles

In this exercise, you will define the profiles of the curb return alignments that will join the edges of traveled way of the intersecting roads.

Curb returns are the curves that connect the edges of traveled way (ETWs) of intersecting roads. While they are often created as simple 2D linework, curb returns must be created as alignments when offsets and horizontal and vertical control are needed for roadway and intersection design. A curb return is usually either a simple curve or chamfer. However, in some cases, it is made up of compound curves or a combination of lines and curves.
The drawings you will use in this tutorial have the curb return alignments already defined.

For more information, see the AutoCAD Civil 3D Help topic Creating Profiles.

This exercise continues from Exercise 3: Removing Overlapping Geometry at the Intersection (page 346).

To design curb return alignments and profiles

NOTE This exercise uses Intersection-3.dwg with the modifications you made in the previous exercise, or you can open Intersection-4.dwg from the tutorial drawings folder (page 615).

1 In the plan view, examine the red curved alignments around the intersection.
   The inner alignments are curb returns, which will serve as baselines for assemblies that will transition between the ETWs and centerlines of the intersecting roads.
   The outer alignments are shoulders, which will serve as targets for the subassemblies that will transition between the curb and daylight sideslope.

2 Select the corridor. Right-click. Click Corridor Properties.

3 In the Corridor Properties dialog box, on the Boundaries tab, right-click Corridor Boundary(1). Click Remove Boundary. Click OK.
   Now that the Side Road has been added to the corridor, this boundary is no longer accurate. You will create a more accurate surface boundary in Exercise 8: Adding a Boundary to the Intersection Corridor Surface (page 367).

4 Click Profiles menu ➤ Create Profile From Surface.

5 In the Create Profile From Surface dialog box, under Alignment, select SW Curb Return. Under Select Surfaces, select Existing Ground. Click Add. Click Draw In Profile View.

6 In the Create Profile View wizard, click Create Profile View. When prompted to select a profile view origin, click to the right of the Side Road profile.

7 Click Profiles menu ➤ Create Profile By Layout. Click the SW Curb Return PROFILE profile view.

8 In the Create Profile - Draw New dialog box, for Name, enter SW Curb Return. For Profile Style, select Design Profile. Click OK.
NOTE You must turn off Dynamic Input to complete the following steps.

9 On the Profile Layout Tools toolbar, click Draw Tangents.
In the next steps, you will specify the curb return beginning and ending elevations from the slope of the Through Road. You will use the Profile Station And Elevation From Plan transparent command to obtain the station and elevation values.

10 On the Transparent Commands toolbar, click Profile Station And Elevation From Plan. Click the SW Curb Return PROFILE profile view.

11 In the plan view, click one of the contours of the Through Road to select the corridor surface. When you are prompted to select a point, snap to the endpoints inside Circles A and B at the ends of the Southwest curb return. Press Enter to end the transparent command. Press Enter to end the Add Tangents command.
The profile view now contains a layout profile, which ties the curb return alignment to the ETWs of the intersecting roads at the appropriate elevations.

12 Repeat Steps 4 through 11 to create surface and layout profiles for the remaining three curb returns, snapping to the appropriate endpoints indicated in plan view:
NOTE The drawing used in the next exercise has all the curb return profiles designed. To save time, you can skip Step 12 and proceed to the next exercise.

- NW Curb Return: F, E
- NE Curb Return: H, G
- SE Curb Return: C, D

To continue this tutorial, go to Exercise 5: Designing Intersection Curb Return Assemblies (page 352).

Exercise 5: Designing Intersection Curb Return Assemblies

In this exercise, you will create assemblies to model the curb returns and join them to the intersecting roads.
To join with the intersecting roads, each curb return must be divided into two regions. The assembly will use the LaneOutsideSuper subassembly, which can target both an alignment and profile. In the first region, the LaneOutsideSuper subassembly targets the alignment and profile of the Side Road. In the second region, it targets the edge of the Through Road. To set these targets, alignments and profiles must exist for the north and south edges of the Through Road corridor.

For more information, see the AutoCAD Civil 3D Help topic Creating Assemblies.

This exercise continues from Exercise 4: Designing Intersection Curb Return Alignments and Profiles (page 349).

To design curb return assemblies

**NOTE** This exercise uses Intersection-4.dwg with the modifications you made in the previous exercise, or you can open Intersection-5.dwg from the tutorial drawings folder (page 615).

1. Click View menu ➤ Named Views.
2. In the View Manager dialog box, under Model Views, select Assemblies. Click Set Current. Click OK.
3. Click Corridors menu ➤ Create Assembly.
4. In the Create Assembly dialog box, under Name, enter Curb Return Left. Click OK. In the drawing window, click above the Curb Return Left text to place the new assembly.
5. Repeat Steps 3 and 4 to create an assembly named Curb Return Right above the Curb Return Right text in the drawing.

**TIP** Give each subassembly a specific meaningful name to make them easy to identify when you are assigning targets. Meaningful names also help you identify subassemblies in the Subassemblies collection in Prospector.

Next, you will change the subassembly name template to specify the side on which you place a subassembly. These names will make it easier to identify the subassemblies after you have created them.

6. In Toolspace, on the Settings tab, expand the Subassembly ➤ Commands collection. Right-click CreateSubAssemblyTool. Click Edit Command Settings.
7 In the Edit Command Settings dialog box, expand the Subassembly Name Templates property. In the Create From Macro row, click in the Value cell. Click 

8 In the Name Template dialog box, under Name, delete the (<[Next Counter(CP)]>) formula. Under Property Fields, select Subassembly Side. Click Insert. Click OK. Click OK to close the Edit Command Settings dialog box.

9 Using the Civil 3D Metric - Structures tool palette, add the UrbanCurbGutterValley1 subassembly to the left side of the Curb Return Left assembly.

10 Using the Civil 3D Metric - Generic tool palette, add the LinkWidthAndSlope subassembly to the back of the UrbanCurbGutterValley1 subassembly using these parameters:
   ■ Side: Left
   ■ Width: 1.5
   ■ Slope: 2%

11 Using the Civil 3D Metric - Basic tool palette, attach the BasicSideSlopeCutDitch subassembly to the LinkWidthAndSlope subassembly using these parameters:
   ■ Side: Left
   ■ Foreslope Width: 0
   ■ Bottom Width: 0
   ■ Backslope Width: 0

12 Using the Civil 3D Metric - Roadway tool palette, add the LaneOutsideSuper subassembly to the right side of the Curb Return Left assembly using the default parameters.

13 Press Esc to exit out of subassembly placement mode.
14 In the drawing window, click the Curb Return Left assembly baseline. Right-click. Click Assembly Properties.

15 In the Assembly Properties dialog box, on the Construction tab, examine the names of the subassemblies.
Notice that the default subassembly name displays the side on which you added each subassembly. Including the side makes it easy to see how the assembly is structured. This practice is especially helpful when you create symmetrical assemblies, where the same subassemblies are used on opposite sides of the baseline.

Next, you will give the subassemblies even more specific names. Specific names make it easy to assign targets and identify similar subassemblies on the Prospector tab in the Subassemblies collection. In a project, such as this, that uses a subassembly multiple times, it is critical that each subassembly has a descriptive, distinct name.

16 In the Assembly Properties dialog box, select UrbanCurbGutterValley1 - Left. Click it again to highlight the text. Enter Curb - CR-L. Press Enter.

17 Rename the parent Group collections as CR-L-L and CR-L-R.

18 Rename the remaining subassemblies using the following guidelines:
   ■ LinkWidthAndSlope - Left: Shoulder - CR-L
   ■ BasicSideSlopeCutDitch - Left: Slope - CR-L
   ■ LaneOutsideSuper - Right: Lane - CR-L

19 In the Assembly Properties dialog box, click OK.
20 Select the slope, shoulder, and curb subassemblies in the Curb Return Left assembly. Right-click. Click Mirror.

21 Click the assembly marker above the Curb Return Right text.

22 Repeat Steps 19 and 20 to mirror the lane subassembly from the Curb Return Left assembly to the Curb Return Right assembly.

Further exploration: Follow Steps 15 through 18 to rename the subassemblies in the Curb Return Right assembly.

NOTE The drawing used in the next exercise has all the subassemblies named appropriately. To save time, you can skip the further exploration task and proceed to the next exercise.

To continue this tutorial, go to Exercise 6: Adding the Curb Returns to the Intersection (page 356).

Exercise 6: Adding the Curb Returns to the Intersection

In this exercise, you will add each curb return alignment to the corridor as a baseline, and then create additional regions so that you can use multiple alignment and profile targets.

This exercise is divided into two phases. In the first phase, you will add a curb return alignment as a baseline and examine the results. In the second phase,
you will create a profile of the edge of the through road, split the baseline into two regions, and then reassign the assemblies to target the new profile.

For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Parameters.

This exercise continues from Exercise 5: Designing Intersection Curb Return Assemblies (page 352).

To add the curb returns to the intersection

**NOTE** This exercise uses Intersection-5.dwg with the modifications you made in the previous exercise, or you can open Intersection-6.dwg from the tutorial drawings folder (page 615).

1. Select the corridor. Right-click. Click Corridor Properties.
2. In the Corridor Properties dialog box, on the Parameters tab, click Add Baseline.
3. In the Pick Horizontal Alignment dialog box, select SW Curb Return. Click OK.
4. In the Baseline (3) row, change the Name to SW Curb Return.
5. In the SW Curb Return row, click the Profile column.
6. In the Select A Profile dialog box, select SW Curb Return. Click OK.
7. Right-click the SW Curb Return baseline. Click Add Region. In the Select An Assembly dialog box, select Curb Return Left. Click OK.
8. In the SW Curb Return, Region(1) row, in the Frequency column, click . In the Frequency To Apply Assemblies dialog box, set the following properties to 1, and then click OK.
   - Along Tangents
   - Along Curves
   - Along Spirals
   - Along Profile Curves

**NOTE** Because the curb return alignments in this drawing do not contain spirals, the Along Spirals setting is ignored.
9 In the SW Curb Return, Region(1) row, in the Target column, click .
   In the Target Mapping dialog box, in the Surfaces row, click <Click Here To Set All>.

10 In the Pick A Surface dialog box, select Existing Ground. Click OK.

11 In the Target Mapping dialog box, in the Target Alignment row, click the Object Name cell.

   **NOTE** Notice that the Subassembly column lists the subassemblies that are included in the assembly that is assigned to the region.

12 In the Set Width Or Offset Target dialog box, in the Select Object Type To Target list, select Alignments. In the Select Alignments list, select SW Shoulder. Click Add. Click OK.

13 Repeat Steps 10 and 11 to set the subassemblies to target the following objects:

   **NOTE** Notice that because you assigned meaningful names to the subassemblies when you created the assemblies in Exercise 5: Designing Intersection Curb Return Assemblies (page 352), it is easy to determine the subassembly for which you are assigning a target.

   Width Or Offset Targets
   - Shoulder - CR-L: SW Shoulder
   - Lane - CR-L: Side Road

   Slope Or Elevation Targets
   - Shoulder - CR-L: <None>
   - Lane - CR-L: Side Road FGCL

14 Click OK to close the Target Mapping dialog box. Click OK to close the Corridor Properties dialog box and rebuild the corridor.

   Notice that the selected assembly has been applied to the curb return, but the assembly overlaps the Through Road geometry. In the following steps, you will create a profile of the South Edge of Through Road alignment, split the baseline region, and then set the second region to target the South Edge of Through Road profile.
To create a profile of the Through Road edge and reassign targets

1 In the Layers list, on the C-ROAD-EOP layer, click 🏡 .
   An alignment is displayed between Circles E and G, and Circles B and D. You will use these alignments to create profiles, which the second region of the curb returns will target.

2 Click Profiles menu ➤ Create Profile From Surface.

3 In the Create Profile From Surface dialog box, under Alignment, select Through Road-EOP-S. Under Select Surfaces, select Existing Ground. Click Add. Click Draw In Profile View.

4 In the Create Profile View wizard, click Create Profile View. When prompted to select a profile view origin, click to the right of the curb return profile views.

5 Click Profiles menu ➤ Create Profile By Layout. Click the Through Road-EOP-S PROFILE profile view.

6 In the Create Profile - Draw New dialog box, under Name, notice that the name template specifies that the profile will be automatically named using the alignment name and profile type. Click OK.

**NOTE** You must turn on Endpoint OSNAP to complete the following steps.
7 On the Profile Layout Tools toolbar, click Draw Tangents.

8 On the Transparent Commands toolbar, click Profile Station And Elevation From Plan. Click the Through Road-EOP-S PROFILE profile view.

9 In the plan view, click one of the contours of the Through Road to select the corridor surface. When you are prompted to select a point, snap to the endpoints inside Circles D and B. Press Enter to end the transparent command. Press Enter to end the Add Tangents command.

The profile view now contains a layout profile, which will serve as a target for the southwest and southeast curb return regions.

10 In the plan view, select the corridor. Right-click. Click Corridor Properties.

11 Under SW Curb Return, right-click Region(1). Click Split Region. When prompted to specify a station, snap to the center of Circle I. Press Enter to end the Split Region command.

12 In the SW Curb Return, Region(2) row, in the Target column, click .

In the Target Mapping dialog box, in the Object Name column, set the subassemblies to target the following objects:

NOTE The targets that you set for the first region are applied to the new region. When you set a new target, make sure that you delete the old one.

Width Or Offset Targets
- Shoulder - CR-L: SW Shoulder
Lane - CR-L: South Edge of Through Road-EOP-S
Slope Or Elevation Targets
Shoulder - CR-L: <None>
Lane - CR-L: Through Road-EOP-S - Layout

Click OK to close the Target Mapping dialog box. Click Apply to rebuild the corridor.
Notice how the assembly now targets different alignments and profiles, based on where you split the region. Below Circle I, the assembly targets the Side Road alignment and profile. To the left of Circle I, the assembly targets the Through Road-EOP-S alignment and profile. The new targets resolve the issue of the geometry overlapping the Through Road geometry.

In the Corridor Properties dialog box, clear the check box next to SW Curb Return. Click Apply.
The regions you created are hidden. By hiding the completed region, you can concentrate on the design of the other curb returns. When you rebuild the corridor to incorporate the other curb returns, hidden curb returns will not be rebuilt.

**TIP** Use the Corridor Properties dialog box to turn off the modeling of regions not required for current operations. Turning off regions that you do not currently need improves the speed of corridor rebuilding.
If the corridor surface drops to zero elevation at the end of the last region, there are two possible causes:

- First, you did not snap the layout profile to the end of the existing ground profile. Use the Profile Grid View to note the elevation of the last PVI. Using the layout profile's endpoint grip, snap the last PVI to the endpoint of the existing ground profile. Then, make sure the PVI elevation value is identical to the value that you noted earlier.

- Second, the actual End Station value of the baseline alignment and profile is slightly less than the value that is specified for the region. This value is rounded up to accommodate the specified precision setting. You can correct this by reducing the End Station value of that region by 0.01m. The End Station setting is located in the Corridor Properties dialog box on the Parameters tab.

Repeat all the steps in this exercise to model the remaining three curb returns, creating a profile for the Through Road-EOP-N alignment.

**NOTE** If you use the sample drawing listed in the next exercise, all four curb returns are already modeled.
In the Corridor Properties dialog box, select the check boxes for all baselines. Click OK.

The corridor is rebuilt and displayed.

To continue this tutorial, go to Exercise 7: Evaluating the Intersection Corridor Surface for Drainage Issues (page 363).

**Exercise 7: Evaluating the Intersection Corridor Surface for Drainage Issues**

In this exercise, you will analyze the corridor surface to determine whether its elevation must be adjusted to improve drainage.

When you designed the curb return profiles in Exercise 4: Designing Intersection Curb Return Alignments and Profiles (page 349), you set a constant grade from the beginning to the end. Now that the corridor surface is complete, you may need to add high or low points to provide better drainage. To perform this analysis, you will use the AutoCAD Civil 3D water drop analysis feature.

For more information, see the AutoCAD Civil 3D Help topic *Drawing Water Drop Paths*.

This exercise continues from Exercise 6: Adding the Curb Returns to the Intersection (page 356).
To perform a water drop analysis on the corridor intersection

NOTE This exercise uses Intersection-6.dwg with the modifications you made in the previous exercise, or you can open Intersection-7.dwg from the tutorial drawings folder (page 615).

1 Click Surfaces menu ➤ Utilities ➤ Water Drop. Press Enter to select the surface.

2 In the Select A Surface dialog box, select Intersection. Click OK.

3 In the Water Drop dialog box, in the Place Marker At Start Point row, select Yes. Click OK.

4 When prompted to select a point, click various places near the center of the intersection and in the curb return quadrants.

Notice that while the surface drains primarily toward the Northeast quadrant, there is a low point near Circle F. In the following steps, you will modify the path of the water by adding a PVI at a lower point near the middle of the Northwest curb return.

5 Press Enter to end the water drop command.

6 Zoom in to the NW Curb Return PROFILE.
7 Select the blue, layout profile line. Right-click. Click Edit Profile Geometry.

8 In the Profile Layout Tools toolbar, click Insert PVI.

9 Click the blue layout profile line near its midpoint. Press Enter to end the Insert PVI command.

10 Click the red PVI grip at the midpoint. Drag the PVI straight down until it is slightly lower than the beginning point of the profile. Click to place the PVI. Press Esc to deselect the profile.

11 In the plan view, select the corridor. Right-click. Click Rebuild Corridor. The corridor is updated to reflect the new PVI in the Northwest quadrant of the intersection. Notice that the waterdrop paths did not update. In the following steps, you will delete the waterdrop paths, and use the existing start point markers to examine the result of the new PVI location.

12 In the plan view, select one of the waterdrop paths. Right-click. Click Select Similar. Press Delete.

13 Click Surfaces menu ➤ Utilities ➤ Water Drop. Press Enter to select the surface.

14 In the Select A Surface dialog box, select Intersection. Click OK.

15 In the Water Drop dialog box, click OK.

16 When prompted to select a point, click the start point markers of the previous water drop analysis.
Notice that the water now drains near the middle of the Northwest curb return.

Press Enter to end the water drop command.

**TIP** To hide the waterdrop paths, turn off the C-TOPO-WDRP layer. To delete the waterdrop paths, select one path and one start point marker, right-click, click Select Similar, and then press Delete.

**Further exploration:** Lower the PVI that you created in the NW Curb Return profile, perform another waterdrop analysis, and examine the results. Use the procedures in this exercise to add PVIs to other layout profiles in the intersection to affect runoff.

To continue this tutorial, go to Exercise 8: Adding a Boundary to the Intersection Corridor Surface (page 367).
Exercise 8: Adding a Boundary to the Intersection Corridor Surface

In this exercise, you will create an accurate boundary of the final corridor surface.

Adding a surface boundaries to a corridor prevents triangulation outside the daylight line of the corridor surface. An accurate boundary around the corridor surface provides more accurate surface area and volume calculations.

For more information, see the AutoCAD Civil 3D Help topic Adding and Editing Corridor Boundaries.

This exercise continues from Exercise 7: Evaluating the Intersection Corridor Surface for Drainage Issues (page 363).

To add a boundary to the corridor

NOTE This exercise uses Intersection-7.dwg with the modifications you made in the previous exercise, or you can open Intersection-8.dwg from the tutorial drawings folder (page 615).

TIP Use a single viewport to make it easier to pan and zoom in this exercise. Select View menu ➤ Viewports ➤ 1 Viewport.

1 In the drawing, click the corridor. Right-click. Click Corridor Properties.

2 In the Corridor Properties dialog box, click the Boundaries tab.

3 In the Boundary table, right-click the Intersection surface. Click Add Interactively.

NOTE You must turn on Endpoint OSNAP to complete the following steps.

4 In the drawing, click the green daylight feature line North of station 1+160 on the Through Road alignment.

5 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.

6 Pan to the right end of the corridor.

Notice that a red line appears along the first feature line you selected.
Clicking on any point along the current feature line causes the red boundary to persist from the previous point.

7 Using the endpoint OSNAP, click station 1+280, which is the corridor end station.

8 Click the green daylight feature line at the South of station 1+270. This station is the location of the nearest assembly along the next feature line. It is not labeled, but is located between stations 1+260 and 1+280.

9 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK. Notice that the red boundary has crossed the corridor at the ending station and continued on to the feature line you selected in Step 8. If you had clicked a point on the upper feature line before the ending station, the boundary would have crossed at the nearest assembly.
10  Pan to the intersection. Using the endpoint OSNAP, click the blue assembly line to the left of station 1+160. This station is location the last assembly in the current feature line.

11  On the green daylight feature line along the Southeast curb return, click the blue assembly line that is to the left of the one you clicked in Step 10.
This station is the location of the nearest assembly along the next feature line.

12 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.

13 Click the green daylight feature line along the Southeast curb return where it intersects with the blue assembly line marked that passes through Circle A. This station is the location of the nearest assembly along the next feature line.

14 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.

15 Pan to station 0+100, which is at the lower end of the Side Road portion of the corridor. Continue this procedure until the boundary follows all the daylight lines around the corridor. Remember that to continue the boundary onto another feature line, you must click the last assembly in the current feature line, and then click the first assembly in the next feature line.

16 When the boundary reaches the beginning, enter C on the command line to close the boundary and return to the Corridor Properties dialog box.
17 In the Corridor Properties dialog box, expand the Intersection surface collection item to see the boundary item. Change the corridor boundary name to Through Road - Side Road Intersection and set its Use Type to Outside Boundary.

18 Click OK to create the boundary and close the Corridor Properties dialog box.

Notice that the corridor surface contours no longer appear outside the daylight line.

To continue to the next tutorial, go to Tutorial: Roundabout Design (page 371).

**Tutorial: Roundabout Design**

This tutorial demonstrates how to design a four-way roundabout within a corridor.

Because a roundabout is a type of intersection, its design process is similar to the steps outlined in the Intersection Design tutorial (page 339). The main difference in the process is in the construction of the roundabout median and lane. While curb return assemblies in an intersection target the road centerlines, in a roundabout they target the outside edge of the roundabout lane.

Because the roundabout design process is so complex, it helps to break it down into discrete tasks. This tutorial demonstrates each of the most common tasks involved in roundabout design.
Some of the tasks that you completed in the Intersection Design tutorial (page 301) have already been completed for this tutorial. In the roundabout design sample drawings, the following tasks are already completed:

- All of the necessary alignments have been created.
- The Through Road and Side Road alignments have matching profile elevations (page 340).
- Both the Through Road and Side Road alignments have been added to the corridor (page 345).
- Left and right curb return assemblies (page 352) have been created.

**IMPORTANT** Before you begin this tutorial, you must have a thorough understanding of the concepts that are explained in the basic Corridors Tutorials (page 301).

For more information, see the AutoCAD Civil 3D Help topic Creating Corridors.

**Exercise 1: Removing Overlapping Geometry at the Roundabout**

In this exercise, you will remove the overlapping geometry at the roundabout by splitting the intersecting roads into several regions.
Corridor regions are used to associate assemblies to specific station ranges along the corridor. In this exercise, you will leave some of the corridor geometry in place inside the roundabout median. You must keep some of the geometry because you will extract surface elevations from these areas in a later exercise.

For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Regions Using Grips.

To remove overlapping corridor geometry

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open Roundabout-1.dwg. This drawing contains a fully developed corridor that includes two intersecting alignments named Through Road and Side Road. The layout profiles of the roads match at their point of intersection.

The drawing also includes both an Existing Ground surface and a corridor surface named Roundabout. Key points of interest are marked with a circle and a letter. You will use these points, as well as the other alignments in the drawing, later in this tutorial.

2. In the plan view, select the corridor. Right-click. Click Corridor Properties.

3. In the Corridor Properties dialog box, on the Parameters tab, under Through Road, right-click Region (1). Click Split Region.
NOTE You must turn off OSNAP to complete the following steps.

4 When prompted to specify a station, click to the right of the blue assembly marker line that is to the right of Circle B. Click to the left of the blue assembly marker that is to the left of Circle D. Press Enter.

5 In the Corridor Properties dialog box, on the Parameters tab, in the Through Road, Region (2) row, click the Assembly column.

6 In the Select An Assembly dialog box, select Null Assembly. Click OK.

7 In the Corridor Properties dialog box, on the Parameters tab, under Side Road, right-click Region (1). Click Split Region.

8 When prompted to specify a station, click above the point of tangency marker that is above Circle C. Click below the blue assembly marker that is below Circle A. Press Enter.

9 In the Corridor Properties dialog box, on the Parameters tab, in the Side Road, Region (2) row, click the Assembly column.

10 In the Select An Assembly dialog box, select Null Assembly. Click OK.

11 Click OK to close the Corridor Properties dialog box.

The corridor is rebuilt, and the overlapping geometry has been removed. Some of the corridor geometry remains in place inside the roundabout median, because you will extract surface elevations from these areas in a later exercise.
NOTE If you would like to examine the construction of the assemblies used in this drawing, go to the Assemblies Named View.

To continue this tutorial, go to Exercise 2: Designing Roundabout Alignments and Profiles (page 375).

**Exercise 2: Designing Roundabout Alignments and Profiles**

In this exercise, you will design the profiles of the alignments that represent the inside and outside edges of the roundabout lane.

You will set the roundabout profile elevations to the same elevation as the existing corridor. The roundabout median, which is the inside edge of the roundabout lane, projects inward to a single elevation at its center.

The provided drawings have the necessary alignments already defined.

For more information, see the AutoCAD Civil 3D Help topic *Creating Profiles*.

This exercise continues from Exercise 1: Removing Overlapping Geometry at the Roundabout (page 372).
To define curb return alignments and profiles

NOTE This exercise uses Roundabout-1.dwg with the modifications you made in the previous exercise, or you can open Roundabout-2.dwg from the tutorial drawings folder (page 615).

1 In the plan view, examine the red circular alignments.
   The inner alignment is the roundabout median. This alignment will serve as the baseline for the Roundabout assembly, which will model the median and lane.
   The outer alignment is the outside edge of the roundabout lane. This alignment will serve as a target for both the Roundabout assembly and the assemblies that model the curb returns.
   Both circular alignments consist of a series of three-point fixed curves with identical radii. Each curve entity starts on one of the centerline road alignments, and ends on the other.

2 Click Profiles menu ➤ Create Profile From Surface.

3 In the Create Profile From Surface dialog box, under Alignment, select Roundabout Median Edge. Under Select Surface, select Existing Ground. Click Add. Click Draw In Profile View.

4 In the Create Profile View wizard, click Create Profile View. When prompted to select a profile view origin, click below the Side Road PROFILE profile view.

5 Click Profiles menu ➤ Create Profile By Layout. Click the Roundabout Median Edge PROFILE profile view.

6 In the Create Profile - Draw New dialog box, for Profile Style, select Design Profile. Click OK.

NOTE You must turn on Endpoint OSNAP to complete the following steps.

7 On the Profile Layout Tools toolbar, click Draw Tangents.
   In the next steps, you will specify the median elevations from the slope of the Through Road and Side Road. You will use the Profile Station And Elevation From Plan transparent command to obtain the station and elevation values.
8 On the Transparent Commands toolbar, click Profile Station And Elevation From Plan. Click the Roundabout Median Edge PROFILE profile view.

9 In the plan view, click one of the contours to select the corridor surface. When you are prompted to select a point, snap to the endpoints inside Circles A, B, C, and D. Press Enter to end the transparent command. Press Enter to end the Add Tangents command.

The profile view now contains a layout profile, which ties the median edge to the appropriate elevations of the intersecting roads. Notice that a PVI was not created at the end station. You will manually add a PVI in the following steps.

NOTE You must turn on Endpoint OSNAP and Endpoint OTRACK to complete the following steps.

10 On the Profile Layout Tools toolbar, click Insert PVI.

11 When you are prompted to specify a point for the new PVI, hover the cursor over the endpoint of the red existing ground profile. Hover the cursor over the beginning point of the blue layout profile that you created in the Roundabout Median Edge PROFILE view. Move the cursor to the point where the dashed tracking lines intersect. Click to place the PVI. Press Enter.

12 On the Profile Layout Tools toolbar, click Profile Grid View.
In the Profile Entities vista, notice that the PVI Elevation values of the first and last PVIs are identical. In the last row, notice that the PVI Station is 0+094.25m.

In the drawing window, click the red existing ground profile. In the Profile Entities vista, scroll down until you can see the last row. Notice that, like the ending station of the layout profile, the PVI Station value is 0+094.25m.

**NOTE** If the PVI Station values of the ending stations do not match, it is probably because you did not track from the endpoint of the existing ground profile. On the Profile Layout Tools toolbar, click Delete Entity, and then click the last tangent in the blue layout profile. Repeat Steps 10 through 13 to add the PVI.

Repeat Steps 2 through 13 to create profiles of the Roundabout Lane Edge alignment.

**NOTE** The drawing used in the next exercise has the Roundabout Lane Edge profile designed. To save time, you can skip Step 14 and proceed to the next exercise.

To continue this tutorial, go to Exercise 3: Designing the Roundabout Assembly (page 378).

**Exercise 3: Designing the Roundabout Assembly**

In this exercise, you will create an assembly to model the roundabout median and lane.

The roundabout assembly attaches to the Roundabout Median Edge alignment. On the inside of the alignment, the assembly consists of a curb and a subassembly that links to an elevation at the center of the roundabout. On the outside, it consists of a road lane subassembly that targets the Roundabout Lane Edge profile.

For more information, see the AutoCAD Civil 3D Help topic *Creating Assemblies*.

This exercise continues from Exercise 2: Designing Roundabout Alignments and Profiles (page 375).
To design the roundabout assembly

NOTE This exercise uses Roundabout-2.dwg with the modifications you made in the previous exercise, or you can open Roundabout-3.dwg from the tutorial drawings folder (page 615).

1 Click View menu ➤ Named Views.

2 In the View Manager dialog box, under Model Views, select Assemblies. Click Set Current. Click OK.

3 Click Corridors menu ➤ Create Assembly.

4 In the Create Assembly dialog box, under Name, enter Roundabout. Click OK. In the drawing window, click above the Roundabout text to place the new assembly.

5 Using the Civil 3D Metric - Structures tool palette, add the UrbanCurbGutterValley1 subassembly to the left side of the Roundabout baseline.

6 Using the Civil 3D Metric - Generic tool palette, add the LinkOffsetAndElevation subassembly to the back of the UrbanCurbGutterValley1 subassembly using these parameters:
   ■ Offset From Baseline: -15.000m
   ■ Elevation: 56.000m

7 Using the Civil 3D Metric - Roadway tool palette, add the LaneOutsideSuper subassembly to the assembly using these parameters:
   ■ Side: Right
   ■ Width: 6.000m

8 Press Esc to exit subassembly placement mode.

9 In the drawing window, click the Roundabout assembly baseline. Right-click. Click Assembly Properties.
In the Assembly Properties dialog box, on the Construction tab, click LinkOffsetAndElevation - Right. Click it again to highlight the text. Enter Median - Roundabout.

**TIP** Give each subassembly a specific meaningful name to make them easier to identify when you are assigning targets. Meaningful names also help you identify subassemblies in the Subassemblies collection in Prospector.

11 Rename the parent Group collections to Roundabout - L and Roundabout - R.

12 Rename the other subassemblies using the following guidelines:
   - UrbanCurbGutterValley1 - Left: Curb - Roundabout
   - LaneOutsideSuper - Right: Lane - Roundabout

13 In the Assembly Properties dialog box, click OK.

To continue this tutorial, go to Exercise 4: Adding the Roundabout to the Corridor (page 380).

### Exercise 4: Adding the Roundabout to the Corridor

In this exercise, you will add the roundabout to the corridor, and assign the appropriate targets. You will adjust the regions of the Main Road and Side Road baselines to better suit the design.

For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Parameters.

This exercise continues from Exercise 3: Designing the Roundabout Assembly (page 378).

**To add the roundabout to the corridor**

**NOTE** This exercise uses Roundabout-3.dwg with the modifications you made in the previous exercise, or you can open Roundabout-4.dwg from the tutorial drawings folder (page 615).

1 In plan view, select the corridor. Examine the grips that are displayed at the four regions.
You can use the grips to graphically adjust the location of the region splits.

- The \( \text{grips} \) adjust the location of the regions separately. If you move one of these grips, there will be a gap between the regions.

- The \( \text{grips} \) adjust the location of both regions simultaneously. If you move this grip, the ending station value of the first region and the starting station value of the second region will match.

**NOTE:** You must turn on Endpoint OSNAP to complete the following steps.

2 Using the \( \text{grips} \), move the region splits to the following locations:

- Through Road West: Circle O
- Through Road East: Circle L
- Side Road North: Circle N
- Side Road South: Circle I

You extracted the necessary corridor elevations from these regions in Exercise 2: Designing Roundabout Alignments and Profiles (page 375). The corridor surface information in these areas is no longer needed, so the regions can be pulled back to the appropriate design locations.

3 Select the Corridor. Right-click. Click Rebuild Corridor.

The corridor rebuilds and displays the new locations for the region splits.
Notice that the region splits at the North and East of the roundabout are past the location that you clicked. You will correct the splits by adjusting the ending station value of the regions that do not reference an assembly.

4 Select the corridor. Right-click. Click Corridor Properties.

5 In the Corridor Properties dialog box, on the Parameters tab, in the Through Road, Region (2) row, click the End Station cell. Reduce the End Station value by 0.01 meter. In the Side Road, Region (2) row, reduce the End Station value by 0.01 meter. Click Apply. The corridor rebuilds to reflect the new end station values.

6 In the Corridor Properties dialog box, on the Parameters tab, click Add Baseline.

7 In the Pick Horizontal Alignment dialog box, select Roundabout Median Edge. Click OK.

8 In the Baseline (3) row, change the Name to Roundabout Median.

9 In the Roundabout Median row, in the Profile column, click <Click Here>.

10 In the Select A Profile dialog box, select Roundabout Median Edge - Layout. Click OK.

11 Right-click Roundabout Median. Click Add Region. In the Select An Assembly dialog box, select Roundabout. Click OK.
12 In the Roundabout Median, Region (1) row, in the Frequency column, click . In the Frequency To Apply Assemblies dialog box, set the following properties to 1.000m:
- Along Tangents
- Along Curves
- Along Spirals
- Along Profile Curves

13 In the Roundabout Median, Region (1) row, in the Target column, click .

14 In the Target Mapping dialog box, in the Object Name column, click the Width Alignment row.

**NOTE** Notice that the Subassembly column lists the subassemblies that are included in the assembly that is assigned to the region.

15 In the Set Width Or Offset Target dialog box, in the Select Alignments list, select Roundabout Lane Edge. Click Add. Click OK.

16 Repeat Steps 14 and 15 to set the subassemblies to target the following objects:

**NOTE** Notice that because the subassemblies have meaningful names, it is easy to determine the subassembly for which you are assigning a target.

**Width Or Offset Targets**
- Median - Roundabout: <None>
- Lane - Roundabout: Roundabout Lane Edge

**Slope Or Elevation Targets**
- Median - Roundabout: <None>
- Lane - Roundabout: Roundabout Lane Edge - Layout

17 Click OK to close the Target Mapping dialog box.

18 In the Corridor Properties dialog box, click OK to rebuild the corridor. Notice that the roundabout has been modeled and is included in the corridor. As shown in the following image, the elevation might drop to
zero at the intersection of the beginning and ending stations of the Roundabout Median Edge alignment. This happened because the actual ending station value is less than the value that is set for the region. This difference results in the end of the region overlapping the beginning. You will correct this in the following steps.

19 Select the corridor. Right-click. Click Corridor Properties.

20 In the Corridor Properties dialog box, in the Roundabout Median, Region (1) row, change the End Station value from 0+194.25 to 0+194.24.
The actual End Station value of the baseline alignment and profile is slightly less than 0+194.25, but the value is rounded up to accommodate the specified precision setting. Reducing the value by 0.01 meter will resolve the conflict, without a noticeable loss of accuracy.

21 Click OK.
The corridor is rebuilt, and the elevation error is resolved.
Corridor with properly modeled roundabout assembly

To continue this tutorial, go to Exercise 5: Designing Roundabout Curb Return Alignments and Profiles (page 385).

Exercise 5: Designing Roundabout Curb Return Alignments and Profiles

In this exercise, you will define the profiles of the curb return alignments that will join the roundabout lane to the edges of traveled way of the intersecting roads.

_Curb returns_ are the fillets that connect the edges of traveled way (ETWs) of intersecting roads. While they are often initially designed using simple 2D linework, their final design must be created as alignments when offsets and horizontal and vertical control are needed for roadway and intersection design.
In a standard intersection, a curb return is usually either a simple curve or chamfer. However, in complex intersections, such as a roundabout, it usually consists of either compound curves or a combination of lines and curves.

The provided drawings have the curb return assemblies already created and the alignments already defined.

For more information, see the AutoCAD Civil 3D Help topic *Creating Assemblies*.

This exercise continues from Exercise 4: Adding the Roundabout to the Corridor (page 380).

To define curb return alignments and profiles

**NOTE** This exercise uses *Roundabout-4.dwg* with the modifications you made in the previous exercise, or you can open *Roundabout-5.dwg* from the tutorial drawings folder (page 615).

1. In the plan view, examine the red curved alignments that travel from one road, to the edge of the roundabout, and then on to the other road. The inner alignments are curb returns. The curb returns will serve as baselines for the assemblies that will transition between the ETWs of the roundabout and the intersecting roads. The outer alignments are shoulders. The shoulders will serve as targets for the subassemblies that will transition between the curb and daylight sideslope.

2. Click View menu ➤ Named Views.

3. In the View Manager dialog box, under Model Views, select Profiles. Click Set Current. Click OK.

4. Click Profiles menu ➤ Create Profile From Surface.

5. In the Create Profile From Surface dialog box, under Alignment, select SW Curb Return. Under Select Surfaces, select Existing Ground. Click Add. Click Draw In Profile View.

6. In the Create Profile View wizard, click Create Profile View. When prompted to select a profile view origin, click to the right of the Roundabout Lane Edge PROFILE view.

   In the next few steps, you will apply a label style that displays the alignment station and corridor surface elevation at each alignment geometry point. Using the data displayed in these labels, you will create a layout profile for the curb returns by entering PVI station and elevation values.
For more information about creating label styles that refer to other objects, see the Creating a Label Style that Refers to Another Object tutorial exercise (page 595).

7 In the plan view, select the SW Curb Return alignment. Right-click. Click Edit Alignment Labels.

8 In the Alignment Labels dialog box, under Type, select Geometry Points. Under Geometry Point Label Style, select Surface Elevation At Alignment Station. Click Add.

9 In the Geometry Points dialog box, make sure that all check boxes are selected. Click OK.

In the Geometry Points dialog box, you can specify the geometry points that you want to label. In this case, you want to label all of the significant geometry points.

10 In the Alignment Labels dialog box, click OK.

The labels are added to the alignment, but the elevation values are displayed as ???. These characters are displayed because you have not associated a surface with the elevation label component.

11 Press Esc to deselect the alignment. Ctrl+click each Surface Elevation At Alignment Station label. Right-click. Click Properties.

12 In the Properties palette, under Reference Text Objects, in the Surface Elevation At Alignment Station row, click <none>. Click . When prompted to select an object, click the Roundabout corridor surface. Close the Properties palette. Press Esc to deselect the labels.

The labels now display the station and Roundabout surface elevation at the alignment geometry points. If the labels overlap other details in the drawing, drag them to a new location.

13 Click Profiles menu ➤ Create Profile By Layout. Click the SW Curb Return PROFILE profile view.

14 In the Create Profile - Draw New dialog box, click OK.

15 On the Profile Layout Tools toolbar, click Insert PVIs - Tabular.

16 In the Insert PVIs dialog box, enter the Station and Elevation values that are displayed on the labels you created. Enter the data in ascending order by station. Click OK after you enter the elevations at the first three stations.
If you enter the Station value of the last station, you may be notified that the station is out of the alignment limits. This notification is displayed because the actual station value is less than the value that is displayed by the precision of the station label. The actual station value of the layout profile endpoint must match the actual station value of the existing ground profile endpoint. You can work around this difference by clicking Insert PVI on the Profile Layout Tools toolbar, and then using either of the following methods:

- Snap to the endpoint of the red existing ground profile. Use the Profile Grid View to set the new PVI elevation of the value displayed in the Surface Elevation At Alignment Station label.

- On the Profile Layout Tools toolbar, click Insert PVI, and then use the Profile Station And Elevation From Plan transparent command to set the last PVI. For information about using the Profile Station And Elevation From Plan transparent command, see the Designing Intersection Curb Return Alignments and Profiles exercise (page 349) in the Intersections tutorials.

Repeat Steps 4 through 16 to create surface and layout profiles for the remaining three curb returns.
NOTE The drawing provided for the next exercise has all four curb return profiles designed. If you would like to skip Step 17, open Roundabout-6.dwg.

**TIP** To improve drawing performance, hide any labels that you do not currently need. Because labels are dynamically linked to the object they annotate, processing power is taken to update labels when their parent object is rebuilt.

Now that the profiles have been created, the Surface Elevation At Alignment Station labels are no longer necessary. You can hide these labels in several ways:

- **Alignment Labels Dialog Box**: If you clear the labels from the Alignment Labels dialog box, the labels are cleared from the alignment.

- **Feature Label Style Defaults**: If you set the label visibility to False at the feature level, all labels for that feature type in the drawing are hidden.

- **Label Type Label Style Defaults**: If you set the label type visibility to False at the label type level, all labels of that type in the drawing are hidden.
Label Style: If you set the label style visibility to False, all labels that use that style are hidden.

For this exercise, the preferred method is to set the label style visibility to False. This method hides all the Surface Elevation At Alignment Station labels for all four curb returns without affecting the other labels in the drawing.

18 In Toolspace, on the Settings tab, expand the Alignment ➤ Label Styles ➤ Station ➤ Geometry Point collections. Right-click Surface Elevation At Alignment Station. Click Edit.

19 In the Label Style Composer dialog box, on the General tab, change the Visibility setting to False. Click OK.

To continue this tutorial, go to Exercise 6: Adding the Curb Returns to the Roundabout (page 390).

Exercise 6: Adding the Curb Returns to the Roundabout

In this exercise, you will add each curb return alignment to the corridor as a baseline. You will then assign additional regions so that you can use multiple alignment and profile targets.

This exercise is divided into two phases. In the first phase, you will add a curb return alignment as a baseline and examine the results. In the second phase, you will split the baseline into several regions, and then reassign the assemblies to target the appropriate profiles.

For more information, see the AutoCAD Civil 3D Help topic Editing Corridor Parameters.

This exercise continues from Exercise 5: Designing Roundabout Curb Return Alignments and Profiles (page 385).

To add the curb returns to the roundabout

NOTE This exercise uses Roundabout-5.dwg with the modifications you made in the previous exercise, or you can open Roundabout-6.dwg from the tutorial drawings folder (page 615).

1 Select the corridor. Right-click. Click Corridor Properties.
2 In the Corridor Properties dialog box, on the Parameters tab, Click Add Baseline.

3 In the Pick Horizontal Alignment dialog box, select SW Curb Return. Click OK.

4 In the Baseline (4) row, change the Name to SW Curb Return.

5 In the SW Curb Return row, click the Profile column.

6 In the Select A Profile dialog box, select SW Curb Return - Layout. Click OK.

7 Right-click SW Curb Return. Click Add Region. In the Select An Assembly dialog box, select Curb Return Left. Click OK. The Curb Return Left assembly will model the left-hand travel lanes, and place the lane on the right side of the baseline. The Curb Return Right assembly will model the right-hand travel lanes, and place the lane on the left side of the baseline.

8 In the SW Curb Return, Region(1) row, in the Frequency column, click . In the Frequency To Apply Assemblies dialog box, set the following properties to 1.000m:
  ■ Along Tangents
  ■ Along Curves
  ■ Along Spirals
  ■ Along Profile Curves

9 In the SW Curb Return, Region(1) row, in the Target column, click . In the Target Mapping dialog box, in the Object Name column, click <Click Here To Set All>.

10 In the Pick A Surface dialog box, select Existing Ground. Click OK.

11 In the Target Mapping dialog box, in the Object Name column, click the Target Alignment row. Notice that the Subassembly column lists the subassemblies that are included in the assembly that is assigned to the region.

12 In the Set Width Or Offset Target dialog box, in the Select Alignments list, select SW Shoulder. Click Add. Click OK.
13  Repeat Steps 11 and 12 to set the subassemblies to target the following objects:

**NOTE** Notice that because the curb return subassemblies have meaningful names, it is easy to determine the subassembly for which you are assigning a target.

<table>
<thead>
<tr>
<th>Width Or Offset Targets</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ Shoulder - CR-L: SW Shoulder</td>
</tr>
<tr>
<td>■ Lane - CR-L: Side Road</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Slope Or Elevation Targets</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ Shoulder - CR-L: &lt;None&gt;</td>
</tr>
<tr>
<td>■ Lane - CR-L: Side Road FGCL</td>
</tr>
</tbody>
</table>

14  Click OK to close the Target Mapping dialog box. In the Corridor Properties dialog box, click OK to rebuild the corridor.

Notice that the selected assembly has been applied to the curb return, but there are two problems:

■ First, the elevation of the region drops to zero at the ending station of the alignment. This happened because the actual End Station value of the baseline alignment and profile is slightly less than the End Station value of the region, but the value is rounded up to accommodate the specified precision setting. You will correct this in Steps 15 and 16.

■ Second, the assembly overlaps the Roundabout geometry. In the next procedure, you will split the baseline into three regions, and then set the regions to target the appropriate profiles.
15 Select the corridor. Right-click. Click Corridor Properties.

16 In the Corridor Properties dialog box, in the SW Curb Return, Region (1) row, reduce the End Station value by 0.01m. Click OK.

The actual End Station value of the baseline alignment and profile is slightly less than the value that is displayed in the Corridor Properties dialog box, but the value is rounded up to accommodate the specified precision setting. Reducing the value by 0.01 meter resolves the conflict, without a noticeable loss of accuracy.

**NOTE** If the region is not corrected, click OK to close the Corridor Properties dialog box and rebuild the corridor.

---

**To split the corridor region**

**NOTE** You must turn on Endpoint OSNAP to complete the following steps.

1. In the Corridor Properties dialog box, under SW Curb Return, right-click Region (1). Click Split Region. When prompted to specify a station, in the plan view, snap to the endpoints in Circles G and F. Press Enter to end the Split Region command.
2. In the SW Curb Return, Region (2) row, in the Target column, click ![icon](image). In the Target Mapping dialog box, in the Object Name column, set the subassemblies to target the following objects:

**NOTE** The targets that you set for the first region are applied to the new region. When you set a new target, make sure that you delete the old one.

**Width Or Offset Targets**
- Shoulder - CR-L: SW Shoulder
- Lane - CR-L: Roundabout Lane Edge

**Slope Or Elevation Targets**
- Shoulder - CR-L: <None>
- Lane - CR-L: Roundabout Lane Edge - Layout

3. In the SW Curb Return, Region (3) row, in the Target column, click ![icon](image). In the Target Mapping dialog box, in the Object Name column, set the subassemblies to target the following objects:

**Width Or Offset Targets**
- Shoulder - CR-L: SW Shoulder
- Lane - CR-L: Through Road

**Slope Or Elevation Targets**
- Shoulder - CR-L: <None>
- Lane - CR-L: Through Road FGCL

4. Click Apply to rebuild the corridor.

Notice that the assembly now targets different alignments and profiles based on where you split the region. Below Circle G, the assembly targets the Side Road alignment and profile. Between Circles G and F, the assembly targets the Roundabout Lane Edge alignment and profile. To the left of Circle F, the assembly targets the Through Road alignment and profile.
TIP To reduce the amount of time it takes to rebuild a corridor, hide any baselines or regions that you do not need to see. In the Corridor Properties dialog box, clear the check box next to a baseline that you want to hide. Click Apply.

5 Repeat all the steps in this exercise to model the remaining three curb returns.

NOTE The drawing provided for the next exercise has all four curb returns modeled. If you would like to either examine the targets of the curb returns or skip Step 5, open Roundabout-7.dwg.
To continue this tutorial, go to Exercise 7: Evaluating the Roundabout Corridor Surface for Drainage Issues (page 396).

**Exercise 7: Evaluating the Roundabout Corridor Surface for Drainage Issues**

In this exercise, you will analyze the roundabout corridor surface to determine whether its elevation must be adjusted to improve drainage.

As is true in intersection design, the curb return profiles greatly affect drainage. In roundabout design, the profile of the roundabout itself adds even more complexity to drainage. To determine whether there are any drainage issues, you will use the AutoCAD Civil 3D water drop analysis feature. If you find any issues, you can adjust any of the curb return or roundabout profiles to improve drainage.

For more information, see the AutoCAD Civil 3D Help topic *Drawing Water Drop Paths*.

This exercise continues from Exercise 6: Adding the Curb Returns to the Roundabout (page 390).
To perform a water drop analysis on the roundabout corridor surface

NOTE This exercise uses Roundabout-6.dwg with the modifications you made in the previous exercise, or you can open Roundabout-7.dwg from the tutorial drawings folder (page 615).

1. Click Surfaces menu ➤ Utilities ➤ Water Drop. Press Enter to select the surface.
2. In the Select A Surface dialog box, select Roundabout. Click OK.
3. In the Water Drop dialog box, change the Place Marker At Start Point value to Yes. Click OK.
4. When prompted to select a point, click various locations in both the roundabout median and lane. Notice that all waterdrop paths end at a low point on the East edge of the median, very near the Through Road alignment. In the following steps, you will modify the path of the water by moving the lowest PVI of the roundabout median edge profile.

5. Press Enter to end the water drop command.
6. Zoom in to the Roundabout Median Edge PROFILE view.
7. Click the blue layout profile line to select it. Notice that the second PVI from the right is lower than the others.
8. Use the red triangular grip to move the low PVI to the right so that it is approximately midway between its current location and the last PVI.

9. Press Esc to deselect the profile.

10. In the plan view, select the corridor. Right-click. Click Rebuild Corridor. The corridor updates to reflect the new PVI location. Notice that the waterdrop paths did not update. In the following steps, you will delete the waterdrop paths, and use the existing start point markers to examine the result of the new PVI location.

11. In the plan view, select one of the waterdrop paths. Right-click. Click Select Similar. Press Delete.

12. Click Surfaces menu ➤ Utilities ➤ Water Drop. Press Enter to select the surface.

13. In the Select A Surface dialog box, select Roundabout. Click OK.

14. In the Water Drop dialog box, click OK.
When prompted to select a point, click the starting points of the previous waterdrop analysis.

Notice that the water now drains toward the Northeast quadrant.

Press Enter to end the water drop command.

In the plan view, select one of the waterdrop paths, and one of the start point markers. Right-click. Click Select Similar. Press Delete.

To continue this tutorial, go to Exercise 8: Adding a Boundary to the Roundabout Corridor Surface (page 399).

**Exercise 8: Adding a Boundary to the Roundabout Corridor Surface**

In this exercise, you will create an accurate boundary of the final roundabout corridor surface.

Adding a boundary to a corridor surface prevents triangulation outside the daylight line of the corridor. An accurate boundary around the corridor surface results in more accurate surface area and volume calculations.

For more information, see the AutoCAD Civil 3D Help topic *Adding and Editing Corridor Boundaries.*
This exercise continues from Exercise 7: Evaluating the Roundabout Corridor Surface for Drainage Issues (page 396).

To add a boundary to the corridor

**NOTE** This exercise uses Roundabout-7.dwg with the modifications you made in the previous exercise, or you can open Roundabout-8.dwg from the tutorial drawings folder (page 615).

**TIP** Using a single viewport makes it easier to pan and zoom in this exercise. On the command line, enter Viewports. In the Viewports dialog box, under Standard Viewports, select Single. Click OK.

1. In the drawing, click the corridor. Right-click. Click Corridor Properties.
2. In the Corridor Properties dialog box, click the Boundaries tab.
3. In the Boundary table, right-click the Roundabout surface. Click Add Interactively.

**NOTE** You must turn on Endpoint OSNAP to complete the following steps.

4. In the drawing window, to the right of the roundabout, click the green daylight feature line North of station 1+180.
5. Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.
6. Pan to the East end of the corridor.
   Notice that a red line appears along the daylight feature line.

**NOTE** Clicking on any point along the current feature line causes the red boundary to persist from the previous point.
7 Using the endpoint OSNAP, click the corridor end station.

8 Click the green daylight feature line at the South of station 1+270. This station is the location of the nearest assembly along the next feature line.

9 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK. Notice that the red boundary has crossed the corridor at the ending station and continued on to the feature line you selected in Step 8. If you had clicked a point on the upper feature line before the ending station, the boundary would have crossed at the nearest assembly.
10 Pan to the roundabout. Using the endpoint OSNAP, click the blue assembly line that passes through Circles L and K. This station is location the last assembly in the current feature line.

11 On the green daylight feature line along the Southeast curb return, click the blue assembly line that is immediately to the left of the one you clicked in Step 10.
This station is the location of the nearest assembly along the next feature line.

12 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.

13 Using the endpoint OSNAP, click the blue assembly line that passes through Circles I and J.

This station is the location of the last assembly in the current feature line.

14 On the green daylight feature line along the Southeast curb return, click the blue assembly line that is immediately below the one you clicked in Step 13.

This station is the location of the nearest assembly along the next feature line.

15 Because there are multiple feature lines at this location, the Select A Feature Line dialog box is displayed. Click Daylight. Click OK.

16 Pan to the South end of the Side Road portion of the corridor. Continue this process until the boundary follows all the daylight lines around the corridor. Remember that to continue the boundary onto another feature line, you must click the last assembly in the existing feature line, and then click the first assembly in the next feature line.
When the boundary reaches the beginning, enter C on the command line to close the boundary and return to the Corridor Properties dialog box.

In the Corridor Properties dialog box, expand the Roundabout surface collection item to see the boundary item. Change the corridor boundary name to Roundabout Boundary and set its Use Type to Outside Boundary.

Click OK to create the boundary and close the Corridor Properties dialog box.

Notice that the corridor surface contours no longer appear outside the daylight line.
Sections Tutorials

These tutorials will get you started working with the section views, which provide a view of the terrain cut at an angle across a linear feature, such as a proposed road.

Typically, sections are cut across the centerline alignments of a corridor. These sections are then plotted, either individually for a station, or as a group for a range of stations.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Sections*.

**Tutorial: Working with Section Views**

This tutorial demonstrates how to display cross sections of the corridor model surfaces along the centerline alignment. You will create sample lines and then generate the sections.

Cross sections show the elevations of lines that are perpendicular to the alignment. They can be derived from surfaces, corridors models, and corridor surfaces. Furthermore, they can be either dynamic or static. When a surface or corridor is modified, dynamic sections are automatically updated. A static section shows the elevations at the time it was created, but does not react to later geometry changes. Similarly, dynamic sample lines associated with an alignment move with the alignment if it is modified.

**TIP** You can use the workflow that is demonstrated in this tutorial to create section views from a corridor Xref. Section views created from an Xref can be dynamically linked to the corridor model; if the corridor model in the Xref drawing changes, the section views update automatically.
Exercise 1: Creating Sample Lines

In this exercise, you will create a set of sample lines along the alignment. This is the first step in generating cross sections.

The sample lines define the stations at which the cross sections are cut, and also the width of the sections to the left and right of the alignment. A set of sample lines is stored in a Sample Line Group for the alignment. Each sample line group has a unique name. Each line within the group also has a unique name.

For more information, see the AutoCAD Civil 3D Help topic Creating and Editing Sample Lines and Sections.

To create sample lines

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Sections-1a.dwg.
2. Press F3 to turn off OSNAP.
3. Click Sections menu ➤ Create Sample Lines.
4. At the Select An Alignment prompt, press Enter to display the Select Alignment dialog box.
5. Select Centerline (1). Click OK.
6. The Create Sample Line Group dialog box is displayed. This dialog box defines the characteristics of the sample line group. The templates shipped with AutoCAD Civil 3D contain pre-defined line styles and line label styles for the sample lines.
7. For Sample Line Style, select Road Sample Lines.
8. For Sample Line Label Style, select Name & Section Marks.
9. The Select Data Sources To Sample section lists the possible data sources for the cross sections. Data sources may include surfaces, corridor models, and corridor surfaces. Each surface and corridor surface results in a single cross-sectional string. Using the corridor model as a source includes all of the points, links, and shapes in the model.
10. Verify that the Sample check boxes are selected for all entries in the table.
9 You can double-click a Style cell in the table to select the Section Style. Set the Section Styles to the following:
   ■ EG: Existing Ground
   ■ Corridor - (1): All Codes
   ■ Corridor - (1) Top: Finished Grade
   ■ Corridor - (1) Datum: Finished Grade

10 Click OK to close the dialog box.
   The Sample Line Tools toolbar is displayed. A Specify Station prompt is displayed on the command line.

11 On the toolbar, click the arrow next to the Sample Line Creation Methods button. Click From Corridor Stations. This option creates a sample line at each station found in the corridor model.
   The Create Sample Lines - From Corridor Sections dialog box is displayed. This dialog box provides settings for defining the station range and widths of the sample lines. Notice that it includes options for setting the Start Station and End Station, and for using offset alignments to set the Left Swath Width and Right Swath Width.

12 Set the Width values for both the Left Swath Width and Right Swath Width to 150. Click OK. This creates and draws the sample lines and returns you to the Sample Line Tools for defining additional lines, if desired.

13 Close the Sample Lines Tools toolbar.

To continue this tutorial, go to Exercise 2: Creating Section Views (page 407).

Exercise 2: Creating Section Views

In this exercise, you will create section views for each sample line. First, you will modify some of the settings that apply to section views.

For more information, see the AutoCAD Civil 3D Help topic Creating and Editing Section Views.

This exercise continues from Exercise 1: Creating Sample Lines (page 406).
**To create section views**

**NOTE** This exercise uses Sections-1a.dwg with the modifications you made in the previous exercise.

1. In Toolspace, on the Settings tab, expand the Section View ➤ Group Plot Styles collection. Select the Plot All style. Right-click. Click Edit.

2. In the Group Plot Style dialog box, click the Array tab. This tab defines how multiple section views are organized.

3. Under Space Between Adjacent Views, change both the Column and Row values to 12. This defines the separation between adjacent section views. Click OK.

4. Pan and zoom to the area just above the two profile views in the drawing.

5. Click Sections menu ➤ Create Multiple Section Views. The Create Multiple Section Views wizard is displayed. This wizard defines the characteristics of the section views being created.

   On the General page, the defaults include Road Section as the Section View Style, and Plot All as the Group Plot Style.

6. In the Station Range area, select User Specified. In the End field, enter 10+00.00.

   For this exercise, you will not create section views of the full corridor.

7. Click Next.

   On the Offset Range page, notice that the Left and Right values are 150. This is the sample line swath width value that you specified in Exercise 1: Creating Sample Lines (page 406).

8. Click Next.

   On the Elevation Range page, you can specify the height of the section views.

9. On the Elevation Range page, select the User Specified option. For Height, enter 100.000'. For Section Views Height Option, select Follow A Section. In the Select Section list, select EG.

   These settings specify that all section views will be 100-feet tall and the elevation will follow the EG surface elevation.

10. Click Next.
The Section Display Options page specifies the object and label styles for the sampled objects. In this exercise, you will suppress the labels.

11 On the Section Display Options page, in the Clip Grid column, click the Corridor - (1) Top row.

12 In the EG row, click the value in the Change Labels column.

13 In the Select Style Set dialog box, select No Labels. Click OK.

14 Repeat Steps 12 and 13 to apply the No Labels style to the Corridor - (1) Top and Corridor - (1) Datum surfaces.

15 Click Next.

16 On the Data Bands page, in the Set Band Properties area, for the Section Data Band Type, for Surface 1, select Corridor (1) - Top. For Surface 2, select Corridor (1) - Datum.

17 Click Create Section Views.

18 At the Identify Section View Origin prompt, select a point to the right of the lower profile view.

19 Pan and zoom around one of the section views.

**Further exploration:** Not saving any changes, use the Toolspace Settings tab to experiment with modifying the following settings:

- Section View Styles collection ➤ Road Section style
- Section collection ➤ Section Styles and Label Styles

To continue this tutorial, go to Exercise 3: Adding a Section View Grade Label (page 409).

**Exercise 3: Adding a Section View Grade Label**

In this exercise, you will create a section view grade label.

For more information, see the AutoCAD Civil 3D Help topic *Sample Line, Section, and Section View Labels*.

This exercise continues from Exercise 2: Creating Section Views (page 407).
To add a section view grade label

NOTE This exercise uses Sections-1a.dwg with the modifications you made in the previous exercise, or you can open Sections-1b.dwg from the tutorial drawings folder (page 615).

1 Zoom in to one of the section views so that you can clearly see the section view and its annotations.

2 Click Sections menu ➤ Add Section View Labels ➤ Add Section View Labels.
   The Add Labels dialog box is displayed. You will change the existing Grade Label Style to show a grade percentage between two points and the slope length between those points.

3 In the Add Labels dialog box, in the Label Type list, select Grade. In the Grade Label Style list, select Grade_Slope. Click Add.
   On the command line, you are prompted to select a section view.

4 In the drawing, click a grid line of the section view.
   On the command line, you are prompted to pick a point.

5 In the section view, snap to a low point in the section. Snap to a higher point “up the hill”.
   The grade between the two points is displayed. If you wish, add more grade labels to other pairs of points anywhere in the section view.

6 Right-click or press Esc to end the labeling session.

7 In the Add Labels dialog box, click Close.

To continue this tutorial, go to Exercise 4: Adding a Data Band to a Section View (page 410).

Exercise 4: Adding a Data Band to a Section View

In this exercise, you will add a data band, which is an optional graphic frame that is associated with the section view.

For more information, see the AutoCAD Civil 3D Help topic Section View Bands.

This exercise continues from Exercise 3: Adding a Section View Grade Label (page 409).
To add a data band to a section view

**NOTE** This exercise uses Sections-1b.dwg with the modifications you made in the previous exercise.

1. Zoom in to a section view so that you can clearly see one section view and its annotations.
2. Select a section view. Right-click and click Section View Properties.
3. Click the Bands tab and review the contents of the tab. The section views in the drawing already have a band that contains Major Offset data, so you will select a different type to add.
4. From the Band Type list, select Section Segment.
5. From the Select Band Style list, select FG Segments.
6. Click Add.
7. In the List of Bands table, scroll to the right and click the Section 1 cell for the new band that you created. From the drop-down list, select the Corridor (1) Top surface.
   **NOTE** The name of the Corridor (1) Top surface varies depending on the section view that you are editing.
8. Click Apply.
   A data band is added to the section view in the drawing. Notice that there is no data displayed in the band. This happened because the default Weeding factor specifies that any section segments that are less than 100 drawing units long are not displayed in the band. In the next step, you will reduce the Weeding factor and examine the results.
9. In the Section View Properties dialog box, on the Bands tab, in the Section Segment row, change the Weeding value to 5.0000. Click OK. Segment lengths that are greater than 5 drawing units long are annotated in the new data band.

To continue to the next tutorial, go to Quantity Takeoff from Corridor Models (page 412).
Tutorial: Quantity Takeoff from Corridor Models

This tutorial demonstrates how to calculate cut and fill earthwork quantities, using the sample lines created in the previous tutorial.

Earthwork and material volumes are calculated by comparing two sample line surfaces to each other. You can calculate quantities between sample lines derived from regular surface models and from corridor surfaces.

User-definable tables specify which materials are defined by which surfaces, and the characteristics of these materials. Finally, average end area analysis is used to tabulate the material quantities along the corridor.

For more information, see the AutoCAD Civil 3D Help topic Creating Quantity Takeoff Tables and Reports.

Exercise 1: Reviewing Quantity Takeoff Settings

In this exercise, you will review the different settings available for quantity takeoff.

For more information, see the AutoCAD Civil 3D Help topics Editing Quantity Takeoff Settings and Creating a Quantity Takeoff Criteria.

To review quantity takeoff settings

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Sections-2.dwg. The drawing opens, displaying three viewports.

2. In Toolspace, on the Settings tab, expand Quantity Takeoff ➤ Commands.

3. Under the Commands collection, double-click GenerateQuantitiesReport to display the Edit Command Settings dialog box.

4. Browse through the various settings available, but do not change any settings. When finished, click Cancel.

5. In Toolspace, on the Settings tab, expand Quantity Takeoff ➤ Quantity Takeoff Criteria. Three styles are defined in the collection.
6 Double-click the Earthworks style to open the Quantity Takeoff Criteria dialog box.

7 Click the Material List tab.
   This tab contains a pre-defined table for calculating earthworks (cut and fill) by comparing a Datum surface layer to an existing ground surface layer.

8 Expand the Earthworks item in the table. You will use the Earthworks criteria in the next exercise to calculate the quantity takeoff.
   Notice that the Condition for the EG surface is set to Base, while the condition of the Datum surface is set to Compare. This indicates that the material is going to be fill when Datum is above EG, and cut when Datum is below EG.
   Also note the three Factor values in the table:
   ■ The Cut factor is typically used as an expansion factor for excavated material. It is usually 1.0 or higher.
   ■ The Fill factor is typically used as a compaction factor for fill material. It is usually 1.0 or lower.
   ■ The Refill factor indicates what percentage of cut material can be reused as fill. It should be 1.0 or lower.

9 Click Cancel to close the dialog box.

To continue this tutorial, go to Exercise 2: Calculating Quantity Takeoff Volumes (page 413).

**Exercise 2: Calculating Quantity Takeoff Volumes**

In this exercise, you will use the Earthworks criteria to generate a quantity takeoff report.

For more information, see the AutoCAD Civil 3D Help topics *Generating Material Lists* and *Generating Quantity Takeoff Tables and Reports*.

This exercise continues from Exercise 1: Reviewing Quantity Takeoff Settings (page 412).
To calculate quantity takeoff volumes

NOTE This exercise uses Sections-2.dwg with the modifications you made in the previous exercise.

1. Click Sections menu ➤ Compute Materials to display the Select A Sample Line Group dialog box.

2. From the Select Alignment list, select Centerline (1).

3. From the Select Sample Line Group list, select SLG-1. Click OK.
   The Compute Materials dialog box is displayed, showing a list of all items defined in the selected criteria.

4. Verify that the Quantity Takeoff Criteria field is set to Earthworks.

5. In the table, expand the Surfaces item. This shows surfaces EG and Datum. Next, you will set the actual object names that define those surfaces.

6. In the Object Name column, in the EG row, click <Click Here...>. Select EG from the list.

7. In the Object Name column, in the Datum row, click <Click Here...>. Select Corridor - (1) Datum from the list.
   In the Earthworks criteria settings, EG is set as the base surface and Datum is set as the Compare surface. The Object Name fields specify which object calls for both an EG surface as the base and a Datum surface as the comparison. These criteria can be used with multiple projects and corridors.
   The Object Name fields in the Compute Materials dialog box define a specific surface and corridor surface to map to the names in the Earthworks criteria.

8. Click OK to close the dialog box and calculate the quantities.
   The calculation is performed and a list of materials is stored with the sample line group properties. In the drawing, notice that the cut and fill areas in each section are shaded. Hover the cursor over the shaded areas to examine the information that is displayed.
   To view the results of the calculation, you will create a volume report.

9. Click Sections menu ➤ Generate Volume Report to display the Report Quantities dialog box.

10. From the Select Alignment list, select Centerline (1).
From the Select Sample Line Group list, select SLG-1.

For Select A Material List, select Material List - (1).

This is the material list you created by calculating volume quantities for the sample line group using the Earthworks criteria.

For Select A Style Sheet, select Earthwork.xsl.

Select Display XML Report to automatically display the report after it is generated.

Click OK.

The report is displayed.

The Cut Area is the area of material in cut, multiplied by the Cut Factor defined in the quantity takeoff criteria. The Fill Area is the area of fill material multiplied by the Fill Factor.

The areas for each material are averaged between stations and multiplied by the station difference to produce the incremental volumes. These volumes are added from station to station to produce the cumulative volumes.

Finally, the Cum. Net Volume value at each station is calculated as the cumulative Reusable volume minus the cumulative Fill volume.

To continue to the next tutorial, go to Working with Mass Haul Diagrams (page 415).

**Tutorial: Working with Mass Haul Diagrams**

This tutorial demonstrates how to create and edit mass haul diagrams to display earthworks in profile.

Mass haul is defined as the volume of material multiplied by the distance it is moved during construction. A mass haul diagram consists of two objects: a mass haul line, and a mass haul view. The mass haul line represents the free haul and overhaul volumes in cut and fill conditions along an alignment. The mass haul view is the grid on which the mass haul line is drawn.

The middle axis of the mass haul view is known as the balance line. The location of the mass haul line relative to the balance line indicates material movement in the current design. When the mass haul line rises above the balance line, it indicates a region in which material is cut. When the mass
haul line falls below the balance line, it indicates a region in which material
is fill.

There are two methods to compare free haul volume and overhaul volume:

**Grade Points**

Grade points are stations at which the proposed project design transitions
from cut to fill. In a mass haul diagram, a grade point is the highest or lowest
point in a mass haul region. A grade point is the highest point in a mass haul
region where the profile transitions from a cut condition to a fill condition.
A grade point is the lowest point in a mass haul region where the profile
transitions from a fill condition to a cut condition.

In the grade points method of measuring free haul, a horizontal line the length
of the specified free haul distance is drawn. The line is positioned so that it is
both parallel to the balance line and touches the mass haul line. The volume
that is enclosed in the area formed by this line and the mass haul line is free
haul.

In the following image, the green areas are free haul volume, and the red areas
are overhaul volume. The magenta circles and arrows indicate the grade points
on the mass haul line and profile. The vertical magenta lines illustrate the
relationship between the mass haul line and profile in the grade point
balancing method.
Balance Points

Balance points are the stations at which the net cut and fill volumes are equal. In a mass haul diagram, the balance points are located on the balance line, where the net volume is zero. In the balance points method of measuring free haul, the mass haul line is duplicated and shifted horizontally to the right (where the project transitions from cut to fill) or to the left (where the project transitions from fill to cut) by the free haul distance.

In the following image, the green areas are free haul volume, and the red areas are overhaul. The arrows illustrate the free haul distance in cut and fill conditions.

For more information, see the AutoCAD Civil 3D Help topic Using Mass Haul Diagrams.

Exercise 1: Creating a Mass Haul Diagram

In this exercise, you will create a mass haul diagram that displays free haul and overhaul volumes for a project site.

To create a mass haul diagram, the following items must be available:

- an alignment
two surfaces
a sample line group
a material list

The sample drawing that you will use for this exercise contains all of these objects, except for a material list.

In this exercise, you will create the material list, and then create the mass haul diagram.

For more information, see the AutoCAD Civil 3D Help topic *Using Mass Haul Diagrams*.

**To create a material list for a mass haul diagram**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing *Mass Haul-1.dwg*.

2. Click Sections menu ➤ Compute Materials.
   The Select A Sample Line Group dialog box lists the alignments and sample line groups that are in the drawing. A material list, which specifies an EG and Datum surface to compare, is stored with the properties of the sample line group.

3. In the Select A Sample Line Group dialog box, click OK.

4. In the Compute Materials dialog box, use the Object Name column to specify the surfaces to include in the material list:
   - In the Surfaces, EG row, click <Click Here To Set All>. Select Existing Ground.
   - In the Surfaces, Datum row, click <Click Here To Set All>. Select Basic Road Corridor Datum.

5. Click OK.
   The material list is created and saved with the sample line group.

**To create a mass haul diagram**

1. Click Sections menu ➤ Create Mass Haul Diagram.
2 In the Create Mass Haul Diagram wizard, on the General page, specify the following settings:

- Mass Haul View Name: Mass Haul Balancing
- Mass Haul View Style: Free Haul and Overhaul

3 Click Next.

4 On the Mass Haul Display Options page, examine the settings in the Material area. The selection in the Material List is the material list you created in the previous procedure. Examine the options that are available in the Choose A Material To Display As Mass Haul Line list, but accept the default Total Volume option. In the Mass Haul Line area, specify the following settings:

- Mass Haul Line Name: Mass Haul Line Total Volume
- Mass Haul Line Style: Free Haul and Overhaul - Grade Point

5 Click Next.

6 On the Balancing Options page, under Free Haul Options, select the Free Haul Distance check box. Enter 300.0000’ as the free haul distance. This value specifies that the distance that the earthmover hauls material at the standard rate. Material moved beyond this distance is considered overhaul, and typically is charged at a higher rate.

7 Click Create Diagram.

8 In the drawing, snap to the center of the red circle that is above the profile view to place the mass haul diagram. The mass haul diagram is displayed, and contains three mass haul regions. As shown in the following image, mass haul regions identify station ranges where material is either cut or fill. When the mass haul line is above the balance line, material is cut. When the mass haul line is below the balance line, material is fill.
To continue this tutorial, go to Exercise 2: Balancing Mass Haul Volumes (page 420).

**Exercise 2: Balancing Mass Haul Volumes**

In this exercise, you will balance the mass haul volumes above and below the balance line, which will eliminate overhaul volume.

For more information, see the AutoCAD Civil 3D Help topic *Using Mass Haul Diagrams*.

This exercise continues from Exercise 1: Creating a Mass Haul Diagram (page 417).
To balance mass haul volumes for cut material

NOTE This exercise uses Mass Haul-1.dwg with the modifications you made in the previous exercise, or you can open Mass Haul-2.dwg from the tutorial drawings folder (page 615).

1 Zoom in on the mass haul region that is on the left-hand side of the diagram.
   Notice that the highest point of the green free haul area is at station 3+25. This is the grade point, which is the point at which free haul transitions from cut to fill. Depending on the site conditions, grade points can be logical locations for dump sites or borrow pits, which can reduce or eliminate overhaul.

2 At station 3+25, hover the cursor over the mass haul line.
   Notice that the tooltip displays the current station number (3+25) and volume (approximately 1500.00 Cu. Yd.).

3 Select the mass haul line. Right-click. Click Mass Haul Line Properties.
4 In the Mass Haul Line Properties dialog box, click the Balancing Options tab. In the Add/Remove Borrow Pits And Dump Sites area, click Add Dump Site.
5 In the Station cell, enter 325.
   This is the number of the station at the grade point for the volume above the balance line.
6 In the Capacity cell, enter 1500.
   This is the approximate volume (1500.00 Cu. Yd.) at the grade point.
7 Click OK.
   The cut volume above the balance line is entirely free haul. Notice that now there is a red, overhaul volume below the balance line. You will balance the fill volume in the following procedure.
To balance mass haul volumes for fill material

1. Below the balance line, zoom in to station 6+25 on the mass haul line. Notice that this is near the point at which the overhaul volume (in red) and the free haul volume (in green) meet the mass haul line. If you examine this station on the profile, you see that it is also a relatively flat section of the existing ground surface. Flat areas can also be good locations for dump sites and borrow pits.

2. At station 6+25, hover the cursor over the mass haul line. Notice that the tooltip displays the current station number and volume, which is approximately 2000.00 Cu. Yd.


4. In the Mass Haul Line Properties dialog box, click the Balancing Options tab. In the Add/Remove Borrow Pits And Dump Sites area, click Add Borrow Pit.

5. In the Station cell for the borrow pit, click .

6. In the drawing, pan to left so that you can see the corridor and surface. Click near station 6+25 on the corridor.
Notice the lack of surface contours in the area around station 6+25. This indicates that the region is relatively flat.

7 In the Capacity cell for the borrow pit, enter 2000.
   This is the approximate volume value that you noted in Step 2.

8 Click OK.
   The fill volume below the balance line is entirely free haul.

Further exploration: Balance the mass haul volumes in the third region by adding a dump site at station 11+50 with a capacity of 10000 Cu. Yd.

9 Close the drawing, but do not save your changes.

To continue this tutorial, go to Exercise 3: Editing the Mass Haul Line Style (page 423).

Exercise 3: Editing the Mass Haul Line Style

In this exercise, you will create a mass haul line style that is based on an existing style.

The mass haul line style controls the display of the line that displays free haul and overhaul volumes in a mass haul view. The display components, such as color, linetype, and hatch patterns, in the mass haul line style are similar to the components that are in other object styles. The mass haul line style also specifies the method with which free haul is measured.

In this exercise, you will copy an existing mass haul line style to create a new style. You will examine the differences between the grade point and balance point methods of measuring free haul.
NOTE The mass haul view style uses many of the same options as the profile view style. For information about editing the profile view style, see the Editing the Profile View Style exercise (page 231).

For more information, see the AutoCAD Civil 3D Help topic Using Mass Haul Diagrams.

This exercise continues from Exercise 2: Balancing Mass Haul Volumes (page 420).

To edit the mass haul line style

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Mass Haul-2.dwg.

2 In the drawing, select the mass haul line. Right-click. Click Mass Haul Line Properties.

3 In the Mass Haul Line Properties dialog box, on the Information tab, in the Object Style area, click the arrow next to . Click Copy Current Selection.

4 In the Mass Haul Line Style dialog box, on the Information tab, change the Name to Free Haul and Overhaul - Balance Point.

5 On the Free Haul tab, in the Free Haul Options area, notice that the Measure From Grade Point option is selected. Also notice that the graphic to the right resembles the mass haul diagram in the drawing. Grade points are the points at which volumes transition from cut to fill. When free haul is measured from grade points, the highest point (or lowest, if below the balance line) is the grade point.

6 Select Measure From Balance Point.

   Notice that the graphic changes. Balance points are the points at which the mass haul line crosses the balance line. These are the station at which the cut volume and fill volume are equal.

7 On the Display tab, in the Component Hatch Display area, in the Free Haul Area Hatch row, click the Pattern cell.

8 In the Hatch Pattern dialog box, for Pattern Name, select CROSS. Click OK.
9 In the Mass Haul Line Style dialog box, click the Display tab. In the Component Hatch Display area, in the Free Haul Area Hatch row, change the Scale to 30.0000.

10 Repeat Steps 7 through 9 to change the Overhaul Area Hatch Pattern to DASH.

**NOTE** A solid component fill provides the best performance. Drawing regeneration may be slower if a hatch pattern is used on a long mass haul diagram.

11 Click OK to close the Mass Haul Line Style and Mass Haul Line Properties dialog boxes.

The patterns you selected are displayed in the free haul and overhaul areas of the mass haul diagram. Notice that the mass haul diagram uses the balance point method to measure free haul.
These tutorials will get you started working with the pipe networks features, which you use to design and model the flow and function of a utility system, such as a storm or sanitary sewer.

**NOTE** If you have not installed AutoCAD Civil 3D to the default location, you may receive messages in the Event Viewer indicating that pipe network part catalogs are not found. To avoid these messages, it is recommended that you follow the exercises in the order presented. Alternatively, you can reset the path to the catalogs by clicking Pipes menu ➤ Set Pipe Network Catalog.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Pipe Networks*.

**Tutorial: Creating a Pipe Network**

This tutorial demonstrates how to create a pipe network using the specialized layout tools.

You create a pipe network by selecting start and end points for pipes and locations for structures. You can connect pipes to a structure or to another pipe. The types of pipes and structures you can create in the pipe network are specified by a parts list. A parts list is a subset of the entire pipe network part catalog.

When you create a pipe network, you can associate it with a default surface and alignment. The placement and sizing of parts is adjusted as you lay out your pipe network using the surface data and the design rules for your pipe network. The alignment is primarily a reference for pipe network labeling.
Exercise 1: Creating a Pipe Network

In this exercise, you will create a pipe network that represents a storm water system. The pipe network is associated with a surface and alignment, and uses parts taken from a standard parts list.

For more information, see the AutoCAD Civil 3D Help topic Creating Pipe Networks Using the Layout Tools.

To create a pipe network

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing PipeNetworks-1.dwg. This drawing contains an existing ground surface, an alignment, and existing ground and layout profiles for the alignment. It also contains a surface exported from a corridor that uses the alignment as its baseline.

2. In the drawing window, zoom to the area on the alignment between station 7+00 and 11+00.

3. In Toolspace, on the Prospector tab, expand the Pipe Networks collection, then right-click Networks. Click Create Pipe Network By Layout. Alternatively, you can click Pipes menu ➤ Create Pipe Network By Layout.

4. To select the surface taken from the corridor, in the Create Pipe Network dialog box, in the Surface Name list, select ROAD1_SURF.

5. In the Alignment Name list, select ROAD1.

6. Click OK.

   The new pipe network is added to the Toolspace Prospector tab, Pipe Networks ➤ Networks collection, and the Network Layout Tools toolbar is displayed. The network currently is empty. You will add parts to the network in the following steps.

8 In the Pipes List, expand Concrete Pipe. Select 18 Inch Concrete Pipe.

9 Ensure that Draw Pipes and Structures is selected.

10 Ensure the Upslope/Downslope option is set to (downslope).

11 On the command line, enter ‘SO to activate the Station Offset Civil Transparent command.

12 In the drawing window, click one of the alignment station labels to select the alignment ROAD1

13 On the command line, enter 700 as the station.

14 On the command line, enter -15 as the offset.
   A catch basin is placed at the specified point. The offset is designed to position the catch basin so that its outside edge is flush with the outside edge of the road shoulder.

15 With the Station Offset command still active, create another structure by entering 800 for the station and -15 as the offset.
   A second catch basin is created. The two structures are connected by a pipe of the type specified in the Pipe list. The pipes follow a downhill slope based on the corridor surface terrain and the design rules for the type and size of pipe. Later, you will view the vertical placement of the pipes you created in a profile view.

16 To change the direction of the vertical pipe network layout, toggle the Upslope/Downslope button to .

17 With the Station Offset command still active, create additional structures with an offset of -15 at stations 9+50, 11+00, and 12+50.
   As you place the catch basins, connecting pipes are created with slope values specified by the design rules and the Upslope/Downslope setting.

18 Press Enter to end the Station Offset command.

19 Pan until you can see the segment of the alignment between station 12+50 and Station 13+00.

20 With the drawing command still active, on the command line, enter C to begin creating a curved pipe.

21 On the command line, enter ‘SO.
Create a structure at the end of the curved pipe by entering 1300 for the station and -15 as the offset.

Press Enter to end the Station Offset command.

Press Enter to end the drawing command.

To continue this tutorial, go to Exercise 2: Adding Additional Parts to the Pipe Network (page 430).

Exercise 2: Adding Additional Parts to the Pipe Network

In this exercise, you will add to your pipe network by creating pipes and structures that connect to existing structures.

Whenever you are laying out a pipe network, you have the option of connecting to existing pipe network parts. AutoCAD Civil 3D gives you visual cues when the pipe or structure you are creating will either connect to an existing object or break a pipe to create a junction.

In the previous exercise, you used the Draw Pipes And Structures tool to place structures and pipes simultaneously. In this exercise, you will add catch basins using the Draw Structures Only tool, and then connect the catch basins to network using the Draw Pipes Only tool.

For more information, see the AutoCAD Civil 3D Help topic Adding a Part to a Pipe Network.

This exercise continues from Exercise 1: Creating a Pipe Network (page 428).

NOTE This exercise uses Pipe Networks-1.dwg with the modifications you made in the previous exercise, or you can open Pipe Networks-1B.dwg from the tutorial drawings folder (page 615).

To create pipes and structures simultaneously

1. Click Pipes menu ➤ Edit Pipe Network. In the drawing window, click a pipe network part.
   Alternatively, you can right-click a pipe network part, and then click Edit Network.
2 In the Structures list, ensure that Eccentric Cylindrical Structure ➤ Eccentric Structure 48 Dia 18 Frame 24 Cone 5 Wall 6 Floor is selected. In the Pipes list, ensure that 18 Inch Concrete Pipe is selected.

3 Toggle the Upslope/Downslope option to (downslope).

4 Click Structures Only.

5 On the command line, enter ‘SO.

6 Click a label on the ROAD1 alignment to select it.

7 Create a structure by entering 960 for the station and 15 as the offset.

8 Repeat Step 7 to add structures that are offset 15 feet from stations 11+10, 12+60, and 13+10.

9 Press Enter twice to exit the Station Offset and Add Structures commands.

10 On the Network Layout Tools toolbar, click Pipes Only.

11 Place the cursor over the structure that is offset 15 from station 9+60. A connection marker that indicates that the pipe can be attached to the structure is displayed.

12 With the connection marker displayed, click the structure to connect the new pipe to it.

13 Place the cursor over the structure that is offset -15 feet from station 9+50. With the connection marker displayed, click the structure to connect the new pipe to it.

14 On the command line, enter S to select a new start point.

15 Repeat Steps 11 through 14 to add pipes between the structures that are offset 15 feet from stations 11+10, 12+60, and 13+10 and the main network.

16 Press Enter twice to exit the Station Offset and Add Pipes commands.

To continue to the next tutorial, go to Changing Pipe Network Properties (page 432).
Tutorial: Changing Pipe Network Properties

This tutorial demonstrates how to add parts to your pipe network parts list. You will also learn how to change the surface, alignment, and design rules that are referenced when you are laying out a pipe network.

In the previous tutorial, the storm system parts you used were designed for a roadway design and took their placement and elevation from the road surface. In this tutorial, you create a branch for the pipe network that travels off the road surface into unfinished terrain, using manholes to connect the pipes and terminating in a headwall.

In addition to selecting different structures, pipes, and layout modes, you can also use the Network Layout Tools toolbar to change the configuration of your pipe network as you work. As you create your design, you can switch to a different parts list, add parts to the parts list, or change the referenced surface and alignment.

For more information, see the AutoCAD Civil 3D Help topic Editing Pipe Network Settings.

Exercise 1: Adding Parts to the Parts List

In this exercise, you will add a new part to the parts list by selecting a part family and size from the pipe network part catalog.

This exercise demonstrates how to access your parts lists from the Network Layout Tools toolbar. You can also create, view, and edit parts lists using the Toolspace Settings tab.

For more information, see the AutoCAD Civil 3D Help topic Part Catalog and Parts List.

To add a part family to the pipe network parts list

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Pipe Networks-2.dwg.

2. Click Pipes menu ➤ Edit Pipe Network.

3. In the drawing window, click a pipe network part.
4 On the Network Layout Tools toolbar, click to open the Select Parts List dialog box.

5 In the Select Parts List dialog box, click .

6 In the Network Parts List dialog box, on the Structures tab, right-click the parts list name in the tree view. Click Add Part Family.

7 In the Part Catalog dialog box, under Inlet-Outlets, select Concrete Rectangular Headwall. Click OK.

   The new part family is added to the tree view.

8 On the Structures tab, in the tree view, notice that no part sizes are available in the Concrete Rectangular Headwall family. You will add them in the following steps.

9 Right-click Concrete Rectangular Headwall, and click Add Part Size.

10 In the Part Size Creator dialog box, click the Headwall Base Width row. In the Add All Sizes cell, select the check box. Click OK.

11 Expand Concrete Rectangular Headwall.

   Notice that all available part sizes were added to the tree view. Notice that for each part in the list you can select an object style, design rules, and a render material.

12 On the Pipes tab, in the tree view, right-click Concrete Pipe. Click Add Part Size.

13 In the Part Size Creator dialog box, click the Inner Pipe Diameter row. Click the Value cell. From the value list, select 24.000000. Click OK.

   The new part size is added to the tree view.

14 Click OK to close the Network Parts List dialog box.

15 Click OK to close the Select Parts List dialog box.

To continue this tutorial, go to Exercise 2: Changing the Surface, Alignment, and Rules Configuration (page 434).
Exercise 2: Changing the Surface, Alignment, and Rules Configuration

In this exercise, you will change the surface and alignment that are referenced by the pipe network parts. You will also examine the design rules for a part. AutoCAD Civil 3D uses the referenced surface, alignment, and rules to determine the size and placement of pipe network parts. For example, if you create a manhole structure, the top rim of the structure is typically automatically placed at the elevation of the referenced surface. If the design rules for the manhole specify an adjustment value for rim of the structure, the rim is placed at the surface elevation plus or minus the adjustment value.

For more information, see the AutoCAD Civil 3D Help topic Part Rules.

This exercise continues from Exercise 1: Adding Parts to the Parts List (page 432).

To change surface, alignment, and rules settings

NOTE This exercise uses Pipe Networks-2.dwg with the modifications you made in the previous exercise, or you can open Pipe Networks-2B.dwg from the tutorial drawings folder (page 615).

1. If the Network Layout Tools toolbar is not already open, click Pipes menu ➤ Edit Pipe Network. In the drawing window, click a pipe network part. First, you will change the referenced surface. Associating a pipe network with a surface causes the pipe network to automatically reference the surface elevation data.

2. On the Network Layout Tools toolbar, click .

3. In the Select Surface dialog box, select EG. Click OK. Next, you will change the referenced alignment. Associating a pipe network with an alignment causes the pipe network to automatically reference the alignment station data.

4. Click . In the Select Alignment dialog box, select XC_STORM. Click OK.
Finally, you will examine the design rules for two parts. Part rules are the properties that affect how pipe network parts behave when you move or edit them.

Click \([\text{Click}]\) .

In the Select Parts List dialog box, click \([\text{Click}]\) Edit Current Selection.

In the Network Parts List dialog box, on the Structures tab, expand Eccentric Cylindrical Structure. Click Eccentric Structure 48 Dia 18 Frame 24 Cone 5 Wall 6 Floor.

In the Rules cell, click \([\text{Click}]\) . In the Structure Rule Set dialog box, click \([\text{Click}]\) Edit Current Selection. In the Structure Rule Set dialog box, click the Rules tab.

The selected design rules specify that the structure has a maximum drop value of 3.000’ and maximum pipe diameter or width of 4.000’. You can modify these values, or click Add Rule to add another rule.

Click Cancel twice.

On the Pipes tab, expand Standard then Concrete Pipe. Click 24 Inch Concrete Pipe.

In the Rules cell, click \([\text{Click}]\) . In the Pipe Rules Set dialog box, click \([\text{Click}]\) Edit Current Selection. In the Pipe Rule Set dialog box, click the Rules tab.

The selected design rules allow pipes of a maximum length of 200 feet, which is typical of a pipe layout that travels through open terrain.

Click OK to close the Pipe Rule Set, Pipe Rule Set, Network Parts List, and Select Parts List dialog boxes.

To continue this tutorial, go to Exercise 3: Adding a Branch to a Pipe Network (page 435).

**Exercise 3: Adding a Branch to a Pipe Network**

In this exercise, you will add a branch to the existing pipe network layout and use the part status to review and edit the layout.
In addition to indicator icons that indicate where parts can be connected, you will see icons when the pipe or structure you are adding to the layout will break an existing pipe. The pipes created by the break are automatically connected to the new structure or pipe.

For more information, see the AutoCAD Civil 3D Help topic Adding a Part to a Pipe Network.

This exercise continues from Exercise 2: Changing the Surface, Alignment, and Rules Configuration (page 434).

To add the branch to the pipe network

**NOTE** This exercise uses Pipe Networks-2B.dwg with the modifications you made in the previous exercise.

1. If the Network Layout Tools toolbar is not already open, click Pipes menu ➤ Edit Pipe Network. In the drawing window, click a pipe network part.

2. On the Network Layout Tools toolbar, ensure that the surface EG and the alignment XC_STORM are selected.
   For more information, see Exercise 2: Changing the Surface, Alignment, and Rules Configuration (page 434).

3. In the Structures list, expand the Concrete Rectangular Headwall collection. Select 44 x 6 x 37 Inch Concrete Rectangular Headwall.

4. In the Pipes list, expand the Concrete Pipe collection. Select 24 Inch Concrete Pipe.

5. Click Structures Only.

6. Toggle the Upslope/Downslope button to Upslope.

7. In the drawing window, zoom to station 4+00 on XC_STORM.

8. Click near the alignment to place the headwall structure.


10. Hover the cursor over the rectangular headwall structure. With the connection marker displayed, click to connect the pipe.

11. Pan to the structure that is offset -15 feet from station 8+00 on ROAD1.
12 Hover the cursor over the structure. With the connection marker displayed, click the structure to connect the pipe.

13 Press Enter to end the command.

14 Pan to the headwall at the end of the branch. Click the headwall to select it.

15 Use the circular editing grip to rotate the headwall until it is perpendicular to the attached pipe.

16 Press Esc to deselect the headwall.

17 In Toolspace, on the Prospector tab, expand Pipe Networks ➤ Networks ➤ Network - (1). Click Pipes.

18 In the item view, in the row for Pipe - (10), place your cursor over the circular icon in the Status cell to view the design rules that have not been met.

   The pipe exceeds the maximum length and maximum cover found in the rules. In the next few steps, you will correct the length by adding a structure to the middle of the pipe span.

19 Right-click the row for Pipe - (10). Click Zoom To.

   The full extents of the pipe are displayed in the drawing window.

20 Click Pipes menu ➤ Edit Pipe Network. Click a pipe network part.

21 On the Network Layout Tools toolbar, in the Structures list, select Eccentric Cylindrical Structure ➤ Eccentric Structure 48 Dia 18 Frame 24 Cone 5 Wall 6 Floor.

22 Click Structures Only.

23 In the drawing window, pan to station 2+00 on alignment XC_STORM.

   **NOTE** You must turn off OSNAP to complete the following steps.

24 Place your cursor over a location on the pipe that is close to station 2+00.

   A break pipe marker is displayed ——— to indicate that the pipe will be severed by placing the structure there.
25 With the break pipe marker displayed, click to place the manhole at the location, and create two pipes from the one.

26 Press Enter to end the command.

To continue to the next tutorial, go to Viewing and Editing Pipe Networks (page 438).

**Tutorial: Viewing and Editing Pipe Networks**

This tutorial demonstrates how you can view and edit the parts of your pipe network in profile and section views.

You can draw some or all of the part of a pipe network in a profile view. After the parts are drawn in a view, you can adjust their vertical layout by either grip editing or directly editing the values found in tabular format in the part properties dialog box. You also can add tables to organize pipe network part data, and label the parts to make them easy to identify.

When you create a section view, any pipe network parts that are located at the cross-section are drawn in the view.

For more information, see the AutoCAD Civil 3D Help topic Editing Pipe Networks.

**Exercise 1: Drawing Pipe Network Parts in a Profile View**

In this exercise, you will draw the pipe network parts in a profile view.

For more information, see the AutoCAD Civil 3D Help topic Displaying Pipe Networks in Profile View.
This exercise uses the pipe network and branch you created in the Changing Pipe Network Properties (page 432) tutorial.

**To draw pipe network parts in a profile view**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Pipe Networks-3.dwg.

2. In the drawing window, zoom to a section of the pipe network.

3. Click a pipe to select it. Right-click. Click Draw Parts In Profile View.

4. Zoom to the profile for the alignment that represents the road (PV - 1). Click the profile grid.
   The pipe or structure you selected is drawn in the profile view.

5. Press Esc to deselect the pipe.

6. Select the profile view grid. Right-click. Click Profile View Properties.

7. In the Profile View Properties dialog box, on the Pipe Networks tab, select the check box in the Draw column for each part entry in the pipe network except for Pipe - (10), Pipe - (10)(1), Structure (11), and Structure (12).

8. Click OK.
   All the pipe network parts you selected in Profile View Properties are displayed in the profile view.

To continue this tutorial, go to Exercise 2: Adding Labels to Pipe Network Parts (page 439).

**Exercise 2: Adding Labels to Pipe Network Parts**

In this exercise, you will add labels to the pipe network parts drawn in both plan and profile views.

**NOTE** For more detailed tutorials on labels, go to the Labels and Tables Tutorials (page 537).

For more information, see the AutoCAD Civil 3D Help topic *Labeling Pipe Networks*.

This exercise continues from Exercise 1: Drawing Pipe Network Parts in a Profile View (page 438).
To add labels to pipe network parts in a profile

NOTE This exercise uses Pipe Networks-3.dwg with the modifications you made in the previous exercise.

1. Zoom to the pipe network parts drawn in the profile view.
2. Click Pipes menu ➤ Add Pipe Network Labels ➤ Add Pipe Network Labels.
3. In the Add Labels dialog box, select the following values:
   ■ Label Type: Single Part Profile
   ■ Pipe Label Style: Standard
4. Click Add.
5. In the drawing window, click Pipe - (1), which is between stations 7+00 and 8+00 of the layout profile displayed in the profile view.
   The pipe is labeled with its description. In the following steps, you will create a label style that displays the elevation of the start invert of the pipe.

To create a pipe label style

1. In the Add Labels dialog box, next to the Pipe Label Style list, click the arrow next to . Click Copy Current Selection.
2. In the Label Style Composer dialog box, on the Information tab, for Name, enter Start Invert Elevation.
3. On the Layout tab, click the Contents value under Text. Click .
4. In the Text Component Editor dialog box, on the Properties tab, in the Properties list, select Start Invert Elevation.
5. Click .
6. In the text editor window, click the <[Description(CP)]> property field. Press Delete.
7. Your label content should look like this:

   <[Start Invert Elevation(Uft|P3|RN|AP|Sn|OF)>]
8 Click OK to close the Text Component Editor dialog box.
9 Click OK to close the Label Style Composer dialog box.
10 In the Add Labels dialog box, in the Label Type list, ensure Single Part Profile is selected.
11 In the Pipe Label Style list, ensure that Start Invert Elevation is selected.
12 Click Add.
13 In the drawing window, in the profile view, click Pipe - (2), which is between stations 8+00 and 9+50 of the layout profile.
14 Press Esc to end the add label command.
15 Click the label text to select the label.
16 Click the diamond-shaped label edit grip to make it active. Click a new location for the label at the start end of the pipe, which is the end located next to station 8+00.
   The start and end of a pipe is determined using the direction in which the pipe was drawn.
17 Click the square label edit grip to make it active. Click a new location for the label text that moves it off the pipe.
18 Press Esc to deselect the label.
   Next, you will add a spanning label to a series of two pipes in plan view.

To add labels to pipe network parts in plan view
1 Pan and zoom until you can clearly see the North-South pipe run along the XC_STORM alignment.
2 In the Add Labels dialog box, select the following values:
   ■ Label Type: Spanning Pipes Plan
   ■ Pipe Label Style: 2D Length - Total Span
3 Click Add.
4 Click both pipes along the XC_STORM alignment, then press Enter.
5 When prompted, click a location along the pipe span to place the label.
   The span label is placed on the pipe run in the location you specified. To see which pipes are included in the span, hover the cursor over the label to highlight the pipes.
Finally, you will add labels to all pipe network parts in plan view.

6 Pan and zoom until you can clearly see the plan view of the pipe network.

7 In the Add Labels dialog box, select the following values:
   ■ Label Type: Entire Network Plan
   ■ Pipe Label Style: Standard
   ■ Structure Label Style: Structure Name

8 Click Add.

9 Click a part in the pipe network. All pipes and structures are labeled using the styles you selected.

10 In the Add Labels dialog box, click Close.

To continue this tutorial, go to Exercise 3: Editing Pipe Network Parts in a Profile View (page 442).

Exercise 3: Editing Pipe Network Parts in a Profile View

In this exercise, you will edit the pipe network parts drawn in a profile view using editing grips and by directly editing the part properties.

For more information, see the AutoCAD Civil 3D Help topic Editing Pipe Networks Using Grips.

This exercise continues from Exercise 2: Adding Labels to Pipe Network Parts (page 439).

To edit pipe network parts in a profile view

NOTE This exercise uses Pipe Networks-3.dwg with the modifications you made in the previous exercise, or you can open Pipe Networks-3B from the tutorial drawings folder (page 615).

1 In the drawing window, in the profile view for ROAD1 (PV - (1)), click Pipe - (4), which connects the structures that are offset from stations 11+00 and 12+50 on ROAD1.
2 Click the square editing grip at the center of the pipe to make it active. Click a new vertical location for the pipe so the start invert elevation is approximately 650 feet.

**NOTE** The horizontal grid line immediately below the pipe indicates 650 feet.

As you move your cursor, the tooltip displays the current elevation of the active grip.

3 Click the triangular grip at the start (downslope) end of the pipe to make it active. Click a new position for the pipe end so that it aligns with the end invert elevation of Pipe - (3), which is between stations 11+00 and 9+50.

In the following steps, you edit the pipe properties to create a more precise alignment of the two pipes that connect at Structure - (4).

4 With Pipe - (4) still selected, right-click. Click Pipe Properties.

5 In the Pipe Properties dialog box, on the Part Properties tab, click the Start Invert Elevation value to select it. Press Ctrl+C to copy the value. Click OK.

6 Press Esc to deselect Pipe - (4).

7 Click Pipe - (3) to select it. Right-click. Click Pipe Properties.

8 In the Pipe Properties dialog box, on the Part Properties tab, under Geometry, click the End Invert Elevation value to select it. Press Ctrl+V to replace the value with the one copied from Pipe - (4).

9 Click OK.

   Pipe - (3) and Pipe - (4) now connect to Structure - (4) at the same invert elevation.

10 Press Esc to deselect the pipe.

**TIP** You also can use OSNAPs to quickly match pipe start and end elevations. For more information, see the Using Basic Functionality tutorial exercise (page 12).

**Further exploration:** Repeat the editing procedures with Pipe - (5), which is between stations 12+50 and 13+00, to create a continuous flow line for the pipes.
Exercise 4: Overriding the Style of a Pipe Network Part in a Profile View

In this exercise, you will change the style used by pipe network parts in a profile view using override settings found in the profile view properties.

This exercise continues from Exercise 3: Editing Pipe Network Parts in a Profile View (page 442).

To override the style of an object in a profile view

NOTE This exercise uses Pipe Networks-3B.dwg with the modifications you made in the previous exercise.

1. In the drawing window, zoom to the profile view of ROAD1 (PV- (1)).
2. Click the profile view to select it. Right-click. Click Profile View Properties.
3. On the Pipe Networks tab, click the Pipe - (6) row.
4. Scroll to the right until you can see the Style Override value.
5. Click the Style Override cell.
6. In the Pick Pipe Style dialog box, select Dotted. Click OK.
7. Repeat steps 5 and 6 to override style for Pipe - (7), Pipe - (8), and Pipe - (9).
8. Click OK.
   The pipes that cross the road are now displayed using dotted lines, making it easier to view and edit the main pipe segment. You may have to enter REGEN on the command line to see the style change.
9. Pan and zoom until you can clearly see the structure at station 8+00. Notice that there is no indication of the pipe segment that travels along the XC-STORM alignment. In the next few steps, you will change the structure style to display where a perpendicular pipe connects to a structure.
10. Click the structure to select it. Right-click and select Edit Structure Style.
11 In the Structure Style dialog box, on the Display tab, in the View Direction list, select Profile. Make the Structure Pipe Outlines component visible and change its color to red.

12 Click OK. Notice that a red circle now appears in the structure. The red circle indicates the location of a perpendicular connection of a pipe that is not displayed in the profile view.

To continue this tutorial, go to Exercise 5: Viewing Pipe Network Parts in a Section View (page 445).

Exercise 5: Viewing Pipe Network Parts in a Section View

In this exercise, you will view the pipe network parts in a section view.

For more information, see the AutoCAD Civil 3D Help topic Displaying Pipe Networks in Section Views.

This exercise continues from Exercise 4: Overriding the Style of a Pipe Network Part in a Profile View (page 444).

To view pipe network parts in a section view

NOTE This exercise uses Pipe Networks-3B.dwg with the modifications you made in the previous exercise, or you can open Pipe Networks-3C from the tutorial drawings folder (page 615).

1 In the drawing window, zoom to the area around station 12+60 on the ROAD1 alignment.
2 Click Sections menu ➤ Create Sample Lines.
3 Press Enter when prompted to select an alignment.
4 In the Select Alignment dialog box, select ROAD1 and click OK.
5 In the Create Sample Line Group dialog box, click OK.
6 On the command line, enter 1260.
7 For the left swath width, enter 20.
8 For the right swath width, enter 20.
   The sample line is created at the specified station.
9 Press Enter to end the sample line creation command.

10 Click Sections menu ➤ Create Section View.

11 In the Create Section View wizard, click Section Display Options.

12 On the Section Display Options page, in the Select Sections To Draw list, in the ROAD1_SURF row, click the Change Labels cell

13 In the Select Style Set dialog box, select No Labels. Click OK.

14 Repeat Steps 12 and 13 to apply the No Labels label style set to the entries in the Change Labels column.

15 Click Create Section View.

16 Zoom and pan to a location for the section view.

17 Click to create the section view at your selected location.

18 If a warning event is displayed, close the Event Viewer window.

19 Zoom and pan to the section view to see the pipe network parts in the section view.

To continue this tutorial, go to Exercise 6: Creating Pipe and Structure Tables (page 446).

Exercise 6: Creating Pipe and Structure Tables

In this exercise, you will create a table that displays information about the structures in a pipe network. Then, you will create a table style to display other information.

The procedures for creating pipe and structure tables are very similar. While this exercise focuses on structure tables, you can use the same procedure to create pipe tables.

NOTE For more detailed tutorials on tables, go to the Labels and Tables Tutorials (page 537).

For more information, see the AutoCAD Civil 3D Help topic Adding Pipe Tables and Adding Structure Tables.

This exercise continues from Exercise 5: Viewing Pipe Network Parts in a Section View (page 445).
To create pipe and structure tables

NOTE This exercise uses Pipe Networks-3C.dwg with the modifications you made in the previous exercise.

1 Click Pipes menu ➤ Add Tables ➤ Add Structure.
2 In the Structure Table Creation dialog box, select By Network and click OK.
3 Pan to a clear area in the drawing window and click to place the table.
4 Zoom and pan to the structure table. Examine the contents of the table.
   Next, you will change the contents of the table by creating a table style.
5 Select the table by clicking one of the rulings. Right-click the structure table and select Table Properties.
6 In the Table Properties dialog box, under Table Style, click the down arrow next to . Click Copy Current Selection.
7 In the Table Style dialog box, on the Information tab, change the Name to Structure Stations and Details.
8 On the Data Properties tab, select the Sort Data box. Ensure that Sorting Column is 1 and Order is Ascending. These settings ensure that the table rows are sorted in ascending order by the first column.
9 In the Structure area, click to add a new column to the table.
10 Double-click the new column’s heading cell.
11 In the Text Component Editor dialog box, in the preview pane, enter Station. Click OK.
12 In the Table Style dialog box, in the Structure area, double-click in the Column Value cell in the Station column.
13 In the Table Cell Components dialog box, in the Text Contents row, click in the Value cell. Click .
14 In the Text Component Editor dialog box, select the data that appears in the preview area and press Delete.
15 In the preview area, enter STATION = .
In the Properties list, select Structure Station. Change the Precision value to 1 then click ![button].

Click OK to close the Text Component Editor - Column Contents and Table Cell Components dialog boxes.

In the Table Style dialog box, click the heading cell of the Station column then drag the Station column over the Structure Details column. The Station column is placed between the Structure Name and Structure Details columns.

Click OK to close the Table Style and Table Properties dialog boxes. The table now displays the station at which each structure is located.
Part Builder Tutorials

These tutorials demonstrate how to work with the Part Builder features, which you use to design and model parts (pipes and structures) that are used in pipe networks.

**NOTE** If you have not installed AutoCAD Civil 3D to the default location, you may receive messages in the Event Viewer, indicating that pipe network part catalogs are not found. To avoid these messages, it is recommended that you follow the exercises in the order presented. Alternatively, you can reset the path to the catalogs by clicking Pipes menu ➔ Set Pipe Network Catalog.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*.

**Tutorial: Creating a Cylindrical Manhole Structure**

This tutorial demonstrates how use Part Builder to create a cylindrical-shaped storm drainage manhole structure. It will go through the steps to define the new part in the structure catalog, define the manhole geometry, create profiles, and then establish parameters to control the sizing and dimensions of the manhole.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*. 
Exercise 1: Defining the New Part in the Structure Catalog

In this exercise, you will begin creating a cylindrical-shaped manhole structure in Part Builder by creating a new part chapter, and a new part family within the Structure catalog. You will also configure work planes in the Part Builder parametric modeling environment so that you can proceed with modeling the part in the subsequent exercises.

Because you will be working within the Part Builder environment, you do not need to have a drawing open to begin this exercise. However, the AutoCAD Civil 3D tutorial drawings folder (page 615) includes a drawing that contains the completed part—in this case, a cylindrical manhole structure. If desired, before or after completing this exercise, you can open the Part Builder-1b.dwg file in Civil 3D to see what this finished part looks like.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

1. Click Pipes menu ➤ Part Builder.
2. In the Getting Started – Catalog Screen dialog box, in the Part Catalog list, select Structure. Select the Junction Structure With Frames folder, and then click New Parametric Part. The New Part box dialog is displayed.
3. For Name, enter “Cylindrical Manhole1.” Click in the box next to Description. The description matches the name by default. Click OK. The Part Builder parametric modeling environment is opened.
4. Expand Part Configuration and change the following:
   - Undefined Part Type: change this to Junction Structure
   - Undefined: leave this as as Undefined
   - Undefined Bounded Shape: change this to Cylinder

   The Part is configured as a cylinder shape with the properties of a junction structure.
5. Expand Modeling, and then right-click Work Planes and then click Add Work Plane. The Create Work Plane dialog box is displayed.
6. Click Top, and then click OK. The Top work plane is created.
7. Expand Work Planes. Right-click Top Plane ➤ Rename, and change the name to Rim.
This work plane will be the rim elevation of the new structure.

8 Click Save Part Family. Click Yes. The part is validated and saved. Note that additional parameters are displayed under the Model Parameters and Size Parameters to reflect the Part Configuration settings established in step 1.

To continue this tutorial, go to Exercise 2: Defining the Manhole Geometry (page 451).

**Exercise 2: Defining the Manhole Geometry**

In this exercise, you will define the geometry of the manhole by creating a simple schematic of the structure profile. You will build this portion with dimensions that can be modified from within Civil 3D when the part is in use.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*.

This exercise continues from Exercise 1: Defining the New Part in the Structure Catalog (page 450).

1 Click the View menu ➤ 3D Views ➤ Front. The view of your Part Builder drawing area changes so that you see the Rim work plane from a front view.

2 Expand Modeling. Right-click Work Planes and then click Add Work Plane. The Create Work Plane dialog box is displayed.

3 Click Offset. Name the work plane Top of Riser 1 then click OK.

4 The command line asks you to Select reference work plane. Click the yellow bounding square of the Rim work plane. The command line asks you to Select Offset from work plane. Turn on ORTHO. Select a location approximately 12" lower than the Rim work plane in the negative Z direction, and press enter. In later steps, you will establish a more precise offset by equating these distances with structure parameters. A second work plane is displayed approximately 12" below the first work plane.
5 Repeat Steps 10 through 12 to create the following additional work planes, using the following approximate offsets from the work plane directly above each one:

- Top of Cone: 12"
- Top of Riser 2: 24"
- Top of Barrel: 85"
- Bottom of Structure: 200"

The new work planes are displayed. The new parameters are displayed under Model Parameters showing you the work plane offsets.

6 Change your view to be oriented above the Rim work plane. Expand Work Planes, right-click Rim and then click Set View. The view is oriented to be above the Rim work plane.

7 Add a circular profile to represent the diameter of the frame. Right-click the Rim work plane ➤ Add Profile ➤ Circular. At the command prompt, select a center point for the profile at the approximate center of the work plane and a radius of 12”, similar to how you would draw an AutoCAD circle. A circular profile is displayed, and an entry for a circular profile is displayed under the Rim work plane.

8 Expand Work Planes, right-click Rim ➤ Add Geometry ➤ Point. Place a point at the approximate center of your circular profile. A point is displayed at the approximate center of the circular profile.
Constrain the profile so that the point will be forced to always be located at the center of the profile. Right-click the Rim work plane ➤ Add Constraints ➤ Concentric. The command line prompts you to select a first geometry and a second geometry. Select the point and the circular profile. The point moves to be at the center of the circular profile, and a concentric constraint is displayed under the Rim work plane.

Add a diameter dimension that you can later use as a structure parameter. Right-click the Rim work plane ➤ Add Dimension ➤ Diameter. The command line prompts you to select circle or arc geometry. Select the circular profile on the screen. The command line prompts you to select a dimension position. Select a location on your screen that is close to the profile, but out of your way. A diameter dimension is displayed on screen as well as under your Model Parameters. The actual drawn diameter and dimension value are unimportant at this time.

Draw a circular profile on the Top of Riser 1 work plane. Right-click the Top of Riser 1 work plane, and then click Add Profile ➤ Circular. Following the same procedure as Step 7, draw a circular profile. You can use your center OSNAP to ensure that the center of this profile matches the center of the profile from the Rim work plane. Set the radius to be just slightly larger than the Rim work plane circular profile to ease selection of this profile. The actual radius is not important at this time. A circular profile is displayed.

Add a diameter dimension to the circular profile on the Top of Riser 1 work plane. Right-click the Top of Riser 1 work plane, and then click Add Dimension ➤ Diameter. Follow the same procedure as step 10 to place the dimension. A diameter dimension is displayed for your second circular profile.

Repeat the previous two steps to create a circular profile and corresponding dimension on the Top of Cone work plane. You have three circular profiles.
with appropriate dimensions. Your dimensions may look different than the following illustration.

14 Repeat steps 11 and 12 to create a circular profile and corresponding dimension for the Top of Riser 2 work plane; however, this time, make the profile radius approximately twice as large (approximately 24” radius/48” diameter). You should have four circular profiles displayed, and four corresponding dimensions displayed in the modeling area, and under Model Parameters node.

15 Switch your view to front view by choosing Views ➤ 3DViews ➤ Front. Four profiles from front view are displayed.
16 Add a transition between the Rim circular profile and the Top of Riser 1 circular profile. This represents the manhole cover and frame. Right-click Modifiers and then click Add Transition. The command line prompts you to Select Start Profile. On the screen, select the circular profile on the Rim work plane. The command line prompts you to Select End Profile. On the screen, select the circular profile on the Top of Riser 1 work plane. A transition is displayed similar to the following illustration:
17 Right-click the transition on the screen, and then click Display Order ➤ Send to Back. Add a transition between the Top of Riser 1 circular profile and the Top of Cone circular profile. This represents the manhole cover and frame. Right-click Modifiers and then click Add Transition. The command line prompts you to Select Start Profile. On the screen, select the circular profile on the Top of Riser 1 work plane. The command line prompts you to Select End Profile. On the screen, select the circular profile on the Top of Cone work plane.

Repeat the process to create a transition between the circular profiles on the Top of Cone work plane and the Top of Riser 2 work plane. Remember that you may have to use Display Order ➤ Send to Back to send the transitions to the back, so that you can choose the profiles. To do this, right-click the transition on the screen, and then click Display Order ➤ Send to Back. Transitions are displayed similar to the following illustration:

These transitions stay dynamic to profiles used to create them, including adjustments to work plane offsets, and diameter dimensions.

18 Switch your view back to an overhead view by selecting the Top of Barrel work plane, right-clicking and choosing Set View. Your view switches to an overhead view in relation to this work plane.
19 Make two circular profiles with corresponding dimensions on the Top of Barrel work plane. Use steps 11 and 12 for reference. The first should be approximately the same size as the profile on the Top of Riser 2 work plane (24"R/48"D), the second should be approximately twice as large (48"R/96"D). Two circular profiles are displayed on your screen. Two corresponding dimensions are displayed both on screen and under Model Parameters.

20 Make one circular profile with a corresponding dimension on the Bottom of Structure work plane. Use steps 11 and 12 for reference. The profile should be approximately the same size as the larger profile on the Top of Barrel work plane (48"R/96"D). You should now have seven (7) total circular profiles and corresponding dimensions both on screen and under Model Parameters. Remember that these diameters are approximate at this point. The ones you created may not look exactly like the ones displayed in this tutorial.

21 Change your view to a Front view. The stack of work planes and the transitions created in step 17 are displayed.

22 Following the same methodology for the first batch of transitions created in steps 16 and 17, add transitions between the Top of Riser 2 Profile, and the smaller Top of Barrel profile, then the larger Top of Barrel profile and the Bottom of Structure profile. (You may have to use Draw Order to send certain profiles to the back, in order to choose the correct one.
for each transition.) The model you created should now look similar to the following illustration:

23 Change your view to SW isometric.
Change your visual style to Conceptual.
Change your visual style back to 2D wireframe, then change your view back to Top view.
To continue this tutorial, go to Exercise 3: Matching Offsets and Dimensions to Parameters (page 461).

**Exercise 3: Matching Offsets and Dimensions to Parameters**

In this exercise, you will match the work plane offsets and diameter dimensions to the parameters. The next step, though, is to create a few more structure parameters.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*.

This exercise continues from Exercise 2: Defining the Manhole Geometry (page 451).

1. Expand Model Parameters and Size Parameters.
Note that there are entries listed for the work plane offsets, structure parameters and body diameter dimensions.

2 Right-click Size Parameters and then click Add. The Edit Part Sizes dialog box is displayed, along with the New Parameter dialog box.

3 Select Structure Riser Height 1 and press OK. A new parameter of SRZ1 is displayed in the Edit Part Sizes dialog box.

4 In the Edit Part Sizes dialog box, click New to display the New Parameter dialog box. Add the following additional parameters using the New Parameter dialog box:
   ■ Structure Riser Height 2
   ■ Inner Structure Diameter
   ■ Frame Diameter
   ■ Frame Height
   ■ Cone Height
   ■ Slab Thickness
   ■ Barrel Height
   ■ Barrel Pipe Clearance

   Each new parameter is displayed in the Edit Part Sizes dialog box.

5 The next step is to assign some preliminary values to the structure parameters. These will be refined later by adding lists of possible structure sizes. Right-click Model Parameters ➤ Edit. The Model Parameters dialog box is displayed.

6 Note that the structure parameters have all been assigned an initial value of zero. Change the numbers in the Equation column to match the following constants (all in inches):
   ■ $F_{th} = 15$
   ■ $SB_{H} = 84$
   ■ $SB_{PC} = 72$
   ■ $SB_{SD} = 168$
   ■ $SB_{SH} = 315$
   ■ $SCH = 24$
These constants can be changed later to variables, lists, ranges, or tables for further part customization. Keep the Model Parameters dialog box open for the next step.

7 Next, you’ll change each of the work plane offset parameters (WPOf1 through WPOf5) to correspond with a structure parameter. For example, instead of the first offset being approximately 12”, it now corresponds with the SFH parameter. So if you later adjust the SFH parameter, the work plane offset (and its plane geometry, profiles and dimensions) will adjust accordingly.

Select WPOf1, and then select Calculator. The Equation Assistant dialog box is displayed.

8 Select the Variable button to use the pull down to select which structure parameter should match this work plane offset. Click SFH. Press OK to exit the Equation Assistant dialog box. The SFH parameter is displayed under the Equation column in the Model Parameters dialog box.

9 Repeat the previous two steps for each work plane offset parameter using the following values:

- WPOf2 = SRZ1
- WPOf3 = SCH
- WPOf4 = SRZ2
- WPOf5 = SBSH
Remain in the Model Parameters dialog box for the next step. The following parameters are displayed under the equation column in the Model Parameters dialog box:

<table>
<thead>
<tr>
<th></th>
<th>Value</th>
<th>Unit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WPOf1</td>
<td>8.0000</td>
<td>SFH</td>
<td>Workplane Offset 1</td>
</tr>
<tr>
<td>WPOf2</td>
<td>8.0000</td>
<td>SRZ1</td>
<td>Workplane Offset 2</td>
</tr>
<tr>
<td>WPOf3</td>
<td>24.0000</td>
<td>SCH</td>
<td>Workplane Offset 3</td>
</tr>
<tr>
<td>WPOf4</td>
<td>120.0000</td>
<td>SRZ2</td>
<td>Workplane Offset 4</td>
</tr>
<tr>
<td>WPOf5</td>
<td>172.0000</td>
<td>SBSH</td>
<td>Workplane Offset 5</td>
</tr>
</tbody>
</table>

Next you map each body diameter dimension to a corresponding structure diameter parameter. Using the calculator tool in the Model Parameters dialog box, set the equation column for each body diameter parameter making the following matches:

- BdyD1 = SFD
- BdyD2 = SFD
- BdyD3 = SFD
- BdyD4 = 2*SFD
- BdyD5 = 2*SFD
- BdyD6 = SID
- BdyD7 = SID

The following parameters are displayed under the equation column in the Model Parameters dialog box:

<table>
<thead>
<tr>
<th></th>
<th>Value</th>
<th>Unit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bdy01</td>
<td>24.0000</td>
<td>SFD</td>
<td>Body Diameter 1</td>
</tr>
<tr>
<td>Bdy02</td>
<td>24.0000</td>
<td>SFD</td>
<td>Body Diameter 2</td>
</tr>
<tr>
<td>Bdy03</td>
<td>24.0000</td>
<td>SFD</td>
<td>Body Diameter 3</td>
</tr>
<tr>
<td>Bdy04</td>
<td>48.0000</td>
<td>2*SFD</td>
<td>Body Diameter 4</td>
</tr>
</tbody>
</table>
Press OK to exit the Model Parameters dialog box. Save the part. The part updates to reflect any dimension changes. If desired, change your view to isometric, and your visual style to conceptual, to see how the part is progressing.

Change the Autolayout location to the center of the Rim circular profile. This ensures that the structure is inserted properly into your drawing. Select Layout Data, right-click and then click Select Placement Point. The command line prompts you to Select a Placement Point.

Use your node OSNAP to select the point at the center of the Rim work plane circular profile. A small, cyan marker is displayed at that location. This marks the structure insertion point.

Save the part.

To continue this tutorial, go to Exercise 4: Verifying the New Part (page 465).

Exercise 4: Verifying the New Part

In this exercise, you will verify that the new part reacts as expected in a drawing by opening a drawing, regenerating the structure catalog, and accessing the new part from a Part List.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

This exercise continues from Exercise 3: Matching Offsets and Dimensions to Parameters (page 461).

At this point, it is important to determine how the new part reacts in a drawing situation. Exit the Part Builder utility by clicking the small X in the upper right corner of the Part Browser. (The Part Browser is the left pane portion of the Part Builder application window.) If you are prompted to save the part, click Yes. Part Builder closes.
2 Open the tutorial drawing called Part Builder-1a.dwg, and enter PartCatalogRegen in the command line. Enter S to indicate you want to regenerate the structure catalog. Press Enter. Click OK, and then press ESC to exit the PARTCATALOGREGEN command. A drawing opens with a sample surface, and the part catalog regenerates.

3 Create a new Parts List called “Test Parts List”. The Parts List dialog box is displayed.

4 On the Structures tab, click Add Part Family. The Add Part Family dialog box is displayed.

5 Click your part, and then click OK. An entry is displayed on the Structures tab for the manhole.

6 Right-click your part and then click Add Part Size. The Part Size Creator dialog box is displayed. This dialog box lists all of the parameters as constants right now.

   **NOTE** Do a quick visual check on the Part Size Creator dialog box to verify that all values are nonzero. If any of the properties are displayed in the Part Size Creator dialog box as zero, the part will not insert into the drawing properly.

7 Now add a few pipes to your Test Parts List. Exit the Parts List dialog box. A new Parts List is created.

8 Create a pipe network by layout that contains approximately three structures and two pipes.

9 Observe how your structures are displayed in plan (2D) views and in 3D view (Object Viewer).
10 Make an alignment from network parts, and a corresponding profile view. Note how your structures respond to edits, adjustments, and changes of pipe inverts.

11 Click Pipes menu ➤ Part Builder, or enter PartBuilder at the command line. Select Manhole 206 Type A, and then click Modify Part Sizes. Part Builder opens to your custom part.

12 Add some variables to the Cone Height (SCH), Riser 1 Height (SRZ1), and Barrel Height (SBH) to make it easier to edit your structure after it has
been inserted into the drawing. Right-click Size Parameters and then click Edit Configuration. The Edit Part Sizes dialog box is displayed.

13 Under SCH, SRZ1 and SBH, change the Data Storage from Constant to List. Each parameter now accepts additional values.

14 Click Values from the drop-down list at the top of the Edit Part Sizes dialog box. The Edit Part Sizes dialog box switches to Values mode.

15 Move your cursor to become active in the SCH column, and then click the Edit button from the Edit Part Sizes dialog box toolbar. The Edit Values dialog box is displayed.

16 Click Add to add the following values: 0, 6, 12, 18. Click OK to exit the dialog box. A list of values is now available for SCH.

17 Repeat Steps 16 and 17 for SRZ1 and SBH, adding the following values to each list:
   - SRZ1 = 12, 24, 36, 48, 60
   - SBH = 100, 120, 140, 180

Click OK to exit the Edit Part Sizes dialog box. Lists of values are now available for SRZ1 and SBH.

18 Save your part.

Additional customizations can be made to the geometry of a manhole such as this one using the principles learned in the vault structure tutorial exercise, as well as other part building exercises.

19 Exit the Part Builder utility, click the small X in the upper right corner of the Part Browser. (The Part Browser is the left pane portion of the Part Builder application window.) If you are prompted to save the part, click Yes. Part Builder closes.

You can open Part Builder-1.dwg in the tutorial drawings folder (page 615) in Civil 3D to see what this finished part looks like in a drawing.

**Tutorial: Creating a Drop Inlet Manhole Structure**

This tutorial demonstrates how to use Part Builder to create a drop inlet manhole structure. It will go through the steps to define the new part in the
structure catalog, define the manhole geometry, create profiles, and then establish parameters to control the sizing and dimensions of the manhole.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder

Exercise 1: Defining the New Part in the Structure Catalog

In this exercise, you will begin creating a drop inlet manhole structure in Part Builder by creating a new part chapter, and a new part family within the Structure catalog. You will also configure work planes in the Part Builder parametric modeling environment so that you can proceed with modeling the part in the later exercises.

This exercise uses a different process than the process that was used in the previous tutorial.

Because you will work in the Part Builder environment, you do not need to have a drawing open to begin this exercise. However, the AutoCAD Civil 3D tutorial drawings folder includes a drawing that contains the completed part—in this case, a manhole structure with a drop inlet. If desired, before or after completing this exercise, you can open the Part Builder-2.dwg file in Civil 3D to see what this finished part looks like.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

1  Click Pipes menu ➤ Part Builder.

2  In the Getting Started – Catalog Screen dialog box, in the Part Catalog list, select Structure.

3  Click the US Imperial Structure Catalog folder, and then click New Chapter. Enter Custom for name, and then click OK.
   A new Chapter is created for custom structures.

4  Select the Custom folder, and then click New Parametric Part.
   The New Part dialog box is displayed.

5  For Name, enter “NO 233a”. Click in the Description field, and add “Outside Drop Connection” to the default Description, and then click OK.
   The Part Builder parametric modeling environment is opened.
6 Expand Part Configuration and change the following:
   - Undefined Part Type: change this to Junction Structure
   - Undefined: change this to Manhole (do this by double-clicking and then entering “Manhole” into this field)
   - Undefined Bounded Shape: change this to Cylinder

   The Part is configured as a cylinder shape with the properties of a junction structure.

7 Expand Modeling, right-click Work Planes, and then click Add Work Plane.
   The Create Work Plane dialog box is displayed.

8 Click Top, enter “Rim” for Name, and then click OK.
   A top work plane is created which represents the rim elevation of the structure.

9 Expand Work Planes, right-click Rim ➤ Add Geometry ➤ Point.
   You are prompted to pick a point.

10 Click a point near the center of the yellow rectangle, and then press ESC.
    A point is created on the Rim work plane near the center. This is a reference point to begin the construction of the part.

11 Right-click Work Planes and then click Add Work Plane.
    The Create Work Plane dialog box is displayed.

12 Click Right, enter “Vertical Axis” for Name, and then click OK.
    The Right side Vertical Axis work plane is created.

13 Click Save Part Family. Click Yes.
    Stay in the Part Builder environment for the next exercise. The part is validated and saved. Depending on the part type, and on the Bounding Shape selected, certain Model Parameters and Size Parameters are automatically added to the part definition.

To continue this tutorial, go to Exercise 2: Defining the Manhole Geometry (page 471).
Exercise 2: Defining the Manhole Geometry

In this exercise, you will define the geometry of the drop inlet manhole by creating a simple schematic of the structure profile. You will build this portion with dimensions that can be modified from within Civil 3D when the part is in use.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

This exercise continues from Exercise 1: Defining the New Part in the Structure Catalog (page 469).

1. Expand Modeling ➤ Work Planes, right-click Vertical Axis ➤ Set View. The current view and UCS is set to match the work plane.

2. Right-click Vertical Axis, and then click Add Geometry ➤ Line. Create a line with 5 segments on the work plane. Begin by snapping to the node of the reference point on the Rim work plane and Use Ortho to make it easier to draw a straight line. Make the segments about 24 units long. A line geometry object is shown in the drawing. This line represents the vertical axis of the manhole. Each segment represents a component of the structure. Starting from the top, the segments represent the frame, the cone, and the last 3 segments represent the barrel. You will use the extra vertices to place the incoming Dip Tee and the Drop 90° Elbow in the next steps.
3 Use the Add Geometry ➤ Line and Add Geometry ➤ Arc to draw the schematic of the drop assembly. Don’t worry about making the parts perfectly meet. You will use constraints to make the geometry match up properly. Make the two horizontal lines that connect to the vertical line about 36 units long. Next you will establish some constraints to keep the components of the profile in the correct location relative to one another.
4 Right-click Vertical Axis ➤ Add Constraints ➤ Parallel. Select the bottom line segment of the manhole centerline, and then click the segment directly above it. The bottom two segments are now constrained such that they are parallel to each other.

5 Repeat the process, working your way up the centerline, constraining adjacent line segments to Parallel. All segments representing the centerline of the structure are constrained to be parallel to one another.

6 Right-click Vertical Axis ➤ Add Constraints ➤ Perpendicular. Select the bottom segment of the structure centerline and the lower horizontal line.

7 Repeat for the upper horizontal line. The lower and upper horizontal components of the drop pipe are constrained to perpendicular to the structure centerline.

8 Right-click Vertical Axis ➤ Add Constraints ➤ Parallel. Select the bottom line segment of the manhole centerline and then click the vertical segment of the drop pipe. The vertical drop pipe is constrained to parallel to the structure centerline.

9 Right-click Vertical Axis ➤ Add Constraints ➤ Coincident. Click the point at the top of the vertical drop pipe, and then the left end of the
upper horizontal line. This positions the rectangle so that its center is located at the fixed point.

10 Right-click Vertical Axis ➤ click Add Constraints ➤ Parallel. Select the right upper horizontal segment, and then the left upper horizontal segment. The two upper segments are constrained to parallel.
11 Right-click Vertical Axis ➤ Add Constraints ➤ Tangent. Select the lower horizontal line, and then the arc. Repeat for the arc and the vertical segment of the drop pipe. The drop pipe bend arc is constrained to be tangent with the horizontal and vertical segments of the pipe.
12  Right-click Vertical Axis ➤ Add Dimension ➤ Distance. Click the bottom and then top points at the ends of the top segment of the centerline. Click a point to set the location of the dimension. A dimension named LenA1 is created for the line segment representing the frame height.

13  Repeat these steps for each segment of the centerline, starting at the top and ending at the bottom segment. Dimensions named LenA2 through LenA5 are created for the centerline of the structure.

**NOTE** For this exercise, make sure you dimension the segments in the order shown in the following illustration.
Add a Distance dimension to the lower horizontal line by picking the points at each end. This represents the distance from the structure centerline to the start of the elbow. This is used to ensure that the drop stays on the outside of the structure. LenA6 is created.
15 Right-click Vertical Axis ➤ Add Dimension ➤ Diameter. Select the arc that represents the elbow. Click a point to set the location of the dimension. BdyD1 is added to the arc.

16 Add one final length dimension to the left upper horizontal line segment. LenA7 is added.
Click Save Part Family. The part is saved.  
Next you will add Profiles that represent the diameters of the frame, top of cone, barrel, and drop pipe.
First, you'll create the profile for the frame diameter.

Right-click Vertical Axis ➤ Add Profile ➤ Circular. Click an open area near the top right of the vertical axis to define the center and then click again about 12 units away to define the diameter. A circle profile is drawn.

Right-click Vertical Axis ➤ Add Dimension ➤ Diameter. Click the circle drawn in the previous step. Click a point to set the location of the dimension. BdyD2 is created for the frame diameter.
20 Expand Vertical Axis. Right-click Circular Profile ➤ Rename. Enter “Frame Cylinder Diameter”. This will make it easier to work with this shape later.

21 Next, repeat the previous two steps to create and dimension the top of cone profile with a radius of about 18 units, and the barrel profile with a radius of about 24 units. The top of cone profile is drawn and dimensioned with BdyD3. The barrel diameter profile is drawn and dimensioned with BdyD4.
Next, create and dimension the drop pipe profile. Right-click Vertical Axis ➤ Add Profile ➤ Circular. Click an open area to the left of the upper end of the vertical axis to define the center and then click again about 6 units away to define the diameter.

Add a diameter dimension to the pipe profile. The pipe profile is created and dimensioned with BdyD5.
24 Rename the three Circular Profiles to Cone Top Diameter, Barrel Cylinder Diameter, and Drop Pipe Diameter. Renaming the profiles will make them easier to work with later.

25 Click Save Part Family.
   The next exercise continues working on this part.

To continue this tutorial, go to Exercise 3: Creating Profiles and Establishing Parameters (page 482).

**Exercise 3: Creating Profiles and Establishing Parameters**

In this exercise, you will extrude the part profiles to create the 3D model. You will then establish the model parameters to control the sizing and dimensions of the manhole.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*.

This exercise continues from Exercise 2: Defining the Manhole Geometry (page 471).

1 Right-click Modifiers ➤ Add Path. When prompted for path, select the top line segment (the segment dimensioned LenA1), then select the Frame Cylinder Diameter profile (the circle dimensioned BdyD2) for the start profile, and select it again for the end profile. The Frame Cylinder Diameter profile is applied along the path (length) of the top line segment.
2 Change the view to SE Isometric to get a better view of the Path. Change the view back to Right.
Repeat the Add Path command for the cone segment. For the start profile, select the Cone Top Diameter profile (dimensioned with BdyD3). For the end profile, select the Barrel Cylinder Diameter profile (dimensioned with BdyD4).
Repeat the Add Path command for the remaining three line segments. Use the Barrel Cylinder Diameter profile for both the start and end profiles for each of the three segments. Change your view to SE Isometric to see the part in 3D. Change view back to Right.
Next, you’ll add paths for the drop pipe assembly. Right-click Modifiers ➤ Add Path. Select the lower horizontal segment for the path and the Drop Pipe Diameter profile for the start and end profiles.
6 Add Path for the curved elbow. When the Enter Number of Path Segments dialog box is displayed, verify that “Do not segment path” is checked, and then click OK. Then add the path modifier for the vertical segment of the drop pipe. Use the Drop Pipe Diameter profile.

7 Finish the drop pipe assembly by adding paths for the upper segments. Start with the right upper segment. Switch to SE isometric view.
Switch back to Right view.

Next, you will merge the structure components with the drop pipe assembly components. Right-click Modifiers ➤ Boolean Add. When prompted to select objects, select the bottom two barrel segments, and the lower horizontal pipe segment, and then press Enter. The parts are merged.
9 Right-click Modifiers ➤ Boolean Add. When prompted to select objects, select the top two barrel segments, and the upper two horizontal pipe segments, and then press Enter.
10 Right-click Modifiers ➤ Boolean Add. When prompted to select objects, select the upper horizontal pipe segment, and the vertical pipe segment, and then press Enter.

11 Switch the view to SE Isometric.
Next you will set the placement point for the part.
Add new Top workplane; Add Point reference; Select placement point on Top workplane Expand AutoLayout Data. Right-click Layout Data, and then click Set Placement Point. Use the node object snap to click the top point on the vertical axis. This is the point at which the part is inserted into the drawing (insertion point).
13 Save the part. Click Save Part Family.

14 Right-click Size Parameters ➤ Add ➤ Edit Configuration.

15 Click New. Add the following Parameters clicking New for each:
   ■ Barrel Height
   ■ Frame Height (SFH)
   ■ Frame Diameter (SFD)
   ■ Cone Height (SCH)
   ■ Inner Structure Diameter (SID)
   ■ Barrel Pipe Clearance (SBPC)

   Click OK when all of the parameters have been added.

16 Click Save Part Family. Right-click Model Parameters, and then click Edit. Double-click in the Equation column next to each of the following, and set the Equation for each parameters as shown below:
   ■ FTh to 6
   ■ WTh to 4
   ■ SBH to 74
   ■ FTh to 6
   ■ SBPC to 3
Saving the part causes the Model Parameters to update, including the new Size Parameters.

17 Right-click Size Parameters, and then click Edit Configuration. The Edit Part Size dialog box is displayed.

18 Locate the SRS column, click Constant, and change it to Range. The SRS parameter is now formatted as a range of values. Click the drop-down arrow button next to Parameter Configuration, and select Values. The view is changed to show the value of each parameter. Click the cell in the SRS column, and then click the Edit button on the Edit Part Sizes dialog box toolbar. The Edit Values dialog box is displayed. Set the Minimum to 36, the Maximum to 12000, the Default to 120, and then click OK.

19 Right-click Model Parameters, and then click Edit. Edit the Equations and Descriptions for the BdyD# parameters as shown in the following table:

<table>
<thead>
<tr>
<th>BdyD1</th>
<th>12</th>
<th>Elbow Bend Diameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>BdyD2</td>
<td>SFD</td>
<td>Frame Cylinder Diameter</td>
</tr>
<tr>
<td>BdyD3</td>
<td>SFD+(2*Wth)</td>
<td>Cone Top Diameter</td>
</tr>
<tr>
<td>BdyD4</td>
<td>SID+(2*Wth)</td>
<td>Barrel Cylinder Diameter</td>
</tr>
<tr>
<td>BdyD5</td>
<td>12</td>
<td>Incoming Pipe Diameter</td>
</tr>
</tbody>
</table>
20 Make the following additional edits:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Equation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SBH</td>
<td>SRS-SFH-SCH</td>
</tr>
<tr>
<td>SBPC</td>
<td>3.0</td>
</tr>
<tr>
<td>SBSD</td>
<td>SID+(2*Wth)</td>
</tr>
<tr>
<td>SBSH</td>
<td>SRS+FTh</td>
</tr>
</tbody>
</table>

21 Edit the Equations and Descriptions for the LenA# parameters as shown in the following table:

<table>
<thead>
<tr>
<th>LenA1</th>
<th>Equation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SFH</td>
<td></td>
<td>Frame Cylinder Height</td>
</tr>
<tr>
<td>SCH</td>
<td></td>
<td>Cone Cylinder Height</td>
</tr>
<tr>
<td>SVPC</td>
<td>SFH-SCH+(BdyD5/2)</td>
<td>Top Pipe CL</td>
</tr>
<tr>
<td>SRS+FTh-SFH-SCH-LenA3-LenA5</td>
<td></td>
<td>Top Pipe CL to Bottom Pipe CL</td>
</tr>
<tr>
<td>24</td>
<td></td>
<td>Bottom Pipe CL to Struct Bottom</td>
</tr>
<tr>
<td>(SID/2)+WTh+(BdyD5/2)+Z</td>
<td></td>
<td>CL Vert Pipe to Incoming Pipe</td>
</tr>
</tbody>
</table>

Click Close. Change to SE Isometric view and note the changes to the geometry of the structure.

22 Change the 4 circular profiles so they are not visible by right-clicking on each and then clicking Visible.

The circular profiles are no longer visible

23 Repeat the previous step for all of the Dimensions.

24 Change view to SE Isometric and examine the part. It should look like the image at right.
Click Save Part Family. Close out of the Part Builder Environment, and then re-open the Part.

To exit the Part Builder utility, click the small X in the upper right corner of the Part Browser. (The Part Browser is the left pane portion of the Part Builder application window.) If you are prompted to save the part, click Yes. Part Builder closes.

After all the changes that have been made, now is a good time to close out and re-open the part so that all of the data is freshly loaded into the part builder environment.

25 Right-click Size Parameters, and then click Edit Configuration.

26 Change the Data Storage type to List for the following parameters:
   ■ WTh
   ■ FTh
Click the drop-down arrow button next to Parameter Configuration, and select Values.

Select the 4.000 in the WTh column, click the Edit button from the Edit Part Sizes dialog box toolbar, and add the following values: 4.0, 6.0. Click OK.

Repeat the previous step for each of the following parameters:
- FTh: 6.0, 8.0, 12.0
- SFH: 4.0, 6.0, 8.0
- SFD: 24.0, 36.0
- SCH: 24.0, 36.0
- SID: 48.0, 60.0, 72.0

Click the drop-down arrow button next to Values, and select Calculations.

Double click in the cell in the PrtSN to open the Calculation Assistant.

Change the Precision to 0.

Click in the text box, right after PrtD, and press the space bar.

From the Insert Variable list, select FTh and then click Insert. The FTh variable is inserted into the Part size name.

Enter “in Floor” after the FTh variable. (Exclude the quotation marks.)

Repeat the previous steps, adding variables and text for SCH, SFD, SFH, SID, WTh. The complete string should look something like this:

PrtD FTh in Floor SCH in Cone Hgt SFD in Frame Dia SFH in Frame Hgt SID in Barrel Dia WTh in Wall.

Click Evaluate to see the resultant part name.

Note that the name is long and partially cut off on the right. Click the name and use your keyboard arrow keys to see the rest of the name. This
is a required step to ensure that each part has a unique part name when added to the part list.

38 Click OK twice to close all dialog boxes.

39 Save the Part. Switch Visual Style to Conceptual. The part should look like the following:

40 Right-click Model Parameters, and then click Edit.

41 Double click the Equation for SVPC and enter: SFH+SCH+SBPC. Change the Visual Style to 2D Wireframe. Right-click Vertical Axis ➤ Add Geometry ➤ Point Reference.

42 Click the point in the center of the Rim work plane.
A reference point (green) is created where the two planes meet in line with the vertical axis of the structure.
43  Right-click Vertical Axis ➤ Add Constraints ➤ Coincident. Click the top point of the vertical axis, then click the reference point created in the previous step. The entire structure moves upward so that the rim elevation matches the top work plane.

44  Click Generate Bitmap.

45  Click SE Isometric View.

46  Click OK. A bitmap image is generated. This is the image of the part that is displayed when viewing the part in the part catalog. It is not used not when viewing the part in a drawing.
Click Save Part Family.

Exit the Part Builder utility by clicking the small X in the upper right corner of the Part Browser. (The Part Browser is the left pane portion of the Part Builder application window.) If you are prompted to save the part, click Yes. Part Builder closes.

In Civil 3D, you can open Part Builder-2.dwg in the tutorial drawings folder (page 615) to see what this finished part looks like in a drawing.

**Tutorial: Creating a Vault Structure**

This tutorial demonstrates how to use Part Builder to create a vault structure. It will go through the steps to define the new part in the structure catalog, define the manhole geometry, create profiles, and then establish parameters to control the sizing and dimensions of the vault.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*. 
Exercise 1: Defining the New Part in the Structure Catalog

In this exercise, you will begin creating a vault structure in Part Builder by creating a new part chapter, and a new part family within the Structure catalog. You will also configure work planes in the Part Builder parametric modeling environment so that you can proceed with modeling the part in the subsequent exercises.

Because you will work in the Part Builder environment, you do not need to have a drawing open to begin this exercise. However, in Exercise 5, Using the New Part, you will be instructed to open a drawing (Part Builder-3a.dwg) and use the part in a pipe network.

The AutoCAD Civil 3D tutorial drawings folder (page 615) includes a drawing that contains the completed part—in this case, a vault manhole structure. If desired, before or after completing this exercise, you can open the Part Builder-3b.dwg file In Civil 3D to see what this finished part looks like.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

1. Click Pipes menu ➤ Part Builder, or enter PartBuilder at the command line. The Getting Started - Catalog Screen dialog box is displayed.
2. Click the US Imperial Structures Folder, then click New Chapter. Enter Custom for name and then click OK. A new Chapter is created for custom structures.
3. Verify that the Custom Folder is selected, then click New Parametric Part. The New Part dialog box is displayed.
4. For Name enter "Vault 5106-LA with Top 5106TL3- 332". Click in the box next to Description. The description matches the name by default. Click OK. The Part Builder environment is opened.
5. Expand Part Configuration and change the following:
   - Undefined Part Type: change this to Junction Structure
   - Undefined: change this to Rectangular Vault (do this by double-clicking and then entering “Rectangular Vault” into this field)
   - Undefined Bounded Shape: change this to Box
The Part is configured as a box shape with the properties of a junction structure.

6 Expand Modeling. Right-click Work Planes, and then click Add Work Plane. The Create Work Plane dialog box is displayed.

7 Click Top, and then click OK. The Top work plane is created.

8 Expand Work Planes. Right-click Top Plane and then click Rename. Change the name to Rim. This work plane will become the rim elevation of the new structure.

9 Click Save Part Family. Click Yes. Stay in the Part Builder environment for the next exercise. The part is validated and saved.

To continue this tutorial, go to Exercise 2: Defining the Vault Top Section Geometry (page 503).

Exercise 2: Defining the Vault Top Section Geometry

In this exercise, you will build the top portion of the vault. This is a rectangular frame with a rectangular opening. You will build this portion with dimensions that can be modified from within Civil 3D when the part is in use.

For more information, see the AutoCAD Civil 3D Help topic Understanding Part Builder.

This exercise continues from Exercise 1: Defining the New Part in the Structure Catalog (page 502).

1 Expand Modeling ➤ Work Planes, right-click Rim ➤ Set View. The current view and UCS is set to match the work plane.

2 Right-click Rim ➤ Add Profile ➤ Rectangular. Click two points to draw a rectangle in the drawing area. A rectangular profile object is shown in the drawing.

3 Expand Rim, right-click Rectangular Profile in the Content Builder window and then click Rename. Enter Frame Outer Edge as the name. This name makes it easier to identify the component.

4 Repeat these steps to create another rectangular profile within the first one. Name it Frame Opening.
Next you will establish some construction geometry and constraints to keep the opening positioned at the center of the box. Rectangular profiles representing the outer edge of the frame and the opening have been created.

5 Right-click Rim ➤ Add Geometry ➤ Point. Click a location near the center of the rectangles. Press ESC. This becomes the center point of the structure.

6 Expand the Geometry folder. Right-click Point 2D ➤ Rename. Enter Fixed Center for the name. This name makes it easier to identify the component.

7 Right-click Fixed Center ➤ Fixed. The point is now fixed. Constraints that include this point will not move the point.
8 Right-click Rim ➤ Add Constraints ➤ Equal Distance. Click the point at the top left corner of the outer rectangle, then the Fixed Center Point. For the second pair, click the point at the bottom right corner of the outer rectangle, and the Fixed Center Point.

9 Repeat this step for the bottom left and upper right corners of the outer rectangle. This constrains the outer rectangle so that it is centered about the Fixed Center.

10 Repeat these steps for the four corners of the inner rectangle. Both rectangles are now centered about the fixed point.

11 Right-click Rim ➤ Add Constraints ➤ Parallel. Click any line on the outer rectangle, then the line that is parallel to it on the inner rectangle. This constraint prevents the inner rectangle from rotating within the outer rectangle.
12 Right-click Rim ➤ Add Dimension ➤ Distance. Click two points at either end of the top side of the outer rectangle. Click a point to set the location of the dimension. A dimension named LenA1 is created for the long side of the outer edge of the frame.

13 Repeat these steps for the right side of the outer rectangle. A dimension named LenA2 is created for the short side of the outer edge of the frame.
14 Repeat these steps for top and right sides of the opening, in that order. Reposition the dimensions as needed so that they are easy to read. LenA3 and LenA4 are created for the long side and short side of the opening, respectively.

15 Click the View menu ➤ 3D Views ➤ SW Isometric. This 3D view is better suited for the next steps.

16 Right-click Modifiers ➤ Add Extrusion. Click the outer rectangle. The Extrusion Modifier dialog box is displayed.

17 Verify that Type is set to Blind. Enter 8 for Distance and check the box next to Flip. Click OK. An extrusion modifier is created for the outer rectangle.
Repeat these steps to create an Extrusion modifier for the inner rectangle using a distance of 9. An extrusion modifier is created for the inner rectangle.
Right-click Model dimensions ➤ Add Distance. Click one of the vertical edges of the outer box extrusion. Click a point to set the location of the dimension. LenB1 is created for the height of the frame section.

Repeat this step for the inner box extrusion. LenB2 is created for the height of the opening extrusion.
21 Expand Model Parameters, right-click Model Parameters, and then click Edit. The Model Parameters dialog box is displayed.

22 Click LenB2, then click Calculator. Click Variable, then select LenB1. Enter +1 after LenB1 and then click OK, then Close.
   This ensures that the extrusion for the opening is always deeper than the thickness of the frame. You could also have double clicked the cell in the Equation column and entered in your own formula.

23 Right-click Modifiers ➤ Add Boolean Subtract. Click the outer box, then the inner box, and then press Enter. The inner box is subtracted from the outer box creating a third modifier which is the result of this action.
24 Expand Modifiers. Notice the three modifiers that have been created. The Extrusion modifiers have been set to invisible by default as a result of the Subtract command. Rename the modifier named Subtract to Frame.

25 Right-click Size Parameters and then click Edit Configuration. The Edit Part Sizes dialog box is displayed.

26 Scroll to the right until you see the SBSL (Structure Length) column. Click Constant in the SBSL column, and change it to list. Do the same for the SBSW (Structure Width) Column. These parameters can now be specified by a list of values, rather than by a single constant.

27 Click the drop-down arrow button next to Parameter Configuration, and select Values. Click the cell under SBSL, and then click the Edit button from the Edit Part Sizes dialog box toolbar. The Edit Values dialog box is displayed.

28 Change the current value to 48. Then use the Add button to create values of 60, 72, 84, 96, 108, and 120. This makes it so that the Structure Length parameter can be adjusted in 12-inch increments.

29 Repeat this step for the SBSW column, creating values of 36, 48, 60, and 72.
30 Set the value of SBSL to 120 and the value of SBSW to 60. Click the Update Model button in the Edit Part Sizes dialog box toolbar. This updates the values under Model Parameters to match the Part Parameters.

31 Click OK. Right-click Model Parameters and then click Edit. Click LenA1, and then click Calculator.

32 Click Variable, and then click SBSL. Click OK, and then Close.

33 Repeat these steps for LenA2, equating it to SBSW. The model is updated to reflect the changes to the dimensions.

34 Right-click Size Parameters and then click Edit Configuration. Click New. The New Parameter dialog box is displayed.

35 Click Frame Length, and then click OK. Click New, then click Frame Width, OK. Two new parameters have been added: frame length (SFL) and frame width (SFW).

36 Scroll to the right until you see the SFL and SFW columns. Change Constant to List for each of these columns. Then change the view to Values.

37 Using the same procedure that was used for SBSL and SBSW, add values of 36, 48, 60, 72, 84, 96, and 108 for SFL. Add values of 24, 36, 48, and 60 for SFW.

    These values are now controlled by lists that can ultimately be manipulated from within Civil 3D when the part is in use.

38 Click OK to close the Edit Part Sizes dialog box. Click Save Part Family. This saves the part as well as updates the Model Parameters to include the newly added Size Parameters.
Right-click Size Parameters and then click Edit Values. Set the following values:

- SFL: 108
- SFW: 48

Click the Update Model button in the Edit Part Sizes dialog box toolbar, and then click OK. This updates the Model Parameter values so that they match the Part Parameter values where applicable.

Expand Model Parameters, edit LenA3 and LenA4 to equate to SFL and SFW respectively. The model updates to reflect the changes to the dimensions.

Click Save Part Family. Remain in the Part Builder environment for the next exercise.

To continue this tutorial, go to Exercise 3: Defining the Vault Box Geometry (page 513).

**Exercise 3: Defining the Vault Box Geometry**

In this exercise, you will build the box portion of the vault. You will use projection geometry and constraints to link the box to the frame so that a single set of dimensions can control both.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*. 
This exercise continues from Exercise 2: Defining the Vault Top Section Geometry (page 503).

1. Continue from the previous exercise in the Part Builder environment. Click the View menu ➤ 3D Views ➤ SW Isometric. Next you will create a reference work plane at the bottom of the frame. This view makes it easier to perform the next few steps.

2. In the Content Builder window, right-click Work Planes, and then click Add Work Plane. The Create Work Plane dialog box is displayed.

3. Click Reference then enter Top of Box for Name. Click OK. You are prompted for a modifier.

4. When prompted for modifier, select the 3D frame object.
A new yellow rectangle is displayed representing the reference plane at the bottom of the frame (also top of box). This reference plane is attached to the modifier and moves if the frame thickness is adjusted.

When prompted for the work plane, select the yellow rectangle at the top of the frame object (this represents the top plane).

When prompted for the reference work plane, click along the lower edge of the frame object.
5 Right-click Top of Box and then click Set View. Next, click the View menu ➤ 3D Views ➤ SW Isometric. This sets the working plane to Top of Box and then returns the drawing to its original view.

6 Right-click Top of Box ➤ Add Geometry ➤ Projected Geometry. You are prompted for a modifier.

7 Click the 3D frame object. When prompted for the geometry to project, click one of the lower edges. The line highlights in red when the cursor is in the correct position. Repeat this process for the three remaining lower edges.
This creates geometry that is linked to the lower edge of the frame extrusion. This is a key relationship in building the box section below the frame so that it is aligned with the frame. The projected geometry is displayed in green.

8 Set the visibility of all geometry and profiles in the Rim work plane to off. Right-click Top of Box and then click Set View. Objects in the Rim work plane are turned off so that you do not snap to them or use them inadvertently.

9 Right-click Top of Box ➤ Add Profile ➤ Rectangular. You are prompted for rectangle points.

10 Click two points to create a rectangle that is outside of the current geometry. In Content Builder, change the name Rectangular Profile to Outer Wall. A rectangular profile is drawn.

11 Draw a second rectangular profile within the first. Change its name to Inner Wall. There are now two rectangular profiles.
Right-click Top of Box ➤ Add Constraints ➤ Equal Distance. Click the left side of the outer rectangle, then the left side of the inner rectangle. Then click the top side of the outer rectangle and the top side of the inner rectangle. The distance between the outer wall and inner wall on the left side is set to always match the distance between the outer wall and inner wall on the top side.

Repeat this procedure, first clicking the top pair of lines then clicking the right pair. Continue around the rectangle in a clockwise direction, finishing up by setting the right side equal to the bottom side.
All sides are now equal. With these constraints in place, you can change the thickness of one side and the changes affect all sides.

Right-click Top of Box ➤ Add Dimension ➤ Perpendicular Distance. Click a line on the inner rectangle then the corresponding parallel line on the outer rectangle. Click either of the lines once again to set a perpendicular reference object. Pick a point between the two lines for the dimension position and enter 4 for the dimension value. A new dimension named LenA5 is created. This single dimension sets the wall thickness of the box. Because of the equal distance constraints established in the step above, this dimension controls all four sides.
15 Right-click Top of Box ➤ Add Constraint ➤ Coincident. Click the black point at the top left corner of the outer box, then click the green projected point at the top left corner of the frame.

The black point is moved to be coincident with the green point. Because of constraints, the top and left sides of both rectangles are moved and the 4" distance between the inner and outer walls is maintained.
Repeat this procedure for all four corners. You may need to use Shift+Space to select the green point. The Top of Box geometry is linked to the green projected geometry, which is linked to the extrusion modifier projected from the Rim work plane. With these relationships, the geometry of the entire vault can be controlled with a few parameters.

Right-click Model Parameter and then click Edit. Change the Equation for LenA5 to Wth. Change the value for Wth to 4. Wall thickness (Wth) is one of the size parameters that is built in to this part type.

Click the View menu ➤ 3D Views ➤ 3W Isometric. Right-click Modifiers and then click Add Extrusion. You are prompted to select a profile.

Click the outer rectangle. Enter 48 for Distance and check the box next to Flip. Click OK.
An extrusion is created that extends downward 48 inches.

20 Change the name of the new extrusion modifier to Box Outside. Repeat these steps for the inner rectangle using a distance of 44 and a name of Box Inside.
The inner extrusion stops 4 inches shy of the outer extrusion, creating a 4-inch thick floor.

21 Right-click Modifiers and then click Add Boolean Subtract. Click the outer extrusion, then the inner extrusion. Press Enter. Name the new modifier Box.
Right-click Size Parameters and then click Edit Values. Change to the following values:

- SBSL = 84
- SBSW = 48
- SFL = 72
- SFW = 36

Click the Update Model button in the Edit Part Sizes dialog box toolbar, and then click OK. Note the change to the model. The model updates according to the size parameter changes.

Click Save Part Family. Stay in the Part Builder environment for the next exercise.

To continue this tutorial, go to Exercise 4: Finalizing the Part (page 524).

**Exercise 4: Finalizing the Part**

In this exercise, you will add the final model and size parameters that will allow the part geometry to be modified in Civil 3D.
For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder.*

This exercise continues from Exercise 3: Defining the Vault Box Geometry (page 513)

1. Continue from the previous exercise in the Part Builder environment. Click the View menu ➤ 3D Views ➤ SW Isometric. Next you will link the Size Parameters that will be available in Civil 3D with the actual dimensions of the Top Section. This view makes it easier to perform the next few steps.

2. Right-click Size Parameters ➤ Edit Configuration. Click the New button at the top of the Edit Part Sizes dialog box. New Parameter dialog box is displayed.

3. Click Frame Height, and then click OK. The Frame Height (SFH) parameter is added.

4. Scroll to the right until you see the SFH column. Click Constant in the SFH column and change it to List. Click the drop-down arrow button next to Parameter Configuration, and select Values. The values for each parameter are shown.

5. Click the value cell in the SFH column, and then click the Edit. Add the values 8, 12, and 16 to the list and then click OK. Set the value of SFH to 8. This parameter will now be available as three sizes in Civil 3D.

6. Click OK. Click Save Part Family. This updates the Model Parameters to include the Size Parameters.

7. Right-click Size Parameters and then click Edit Values. Set the following values:
   - SBSL: 120
   - SBSW: 60
   - SFL: 108
   - SFW: 48
   - SBSH: 48

   Click the Update Model button in the Edit Part Sizes dialog box toolbar. Click OK. This updates the model parameter values to match the size parameters.
8 Right-click Model Parameters and then click Edit. Set the value of LenB1 to SFH. Click Close. LenB1 is the dimension that represents the depth of the outer frame extrusion.

9 Expand Modifiers. Right-click Box and turn off the visibility. Turn on the visibility of Box Outside and Box Inside. This displays the appropriate modifiers for dimensioning.

10 Right-click Model Dimensions and then click Add Distance. Click the outer box extrusion in the drawing, then click a location for the dimension.
Dimension LenB3 is created.

11 Repeat this step for the inner box extrusion.
Dimension Len B4 is created.

12  Right-click Model Parameters, click Edit, and set the equation for LenB3 to LenB4 + Fth (floor thickness). While the Model Parameters dialog box is displayed, set the value for Fth to 4. Len B3 is the length of the Box Outer extrusion which is set to the Box Inner extrusion length plus the thickness of the floor.
13 Equate dimension LenB4 to SRS-SFH (rim to sump height - frame height). Change the value of SRS to 48.

14 Equate SBSH to LenB1+LenB3 Click Close. SBSH is the Structure Height parameter.

NOTE This parameter will be visible in Civil 3D, but will not be able to be edited by the user. It is important that this parameter does not evaluate to zero. If it does, the part will not display in Civil 3D.

15 Make the following changes to Size Parameters.

- **Fth**
  - Change to List
  - Set List to 4,8,12
  - Set the value to 4

- **Wth**
  - Change to List
  - Set list to 4,8,12
  - Set the value to 4

- **Add SIL (Inner Structure Length)**
  - Change to List
  - Set List to 12 inch increments from 48 to 120
  - Set value to 120

- **Add SIW (Inner Structure Width)**
  - Change to List
  - Set List to 12 inch increments from 36 to 60
  - Set value to 60

- **SRS**
  - Change to Range
  - Set Minimum Value to 36
  - Set Maximum Value to 120
Set Default Value to 72

Fth = Floor thickness and Wth = Wall thickness. These parameters will be available in three sizes, and will be editable structure properties in Civil 3D.

SIL=Inner Structure Length and SIW=Inner Structure Width. These parameters will be available in a number of sizes at 12-inch increments. These are the key structure properties that control the length and width of the part in Civil 3D.

RS=Rim to Sump height. This is a key structure property that will allow the depth of the structure to be controlled in Civil 3D.

Click Save Part Family when you are finished so that the part is saved, and the Model Parameters are updated to include the new Size Parameters.

16 Right-click Size Parameters and then click Edit Values. Change the following:
■ SBSL=120
■ SBSW=60
■ SFL=108
■ SFW=48

Click the Update Model button in the Edit Part Sizes dialog box toolbar, and then click OK.

17 Right-click Model Parameters and then click Edit. Make the following changes in the Equation column for each of the following. Make the changes in the order shown.
■ LenA1: SIL + (2*Wth) - LenA1 is the model dimension for the outer length of the box. It has been set to the Inside Structure Length (SIL) plus the thickness of each wall (2 x Wth).
■ LenA2: SIW + (2*Wth) - LenA2 is the model dimension for the outer width of the box. It has been set to the Inside Structure Width (SIW) plus the thickness of each wall (2 x Wth).
■ SBSL: LenA1 - SBSL and SBSW are important structure properties that have been set to the actual model dimensions.
■ SBSW: LenA2
■ SVPC: SFH + 6 - The vertical pipe clearance (SVPC) has been set to the frame height (SFH) plus six inches.
18 Expand Work Planes ➤ Rim ➤ Geometry. Right-click Fixed Center ➤ Visible. The rim center point is displayed in the drawing.

19 Expand Autolayout Data. Right-click Layout Data and then click Set Placement Point. Use the NODE object snap to select the Fixed Center point. The placement point is much like an insertion point for an AutoCAD block.

20 Expand Modifiers. Turn on the visibility of Frame and Box. Turn off all other modifiers.

21 Click Generate Bitmap.

22 Click SW Isometric View. Click OK. A bitmap image has been generated for the part catalog.
Click Save Part Family. Exit the Part Builder Environment.

To continue this tutorial, go to Exercise 5: Using the New Part (page 532).

**Exercise 5: Using the New Part**

In this exercise, you will insert the new vault part into a Civil 3D pipe network, and investigate how it behaves as a Civil 3D pipe network structure.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Part Builder*.

This exercise continues from Exercise 4: Finalizing the Part (page 524).

1. Make sure that you have closed the Part Builder environment from the previous exercise.

2. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open the drawing Part Builder-3a.dwg. This drawing contains a simple sanitary sewer pipe network.

3. In the Toolspace Settings tab, expand Pipe Networks ➤ Parts Lists, and then right-click Sanitary Sewer and then click Edit.

4. Click the Structures tab. Right-click Sanitary Sewer and then click Add Part Family.
5 Check the box next to Vault 5106-LA with Top 5106-TL3-332. Click OK. The part family is added to the parts list.

6 Right-click Vault 5106-LA with Top 5106-TL3-332, and then click Add Part Size. Note the new part size that has been included.

7 Click OK to add a single part size with the default values. Expand Vault 5106-LA with Top 5106-TL3-332. Note the new part size that has been included.

8 Click OK. Click the sanitary sewer manhole in any of the drawing views. Right-click and then click Swap Part.

9 Expand Vault 5106-LA with Top 5106-TL3-332, and select the part beneath it. The part now is displayed as the vault in 3D view, but still is displayed as a manhole in plan view.
10 Click the structure in any of the views. Right-click and then click Structure Properties.

11 Click the Information tab. Click the black triangle next to the edit button, and select Create New.

12 Click the Information tab. Enter Model for Name.

13 Click the Profile tab. Click Display as solid.

14 Click the Display tab. Set the visibility for Model 3D Solid to On.

15 Click OK twice. Note the change to the appearance of the structure in plan view. The vault structure now is displayed with its actual dimensions.

16 Click the vault structure. Right-click and select Structure Properties. Click the Part Properties tab.

17 Change the following:
   - Frame Length = 108
Frame Width = 48
Inner Structure Length = 120
Inner Structure Width = 60

18 Click OK. Note the change to the structure in the drawing. The structure has been updated with the new dimension properties.

19 Save and close the drawing.
These tutorials will get you started creating and editing labels, label styles, and tables.

In AutoCAD Civil 3D 2009, you can annotate objects that exist in externally referenced drawings. This keeps annotations separate from the design data. This greatly reduces the file size of the annotation drawing, and allows greater flexibility in managing design data.

Object labels in AutoCAD Civil 3D include types that are placed automatically and others that you can place manually at points of interest. Sometimes, automatic labels overlap other objects and must be moved. Also, you may want to make some of them look different from others.

Most objects in AutoCAD Civil 3D have two types of labels. The first type is automatically created when the object is created, as defined by the object properties. The second type is a range of object labels that are manually applied as needed. For both types of labels, you can edit the label style and make changes to all labels that use that style. You can also modify individual labels by moving them manually in the drawing. When labels are moved, they assume their dragged state, which can use a different display format. Some labels can be converted to small tags that occupy less space in the drawing, and then the data for each tagged object can be displayed in a table.

Labels are distinct objects that are independent of the parent object that they annotate. Labels are dynamically linked to their parent object and automatically update when the parent object changes. However, labels reside on a separate layer and are not selected when you select the parent object.

**NOTE** Point, parcel area, corridor, and surface watershed labels are not object type labels. They are sub-entities of a parent object and their properties are managed in the Label Properties dialog box.

You can move most labels by simply selecting and dragging them. When you move a label, a line and a direction arrow is automatically created, which points back to the precise point annotated by the label. Also, you can flip labels along a linear object, such as a parcel segment, to the other side of the line.
The easiest way to change the format of a label is by changing its style. If a suitable style is not available, you can copy an existing style that is similar to what you want, make the required changes, and save it as a new style. You can also change the attributes of the existing style. This action requires some forethought, because your changes affect all objects in the drawing that use the style.

Label visibility can be controlled in several ways. First, label visibility is dependent on the parent object. When the layer of the parent object is either turned off or frozen, its labels are also turned off or frozen. The label style can also control its visibility. The visibility of the individual label components, or the entire label object, can be turned on or off in the style. An individual label can also be selected and turned on or off using the Properties palette.

For more information, see the AutoCAD Civil 3D Help topic Understanding Labels in AutoCAD Civil 3D.

**Tutorial: Preparing to Annotate a Drawing**

This tutorial demonstrates how to perform some optional tasks that can make annotating your drawing easier.

First, you will create external references (Xrefs) to drawings that contain the objects that you will annotate in later Labels and Tables tutorials. Second, you will learn how to use the AutoCAD Civil 3D Annotation and Drafting workspace to make it easy to locate all of the annotation commands. In the remaining Labels and Tables tutorial exercises, you will use the standard Civil 3D Complete workspace to annotate the externally referenced objects.

For more information, see the AutoCAD Civil 3D Help topic Civil 3D Workspaces and the AutoCAD Help topic Attach Drawing References (Xrefs).

**Exercise 1: Attaching Drawings as Xrefs for Annotation**

In this exercise, you will attach several drawings to one drawing. By attaching drawings, you can annotate multiple large objects in a single compact drawing.

Detailed labeling is usually one of the last steps in the design process. In AutoCAD Civil 3D 2009, you do not have to annotate objects in the drawings in which they reside. You can create a single drawing with external references (Xrefs) to the object drawings. This process enables you to keep your
annotation drawing size to a minimum, while maintaining the benefit of dynamic label updates.

For more information, see the AutoCAD Help topic Attach Drawing References (Xrefs).

To attach drawings as Xrefs for annotation

1 Using Windows Explorer, navigate to the tutorial drawings folder (page 615). Select all of the drawings that have names beginning with Labels-. Click Edit menu ➤ Copy.

2 Navigate to the My Civil 3D Tutorial Data folder (page 615). Click Edit menu ➤ Paste.
   In a later exercise, you will modify some of the externally referenced drawings. To make the modifications, the drawings must be in a location to which you have write access.

3 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the My Civil 3D Tutorial Data folder (page 615). Open the drawing Labels-1a.dwg.

4 In Toolspace, on the Prospector tab, expand the Labels-1a drawing.
   Although a surface with an outside boundary is displayed in the drawing window, notice that the Surfaces collection is empty. The Surfaces collection is empty because the composite surface is an external reference, or Xref. The surface data, which is quite large, exists in a separate drawing.

   **TIP** In large projects that have multiple surfaces, each surface object should reside in its own drawing. For example, the existing ground surface should exist in one drawing, with other drawings containing data references to it. For example, the proposed ground surface should exist in its own drawing, with a data reference to the existing ground surface.

5 On the command line, enter XREF.
   In the External References dialog box, notice the difference in size between the current drawing (Labels-1a) and the externally referenced drawing that contains the surface (Labels-Surface). While the surface object appears in the current drawing, the size of the current drawing is a fraction of the surface drawing. Using Xrefs, you can use data from another drawing without actually inserting the data.
6 In the External References palette, click the arrow next to Attach DWG.

**NOTE** Notice that you can also attach a drawing from Vault.

7 In the Select Reference File dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615). Select the drawings Labels_Alignments.dwg and Labels_Parcels.dwg. Click Open.

8 In the External Reference dialog box, make sure that the following settings are selected:

- **Reference Type:** Attachment
  - This setting specifies that the Xrefs remain with the current host drawing (Labels-1a.dwg) if the current drawing is attached as an Xref to another drawing. If Overlay is selected, Xrefs that exist in the drawing are ignored if the drawing is attached to another drawing as an Xref.

- **Path Type:** Relative Path
  - This setting specifies that if you move the current and referenced drawings to another location, the references are less likely to be lost.

**TIP** Before creating an Xref, make sure that the referenced drawings are saved in the same directory as the current drawing.

**IMPORTANT** Attached Xrefs must have the following settings. If the insertion point, scale, or rotation is different from the current drawing, the AutoCAD Civil 3D labels will not work.

- **Insertion Point:** Specify On-Screen: Cleared
- **Scale:** Specify On-Screen: Cleared
- **Scale:** Uniform Scale: Selected
- **Rotation:** Specify On-Screen: Cleared

9 Click OK.

The alignments and parcels appear in the drawing window, and the drawings in which they reside are listed in the External References palette. Close the External References palette.
Exercise 2: Exploring the Annotation and Drafting Workspace

In this exercise, you will switch to the annotation and drafting workspace, which presents you with an environment that is dedicated to the annotation of drawing objects.

An Annotation menu is included in the Annotation And Drafting workspace. The Annotation menu groups label and table commands from other feature menus on one menu for convenience.

For more information, see the AutoCAD Civil 3D Help topic Civil 3D Workspaces.
This exercise continues from Exercise 1: Attaching Drawings as Xrefs for Annotation (page 538).

To use the Annotation And Drafting workspace

**NOTE** This exercise uses *Labels-1a.dwg* with the modifications you made in the previous exercise.

1. On the status bar at the bottom of the application window, click Workspace Switching. Click Annotation And Drafting.

   This workspace hides the commands for features that are not related to annotation. You can still access other commands not shown on the menus by entering their command names on the command line.

2. Click Annotation menu.

   Notice that the menu consists of label and table commands for the AutoCAD Civil 3D features. You can access the label or table commands for each feature directly from this menu.

3. Click Add Labels.

   In the Add Labels dialog box, you can select the feature, label type, and label style. This dialog box enables you to easily switch these settings as needed while annotating your drawing. You will use this dialog box throughout the labels tutorials.

   Now that you are familiar with the Annotation And Drafting workspace, switch back to the Civil 3D Complete workspace for the remainder of the tutorials.

4. In the Add Labels dialog box, click Close.

5. On the status bar at the bottom of the application window, click Workspace Switching. Click Civil 3D Complete.

To continue to the next tutorial, go to Tutorial: Adding and Editing Labels (page 542).

**Tutorial: Adding and Editing Labels**

This tutorial demonstrates how to add labels to AutoCAD Civil 3D objects, and then edit the labels to suit your requirements.
Labels are defined by the following properties. You will learn how to work with many of these properties in later tutorial exercises.

- **Location.** Label location in a drawing depends on the object using the label. For example, a parcel area label is usually placed at the center of the parcel, and surface contour labels are usually placed on the contour line.

- **Appearance and Visibility.** Whether a label is visible, and how it appears in a drawing, can be specified in the label style or by managing the AutoCAD properties. You can define different display settings, such as color, linewidth, and linetype, for each label component.

- **Mode.** Many label styles have two modes: label and tag. Tags identify labeled objects within a table.

- **Behavior.** Labels behave according to their association with objects. For example, if you move an object in a drawing, the label moves with it. Also, behavior can also determine how a label is positioned or oriented in a drawing.

- **Anchor.** A label is placed in relation to an object or another label style component.

- **Plan-Readable Text.** Labels can be placed at any angle, but you can select a plan-readability setting to maintain upright legibility.

For more information, see the AutoCAD Civil 3D Help topic *Inserting and Managing Labels in Drawings*.

### Exercise 1: Adding Labels in Groups

In this exercise, you will use label sets to apply several types of labels to an alignment.

You can automatically add labels as you create objects, such as points, alignments, or parcels. Labeling an object automatically is an efficient way to annotate common elements, such as alignment stations or parcel areas, as they are created.

In this exercise, you will specify a label set to apply as you create an alignment from a polyline. Both the newly created alignment and its labels will reside in the current drawing. Next, you will learn how to modify the properties of the label set after the alignment has been created. Finally, you will learn how...
to apply a label set to an alignment that exists in an externally referenced drawing.

For more information, see the AutoCAD Civil 3D Help topic *Adding Labels to Drawings*.

**To create a label set for a new alignment**

**NOTE** This exercise uses *Labels-1a.dwg* with the modifications you made in the previous exercise, or you can open *Labels-2a.dwg* from the tutorial drawings folder (page 615).

1. Click Alignments menu ➤ Create Alignment From Polyline. On the command line, enter X to select the Xref option.

2. Click the blue polyline on the west side of the site.

Polyline in the externally referenced drawing
3 In the Create Alignment - From Polyline dialog box, for Name, enter West Street. For Alignment Style, ensure that Proposed is selected. Examine the contents of the Alignment Label Set list.

When you create an object, its Create dialog box typically has style selector lists for both the object and the labels. The style selector lists identify the object styles and label styles that are available in the current drawing for that object type. When you create an alignment, profile, or section, you select a label set, which applies a preset style to each of the various labels types that are in the set. You will examine an example of a label set in the following steps. Notice that there is a _No Labels selection. This selection is an empty label set that does not display any labels along the alignment.

**TIP** If you do not want to annotate objects that do not use label sets, you can create a label style that has the visibility of all of its components turned off.

4 From the Alignment Label Set list, select Major Minor And Geometry Points. Click the arrow next to . Select Copy Current Selection.

The Alignment Label Set dialog box displays information about how the Major Minor and Geometry Points label set is configured. You will use this label set as a basis to create a new label set.

The Information tab displays the label set name, description, and the date when it was created or modified.

The Labels tab specifies the label types that are defined in the label set, as well as the label styles that are used by each type. In this example, you use the label set to apply label styles to the geometry points and major and minor stations of an alignment.

**NOTE** Label sets for profiles and sections are constructed in the same manner, using a similar dialog box.

5 In the Alignment Label Set dialog box, on the Information tab, for Name, enter Major-Minor Stations And Start-End Points.

6 On the Labels tab, in the Geometry Points row, in the Style column, click .

7 In the Pick Label Style dialog box, select Alignment Start. Click OK.
8 In the Alignment Label Set dialog box, in the Geometry Points row, in the Geometry Points To Label column, click ....

9 In the Geometry Points dialog box, click to clear all check boxes. Select the Alignment Beginning check box. Click OK.
You can use geometry point label types to label a selection of geometry points using a combination of styles that you specify. In Steps 8 and 9, you applied a geometry point label style to the alignment starting station. In the following steps, you will create another instance of the Geometry Points label type that applies a different style to the alignment ending station.

**TIP** To remove a label type from the label set, select the type and click .

10 In the Alignment Label Set dialog box, on the Labels tab, for Type, select Geometry Points. For Geometry Point Label Style, select Alignment End. Click Add.

11 In the Geometry Points dialog box, click to clear all check boxes. Select the Alignment End check box. Click OK.

12 In the Alignment Label Set dialog box, click OK.

13 In the Create Alignment - From Polyline dialog box, under Conversion Options, clear the Add Curves Between Tangents check box. Click OK.

14 Zoom in to the area surrounding the new alignment and examine the labels that were automatically placed along the alignment.

**NOTE** If the EP: 0+243.63 label is adjacent to the intersecting alignment, click Alignments menu ➤ Reverse Alignment Direction. Click the alignment. Click OK to acknowledge the warning about alignment properties that are affected by the command.

When the alignment is created, it is green. The green color is controlled by the alignment style that you specified in Step 3. Notice that the new red labels are a brighter than the labels that were brought in with the externally referenced objects. The color tones are different so that you can easily identify where the labels reside: bright labels are in the current drawing, and light labels are in the externally referenced drawings.
To modify the label set of an existing alignment

**NOTE** Changes that you make to the alignment label set after the alignment has been created will not be applied to the original label set. To edit the original label set, in Toolspace, on the Settings tab, expand Alignment ➤ Label Styles ➤ Label Sets. Right-click the appropriate label set. Click Edit.

1. In the drawing window, select the West Street alignment. Right-click. Click Edit Alignment Labels.

2. In the Alignment Labels dialog box, for Type, select Geometry Points. For Geometry Points Label Style, select Perpendicular With Tick And Line. Click Add.
3  In the Geometry Points dialog box, click \( \square \) to clear all check boxes. Select the following check boxes:
- Tangent-Tangent Intersect
- Tangent-Curve Intersect
- Curve-Tangent Intersect

4  Click OK to close the Geometry Points and Alignment Label Set dialog boxes.

5  Press Esc to deselect the alignment.

Alignment with modified label set

**NOTE** In the previous image, the EP: 0+243.63 and PC: 0+158.39 labels are shown on opposite sides of the alignment for clarity. You will learn to flip labels to the opposite side of an alignment in a later exercise.
To add labels to an alignment in a referenced drawing

1. Click Alignments menu ➤ Add Alignment Labels ➤ Add/Edit Station Labels. Click the Main Street alignment, which is the long alignment in the middle of the site.

   Because this alignment exists in an externally referenced drawing, the table in the Alignment Labels dialog box is empty. Only labels that are created in the current drawing can be modified in the current drawing. Labels that were created in an externally referenced drawing must be modified in the source drawing.

2. In the Alignment Labels dialog box, for Type, select Geometry Points. For Geometry Point Label Style, select Perpendicular With Tick And Line. Click Add.

   NOTE The Import Label Set button applies a label set that exists in the current drawing.

3. In the Geometry Points dialog box, click OK.

4. In the Alignment Labels dialog box, for Type, select Design Speeds. For Design Speed Label Style, select Station Over Speed. Click Add. Click OK.

   On the Main Street alignment, labels are displayed at each station at which a new design speed is applied, and at each geometry point. These label objects reside in the current drawing and annotate the alignment in the externally referenced drawing.
To continue this tutorial, go to Exercise 2: Manually Labeling an Object (page 550).

**Exercise 2: Manually Labeling an Object**

In this exercise, you will add labels to specific areas on an alignment after it has been created and automatically labeled.

You can manually add labels to most objects, using the Add Labels dialog box. If you are not working in the Annotation And Drafting workspace, you can access the Add Labels dialog box by clicking the <Feature> menu ➤ Add <Feature> Labels ➤ Add <Feature> Labels. For information about the Annotation And Drafting workspace, see the Exploring the Annotation and Drafting Workspace exercise (page 541).

For more information, see the AutoCAD Civil 3D Help topic *Adding Labels to Drawings*. 
This exercise continues from Exercise 1: Adding Labels in Groups (page 543).

To manually label an object

**NOTE** This exercise uses *Labels-2a.dwg* with the modifications you made in the previous exercise.

1. Click Alignments menu ➤ Add Alignment Labels ➤ Add Alignment Labels.

2. In the Add Labels dialog box, select the following options:
   - Feature: Alignment
   - Label Type: Multiple Segment

3. In the three label style fields, accept the default styles.
   You can choose specific styles for each of the Line, Curve, and Spiral label styles. This alignment does not contain any spirals, so the Spiral Label Style setting is ignored.

4. Click Add.

5. On the left-hand side of the site, click the West Street alignment, which you created in Exercise 1: Adding Labels in Groups (page 543).
   The Multiple Segment label command places a label at the middle of each line and curve. This method can be convenient, but sometimes a few of the labels overlap other features of the drawing. In Exercise 3: Selecting and Moving Labels (page 553), you will move some of these labels.

6. In the Add Labels dialog box, select the following options:
   - Feature: Alignment
   - Label Type: Single Segment
   - Line Label Style: Line Label Style ➤ Alignment Name

   **NOTE** Notice that you can use either a General Line Label Style or Alignment Line Label Style. General Line and Curve label styles can be applied to lines and curves that are part of an Alignment or Parcel object.

7. Click Add.
   You are now ready to choose a specific location for a label on the alignment. Unlike multiple segment labels, single segment labels are placed exactly where you click.
8 On the West Street alignment, click near station 0+120 to place a line segment label. Be sure to click the line segment, and not the station label. Because you clicked a line segment, the label style specified in the Line Label Style list in the Add Labels dialog box was used. If you had clicked a curve, the label style specified in the Curve Label Style list would have been used.

9 On the Main Street alignment, which is the long alignment in the middle of the site, click a location between stations 0+140 and 0+160.

10 On the East Street alignment, which is the alignment with the cul-de-sac on the right-hand side of the site, click a location between stations 0+200 and 0+220.

11 In the Add Labels dialog box, in the Line Label Style list, select Line Label Style ➤ Bearing Over Distance. Click Add.

12 On the Main Street alignment, click a location between stations 0+100 and 0+120. A new label displaying bearing and distance information is created.

13 In the Add Labels dialog box, in the Feature list, select Parcel. This selection changes the label type and style selections that are available. The Add Labels dialog box works in the same manner for all of the feature types shown in the Feature list. When you annotate objects in AutoCAD Civil 3D, you can switch the type of object you are labeling, as well as the label type and style of the various elements, as needed. Pay attention to the command line as you annotate objects. Some label types, such as span, slope, grade, and depth, annotate a range of data between two points. For example, if you want to label a grade or depth between two points, you must specify those points in the drawing.

14 In the Add Labels dialog box, click Close.
To continue this tutorial, go to Exercise 3: Selecting and Moving Labels (page 553).

**Exercise 3: Selecting and Moving Labels**

In this exercise, you will select labels and change their location in the drawing.

Your drawing currently contains many labels, some of which overlap one another. You will move them in the following steps.

Some label types, such as alignment station and geometry point labels, are part of a label type group that shares properties. When you click one label in the group, the entire group is selected. Properties for the group are controlled using the AutoCAD Properties palette, which is available when you select the group, right-click, and click Label Properties. You can select the group and then change the properties of all labels in the group simultaneously.
Alternatively, you can use Ctrl+click to select and change label properties individually.

Other label types, such as segment labels, are not part of a group. Each of these labels is treated as an individual object.

Labels are distinct objects that are independent of the parent object that they annotate. Labels are dynamically linked to their parent object and automatically update when the parent object changes. However, labels reside on a separate layer and are not selected when you select the parent object.

If a label resides in an externally referenced drawing, the label cannot be edited in the current drawing.

**NOTE** Point, parcel area, corridor, and surface watershed labels are not object type labels. They are sub-entities of a parent object and their properties are managed in the Label Properties dialog box.

For more information, see the AutoCAD Civil 3D Help topic *Moving Labels in a Drawing*.

This exercise continues from Exercise 2: Manually Labeling an Object (page 550).

**To select and move labels in a drawing**

**NOTE** This exercise uses *Labels-2a.dwg* with the modifications you made in the previous exercise, or you can open *Labels-2b.dwg* from the tutorial drawings folder (page 615).

1. Make sure that you are zoomed in to the area around the West Street label on the alignment on the left-hand side of the site.

2. Select the alignment.

   Notice that the alignment is highlighted, and grips appear along the alignment. The alignment labels, however, are not highlighted.

   In previous versions of AutoCAD Civil 3D, labels were sub-entities of their parent object. Now, most AutoCAD Civil 3D labels are independent objects that reside on their own layer. Although they are independent objects, labels are dynamically linked to their parent object and automatically update to reflect changes in the parent object.

3. Press Esc to deselect the alignment.

4. On the road alignment, click one of the station labels.
Notice that all other station labels along the alignment are now highlighted.

5 Press Esc to deselect the station labels.

6 Click one of the curve labels.
   Notice that while that curve label is selected, the other curve labels are not.
   
   There are two distinct label object types:
   
   ■ *Label type groups*—When you select a label that is part of a label type group, such as an alignment station label, the entire group is selected. If you select a label type group and use the right-click menu to update the label properties, the properties of every label in the group update. To select a single label within a label type group, use Ctrl+click.

   ■ *Single label objects*—When you select a single label object, such as an alignment curve label, only that label object is selected. You can change the properties, including the label style, of single label objects without affecting the other labels of the parent object.

7 Press Esc to deselect the curve label.

8 Click the label showing bearing over distance near station 0+100. Grips appear on the label.

9 Click the label location grip. The grip turns red. Drag the label down and to the left to move it to a clear location. Click to place the label. Press Esc to deselect the label.
Label dragged with the label location grip

A leader line is created from the label to the alignment.

10 Click the West Street label. Grips appear on the label.

11 Click the label anchor grip. The grip turns red. Drag the label to the right. Click near station 0+100 to place the label closer to the center of the line segment. Press Esc to deselect the label.

Label moved with label anchor grip

12 Pan and zoom to the cul-de-sac of the West Street alignment.

13 Use the grips to drag each curve label away from the alignment.
14 Click the EP: 0+243.63 label. A grip appears on the label.

15 Click the grip. The grip turns red. Drag the label up and to the right to move it to a clear location.

A leader line is created from the label to the alignment.

Notice that the label displays without a border. The border is hidden because the dragged state of the label style specified a different format for when the label is dragged to a new location. You will learn about label style settings in the Working with Label Styles tutorials (page 574).

NOTE You can reset a selected label by clicking the circle grip.

16 Press Esc to deselect the EP: 0+243.63 label.

17 Ctrl+click station label 0+000. Press Delete.
18 Repeat these operations, moving and dragging labels to other locations where required. If you want to undo any flipping or dragging operations, select the labels in question. Right-click and click Reset Label.

Alignment with labels moved to improve readability

19 Click one of the station labels on the Main Street alignment.
Notice that both the Main Street and East Street alignments and their station labels are selected. The labels were selected because the labels were created in the externally referenced drawing in which the alignments reside. When an object has been created through an Xref, you can edit its labels only in the source drawing.

20 Press Esc to deselect the Xref.

To continue this tutorial, go to Exercise 4: Working with Label Properties (page 559).
Exercise 4: Working with Label Properties

In this exercise, you will use standard AutoCAD tools to control properties for both individual labels and group labels.

You can change the properties of:

■ an individual label object
■ a label object group
■ an individual label object

In this exercise, you will change all of these properties.

For more information, see the AutoCAD Civil 3D Help topic Modifying Labels in a Drawing.

This exercise continues from Exercise 3: Selecting and Moving Labels (page 553).

To change label properties

NOTE This exercise uses Labels-2b.dwg with the modifications you made in the previous exercise.

1 On the command line, enter LIST.

2 On the West Street alignment, click a station label and a bearing over distance label. Press Enter.
   The AutoCAD Text Window appears, displaying the object type, label type, and layer of the selected label objects.
   For example, in AECC_ALIGNMENT_STATION_LABEL_GROUP
   ■ ALIGNMENT is the object type
   ■ STATION_LABEL indicates that it is a station label object
   ■ GROUP indicates that the label object is part of a label group
   AECC_ALIGNMENT_TANGENT_LABEL is not followed by GROUP because it is an individual object label.

3 Close the AutoCAD Text Window.

4 Next, you will change the label style of an individual label object.
   Click the curve label near station 0+040. Right-click. Click Properties.
5 In the Properties palette, under Civil 3D, change the Curve Label Style to Curve Label Style ➤ Design Data.

6 Press Esc to deselect the label.

7 Next, you will change the label style of all label objects that are part of a label group. In this case, you will change the style of the Major Station label group.

   Click station label 0+040.

   All station labels are highlighted, indicating that they are part of a label group.

8 Right-click. Click Properties.

   **NOTE** Selecting Edit Alignment Labels from the shortcut menu opens the Alignment Labels dialog box, where you can change the alignment label set.

9 In the Properties palette, in the Civil 3D section, under Labeling, change the Major Station Label Style to Perpendicular With Tick.

10 Finally, you will move one label in the geometry points group to the opposite side of the alignment. The other geometry point labels will remain on their current side of the alignment.

   Ctrl+click geometry point label PC: 0+018.54.

11 In the Properties palette, examine the properties that are available. Under General, change the Flipped property to True. Close the Properties palette.

12 Press Esc to deselect the labels.
Alignment labels with modified properties

To continue to the next tutorial, go to Changing the Content of a Label (page 561).

**Tutorial: Changing the Content of a Label**

This tutorial demonstrates how to change label text content for an individual label and for a group of labels.

You will change the content of geometry point labels, which are part of a group of labels. You will override the text content of an individual label in a geometry point group. Then, you will change the geometry point abbreviation in the drawing settings, which will change the text content of all geometry point labels in the drawing.
Exercise 1: Overriding Label Text

In this exercise, you will override the text in a single label. Label text overrides are useful for adding text to an individual label to mark a point of interest without modifying all labels that share a style.

For more information, see the AutoCAD Civil 3D Help topic Overriding Label Text.

To override the text of a label

NOTE This exercise uses Labels-2b.dwg with the modifications you made in the previous exercise, or you can open Labels-3a.dwg from the tutorial drawings folder (page 615).

1. Zoom and pan to the area between stations 0+000 and 0+100 of the Main Street alignment.

2. Ctrl+click the geometry point label PC: 0+035.99. Right-click. Click Edit Label Text.

   NOTE Using Ctrl+click selects only one label in a group. For this exercise, you will override the text of only the PC: 0+035.99 label, and not the other geometry point labels.

3. In the Text Component Editor - Label Text dialog box, place your cursor at the end of the equation in the preview pane. Press Enter.

4. Enter N: in the preview pane.

5. In the Properties list, select Northing. Click to move the Northing formula, then place your cursor at the end of the equation and press Enter.

6. Enter E: in the preview pane.

7. In the Properties list, select Easting. Click to move the Easting formula.

   The formula in the preview pane should look like this:
Click OK.

Notice that the label updates to show the Northing and Easting values at the point of curvature. The other labels at the points of curvature and tangency have maintained their original style settings. To apply this change to the entire group of geometry point labels, you would modify the style that is used by the entire group.

Geometry point label PC: 0+035.99 with overridden text

To return the label to its original style settings, Ctrl+click the label.

Right-click. Click Clear Label Text Override.

To continue this tutorial, go to Exercise 2: Changing Label Content in the Drawing Settings (page 564).
Exercise 2: Changing Label Content in the Drawing Settings

In this exercise, you will change the default abbreviations that appear in geometry point labels.

For more information, see the AutoCAD Civil 3D Help topic Understanding Civil 3D Settings.

This exercise continues from Exercise 1: Overriding Label Text (page 562).

To change label content in the drawing settings

NOTE This exercise uses *Labels-3a.dwg* with the modifications you made in the previous exercise.

1. Zoom and pan to the area between stations 0+000 and 0+080 of the West Street alignment.

2. In Toolspace, on the Settings tab, right-click the drawing name. Click Edit Drawing Settings.

3. In the Drawing Settings dialog box, click the Abbreviations tab.

NOTE In the Drawing Settings dialog box, you can use the Object Layers tab to change the default layer on which AutoCAD Civil 3D objects and their labels are created.

The Alignment Geometry Point Text category lists the abbreviations currently in use for each type of geometry point.

4. In the Value column, change the geometry point abbreviation value to the following:
   - Alignment End: End
   - Tangent-Curve Intersect: Tan-Cur
   - Curve-Tangent Intersect: Cur-Tan

5. Click OK.

The geometry point labels update to reflect the change in the drawing settings.
NOTE If the abbreviations in the geometry point labels have not updated to reflect the changes you made, enter REGEN on the command line.

Geometry point labels with abbreviations modified in drawing settings

6 Close the drawing.

To continue to the next tutorial, go to Working with Tables and Tags (page 565).

**Tutorial: Working with Tables and Tags**

This tutorial demonstrates how to place object data into tables.

Each row in a table contains information about a single object component, such as a line or a curve. You can create tables for point, parcel, alignment, surface, pipe, and structure objects. However, only alignment and parcel tables can be created through Xref.

Some object label styles have two modes: label and tag. *Label* mode is the default label appearance when you annotate an object. *Tag* mode replaces the detailed label information with a short alphanumeric code so you can move
the information into a table. Labels switch to tag mode automatically when a table is inserted into the drawing, using the style-based selection method.

The label styles for the following objects support tag mode:

- general lines and curves
- alignment lines, curves, and spirals
- parcel area, lines, and curves

For more information, see the AutoCAD Civil 3D Help topics Setting Up Label Styles to be Used as Tags and Understanding Tables.

**Exercise 1: Creating a Parcel Area Table**

In this exercise, you will create a table to display information about parcel objects.

You use a similar workflow to create tables for most AutoCAD Civil 3D objects. In this exercise, you will learn about the table tools in AutoCAD Civil 3D, and the dynamic nature of externally referenced drawings. You will add a parcel area table to an externally referenced drawing, and then examine the results in the host drawing.

To create a table for an object, the object must be labeled. Most tables require that you specify the table data by selecting a label style. In this exercise, you will select parcel area labels to create a parcel area table. However, the parcels and area labels exist in an externally referenced drawing. Parcel area tables cannot be created through xref, so you cannot create the table in the current drawing.

For more information, see the AutoCAD Civil 3D Help topic Adding Tables to a Drawing.

**To create a parcel area table**

**NOTE** Before you begin this exercise, you must have the provided Labels-drawings saved in the My Civil 3D Tutorial Data folder (page 615). See the Attaching Drawings as Xrefs for Annotation exercise (page 538) for more information.

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the My Civil 3D Tutorial Data folder (page 615). Open the drawing Labels-4a.dwg.
In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the My Civil 3D Tutorial Data folder (page 615). Open the drawing Labels-Parcels.dwg.

In Labels-Parcels.dwg, zoom in so that you can see all of the parcels adjoining East Street, which is the cul-de-sac alignment on the right-hand side of the drawing.

You will apply a simpler area label style to parcels 37 through 41, and then create a table that will display detailed parcel data.

In Toolspace, on the Prospector tab, expand Sites ➤ Site. Click the Parcels collection.

In the item view at the bottom of Toolspace, use Shift+click to select parcels number 37 through 41. Right-click the Area Label Style column heading. Click Edit.

In the Select Label Style dialog box, select Parcel Number. Click OK.

The parcel area label consists of the parcel number only. In the following steps, you will create a table that displays detailed information about each of these parcels.

Click Parcels menu ➤ Add Tables ➤ Add Area.

In the Table Creation dialog box, in the Select By Label Or Style area, in the Parcel Number row, select the Apply check box.

You can select multiple styles from which to create the parcel table. All the parcels that use the selected styles will be shown in the table.

Click OK.

When you move the cursor into the drawing area, the upper left corner of the table is attached to the cursor.

Move the cursor to the right of the parcels and click.

The table is inserted into the drawing.

Click File menu ➤ Save. Close the Labels-Parcels drawing.

In drawing Labels-4a, on the command line, enter XREF.

In the External References palette, right-click Labels-Parcels. Click Reload.

The current drawing is rebuilt using the updated data from the Labels-Parcels drawing. Notice that the parcel area table you created in the externally referenced drawing is shown, and the parcels at the end of the East Street alignment use the Parcel Number area label style.
To continue this tutorial, go to Exercise 2: Converting Labels to Tags (page 568).

**Exercise 2: Converting Labels to Tags**

In this exercise, you will create some parcel segment labels, and then convert the labels to tags and move the data into a table.

In Exercise 1: Creating a Parcel Area Table (page 566), you created a table in the externally referenced Labels-Parcels drawing. In this exercise, you will create parcel segment labels directly in the current drawing. You will then convert the segment labels to tags and create a table to display the detailed label information.

For more information, see the AutoCAD Civil 3D Help topic *Setting Up Label Styles to be Used as Tags*.

This exercise continues from Exercise 1: Creating a Parcel Area Table (page 566).
To convert labels to tags

NOTE This exercise uses *Labels-4a.dwg* with the modifications you made in the previous exercise.

1. Click Parcels menu ➤ Add Parcel Labels ➤ Add Parcel Labels.

2. In the Add Labels dialog box, select the following options:
   - Label Type: Multiple Segment
   - Line Label Style: Parcel Line Label Style ➤ Bearing Over Distance
   - Curve Label Style: Parcel Curve Label Style ➤ Delta Over Length And Radius

3. Click Table Tag Numbering.

4. In the Table Tag Numbering dialog box, examine the settings that are available.
   The settings specify the starting number and increment for line, curve, and spiral tags. Notice that there are separate starting number and increment properties for both Table Tag Creation and Table Tag Renumbering. For this exercise, accept the default value of 1 for all properties. When you convert the labels to table tags, they will all use a starting number and an increment of 1. You will use the Table Tag Renumbering properties later.

5. In the Table Tag Numbering dialog box, click Cancel.

6. In the Add Labels dialog box, click Add.

7. Click the parcel area labels in the following order: 39, 40, 41, 37, 38. Press Enter to accept the default Clockwise label direction.
   As you click, labels are placed on each parcel segment. If you wish, zoom in to inspect the labels before you convert them to tags.
When you finish labeling parcels, right-click to end the command. The Add Labels dialog box remains open, in case you want to label more parcels or other objects. You can close it, as you will not use it again in this exercise.

Click Parcels menu ➤ Add Tables ➤ Add Segments. This option creates a table that shows both the line and curve segments of the labeled parcels.
10 In the Table Creation dialog box, in the Select By Label Or Style area, select the Apply check box for the two label styles you placed on the parcel segments:

- Parcel Curve: Delta Over Length And Radius
- Parcel Line: Bearing Over Distance

11 Click OK.
When you move the cursor into the drawing area, the upper left corner of the table is attached to the cursor.

12 Move the cursor outside the surface extents and click.
The table is inserted into the drawing. Notice that the line and curve labels around the parcels have been converted to tags.

To continue this tutorial, go to Exercise 3: Renumbering Table Tags (page 572).
Exercise 3: Renumbering Table Tags

In this exercise, you will renumber the table tags you created in the previous exercise.

You will renumber the curve table tags around the cul-de-sac on the East Street alignment so that they follow a clockwise pattern. You will use the Table Tag Numbering dialog box that you examined in the previous exercise to specify the starting number and increment with which to renumber the table tags.

For more information, see the AutoCAD Civil 3D Help topic Renumbering Label Tags.

This exercise continues from Exercise 2: Converting Labels to Tags (page 568).

To renumber table tags

NOTE This exercise uses Labels-4a.dwg with the modifications you made in the previous exercise, or you can open Labels-4b.dwg from the tutorial drawings folder (page 615).

1. In Toolspace, on the Settings tab, right-click the drawing name. Click Table Tag Numbering.

2. In the Table Tag Numbering dialog box, notice that the Table Tag Creation Starting Number values are not 1 as they were Exercise 2: Converting Labels to Tags (page 568). The Starting Number values are the next available numerals based on the line, curve, and spiral tags that exist in the drawing and the specified increment value. If you add more table tags in the drawing, these values prevent the duplication of tag numbers.

NOTE The Table Tag Numbering dialog box specifies the tag numbering settings for all objects. The settings that you specify in the following steps will apply to table tags for all objects.

3. Under Table Tag Renumbering, accept the default values.
   For this exercise, you will restart the curve numbering at 1 and use an increment of 1.

4. Click OK.

5. In the drawing window, zoom in to the area around the cul-de-sac at the end of the East Street alignment.
6 Click Parcels menu ➤ Add Tables ➤ Renumber Tags.

7 Click tag C6.
You are notified that tag number 1 already exists. If you press Enter, the next available curve tag will be applied to this tag. For this exercise, a duplicate tag is acceptable, because you will continue the renumbering to resolve duplicates.

8 On the command line, enter C to create a duplicate curve table tag.
The curve table tag now appears as C1.

9 Repeat Steps 7 and 8 on the remaining curve table tags, so that the curve table tags are labeled C1 through C7 clockwise around the cul-de-sac.

10 To end the command, right-click. Click Enter.

11 Pan to the parcel line and curve table you created in Exercise 2: Converting Labels to Tags (page 568).
Notice that the table has automatically updated to reflect the new curve numbering.

Further exploration: Add segment labels to the rest of the parcels along the East Street alignment, and then convert the labels to table tags. Renumber the table tags along the right-of-way so that they follow a clockwise pattern.
To continue to the next tutorial, go to Working with Label Styles (page 574).

**Tutorial: Working with Label Styles**

This tutorial demonstrates how to define the behavior, appearance, and content of labels using label styles.

Like other AutoCAD Civil 3D objects, every label in a drawing has a style associated with it. If you edit a label style, changes are immediately reflected in all labels in the drawing that use that style.

For more information, see the AutoCAD Civil 3D Help topic *Creating and Editing Label Styles*.

**Exercise 1: Creating a Label Style**

In this exercise, you will create a label style.
In most cases, the easiest way to create a style is to find an existing style that is similar to the format that you want, create a copy, and then modify the copy.

In the following steps, you will create a design speed label style. You will learn various ways to create and edit label styles using the AutoCAD Civil 3D Toolspace.

For more information, see the AutoCAD Civil 3D Help topic Creating New Label Styles.

To create a label style

NOTE This exercise uses Labels-4b.dwg with the modifications you made in the previous exercise, or you can open Labels-5a.dwg from the tutorial drawings folder (page 615).

1  Zoom in to station 0+000 of the Main Street alignment. Examine the design speed label. You will use this label style as a basis to create a new label style that will display the design speed without the station label. The design speed labels will be placed at locations where the stations are already labeled.

   NOTE Design speed information, including the station at which the design speed has been applied, is available in the Alignment Properties dialog box on the Design Speeds tab.

2  Select the design speed label. Right-click. Select Edit Alignment Labels.

3  In the Alignment Labels dialog box, in the Design Speeds row, in the Style column, click

   NOTE You use the Alignment Labels dialog box to create and edit label sets or to import an existing label set.

4  In the Pick Label Style dialog box, click the arrow next to Create New.
NOTE The Create Copy selection uses the format of the current style as a basis for the new style. You will learn about the Create Child Of Current Selection option in Exercise 2: Using a Child Label Style (page 578).

5 In the Label Style Composer dialog box, on the Information tab, enter the following data:
- Name: Design Speeds - Inline
- Description: Small design speed label perpendicular to the alignment

6 Click the General tab.
On the General tab, you can specify the settings for the overall label style, including the visibility, layer, and plan readability. For this exercise, accept the default settings on this tab. You can turn on or off the visibility of the individual label components on either the Summary or Layout tab.

7 Click the Layout tab.
On the Layout tab, you specify the content of the label style. A label can be made up of one or more components, each of which can have separate properties.

8 Examine the contents of the Component Name list.
Each component is shown in the Preview pane on the right side of the dialog box. You can use the buttons to the right of the Component Name list to create, copy, or delete label style components. These components were copied when you created the style from the existing Station Over Speed style.

9 In the Component Name list, select Station. In the General collection, change the Visibility to False.
Notice that your change is shown immediately in the Preview pane. This pane is useful when you are designing a label style. If you do not like what you see in the preview, you can change it before saving the style.

NOTE To delete the Station component, select it from the Component Name list, and then click .
In the Component Name list, select Design Speed. Set the label properties to the following values:

General
- Anchor Component: Line
- Anchor Point: End

Text
- Attachment: Bottom Right
- X Offset: 0.0 mm
- Y Offset: 1.0 mm

In the Text collection, for the Contents property, click the Value column. Click .

You can use the Text Component Editor dialog box to define the content and format of a label style text component. The Properties list displays the available properties that can be displayed in a label component. When you select a component from the list, the applicable values are displayed in the table below.

In the Text Component Editor dialog box, in the preview pane, select the DESIGN text. Press Delete.

Click the <[Design Speed(P3|RN|Sn|OF|AP)]> property block.
After you have selected the property block in the Preview pane, you can modify the specific values that will be applied to the property.

In the Properties list, select Design Speed. Change the Precision value to 0.1. Click to apply the new Precision value to the block in the Preview pane.
Notice that in the block of code, P0 has changed to P1.

In the Preview pane, select the SPEED text.

Click the Format tab.
You can change the style, justification, font, and color of each text component.

With the text in the Preview pane selected, Change the Font to Times New Roman. Click OK.
In the Label Style Composer, notice that the SPEED font is different from the design speed value. The design speed value font did not change because it was not selected when you changed the font.

Click OK to close the Label Style Composer, Pick Label Style, and Alignment Labels dialog boxes. Pan along the Main Street alignment to view the format of the new label style.

18

Label style created from an existing style

To continue this tutorial, go to Exercise 2: Using a Child Label Style (page 578).

**Exercise 2: Using a Child Label Style**

In this exercise, you will create a child label style that derives its default settings from an existing label style, or parent.

In the following steps, you will create a child of an existing alignment label style, and modify some of the child label style properties. You will examine the results, and then override some of the child style properties with those of the parent label style.

For more information, see the AutoCAD Civil 3D Help topic *Modifying Labels in a Drawing*.

This exercise continues from Exercise 1: Creating a Label Style (page 574).
To create a child label style

NOTE This exercise uses *Labels-5a.dwg* with the modifications you made in the previous exercise.

1. Pan to station 0+080 on the West Street alignment.
2. Ctrl+click the station label 0+080. Right-click. Click Label Properties.
3. In the Properties palette, on the Design tab, click the value for Major Station Label Style. Select Create/Edit from the list.
4. In the Label Style dialog box, click the drop-down list and change the style to Perpendicular With Line.

   **NOTE** Make sure that you select Perpendicular With Line, and not Perpendicular With Tick.

5. Click the arrow next to . Click Create Child Of Current Selection.
6. In the Label Style Composer, on the Information tab, change the style name from Perpendicular With Line [Child] to Station Emphasis.
7. On the Layout tab, in the Component Name list, select Station. In the Text category, for Text Height, enter 5.00mm. For Attachment, select Middle Left.
8. Apply the changes by clicking OK in the Label Style Composer and Label Style dialog boxes.

   The station is now displayed in large text that is attached to the end of the line. The size and position of the text are properties of the new style, Station Emphasis. The contents of the text, and the color and length of the line are properties of the parent style, Perpendicular With Line.

9. Press Esc to deselect the label.
10. In the drawing window, Ctrl+click the label 0+100. Change its style to Perpendicular With Line, using the Properties palette.

   Notice that in the style collection displayed in the Properties palette, the new style is indented under its parent. You can also see this placement in Toolspace, on the Settings tab, under Alignment ➤ Label Styles ➤ Station ➤ Major Station ➤ Perpendicular With Line.

---

Exercise 2: Using a Child Label Style | 579
Notice that in the drawing, the STA:0+080 and STA:0+100 label text are different sizes, and the text and line are aligned differently. A child style shares its basic properties with the parent style from which it was created. If a property value changes in the parent style, then the change is also applied to the child style. If a property value changes in the child style, the parent style is not affected.

By creating a child style, you have created the station display you need, without affecting other parts of the drawing. If you had instead changed the properties of the parent style, it would have automatically changed the appearance of any other major stations using that style.

Next, you will set the parent style to override the text setting in the child style.

To override child label style properties

1. In Toolspace, on the Settings tab, expand the Alignment ➤ Label Styles ➤ Station ➤ Major Station collections.
2. Right-click Perpendicular With Line. Click Edit.
3. In the Label Style Composer dialog box, click the Summary tab.
4. Expand the Component 1 property.
5 In the Text : Text Height row, click ✅ in the Child Override column.

In the Child Override column, ✗ is displayed, indicating that the previously independent property of the child has been overridden by the parent.

6 Click OK to close the Label Style Composer dialog box.

Notice that the labels now use the same text size. The STA: 0+080 label text is now the same size as the STA: 0+000 label because the text height of the parent style has overridden that of the child style. The alignment of the line is still different because the text attachment point of the child style was not overridden.

To continue this tutorial, go to Exercise 3: Controlling Label Appearance Using Layers (page 582).
Exercise 3: Controlling Label Appearance Using Layers

In this exercise, you will use layers to change the color and visibility of labels.

The components that make up a label object get their color, line weight, and line type property settings from either the label style or the layer to which the label style refers. When a label style refers to a specific layer, any label style components that are set to either ByLayer or ByBlock inherit the properties of that specific layer. However, if the label style refers to layer 0, then any label style components that are set to either ByLayer or ByBlock inherit their properties from the layer on which the label resides.

A label is an independent AutoCAD Civil 3D object that can be on a separate layer from its parent object. However, the visibility of a label is linked to the layer of the parent object. Turning off or freezing the layer of an object also hides the labels of that object, even if they reside on a different layer.

For more information, see the AutoCAD Civil 3D Help topics Managing General Properties for Label Styles and Managing Layout Properties for Label Styles.

This exercise continues from Exercise 2: Using a Child Label Style (page 578).

To control label appearance with layers

NOTE This exercise uses Labels-5a.dwg with the modifications you made in the previous exercise, or you can open Labels-5b.dwg from the tutorial drawings folder (page 615).

1 On the West Street alignment, zoom and pan to the area between stations 0+100 and 0+120.

2 Click station label 0+120 to select all major station labels. Right-click. Click Properties.
   On the Properties palette, notice that the alignment station labels are on layer C-ROAD-TEXT. If you look at the properties for the alignment itself, you will see that it is on the C-ROAD layer.

3 In the Layers list, in the C-ROAD layer, click ☐ to turn off the C-ROAD layer.

4 On the command line, enter REGEN.
   The alignment and its labels are hidden. This happened because, while labels are independent Civil 3D objects on a separate layer, their visibility
is linked to the layer of the parent object, C-ROAD. Turning off the layer of an object also hides the labels of that object, even if they reside on a different layer.

**NOTE** The blue line that remains in place of the alignment is the polyline in the externally referenced drawing, from which you created the alignment in the *Adding Labels In Groups* (page 543) exercise.

5 In the Layers list, in the C-ROAD layer, click ☑️ to turn on the C-ROAD layer and the station labels.

6 On the command line, enter REGEN.

7 Select label 0+120 to select all major station labels. On the Properties palette, under Labeling, click the field next to Major Station Label Style. Click Create/Edit.

8 In the Major Station Label Style dialog box, click ![Edit Current Selection](image). In the Label Style Composer dialog box, on the General tab, in the Label category, notice that the Layer is 0. If a label style is set to layer 0, any of its color, line type, and line weight properties that are set to ByLayer or ByBlock will inherit the corresponding properties of the layer on which the label resides.

9 Click the Layout tab. In the Text category, notice that the Color property for the Station component is ByLayer. This means that the major station label text inherits the color of the layer to which the style refers. Because the label style refers to layer 0, the major station label text inherits the color of the label object layer, which is C-ROAD_TEXT.

10 In the Color row, click the Value cell. Click ![Change Color](image) and change the Station component color to blue. Notice that the text color updates in the Preview pane.

**NOTE** For greater control of color, lineweight, and linetype, keep all style components set to either ByBlock or ByLayer, and the label style layer set to 0. Then, you can use the layers to modify these properties. This tutorial uses a specific color setting to demonstrate how layer settings affect styles.
11 In the Component Name list, select Tick. In the Tick category, notice that the Color property for the Tick component is ByLayer.

12 Click OK to apply the change in color to the Major Station component and exit the Label Style Composer and Major Station Label Style dialog boxes.

13 Press Esc to deselect the labels.

14 On the command line, enter REGEN. Notice that while the ticks still inherit the red color from the C-ROAD-TEXT layer, the text is blue.

15 Click Alignments menu ➤ Add Alignment Labels ➤ Single Segment.

16 When prompted to select a segment to label, click the alignment between stations 0+060 and 0+080. When a label appears on the alignment, press Enter to end the command.
Select the new label. On the Properties palette, notice that the label is on C-ROAD-TEXT.

When labels are created, they are placed on the layer specified for the label object in the Drawing Settings dialog box on the Object Layers tab. The drawing settings for this drawing specify that alignment labels are created on the C-ROAD-TEXT layer. For more information, see the AutoCAD Civil 3D Help topic Specifying Object Layer Settings.

On the Properties palette, click the field next to Line Label Style. Click Create/Edit.

In the Line Label Style dialog box, click Edit Current Selection. In the Label Style Composer dialog box, on the General tab, in the Label category, notice that the layer style is C-ROAD-BRNG. This means that if any of the color, line type, and line weight properties are set to ByLayer
or ByBlock, they inherit the corresponding properties of the C-ROAD-BRNG layer, no matter what layer the label object is on.

20 Click the Layout tab.

Use the Component Name list to examine the properties of the various label components. Notice that the Color of all the components is ByLayer, except for the Direction Arrow component.

The label components that have their Color property set to ByLayer are red because the color property of the C-ROAD-BRNG layer is red. The direction arrow is blue because its Color property is blue.

21 Click Cancel to exit the Label Style Composer and Line Label Style dialog boxes.

22 In the Layers list, in the C-ROAD-TEXT layer, click to turn off the C-ROAD-TEXT layer.

The major station labels and ticks are hidden, but the tangent label you added is not. The station labels were hidden because they are on the C-ROAD-TEXT layer and their style refers to the C-ROAD-TEXT layer, which you turned off. The tangent label is still visible because, while you turned off the layer it is on, its style components refer to the C-ROAD-BRNG layer, which is still visible.
Notice that the STA:0+080 and STA:0+100 labels you changed in Exercise 2: Using a Child Label Style (page 578) are also still visible. This is because the rest of the major station labels use the Perpendicular With Tick style, which refers to layer 0. Labels STA=0+060 and STA=0+080 use the Perpendicular With Line and Station Emphasis styles, which refer to the C-ROAD-LABL layer.

23 In the Layers list, in the C-ROAD-TEXT layer, click to turn on the C-ROAD-TEXT layer and the station labels.

To continue this tutorial, go to Exercise 4: Changing the Dragged State of a Label (page 588).
Exercise 4: Changing the Dragged State of a Label

In this exercise, you will modify a label style so that a label will display differently when it is dragged from its original location.

Every label style has two default formats: one for when the label is initially created in its normal layout location, and another that is applied when you drag the label away from its normal layout location. The controls for editing the dragged state of a label style are similar to those used for the layout state.

For more information, see the AutoCAD Civil 3D Help topic Managing Dragged Properties for Label Styles.

This exercise continues from Exercise 3: Controlling Label Appearance Using Layers (page 582).

To change the dragged state of a label

NOTE This exercise uses Labels-5b.dwg with the modifications you made in the previous exercise.

1. Zoom in so that you can see the 0+040 station label on the West Street alignment. Click the label to select it and all the other major station labels.

2. Click the grip and drag it away from the alignment.
   The label is now in its dragged state. The text and leader line are red because the dragged state of the label style is set to ByLayer. Keep this label in view so you can see the effects of format changes as you make them.
3 In Toolspace, on the Settings tab, expand Alignment ➤ Label Styles ➤ Station ➤ Major Station. Right-click Perpendicular With Tick. Click Edit.

4 In the Label Style Composer dialog box, click the Dragged State tab. In both the Leader and Dragged State Components categories, notice that the Color, Linetype, and Lineweight properties are all either ByLayer or ByBlock. These settings indicate that when a label is in dragged state, it inherits these properties from either the layer on which the label resides or the block that contains it.

**TIP** Because the Preview pane does not show the dragged state of the label, position the Label Style Composer so that you can see a dragged-state label in the drawing. Each time you change a label property, you can click Apply to see the effects.

5 In the Dragged State Components area, change the Display value to As Composed. Click Apply.

---

**Exercise 4: Changing the Dragged State of a Label**
The label returns to the original layout property settings, and all other style controls in this area are disabled. This type of dragged-state format is easy to apply, but is not suitable for all label types. In particular, note that the leader line does not adapt well to all possible dragged locations.

6 Change the Display value back to Stacked Text. Click Apply. If your label has multiple lines of text, the Stacked Text setting keeps them all stacked horizontally in a compact block. You can see this in action by dragging one of the curve labels from its layout location.

7 Change each of the following property values. Click Apply after each change to see their effects.
   ■ Leader Type: Spline Leader
   ■ Border Visibility: True
   ■ Border Type: Rounded Rectangular
   ■ Border and Leader Gap: 2.0mm
   ■ Leader Attachment: Top Of Top Line

8 After you have applied all the changes that you want to see in the dragged state, click OK.
In this exercise, you will learn several ways to change label styles. Depending on the type of label type you must change, and how many labels of that label type you must change, you can change label styles at the following levels:

- Single label objects, including alignment curve and tangent labels.
- Groups of label objects, including alignment station and geometry point labels.

To continue this tutorial, go to Exercise 5: Changing a Label Style (page 591).
Individual label objects that are part of a group, such as a single alignment station label.

Individually labeled objects in the Prospector list view, including parcels, points, and pipe network objects. See Exercise 1: Creating a Parcel Area Table (page 566) for information about changing parcel area label styles using the Prospector list view.

For more information, see the AutoCAD Civil 3D Help topic Modifying Labels in a Drawing.

This exercise continues from Exercise 4: Changing the Dragged State of a Label (page 588).

To change the label style of a single label object

NOTE This exercise uses Labels-5b.dwg with the modifications you made in the previous exercise, or you can open Labels-5c.dwg from the tutorial drawings folder (page 615).

1 Pan and zoom to the area at the end of the West Street cul-de-sac.

2 Click the red curve label between stations 0+200 and 0+220 on West Street.
   Grips appear on the curve label, but no other labels are selected. This label is a single label object that is not part of a group of labels.

3 Right-click the label. Click Properties.

4 On the Properties palette, in the Civil 3D category, in the Curve Label Style list, notice that you can select a General Curve Label Style. General styles can be applied to line and curve labels that annotate alignment, profile, or parcel segments. Select General Curve Label Style ➤ Radius Only.
   The individual curve label style changes, but the remaining curve labels on the cul-de-sac are not affected.

5 Press Esc to deselect the label.
To change the label style of a group of label objects

1. Click the 0+220 station label. Grips appear on all the station labels, indicating that station label 0+220 is part of the station label group.

2. Right-click the label. Click Properties.

3. On the Properties palette, in the Civil 3D category, in the Major Station Label Style list, select Parallel With Tick. The label style changes for all major station labels on West Street.

4. Press Esc to deselect the major station labels.
To change the label style of an individual label object that is part of a group

1. Ctrl+click the 0+060 station label.
   A grip appears only on label 0+060. The other major station labels are not selected.

2. Right-click the label. Click Properties.

3. On the Properties palette, in the Civil 3D category, in the Major Station Label Style list, select Perpendicular With Line.
   The label style changes for only station label 0+060. The rest of the major station labels on West Street retain their current style.

4. Press Esc to deselect the label.
Major station label type style changed: STA: 0+060 only

To continue this tutorial, go to Exercise 6: Creating a Label Style that Refers to Another Object (page 595).

Exercise 6: Creating a Label Style that Refers to Another Object

In this exercise, you will use the reference text component to create a single label style that annotates two objects of different types.

The Reference Text label component is used to annotate multiple types of objects with a single label. You can insert references to surfaces, profiles, parcels, and alignments. Each reference text component can refer to only one AutoCAD Civil 3D object. If you need a label style to refer to several objects, create a separate reference text component for each referenced object.
In this exercise, you will create a label style that displays the alignment station and surface elevation at each horizontal geometry point. This type of label is useful when you are designing the curb return alignments in corridor intersections. For more information about using a referenced text label in intersection design, see the Matching Corridor Elevations in Profile tutorial exercise (page 340).

For more information, see the AutoCAD Civil 3D Help topic Referenced Text.

This exercise continues from Exercise 5: Changing a Label Style (page 591).

To create a label style that refers to another object

NOTE This exercise uses Labels-5c.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Settings tab, expand the Alignment ➤ Label Styles ➤ Station ➤ Geometry Point collection. Right-click Perpendicular With Tick And Line. Click Copy.

2 In the Label Style Composer dialog box, on the Information tab, for Name, enter Surface Elevation at Alignment Station. Optionally, enter a description.

3 Click the Layout tab.
   You can use this tab to create and edit label style components. You will modify the existing line and geometry point components, and then create two new label components for the new label style. The first component will display the surface elevation, and the second component will display the alignment station.

4 Under Component Name, select Line. Set the following property values:
   ■ Start Point Anchor Component: Tick
   ■ Start Point Anchor Point: Middle Center
   ■ Length: 15.00mm

5 In the Label Style Composer dialog box, under Component Name, select Geometry Point & Station. Set the following property values:
   ■ Start Point Anchor Component: Line
   ■ Anchor Point: End
   ■ Attachment: Middle Left
■ X Offset: 2.00mm

6 In the Label Style Composer dialog box, click the arrow next to . Click Reference Text.

A reference text label component refers to other object types in the drawing, instead of to the object type you are labeling. In this case, the reference text component will refer to a surface object.

7 In the Select Type dialog box, select Surface. Click OK.

8 In the Label Style Composer dialog box, set the following property values:
   ■ Name: Elevation
   ■ Anchor Component: Geometry Point & Station
   ■ Anchor Point: Bottom Left
   ■ Attachment: Top Left

9 In the Text category, in the Contents row, click the Value cell. Click .

10 In the Text Component Editor dialog box, in the preview pane, replace Label Text with EL:. Under Properties, select Surface Elevation. Click to move the Surface Elevation property to the preview pane.

The property block in the preview pane should look like this:
EL: <$[Surface Elevation(Um|P3|Rn|AP|Sn|OF)]$>

11 Click OK.

12 In the Label Style Composer dialog box, click the General tab. Set the Flip Anchors With Text property to True.

Using this setting ensures that when the labels are flipped to maintain plan readability, they will display as mirror images of the original labels.

13 In the Label Style Composer dialog box, click OK.

Next, you will apply the new label style to an alignment and examine the results.
To apply a label style that refers to another object

1. In the drawing window, pan to the intersection of the Main Street and East Street alignments.

2. Click Alignments menu ➤ Add Alignment Labels ➤ Add/Edit Station Labels. Click one of the station labels on the East Street alignment.

3. In the Alignment Labels dialog box, under Type, select Geometry Points. Under Geometry Point Label Style, select Surface Elevation At Alignment Station. Click Add.

4. In the Geometry Points dialog box, click to clear all check boxes. Select the Alignment Beginning check box. Click OK.

5. In the Alignment Labels dialog box, click OK.

6. Drag the label to a clear location, if necessary.

Notice that the label is added to the alignment, but the elevation value is displayed as ???. These characters are displayed because you have not associated a surface with the Elevation component.

Label style that refers to an alignment and surface, with no surface associated with the label
7 Ctrl+click the Surface Elevation At Alignment Station label. Right-click. Click Label Properties.

8 In the Properties palette, under Reference Text Objects, click the cell to the right of Surface Elevation At Alignment Station. Click .

9 In the drawing, click the green surface border. Press Esc to deselect the label.
Examine the label. The surface elevation at the intersection of the alignments is now displayed.

To continue to the next tutorial, go to Using Expressions in Labels (page 599).

**Tutorial: Using Expressions in Labels**

This tutorial demonstrates how to use expressions, which are mathematical formulas that modify a property within a label style.
You use text, lines, and block data components to present static data in a label style. Expressions modify the data in the standard label style components. For example, in the Layout tab of the Label Style Composer dialog box, you can insert an expression in place of a static value when determining the text height of a label. This expression could increase the text height of a spot elevation label to coincide with the elevation height.

In this tutorial, you will update an existing label style to add an expression that displays magnetic compass directions of the alignment at each geometry point.

For more information, see the AutoCAD Civil 3D Help topic *Expressions*.

**Exercise 1: Creating an Expression**

In this exercise, you will create an expression that calculates the magnetic compass direction of an alignment at each geometry point.

Expressions make use of the same properties that you can add to label styles, such as Point Elevation, Northing, and Easting. By using expressions, you can set up separate mathematical formulas, using the existing properties. For example, you could subtract a value from a point elevation, and display that number along side the actual elevation in a point label.

For more information, see the AutoCAD Civil 3D Help topic *Setting Up Expressions*.

**To create an expression**

NOTE This exercise uses *Labels-5c.dwg* with the modifications you made in the previous exercise, or you can open *Labels-6a.dwg* from the tutorial drawings folder (page 615).

1. Zoom and pan to the area between stations 0+000 and 0+100 of the Main Street alignment.
2. Click the PC: 0+035.99 label to select all geometry point labels. Right-click. Click Properties.
3. On the Properties palette, in the Civil 3D category, in the Geometry Point Label Style list, select Additional Details.
   This label style displays geometry points, design speed, and true compass direction at the geometry point. In the next few steps, you will create an expression to calculate the magnetic direction. You will add this...
expression to the geometry point label in Exercise 2: Inserting an Expression Into a Label Style (page 601).

4 In Toolspace, on the Settings tab, expand Alignment ➤ Label Styles ➤ Station ➤ Geometry Point. Right-click the Expressions node. Click New.

5 In the New Expression dialog box, enter the following information:
   ■ Name: Magnetic Direction
   ■ Description: Converts true to magnetic for declination -15.5 degrees.

6 Click Insert Property. Click Instantaneous Direction. This property will be used as the basis for computing the magnetic direction.

7 In the New Expression dialog box, in the Expression field, use the keypad to enter \(-15.5(2\pi/360)\).

**NOTE** Use the \(\pi\) button to enter \(\pi\).

The completed equation looks like this: 
\([\text{Instantaneous Direction}-(15.5(2\pi/360))]\)

The expression includes a conversion from degrees to radians because AutoCAD Civil 3D uses radians for all internal angle calculations. The value used for declination of magnetic North (-15.5 degrees) is just an example. To be accurate, this must match the current value, subject to geographical location and gradual changes over time.

8 In the Format Result As list, select Direction. Click OK.

In Toolspace, on the Settings tab, the ➡️ appears next to the Expressions node, and the new expression appears in the list view.

To continue this tutorial, go to Exercise 2: Inserting an Expression Into a Label Style (page 601).

**Exercise 2: Inserting an Expression Into a Label Style**

In this exercise, you will insert an expression into an existing label style.
After you set up expressions, they are available in the Properties list in the Text Component Editor so that you can add them to label styles. In effect, expressions become new properties that you can use to compose a label style.

Expressions are unique to a particular label style type. Only those properties that are relevant to the label style type are available in the Expressions dialog box.

For more information, see the AutoCAD Civil 3D Help topic Inserting Expressions into Label Styles as Properties.

This exercise continues from Exercise 1: Creating an Expression (page 600).

To insert an expression into a label style

NOTE This exercise uses Labels-6a.dwg with the modifications you made in the previous exercise.

1 In Toolspace, on the Settings tab, expand Alignment ➤ Label Styles ➤ Station ➤ Geometry Point. Right-click Additional Details. Click Edit.

2 In the Label Style Composer dialog box, on the Layout tab, in the Text collection, in the Contents row, click the Value column. Click .

3 In the Text Component Editor, in the Preview pane, place the cursor on a new line below the last property (True Instantaneous Direction).

4 Enter the following text, including the space after the colon: MAG: .

5 On the Properties tab, in the Properties list, select Magnetic Direction, which is the expression you created in Exercise 1: Creating an Expression (page 600), at the top of the list.

6 In the table, ensure that the value for Unit is Degree, and the Format is DD°MM’S.SS.” (unspaced).

7 Ensure that the cursor in the right window is located just after the Mag: label text. Click to add the magnetic compass direction to the label formula.

8 In the Text Component Editor, click OK. The modified labels appear in the Preview pane of the Label Style Composer dialog box.

9 In the Label Style Composer dialog box, click OK.
Press Esc to deselect the labels.
Examine the geometry point labels to see the effect of the expression you added.
These tutorials will get you started working with the plan production tools, which automate the process of creating construction documents from your designs.

The plan production tools simplify the process for preparing sheets from your design drawings. However, these tutorial exercises do not go into detail about the Sheet Set Manager or plotting or publishing processes. For information about these features, see the AutoCAD Help.

You can use the plan production tools with or without using project management (Autodesk Vault). If you choose to manage your plan production files (sheet set files, sheet files, templates) with Autodesk Vault, you must log in to the appropriate project and have the necessary files checked out for editing. For more information, see the AutoCAD Civil 3D Help topic Using Vault with Plan Production Tools.

The following tutorial exercises do not use the Autodesk Vault (project management) features.

**NOTE** All drawings used in these tutorials are available in the tutorial drawings folder (page 615). If you want to save your work from these tutorials, save the drawings to the My Civil 3D Tutorial Data folder (page 615) so that you do not overwrite the original drawings.

For more information, see the AutoCAD Civil 3D Help topic Understanding Plan Production Tools.

**Tutorial: Using the Plan Production Tools**

This tutorial demonstrates how to use the plan production tools to prepare your design for plotting or publishing.

Using the two plan production tool wizards, you can quickly create sheets that automatically display segments of alignments and profiles in your plans.
Instead of having to manually create many viewports on layouts to show segments of alignments, you can create view frames that automatically capture predefined areas along an alignment. This automation saves you from making manual changes when your design data changes. After you select an alignment in your drawing, in just a few seconds you can create sheets that automatically display the desired data.

For more information, see the AutoCAD Civil 3D Help topic *Understanding Plan Production Tools*.

**Exercise 1: Configuring Viewports**

In this exercise, you will learn how to prepare an existing drawing template for use with the plan production tools.

Before using your own custom templates for plan production, you must set the layout viewport type to either *Plan* or *Profile*.

By default, most of the templates provided with AutoCAD Civil 3D have the Viewport Type property set to Undefined. However, the plan production templates that are included have viewports that are already configured to the appropriate viewport type: plan or profile.

For more information, see the AutoCAD Civil 3D Help topic *Configuring Viewports for Plan Production*.

**To configure viewports in an existing template**

1. In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the `C:\Documents and Settings\<User Name>\Local Settings\Application Data\Autodesk\C3D 2009\enu\Template\Plan Production`. Open Civil 3D (Imperial) Plan and Profile.dwt.

   **NOTE** In the Select File dialog box, ensure that Files of Type is set to *Drawing Template (*.dwt)*.

   The template contains two viewports.

2. Select the top viewport. Right-click and select Properties.
   Examine the settings of the viewport, including the size and position contained in the Geometry category.

3. On the Properties palette, scroll down to the Viewport category.

4. Double-click the cell next to Viewport Type.
The drop-down list displays the configuration options for the viewport. The current (top) viewport is set to Plan, while the bottom viewport is set to Profile. These settings specify that when you use this template in the plan production process, the plan view of the alignment will appear in the top viewport, and the corresponding profile will appear in the bottom viewport.

By default, all templates that are not contained in the C:\Documents and Settings\<User Name>\Local Settings\Application Data\Autodesk\C3D 2009\enu\Template\Plan Production folder have their Viewport Type set to Undefined. To configure your custom templates for use with the plan production process, you must change the viewport setting as appropriate.

5 Close Civil 3D (Imperial) Plan and Profile.dwt, but do not save it.

To continue this tutorial, go to Exercise 2: Creating View Frames (page 607).

**Exercise 2: Creating View Frames**

In this exercise, you will use the Create View Frames wizard to quickly create view frames along an alignment.

View frames are rectangular areas along an alignment that represent what is displayed in the associated viewports on the layouts (sheets) to be created.

Before you create view frames, you must have the desired alignment already in your drawing. Depending on the type of sheets you want to produce (plan only, profile only, or plan and profile), you may also need to have a profile already created. If you are creating plan only sheets, then you do not need to have a profile in the drawing.

For more information, see the AutoCAD Civil 3D Help topic Creating View Frames.

**To create view frames**

1 In the AutoCAD Civil 3D window, click File menu ➤ Open. Navigate to the tutorial drawings folder (page 615). Open Plan Production-1.dwg.

   **NOTE** In the Select File dialog box, ensure that Files of Type is set to Drawing (*.dwg).

2 Click General menu ➤ Plan Production Tools ➤ Create View Frames.
In the Create View Frames wizard, on the Alignment page, in the Alignment list, select Maple Road.

In the Station Range section, select Automatic. This setting selects the entire alignment.

Click Next to open the Sheets page.

On the Sheets page, in the Sheet Settings section, select Plan And Profile. This setting creates sheets that display both plan and profile views for each view frame.

In the Template For Plan And Profile Sheet field, click.

In the Select Layout As Sheet Template dialog box, click.

In the Select Layout As Sheet Template file navigation dialog box, browse to the C:\Documents and Settings\<User Name>\Local Settings\Application Data\Autodesk\C3D 2009\enu\Template\Plan Production directory. Select Civil 3D (Imperial) Plan and Profile.dwt and click Open.

In the Select Layout As Sheet Template dialog box, in the Select A Layout To Create New Sheets section, select ANSI D Plan And Profile 40 Scale.

Click OK.

In the View Frame Placement section, select Along Alignment. This setting aligns the view frames along the alignment, as shown in the graphic in the wizard.

Select the Set The First View Frame Before The Start Of The Alignment By option, and enter 50.000’ in the value field. This option sets the distance that the first view frame is placed before the start of the alignment. Entering a distance here provides the specified amount of space before the alignment starting station. This distance ensures that the alignment start location does not coincide with the start of the view frame. If this check box is not selected, then the first view frame is placed at the start of the alignment.

Click Next to open the View Frame Group page.

View frame groups are created automatically. This page lets you specify the object creation criteria for the view frame group object. Examine the settings that are available, but accept the default settings for this exercise.

Click Next to open the Match Lines page.
Match lines are straight lines that are drawn across an alignment in plan view to indicate where the corresponding sheet for that alignment begins and ends. Match lines typically include labels that can identify the previous and next sheet (view frame) along the alignment. Examine the settings that are available, but accept the default settings for this exercise.

16 Click Next to open the Profile Views page.
17 On the Profile Views page, under Profile View Style, select Major Grids.
18 Under Band Set, select Stations Only.
19 Click Create View Frames.
   The view frames are displayed along the alignment in the drawing window. The match lines are displayed as annotated lines between the view frames.
20 In Toolspace, on the Prospector tab, expand View Frame Groups, then expand the VFG - Maple Road collection. Expand the View Frames and Match Lines collections. Notice that they contain the same components you created during the view frame group creation process.

21 In Toolspace, on the Prospector tab, right-click one of the view frames. Notice that you may zoom or pan to the view frame in the drawing. Notice that you may also create a sheet for the individual view frame. In the next exercise, you will create sheets for all the view frames.

22 In the AutoCAD Civil 3D window, click File menu ➤ Save As.
In the Save Drawing As dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615).

In the File Name area, enter Plan Production Tutorial.dwg. Click Save.

To continue this tutorial, go to Exercise 3: Creating Sheets (page 611).

**Exercise 3: Creating Sheets**

In this exercise, you will create sheets from the view frames you created in the previous exercise.

After you have used the Create View Frames wizard to create view frames, then you can create sheets using the Create Sheets wizard.

The sheets that are created represent the layouts (sheets) that are used for construction documents (plans).

For more information, see the AutoCAD Civil 3D Help topic Creating Sheets.

This exercise continues from Exercise 2: Creating View Frames (page 607).

**To create sheets**

**NOTE** This exercise uses Plan Production-1.dwg with the modifications you made in the previous exercise.

1. Click General menu ➤ Plan Production Tools ➤ Create Sheets.

   **NOTE** On any page of this wizard, you may click Create Sheets to create the sheets using the default choices on the wizard pages. If there are criteria that have not been supplied, then the Create Sheets button is not available.

2. In the Create Sheets wizard, on the View Frame Group And Layouts page, in the View Frame Group area, select VFG - Maple Road. Notice that you may select all view frames in the group or a selection of view frames within the currently selected view frame group.

3. In the Layout Creation area, select Number Of Layouts Per New Drawing and accept the default value of 1.

   This option creates a drawing for each layout (sheet). If you enter a value greater than one, three for example, three layouts are created in each new drawing. The total number of sheets and drawings would depend on the length of the alignment selected and other criteria, such as the size and
scale of the viewports in the referenced template. You can only enter an integer that is between zero and 256.

4 In the Choose The North Arrow Block To Align In Layouts list, select North.
This option orients a North arrow block that is defined in the template. This list is populated with all blocks that are present in the current drawing. Notice that there is a (none) selection available, if you do not wish to include a North arrow block.

5 Click Next to display the Sheet Set page.

6 On the Sheet Set page, in the Sheet Set area, select New Sheet Set.
This option specifies that a new sheet set be created to organize the new sheets. A sheet set allows you to manage and publish a series of sheets as a unit. In the following steps, you will specify a location for the individual sheets and the sheet set data (.DST) file. For best results, store the sheet set data file and its associated sheet files in the same location. For more information about working with sheets and sheet sets, see the AutoCAD Help.

7 Click next to Sheet Set File (.DST) Storage Location.

8 In the Browse For Sheet Set Folder dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615) and click Open.

9 Click next to Sheet Files Storage Location.

10 In the Browse For Folder dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615). Click Open.

11 Click Next to display the Profile Views page.

NOTE If the view frames do not include any profile views, then the Profile Views page in the Create Sheets wizard is skipped. The Data References page is displayed next.

12 On the Profile Views page, in the Other Profile View Options area, select Choose Settings.

NOTE You specified the Profile View Settings during Exercise 2: Creating View Frames (page 607).

13 Click Profile View Wizard.
14 In the Create Multiple Profile Views wizard, use the links along the left side or the Back and Next buttons to examine the available settings. Many of the settings are not available because they are already defined by the currently selected view frame group.

For more information, see the Creating Multiple Profile Views (page 239) tutorial exercise.

15 Click Finish.

16 In the Create Sheets wizard, in the Align Views area, select Align Profile And Plan View At Start.

This option aligns the alignment starting station in plan view with the profile starting station in profile view. The profile view shifts to the right to accommodate the exact alignment starting station.

17 Click Next to display the Data References page.

18 On the Data References page, you can select or omit the objects for which you want references included in your sheets. Notice that the Maple Road alignment and profile are selected by default.

19 Select the check box next to Pipe Networks.

20 Click Create Sheets to close the wizard and create the sheets. When you are prompted to save the current drawing, click OK.

21 When prompted, pan to a clear area in the drawing, then click a location for the profile view origin.

After your sheets are created, the Sheet Set Manager is displayed, showing the newly created sheets. For more information on the Sheet Set Manager, see the Sheet Set Manager Help topics in the AutoCAD Help.

22 If the Sheet Set Manager does not open, enter SHEETSET on the command line.

23 On the Sheet Set Manager, select Open from the drop-down list.

24 On the Open Sheet Set dialog box, navigate to the My Civil 3D Tutorial Data folder (page 615) and select VFG - Maple Road.dst. Click Open.

On the Sheet Set Manager, notice that the VFG - Maple Road - (1).dst is open, displaying the five sheets that were created.

25 Select one of the sheets in the list. Right-click and select Open.

The sheet opens as a new drawing.
NOTE You can publish your sheet(s) directly from the Sheet Set Manager or share them by using the eTransmit feature.
Tutorial Folder Locations

**My Civil 3D Tutorial Data folder** If this folder does not already exist, create it at the following location to save the tutorial drawings as you work on them:

C:\My Documents\Autodesk\My Civil 3D Tutorial Data

tutorial drawings folder <Civil 3D installation location>\Help\Civil 3D Tutorials\Drawings

tutorial folder <Civil 3D installation location>\Help\Civil 3D Tutorials
Index

A
alignment 190, 192
  editing grips 192
  selecting subentities 190
alignments 179–180, 183, 185, 189–191, 193, 199, 202, 205, 252
  creating 179–180
    with spirals and curves 180
  criteria-based design 193, 199
    correcting violations 199
    creating with 193
  curves and spirals, adding 183, 185
  design checks, working with 202
  design criteria file, working with 205
  editing 189–191
    grips 191
    parameter values 190
  grips editing 191
  parcels, working with 252
  site interaction 252
  tutorials 179
assemblies 352, 378
  curb returns, defining 352
  roundabout, defining 378
assembly 302, 307, 315
  creating a simple 302
  creating a transition lane 307
    for a divided highway 315
astronomic direction calculator 139
AutoCAD Civil 3D, overview 5
AutoCAD objects 246
  creating parcels from 246

B
base and comparison surfaces, creating 87
blocks 92
  moving multi-view blocks to a surface 92
borrow pits, adding 420
boundaries 55, 330
  creating for a corridor 330
  data clip 55
  boundary, hide 74
  boundary, outer 53
breaklines, adding 51

C
catchment areas 82
  creating 82
corridor 304, 311, 319
  creating a divided highway 319
  creating a simple 304
  creating a transition lane 311
corridor section viewer 320
  using 320
corridor surface 327, 330, 333
  boundaries, creating 330
  creating 327
  rendering 333
  adding baselines 345, 356, 390
  boundaries, creating 330, 367, 399
  creating 314
    divided highway 314
    creating a model with a transition lane 306
  creating a simple 301
  curb returns 349, 352, 385
    alignments and profiles, defining 349, 385
    assemblies, defining 352
  intersection design 339
matching profile elevations 340
overlapping geometry, removing 346, 372
regions, managing 346, 356, 372, 390
roundabout design 371
roundabouts 375, 378
alignments and profiles, defining 375
assemblies, defining 378
surfaces, evaluating drainage 363, 396
tutorials 301, 339
viewing and rendering 327
viewing sections 320
viewing superelevation properties 315
criteria-based design 193, 199, 202, 205, 223–225, 227
correcting violations 199, 227
design checks, working with 202
design criteria file, modifying 205
designing a profile using 223
designing an alignment using 193
profiles, drawing with 225
profiles, specifying criteria for 224
cross sections 405
displaying on an alignment 405
curves 183, 185
adding floating curves 185
adding free curves 183
cut and fill volumes 282
d
data bands 234, 410
adding to a profile view 234
adding to section views 410
editing in a profile view 234
data shortcuts 155–157, 159
creating 157
project folder, setting up 156
referencing 159
using 155
description keys and point groups, creating 23
description keys, creating 24
design checks 202
working with 202
design criteria file 205
modifying 205
display order, parcels 264
divided highway, creating 314
dump sites, adding 420
DYN 15
dynamic input 15

E

elevation 280
editing in a grading 280
export project 177
exporting 265
parcel data 265
expressions 599–601
as label style components 601
creating 600
inserting in a label 601
labels, using in 599
externally referenced drawing 29, 33
displaying 29
removing 33

F

feature lines 272, 275, 285, 292, 294–295
creating 272
crossing, working with 295
elevations, assigning 275
elevations, editing 295
offsetting, in grading 285
rounding corners in 285
smoothing 292
using as breaklines, in grading 294
field book file 115
importing 115
figure 119
editing 119
figures 120
modifying 120
floating curves, adding 185
free curves, adding 183

G

Google Earth 98, 101
importing an image from 101
publishing design data to 98
building footprints, simplifying 285
complex footprints, working with 284
corners, inside 292
creating 272, 277, 288
criteria 268, 283
creating 268
editing 283
editing 279–280, 292
elevation 280
filling a void area 290
settings, reviewing 268
standards, setting up 267
styles 271
creating 271
surfaces 294
tutorials 267
volume balancing 282

H

hatching 333
corridors 333
hide boundary, adding 74
horizontal alignment 179
tutorials 179

I

import project 178
intersection 339, 371
corridor, designing 339, 371

L

labels 409, 439, 537–538, 542–543, 550, 553, 559, 561–562, 564, 568, 572, 574, 578, 582, 588, 591, 595, 599
adding and editing 542
adding to drawings 550
changing appearance 574
controlling appearance using layers 582
creating child styles 578
dragged state, managing 588
expressions 599
externally referenced drawings and 538
layers 582
levels of settings defining 561, 564
moving in drawings 553
overriding label text 562
pipe network 439
preparation 538
properties 559
referencing other objects 595
section view 409
selecting 553
sets, using 543
styles 574, 591
styles, creating 574
tags 568
tags, numbering 572
styles, creating 574
tutorials 537
xref 538
xref drawing, creating in 543
layer 0 582
labels in Civil 3D 582
layers 582
layer objects in Civil 3D 582
layout profiles 215–216, 218
creating 216
editing 218
least squares analysis 122, 125, 129, 133, 137
Mapcheck Report 147, 151
entering data manually 147
working with data 151
mapcheck report, parcel 265
Mapcheck report, parcel 144
mass haul diagrams 415, 417, 420
balancing volumes in 420
creating 417
creating and editing 415
mass haul lines 423
styles 423
match lines 607
creating with view frames 607
material lists 417
creating 417
model views 19
viewing Civil objects in 19
multi-view blocks 92
moving to a surface 92
multiple profile views 239
creating 239
with plan production 239
multiple profile views, creating 239

named views, using 16

object selection 15
object snap 14
objects 15, 81
extracting from a surface 81
viewing 15
offset profile, designing 221
OSNAP 14
outer boundary, adding 53

Panorama window 8
using 8
panorama window, using 8
alignments, working with 252
area table, creating 566
creating 245–246, 248, 250
from AutoCAD objects 246
individual, by layout 248
multiple, by layout 250
creating automatically 250
display order 263–264
displaying and analyzing 263
editing 254
editing geometry 257
exporting data 265
size, editing 255–256
tutorials 245
part builder 449
tutorial 449
Part Builder 449, 465, 469, 501
creating a cylindrical manhole structure 449
creating a drop inlet manhole structure 469
creating a vault structure 501
verifying a new part 465
parts list 432
adding parts to 432
pipe network 427–428, 430, 432, 434–435, 438–439, 442, 445–446
adding a branch 435
adding parts to 430
adding parts to the parts list 432
changing properties of 432
changing surface, alignment, and rules configuration 434
creating 427–428
editing in profile view 442
labeling 439
tables, pipe and structure 446
viewing and editing 438
viewing in a profile 438
viewing parts in section view 445

pan and zoom controls 12

620 | Index
pipe networks 427, 449, 469, 501
  creating a cylindrical manhole structure 449
  creating a drop inlet manhole structure 469
  creating a vault structure 501
tutorial 427
pipe tables 446
plan production 605–607, 611
  sheets, creating 611
tutorials 605
  view frames, creating 607
  viewports, configuring 606
plan production, using 605
point data, adding to a surface 49
point group 25, 28, 30–31
  creating 25
  display order, changing 31
  displaying and editing 28
  style, changing 30
point groups 39
  assigning user-defined properties to 39
point of vertical intersection (PVI) 275, 295
  grading 275, 295
points 23–24, 27, 33, 35
  creating description keys 24
  creating point data 23
description keys and point groups 23
  editing 33
  importing 27
tutorials 23
  user-defined properties 35
profile view 438, 442
  drawing a pipe network in 438
  editing a pipe network in 442
profile views 210, 230–231, 234, 237, 239, 241
  creating and displaying 210
creating multiple 239
data bands 234
displaying and managing 230
  multiple line 241
splitting 237
stacked, creating 241
style 231
  editing 231
copying and offsetting 221
criteria-based design 223–225, 227
correcting violations 227
creating with 223
drawing with 225
  specifying criteria 224
design 215
elevations, matching for corridor intersection 340
finished grade 215
layout 215
layout, creating 216
layout, editing 218
multiple line 241
reviewing characteristics 214
stacked 241
style, changing 212
surface 209–210
  creating and displaying 210
tutorials 209
  adding a drawing to a project 167
  adding points 174
  checking in an object 172
  checking in project points 176
  checking out and modifying an object 170
  checking out and modifying points 175
  creating 166
  creating a reference to an object 169
  creating user accounts and groups 163
exporting 177
importing 178
logging in 162
object data 167
point data 173
setting up 161
specifying path 162
updating an object 172
project management 155
data shortcuts, using 155
tutorials 155
project object 167, 169–170, 172
checking in an object 172
checking out and modifying an object 170
creating a reference to 169
updating 172
project point data 173

Q
quantity takeoff 412–413
creating 412
settings, reviewing 412
volumes, calculating 413

R
rendering 94, 327
corridors 327
surface 94
right-click menu 12
roundabout, designing 371

S
sample lines 406
creating 406
sample tutorial drawings 3
saving 3
section views 407, 409–410, 445
adding a data band 410
adding a grade label 409
creating 407
viewing pipe network parts in 445
sections 321, 324, 405
corridor, editing 324
corridor, viewing 321
displaying on an alignment 405
tutorials 405
selecting and deselecting 13
settings 112
survey 112
sheet set manager 611
using with plan production 611
sheets 611
creating for plan production 611
slide angle parcel editing 255
smoothing a surface 76
split profile 237
standard toolbar 13
structure tables 446
style 78, 212
profiles 212
watershed 78
styles 17, 271, 444, 574
changing 17
grading, creating 271
labels 574
overriding for a part in a pipe network 444
superelevation 315
viewing properties of an alignment 315
analysis 77
changing style and display 62
creating base and comparison 87
data, analyzing 129
data, editing 67
extracting objects from 81
labeling 65
moving multi-view blocks to a surface 92
profile 209
profile characteristics 214
rendering 94
smoothing 76
style 63–64
changing 64
editing 63
visualizing 92
volume calculation 91
volume information, generating 86
surface profiles 210
creating and displaying 210
view frames 607
    creating 607
viewports 16, 606
    configuring for plan production 606
    setting up 16
visual styles 19
    applying 19
visualization 92, 327, 333
    corridors 327, 333
    surface 92
volume calculation, creating 91
volumes 420
    mass haul, balancing in 420

water drop analysis, configuring 82
water drop analysis, creating 77
watershed 78–79
    generating an analysis 79
    style 78
watershed analysis, creating 77
watershed legend, adding 80
workspaces 10, 541
    annotation and drafting, Civil 541
    using 10

Xrefs 538
    labeling Civil drawings 538